#opendaylight-intern: jQuery/XPath for MD-SAL intern

Meeting started by colindixon at 15:00:23 UTC (full logs).

Meeting summary

  1. status update (colindixon, 15:00:28)
    1. https://github.com/neel1438/Opendaylight/ Neel_B has updated his repo (colindixon, 15:00:54)
    2. the main change seems to be adding ConstructXml.java which builds a Node, but does so by making a document (colindixon, 15:03:21)
    3. ConstructXml.java builds a Document (which is also a Node) that actually has the data in it (colindixon, 15:16:30)
    4. http://docs.oracle.com/javase/7/docs/api/org/w3c/dom/Node.html (colindixon, 15:24:18)
    5. http://hangout.vyatta.com/ (colindixon, 15:27:47)
    6. Neel_B, devinavery, regXboi and colindixon gathered in a google hangout to jointly write JUnit test cases (colindixon, 15:59:38)
    7. ACTION: Neel_B To upload junit test and code to his new git repo (devinavery, 17:25:49)
    8. ACTION: Neel_B to then implement the hardcoded nodes to get existing JUnit tests passing (devinavery, 17:26:03)
    9. ACTION: devinavery to download the JUnit code, and work with colindixon and regXboi to come up with more interesting "questions" we want to ask, so we can provide some more xpath statements to test with (devinavery, 17:26:46)
    10. ACTION: devinavery will write the xpath exp and provide to Neel_B to test once his code is passing the existing JUnits (devinavery, 17:27:12)
    11. Next meeting by IRC is set for Monday July 7th, unless e-mails say otherwise. Same time - 11 Est / 10 Central / 8:30 India (devinavery, 17:28:05)
    12. Neel_B to send e-mails as he completes the various work. (devinavery, 17:28:25)
    13. ACTION: Neel_B should send e-mails as he finishes work and upload changes to his git repo. (devinavery, 17:28:44)


Meeting ended at 17:28:49 UTC (full logs).

Action items

  1. Neel_B To upload junit test and code to his new git repo
  2. Neel_B to then implement the hardcoded nodes to get existing JUnit tests passing
  3. devinavery to download the JUnit code, and work with colindixon and regXboi to come up with more interesting "questions" we want to ask, so we can provide some more xpath statements to test with
  4. devinavery will write the xpath exp and provide to Neel_B to test once his code is passing the existing JUnits
  5. Neel_B should send e-mails as he finishes work and upload changes to his git repo.


Action items, by person

  1. colindixon
    1. devinavery to download the JUnit code, and work with colindixon and regXboi to come up with more interesting "questions" we want to ask, so we can provide some more xpath statements to test with
  2. devinavery
    1. devinavery to download the JUnit code, and work with colindixon and regXboi to come up with more interesting "questions" we want to ask, so we can provide some more xpath statements to test with
    2. devinavery will write the xpath exp and provide to Neel_B to test once his code is passing the existing JUnits
  3. Neel_B
    1. Neel_B To upload junit test and code to his new git repo
    2. Neel_B to then implement the hardcoded nodes to get existing JUnit tests passing
    3. devinavery will write the xpath exp and provide to Neel_B to test once his code is passing the existing JUnits
    4. Neel_B should send e-mails as he finishes work and upload changes to his git repo.
  4. regXboi
    1. devinavery to download the JUnit code, and work with colindixon and regXboi to come up with more interesting "questions" we want to ask, so we can provide some more xpath statements to test with


People present (lines said)

  1. colindixon (39)
  2. regXboi (25)
  3. devinavery (22)
  4. Neel_B (21)
  5. odl_meetbot (4)


Generated by MeetBot 0.1.4.