13:46:58 <colindixon> #startmeeting jQuery/Xpath for MD-SAL intern
13:46:58 <odl_meetbot> Meeting started Mon Jul  7 13:46:58 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
13:46:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:46:58 <odl_meetbot> The meeting name has been set to 'jquery_xpath_for_md_sal_intern'
13:47:16 <colindixon> #info Neel_B has code that shows we didn’t quite understand what we needed to make things work
13:48:30 <colindixon> #info it appears as though ThrowExceptionNode should have extended Element instead of Node
13:49:06 <Neel_B> All the functions in Node and Element are same(almost)
13:49:13 <devinavery> Note: In my quick testing, it doesn’t appear we need to implement any of the new methods, just has to be that interface.
13:50:51 <Neel_B> yup
13:50:58 <Neel_B> i just observed
13:51:00 <Neel_B> tjat
13:51:05 <Neel_B> that*
13:51:38 <Neel_B> but one or 2 functions to be implemented
13:52:13 <Neel_B> i will complete it and we will know if this problem is solved or not
13:53:07 <colindixon> #info also for whatever reason we’re still getting “#document” when we call getNodeName() on the root
13:53:27 <colindixon> #action Neel_B to make ThrowExceptionNode extend Element
13:53:33 <Neel_B> colindixon: i guess that is how it should be
13:53:43 <Neel_B> #document should be the root
13:54:00 <Neel_B> followed by a  then its children
13:54:09 <colindixon> #action Neel_B to also figure out what function on the root node actually returns “a” and change that test case to match reality
13:54:30 <colindixon> yeah, I wonder if the root has one child who’s nodeName is “a”
13:54:34 <colindixon> but you can check that
13:54:35 <Neel_B> yeah
13:54:37 <Neel_B> it has
13:54:42 <colindixon> ok
13:54:50 <Neel_B> i checked while iwas playing
13:55:07 <colindixon> so, change the test to assertEquals(a, root.getFirstChild().getNodeName() );
13:55:08 <colindixon> or something
13:55:21 <colindixon> yeah
13:55:23 <colindixon> that works
13:55:34 <colindixon> that fixes it
13:56:05 <Neel_B> i will implement the element node functions and get back to you tomorrow
13:56:19 <Neel_B> also i tried ping example mean while
13:56:33 <colindixon> now we need .getNodeValue()
13:56:51 <Neel_B> i was getting some errors
13:57:10 <Neel_B> will ask you those too
13:57:17 <Neel_B> next time we meet
13:58:00 <Neel_B> yeah
13:58:12 <Neel_B> presently i put node value as null to all
14:00:03 <colindixon> well, you have a String nodeValue in NodeBuilder
14:00:44 <colindixon> so just return that
14:01:09 <Neel_B> HardCodedNodeBuilder() i put that arguement as null
14:01:16 <Neel_B> i will change it soon
14:05:29 <colindixon> now I’m getting a NullPointerException
14:06:05 <Neel_B> what did you try ?
14:07:36 <colindixon> adding the implementation for getNodeValue()
14:11:57 <colindixon> I did the following:
14:11:58 <Neel_B> all the element nodes should have node value null
14:12:21 <colindixon> 1.) added implements Element instead of implements Node
14:13:05 <Neel_B> okay
14:13:37 <colindixon> 2.) added all of those element
14:14:07 <colindixon> methods
14:14:16 <colindixon> I should add throws to them
14:14:37 <Neel_B> actually turns out that what i have written in HardCodedNodeBuilder() are right
14:14:46 <Neel_B> nothing has to be changed
14:15:08 <Neel_B> in terms of getNodeValue()
14:15:13 <colindixon> ok
14:15:17 <colindixon> I had to add getNodeValue()
14:16:21 <colindixon> here are the diffs I have so far: https://gist.github.com/anonymous/5d09817275d3b9659ef2
14:16:27 <colindixon> I think that the NullPointerException
14:16:34 <colindixon> is coming from one of the methods from Element
14:16:37 <colindixon> but I’m not getting an exception
14:16:41 <colindixon> because I didn’t do that right
14:17:09 <colindixon> so if you could add throw new NotSupportedException() to all the new methods in the ThrowsExceptionNode
14:17:10 <colindixon> that would be great
14:17:17 <Neel_B> sorry i forgot to push the value part
14:17:24 <Neel_B> i added it last
14:17:43 <Neel_B> i thought i pushed it
14:18:16 <Neel_B> i have to implement getTextContent()
14:18:37 <Neel_B> which is a bit complex but will try to implement ot
14:19:20 <colindixon> #action Neel_B to make sure that all the new methods (from Element) in ThrowsExceptionNode (which should really now be ThrowsExceptionElement) actually throw exceptions so that we can quickly tell which ones we need to implement
14:19:33 <Neel_B> i am having a powercut here i battery will last only some time so if wecan wrap fast that would be great
14:19:35 <colindixon> #info Neel_B says he has to also implement getTextContent()
14:19:40 <colindixon> sure
14:19:41 <Neel_B> my battery*
14:19:47 <colindixon> so these seem like good action times
14:19:51 <colindixon> can we touch base tomorrow again
14:19:56 <Neel_B> sure
14:19:58 <colindixon> ok
14:19:59 <colindixon> sounds good
14:20:03 <colindixon> will e-mail these notes
14:20:05 <colindixon> #endmeeting