#opendaylight-intern: jQuery/XPath for MD-SAL intern

Meeting started by colindixon at 15:10:24 UTC (full logs).

Meeting summary

  1. status update (colindixon, 15:10:33)
    1. Neel_B is just finishing step 5 from the list devinavery gave him of how to get started with the MD-SAL (colindixon, 15:15:37)
    2. it appears as though Neel_B was having trouble copying the jars/config files to the right place (colindixon, 15:25:49)
    3. the jar files should go in this direcory: /home/neel/odl/mywork/controller/opendaylight/distribution/opendaylight/target/distribution.opendaylight-osgipackage/opendaylight/plugins (colindixon, 15:26:30)
    4. the config (xml) files should go in this directory: /home/neel/odl/mywork/controller/opendaylight/distribution/opendaylight/target/distribution.opendaylight-osgipackage/opendaylight/configuration/initial (colindixon, 15:27:11)
    5. where /home/neel/odl/mywork/controller is the path to the controller repository on Neel_B’s machine (colindixon, 15:28:24)
    6. with that change, Neel_B has his first MD-SAL app up and working in the controller! (colindixon, 15:35:00)

  2. nex steps (colindixon, 15:35:06)
  3. next steps (colindixon, 15:35:36)
    1. devinavery suggests that we could speed up development by setting up an integration test (colindixon, 15:36:22)
    2. change of plans with regards to next steps. Instead of getting a URL up and running in a "running" controller we should use an integration test instead for faster development (devinavery, 15:52:15)
    3. will #action next steps (devinavery, 15:52:27)
    4. ACTION: Neel_B should try running the sample-toaster-it project in the controller source code, to get a feel for how it runs. (devinavery, 15:53:05)
    5. ACTION: Neel_B should then copy to project to his projects so we can modify it (devinavery, 15:53:25)
    6. ACTION: Neel_B should now modify his copy of the integration test to do the minimal amount of work (for example, comment out all comments in the "testToaster" methods) and add in a simple Print line to understand how integration test flow works (devinavery, 15:55:09)
    7. ACTION: Neel_B should then try to import the DOMDataBroker service using the the @Inject method (hopefully all dependencies are already being pulled in). (devinavery, 15:56:52)
    8. ACTION: Neel_B now has a functioning DOMDataBroker installed. Neel_B should use that to first insert a simple toaster and then use it to experiment with how we might merge the element and read interfaces of MD-SAL (devinavery, 15:57:48)
    9. ACTION: Neel_B: Note, Neel_B may want to import the DataBroker (which is the "binding" version to create the toaster information as is done in the toaster provider code. May prove to be easier.) (devinavery, 15:58:31)
    10. The idea in general is to take the toaster iteration test bundle as a starting point, then modifying it a step at a time to test what we want. I think you will only need to comment out the code in the method annotated with the @Test annotation (devinavery, 16:02:06)


Meeting ended at 16:03:41 UTC (full logs).

Action items

  1. Neel_B should try running the sample-toaster-it project in the controller source code, to get a feel for how it runs.
  2. Neel_B should then copy to project to his projects so we can modify it
  3. Neel_B should now modify his copy of the integration test to do the minimal amount of work (for example, comment out all comments in the "testToaster" methods) and add in a simple Print line to understand how integration test flow works
  4. Neel_B should then try to import the DOMDataBroker service using the the @Inject method (hopefully all dependencies are already being pulled in).
  5. Neel_B now has a functioning DOMDataBroker installed. Neel_B should use that to first insert a simple toaster and then use it to experiment with how we might merge the element and read interfaces of MD-SAL
  6. Neel_B: Note, Neel_B may want to import the DataBroker (which is the "binding" version to create the toaster information as is done in the toaster provider code. May prove to be easier.)


Action items, by person

  1. Neel_B
    1. Neel_B should try running the sample-toaster-it project in the controller source code, to get a feel for how it runs.
    2. Neel_B should then copy to project to his projects so we can modify it
    3. Neel_B should now modify his copy of the integration test to do the minimal amount of work (for example, comment out all comments in the "testToaster" methods) and add in a simple Print line to understand how integration test flow works
    4. Neel_B should then try to import the DOMDataBroker service using the the @Inject method (hopefully all dependencies are already being pulled in).
    5. Neel_B now has a functioning DOMDataBroker installed. Neel_B should use that to first insert a simple toaster and then use it to experiment with how we might merge the element and read interfaces of MD-SAL
    6. Neel_B: Note, Neel_B may want to import the DataBroker (which is the "binding" version to create the toaster information as is done in the toaster provider code. May prove to be easier.)


People present (lines said)

  1. Neel_B (41)
  2. devinavery (36)
  3. colindixon (18)
  4. odl_meetbot (5)
  5. regXboi (1)


Generated by MeetBot 0.1.4.