15:39:29 <colindixon> #startmeeting jQuery/XPath for MD-SAL intern
15:39:29 <odl_meetbot> Meeting started Mon Jul 14 15:39:29 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:39:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:39:29 <odl_meetbot> The meeting name has been set to 'jquery_xpath_for_md_sal_intern'
15:39:34 <colindixon> #topic status update
15:39:46 <colindixon> #info Neel_B is fighting a connection refused issue (see mails)
15:40:13 <colindixon> #info it’s not clear exactly what’s causing it, but the current hypothesis is that it’s Neel_B’s prox service provider and he has a mail into the system admin
15:43:15 <Neel_B> i have gone through the tutorial
15:44:29 <colindixon> #info Neel_B did go through creating the MD-SAL archetype
15:44:36 <colindixon> did you push the code to github?
15:46:28 <Neel_B> yeah jquery-mdsal is there already
15:47:05 <Neel_B> i have an app ready
15:47:42 <Neel_B> with DOMDataBroker initialized
15:47:48 <colindixon> cool
15:47:54 <colindixon> #topic next steps
15:48:18 <colindixon> so, I think the next steps (annoyingly) are to proceed without the integration tests
15:49:00 <Neel_B> give me a walk through
15:49:51 <colindixon> yeah… so this is where I’d really like to have devinavery (who we’ll get in 10 minutes or so)
15:50:12 <Neel_B> okay no problem i can wait
15:51:10 <colindixon> :-/ working without the ability to use pax exam to get deterministic data into the MD-SAL is going to make things much harder
15:52:17 <devinavery> Sorry guys. Will be 10 minutes as ~Colin says. If you can summarize the ask of me that will help speed things up as I need to leave in 40 minutes anways. :)
15:55:27 <colindixon> devinavery: so, the basic issues are:
15:55:28 <colindixon> (i) PAX exam seems to be a no-go at the moment for Neel_B b/c of connection refused issues
15:58:58 <colindixon> (ii) while we debug that, we probably want to come up wtih some way to make progress
15:59:19 <colindixon> (iii) to do that probably involves some combination of defining tests and function prototypes
16:02:30 * regXboi finding email
16:03:52 <colindixon> so, Neel_B, have you ever run mininet?
16:06:54 <regXboi> colindixon: looking at the connect failure, do we know *which* port we are trying to connect to and failing on?
16:07:14 <colindixon> I was trying to get Neel_B to give me that answer
16:07:25 <Neel_B> yeah i have run
16:07:27 <colindixon> Neel_B: did you get a port/hostname/IP for that connection failure?
16:07:30 <Neel_B> but on another vm
16:07:47 <devinavery> Thanks Colin. So for #1. I would ask Neel this - if you comment out all of calls in @Test method, and just leave a System.out.println, does it still bomb? It looks like the set up or something with pax-exam at the low level is failing. So I agree, we will have to continue this discussion on e-mail.
16:08:42 <devinavery> For #2 I agree. We we can deploy a real controller and just create a dummy RPC method for now to call our "test" code.
16:08:55 <devinavery> #3 - agreed.
16:09:09 <Neel_B> no
16:09:29 <Neel_B> simple printstatement also gives me the same error
16:09:38 <colindixon> #info devinavery is curious if we can get something with the toaster IT to work if we comment out everything in the @Test methods but a few System.out.println methods to see if things work
16:09:55 <devinavery> Ok. If you do the same thing to the configuration methods do you get the same error?
16:10:21 * regXboi thinks the paxexam port is 8181
16:10:34 * regXboi wonders if its worth looking to see if anything is listening there
16:10:48 <devinavery> regXboi: does pax-ex go external to download bundles if it needs them?
16:11:13 <Neel_B> yeah commenting out configuration method also gives the same error
16:11:15 <regXboi> devinavery: don't know - I'm not that familiar with pax-ex
16:12:31 <colindixon> #action colindixon to send e-mail to controller-dev asking about using pax-exam and why we might get these connection refused errors
16:12:37 <devinavery> regXboi: ok
16:12:40 <regXboi> but I did find a footnote that indicates it tries to pull from net rather than local
16:12:47 <regXboi> or at least it appears to
16:12:48 <colindixon> Neel_B: to do that I *need* to know the port/username/IP that things are failing for you on
16:13:36 <colindixon> #info Neel_B says that he’s getting the same connecton failure exception regardless of how much he tries to comment out in getting the toaster IT up
16:14:05 <Neel_B> i've got nothing
16:14:19 <Neel_B> i sen't you screenshots of what i see
16:14:35 <colindixon> Neel_B: I think there’s going to be some log information above the first screenshot you have
16:14:38 <colindixon> but maybe not
16:15:09 <Neel_B> no the log has the same thing we saw in text and xml format
16:15:10 * regXboi wonders if we specify bundles via references we can keep them local
16:15:30 <colindixon> as a short-term thing for Neel_B to work on, Neel_B what we want is a way to have an MD-SAL RPC that calls the test code we’ve written so far
16:15:58 <devinavery> I just saw a reference that pax-exam tries to connect to itself on port 8181 as regXboi pointed out
16:16:10 <devinavery> And it also uses a randomly generate port too...
16:16:28 <devinavery> In your linux box, do you have your local host name set up in the /etc/host file?
16:16:44 <devinavery> It may be going out to your proxy server if the local names can't be resolved for some reason..
16:17:18 <devinavery> Guys - I need to head out. I will respond with some more questions re-pax-exam.
16:17:20 <devinavery> Thanks
16:17:28 <colindixon> devinavery: no worries, thanks
16:18:10 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Toaster_Step-By-Step this is a long (and good) walkthrough of the toaster from devinavery and others
16:18:55 <Neel_B> okay
16:19:00 <Neel_B> i will go through
16:19:15 <Neel_B> that
16:19:25 <colindixon> #info I think that replacing the the make toast RPC with a call tests RPC and wiring that to the tests we’ve already written so far
16:19:32 <colindixon> #info would be a good exercise
16:20:08 <Neel_B> devinavery: the hostname is set properly
16:20:14 <colindixon> #action Neel_B to go through the toaster step-by-step and try to replace one of the RPCs with a call to the tests we wrote before, i.e., Testcases.java
16:20:37 <colindixon> Neel_B: what about /etc/hosts?
16:20:48 <colindixon> does that have an entry for localhost
16:20:49 <colindixon> ?
16:21:03 <regXboi> colindixon: replace? or add "testToast" as an RPC?
16:21:05 <Neel_B> yeah
16:21:07 <Neel_B> it has
16:21:14 <colindixon> regXboi: either one in my mind
16:21:16 <colindixon> Neel_B: ok
16:21:20 <regXboi> colindixon: ok
16:21:27 * regXboi worries about the random port
16:21:55 <colindixon> regXboi: yeah
16:22:35 <colindixon> so, for now, I think that working your way through the toaster example and then trying to add your own RPC (or modify the existing one) to be able to call our test code would be the best thing Neel_B can work on
16:22:54 <Neel_B> okay
16:23:12 <regXboi> agreed
16:23:27 <colindixon> Neel_B: you can let us know if you hit any snags there and we’ll touch base again
16:23:32 <colindixon> Neel_B: do you want to meet again tomorrow?
16:23:52 <Neel_B> we will decide that on mails
16:23:56 <colindixon> ok
16:24:04 <colindixon> #topic next meeting
16:24:25 <Neel_B> i guess tutorials will give me quite an experience
16:24:27 <colindixon> #info Neel_B will e-mail progress out before tomorrow evening (for him) so that we can decide if we need to meet or not
16:24:33 <colindixon> Neel_B: yeah
16:24:37 <colindixon> this should be good
16:24:44 <colindixon> ok
16:24:51 <Neel_B> yeah will ask out through mails or irc
16:24:59 <colindixon> we’ll leave you to that and you can reach out via mail or IRC
16:25:00 <colindixon> yup
16:25:06 <colindixon> #endmeeting