16:02:46 <colindixon> #startmeeting jQuery/XPath for MD-SAL intern
16:02:46 <odl_meetbot> Meeting started Mon Jul 28 16:02:46 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:46 <odl_meetbot> The meeting name has been set to 'jquery_xpath_for_md_sal_intern'
16:02:55 <colindixon> #topic status update
16:03:23 <colindixon> #info Neel_B says he’s fixed his pax-exam proxy issues :-)
16:03:33 <regXboi> I missed the email - what was the problem?
16:04:34 <colindixon> I’m not sure
16:04:38 <colindixon> and Neel_B seems to be afk
16:04:48 <colindixon> he just messaged me this morning to say that
16:05:19 <colindixon> my guess is that it was his proxy (I thnk most internet in India winds up having a proxy—or I’m guessing that based on things)
16:05:57 <regXboi> ah
16:07:45 <colindixon> so, regXboi, did you play around with pax-exam at all?
16:07:51 <colindixon> I know that was devin’s stuff
16:07:56 <djx> colindixon
16:08:06 <colindixon> djx: yup?
16:08:13 <djx> ups are you guys on a meeting?
16:08:38 <colindixon> djx: sort of, but it’s fine
16:08:48 <regXboi> no - i've not played with pax-exam
16:10:50 <colindixon> neither have I
16:11:06 <regXboi> to quote kyle: #sadpanda
16:12:04 <colindixon> no kidding
16:12:43 <colindixon> regXboi: since Neel_B seems to not be around, maye we just break here
16:12:48 <Neel_B> sorry
16:12:52 <Neel_B> just back
16:12:53 <colindixon> ok
16:12:55 <colindixon> hey Neel_B
16:13:19 <Neel_B> some of the maven plugins don't use
16:13:19 <colindixon> so, Neel_B you have the toaster-it building successfully?
16:13:27 <Neel_B> maven proxy
16:13:44 <Neel_B> so connection refused error
16:13:51 <colindixon> #info the issue seems to have been that some of the maven plugins don’t use the maven proxy settings as you’d like them to
16:14:00 <colindixon> Neel_B: and how did you fix it?
16:14:08 <Neel_B> http://stackoverflow.com/questions/1251192/how-do-i-use-maven-through-a-proxy last answer
16:14:24 <Neel_B> google failed me but bing got me the answer
16:14:35 <colindixon> #link http://stackoverflow.com/questions/1251192/how-do-i-use-maven-through-a-proxy the last answer here was what fixed it for Neel_B
16:14:37 <colindixon> perfect
16:14:56 <colindixon> so, the next step would be to modify the toaster-it to run your testcases as well
16:15:12 <Neel_B> yeah
16:15:15 <colindixon> adn then we can factor it apart into a md-sal-xpath-it or something
16:15:25 <colindixon> Neel_B: and is that what you’re working on?
16:15:30 <colindixon> #topic next steps
16:16:02 <Neel_B> i got DomDataBroke instantiated
16:16:06 <regXboi> colindixon: we need to reflect that link back to others in controller
16:16:15 <colindixon> regXboi: yup
16:16:36 <colindixon> #action colindixon to reply to his own thread on the controller-dev list aobut using maven through a proxy with that link
16:16:44 <colindixon> Neel_B: cool
16:16:59 <colindixon> #link https://meetings.opendaylight.org/opendaylight-intern/2014/jquery_xpath_for_md_sal_intern/opendaylight-intern-jquery_xpath_for_md_sal_intern.2014-07-10-15.10.html the next steps from this earlier meeting should now be things we can get moving
16:17:05 <regXboi> +1 to colindixon's statement - very cool
16:17:15 <regXboi> I agree
16:17:48 <colindixon> so, Neel_B where are you on going through the suggestions from that meeting? (the one I just linked)
16:17:49 <colindixon> and are there things that regXboi and I can help with?
16:18:14 <Neel_B> i will be up all night
16:18:24 <Neel_B> will keep pinging you
16:18:27 <Neel_B> if required
16:18:30 <colindixon> Neel_B: :p
16:18:31 <colindixon> ok
16:18:39 <colindixon> I will be occasioanlly slow to respond
16:18:45 <regXboi> I
16:18:47 <regXboi> er I
16:18:50 <regXboi> ack
16:18:59 <colindixon> but I should be around
16:19:06 <regXboi> er I'll be around as well - but definitely in and out - fighting a couple of deadlines here
16:19:14 <colindixon> so, where are you at this point Neel_B in terms ogetting things to work?
16:19:25 <colindixon> no judgement is intended there, just curious
16:19:48 <colindixon> my guess is here: “Neel_B should now modify his copy of the integration test to do the minimal amount of work (for example, comment out all comments in the "testToaster" methods) and add in a simple Print line to understand how integration test flow works”
16:19:58 <Neel_B> commented out the @test and put print in it
16:20:08 <Neel_B> the print is fine
16:20:25 <Neel_B> studying how the test flow works
16:20:30 <Neel_B> exaclty
16:20:31 <colindixon> perfect
16:21:30 <colindixon> #info Neel_B has the toaster-it running, has commented all the testToaster methods out and added a simple print statement so he knows things are running with his modified code
16:22:18 <colindixon> #info the next two actions are verbatim copied from the 2014-07-10 meeting above
16:22:32 <colindixon> #action Neel_B should then try to import the DOMDataBroker service using the the @Inject method (hopefully all dependencies are already being pulled in).
16:22:41 <colindixon> #action Neel_B now has a functioning DOMDataBroker installed. Neel_B should use that to first insert a simple toaster and then use it to experiment with how we might merge the element and read interfaces of MD-SAL
16:22:49 <colindixon> #action Neel_B: Note, Neel_B may want to import the DataBroker (which is the "binding" version to create the toaster information as is done in the toaster provider code. May prove to be easier.)
16:23:27 <regXboi> :)
16:23:41 <colindixon> #info when we start writing tests, it might be useful compare XPath with our special nodes to XPath on the actual MD-SAL nodes that are converted to a Document
16:23:43 <Neel_B> ok
16:25:52 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/8975/6/ttp-model/model/src/test/java/org/opendaylight/ttp/model/test/TTPYangModelTest.java line 124 of this file shows how to get a Document from a DataObject (Toaster should be a DataObject if we’re using the binding interfaces)
16:25:59 * colindixon goes to look at the toaster interface
16:29:01 <colindixon> ok
16:29:15 <colindixon> so Neel_B I’d try to get the toaster out using the DataBroker interface
16:29:20 <colindixon> let me see if I can just import that
16:30:03 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/md/sal/common/api/data/AsyncDataBroker.html this is the better documented way to get data into and out of the MD-SAL
16:43:32 <colindixon> Neel_B: were you able to get teh @Inject for the data broker to work?
16:43:51 <Neel_B> no didn't try
16:43:59 <colindixon> ok
16:44:15 <Neel_B> what does @inject do ?
16:45:24 <regXboi> colindixon: note: discussing neutron and opencontrail over in #opendaylight
16:45:44 <colindixon> interesting
16:45:58 <colindixon> Neel_B: ok I tried a bit, but it failed I’m trying again
16:46:25 <colindixon> the relevant bits should be to add this near the other @Inject
16:46:36 <colindixon> @Inject
16:46:36 <colindixon> @Filter(timeout=60*1000)
16:46:37 <colindixon> DataBroker dataBroker;
16:46:48 <colindixon> and then do something like this in the test:
16:47:00 <colindixon> InstanceIdentifier<Toaster> iidToaster = InstanceIdentifier.builder(Toaster.class).build();
16:47:00 <colindixon> ReadOnlyTransaction readTx = dataBroker.newReadOnlyTransaction();
16:47:02 <colindixon> //TODO: we might need to change LogicalDatastoreType.CONFIGURATION to LogicalDatastoreType.OPERATIONAL
16:47:03 <colindixon> ListenableFuture<Optional<Toaster>> read = readTx.read(LogicalDatastoreType.CONFIGURATION, iidToaster);
16:47:04 <colindixon> readTx.close();
16:47:05 <colindixon> Toaster t = read.get().get();
16:47:06 <colindixon> System.out.println("Got the toaster t:"+t);
16:47:15 <colindixon> but it may or may not work
16:47:45 <colindixon> #info ahead of this note in the full log are code snippets which should hopefully allow Neel_B to get his hands on a toaster from the MD-SAL
16:48:05 <colindixon> #topic next meeting time and following up
16:48:32 <Neel_B> through mails ?
16:48:48 <colindixon> #info we’ll plan the next meeting through mail
16:48:58 <Neel_B> or tomorrow/day-after  same time ?
16:49:11 <Neel_B> mail seems best
16:50:10 <colindixon> #info lets plan to touch base for at least a few minutes in this time slot tomorrow though (11a–12p central/9:30–10:30p India)
16:50:57 <colindixon> Neel_B: but I’ll be online from 8:30a on tomorrow my time (7p India I think)
16:51:02 <colindixon> #endmeeting