14:11:26 <colindixon> #startmeeting jQuery/Xpath for MD-SAL intern
14:11:26 <odl_meetbot> Meeting started Thu Jul 31 14:11:26 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:11:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:11:26 <odl_meetbot> The meeting name has been set to 'jquery_xpath_for_md_sal_intern'
14:11:43 <colindixon> #info Neel_B is getting a toaster from the pax-exam toaster-it by injecting the DataBroker
14:11:47 <colindixon> #info Neel_B is trying to use DOMDataBroker in the same way, but the DOMDataBroker is null
14:11:52 <colindixon> #topic brainstorming
14:12:00 <colindixon> #info so, data in the MD-SAL is stored two ways: (i) as DataObjects which are actually java Objects that have normal methods and stuff and (ii) as things called CompositeNodes which are basically like DOM Nodes
14:12:26 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-merge/lastSuccessfulBuild/artifact/target/apidocs/org/opendaylight/controller/md/sal/dom/api/DOMDataBroker.html the DOMDataBroker API
14:19:40 <colindixon> #info as a stopgap, you can convert from DataObject which is what you’re getting to a CompositeNode by either injecting a BindingIndependentMappingService or creating a local RuntimeGeneratedMappingServiceImpl and then using it’s toDataDom() method on the Toaster you get out
14:21:10 <Neel_B> okay some snippet may help
14:22:16 <colindixon> #link https://git.opendaylight.org/gerrit/gitweb?p=ttp.git;a=blob;f=ttp-model/model/src/test/java/org/opendaylight/ttp/model/test/TTPYangModelTest.java;hb=47f6704b0c4ba1742b68d6c37bd1402f4918fb82 you can see an example here
14:24:12 <Neel_B> i figured out
14:24:22 <colindixon> sure
14:24:33 <Neel_B> i used BindingIndependentMappingService
14:24:39 <colindixon> and did that work?
14:24:58 <Neel_B> and did
14:25:12 <Neel_B> CompositeNode node = mappingService.toDataDom(t);
14:25:13 <Neel_B> ?
14:25:18 <Neel_B> t is the toaster
14:25:54 <colindixon> yeah
14:26:04 <colindixon> that will give you a CompositeNode
14:26:16 <colindixon> which should be loosely equivalent to a DOM Element I think
14:26:50 <Neel_B> then i created domwriteonly transaction
14:29:03 <Neel_B> the composite node is null :\
14:31:20 <Neel_B> colindixon: you aroud ?
14:31:31 <colindixon> hold on one second
14:32:03 <colindixon> huh
14:32:06 <colindixon> that’s weird
14:32:13 <colindixon> what happens if you use the functions at the top of what I sent you
14:32:23 <colindixon> or copy them
14:32:42 <colindixon> to create a RuntimeGeneratedMappingServiceImpl and then initialize it with a SchemaContext
14:33:13 <Neel_B> actually mappedService mught be null
14:33:25 <Neel_B> any way to initiaize it ?
14:35:33 <Neel_B> trying out the thins in the link
14:39:11 <Neel_B> getSchemaContext() ?
14:40:33 <Neel_B> colindixon:  ?
14:40:52 <colindixon> go look at what I did in the TTPYangModelTest
14:40:55 <colindixon> that should give you the answers
14:43:08 <colindixon> loosely the stuff in the @Before setup() method and the functions and it uses
14:44:27 <Neel_B> that function isnot available ?
14:44:35 <Neel_B> i have to import some where
14:49:41 <colindixon> you should be able to import it the same way as I did
14:49:48 <colindixon> yo might have to add a dependency in the pom for the right bundle
14:50:23 <Neel_B_> yeah trying to do that
14:51:09 <colindixon> hold on and I can see what bundle you need to import
14:51:26 <colindixon> probably bundles
14:51:37 <colindixon> so what are packages are you missing?
14:51:44 <colindixon> that’s usually the easiset way to figure this out
14:51:48 <colindixon> or what classes
14:52:27 <colindixon> (and just be clear, you’re copying the setup() and getSchema() and pasting them into your thing, not trying to call them from where they are, right?)
14:53:37 <Neel_B_> i used @inject to get
14:53:48 <Neel_B_> the schema and mappingservice variable
14:56:03 <colindixon> and did that work?
14:56:08 <colindixon> because I think not
14:58:15 <Neel_B_> that was null
14:58:22 <colindixon> yeah
14:58:45 <Neel_B_> so i was writing the same that you wrote in the file
14:58:45 <colindixon> so, I think you’re going to want to do it like I did in the TTPYangModelTest
14:59:10 <Neel_B_> except that getSchemaContext() was not avaliable
15:00:08 <colindixon> yeah
15:00:17 <colindixon> so copy and paste that function as well for now
15:01:07 <regXboi> am I late?  my calendar came up now...
15:03:54 <Neel_B_> just casuual discussion
15:04:04 <Neel_B_> thought worth writing notes so
15:04:26 <Neel_B_> we will have meeting on monday after this
15:04:56 <colindixon> yeah
15:04:58 <colindixon> sounds good
15:05:54 <Neel_B_> building
15:08:25 <colindixon> https://meetings.opendaylight.org/opendaylight-intern/2014/jquery_xpath_for_md_sal_intern/opendaylight-intern-jquery_xpath_for_md_sal_intern.2014-07-31-14.11.log.txt
15:08:30 <colindixon> regXboi: those are the logs so far
15:09:54 * regXboi reads
15:11:17 <regXboi> I've got nothing to add :(
15:12:03 <colindixon> regXboi: sure
15:12:08 <Neel_B_> context isnot building
15:12:11 <colindixon> Neel_B_: let me know how that works
15:12:14 <colindixon>15:12:17 <regXboi> error message?
15:12:19 <colindixon> do you have an error?
15:12:26 <colindixon> it *does* work in the TTP project
15:14:27 <Neel_B_> http://pastebin.com/me1tqDtr
15:16:14 <colindixon> regXboi: ideas?
15:16:49 <Neel_B_> moduleInfos = BindingReflections.loadModuleInfos();
15:16:54 <Neel_B_> error at this line
15:18:20 <Neel_B_> hi devinavery  :)
15:18:42 <colindixon> wow devinavery, you’re supposed to be on PTO
15:19:02 <devinavery> Hi Neel - sorry. I am not really here. :) I am on leave until next week - we just had a son a week ago and still trying to get back to some level of sane
15:19:03 <devinavery> :)
15:19:14 <regXboi> that is a strange error
15:19:18 <colindixon> devinavery: congrats 1000 times and git off
15:19:21 <colindixon> get off :p
15:19:24 <devinavery> colindixon: yea. First time turning on computer - IRC was still up. :)
15:19:29 <devinavery> See ya
15:19:40 <regXboi> colindixon: +1
15:19:46 <devinavery> Back next wednesday on a limited basis so if anytime comes up send an e-mail. I will see you all then
15:19:48 <regXboi> devinavery: go away!!!
15:20:23 <regXboi> the only thing that I can think of is are you both at the same point in the git stream?
15:21:46 <Neel_B_> https://github.com/neel1438/Opendaylight
15:21:48 <Neel_B_> code updated
15:21:55 <Neel_B_> please look
15:24:06 * regXboi looking
15:26:49 <regXboi> yes, I got the same problem
15:27:34 <regXboi> colindixon: can you pull that code base and see if you have the same problem as well?
15:27:47 <colindixon> colindixon: where isthe code from?
15:27:54 <regXboi> https://github.com/neel1438/Opendaylight
15:28:00 <regXboi> #link https://github.com/neel1438/Opendaylight
15:29:42 <colindixon> ok
15:29:49 <colindixon> duh
15:29:52 <colindixon> let me go nabit
15:29:59 <regXboi> sure
15:33:54 <colindixon> Neel_B_: is the version before this working
15:37:17 <Neel_B_> ill eat and comeback  ...
15:37:23 <colindixon> Neel_B_: sounds good
15:37:31 <colindixon> no worries just trying to help as best I can
15:47:07 <regXboi> colindixon: did you hit the same error
15:48:56 <regXboi> and I'm wondering if this is a problem with the latest version of the ietf yang model?!?!?!
15:49:16 <colindixon> regXboi: I did
15:51:43 <colindixon> yeah I don’t think that’s it
15:53:11 <colindixon> #link http://pastebin.com/me1tqDtr the code with the link above is failing with this error :-/
15:54:24 <regXboi> I think we may need to get Jan/Tony to help with this one
15:54:31 <regXboi> because there isn't anything i'm seeing
16:04:31 <colindixon> #char regXboi
16:04:35 <colindixon> #chair regXboi
16:04:35 <odl_meetbot> Current chairs: colindixon regXboi
16:04:42 <colindixon> in case I wander off, you can end the meeting
16:04:51 <colindixon> regXboi: I haven’t had a chance to play with it yet
16:04:59 <regXboi> ok
16:05:23 * colindixon starts playing :p
16:05:28 <colindixon> regXboi: sooooooooo many things
16:06:41 <regXboi> colindixon: I can imagine
16:10:37 <colindixon> #info I *think* the issue is that you can’t use BindingReflections.loadModuleInfos() from an OSGi environment
16:11:02 <colindixon> #info you have get the BindingIndependentMappingService from as an OSGi service
16:12:39 <regXboi> Neel_B: can you try that?
16:13:45 <colindixon> #info Neel_B_: did you try putting the “@Inject” and “@Filter(timeout=60*1000)” as annotations above the other lines, e.g., “DOMDataBroker domDataBroker;”, “BindingIndependentMappingService mappingService;”, and “SchemaContext context;” to see if that worked?
16:15:20 <colindixon> I have it working
16:15:27 <colindixon> #info I tried that and it worked
16:20:40 <regXboi> colindixon: pastebin of the fixed code?
16:21:07 <colindixon> #link https://github.com/nilok/Opendaylight/commit/608a6fb2fcb6785bd4effa6a19d3cf416d2b7955 the code is here, I’ll issue a pull request
16:22:00 <colindixon> #info just look for the ToasterTest.java file in that mess
16:22:06 <colindixon> I also cleaned some things up :-/
16:27:13 <regXboi> #info regXboi confirms that works
16:59:10 <regXboi> #action to ping Neel_B and make sure he's made the changes colindixon has suggested
16:59:14 <regXboi> #endmeeting