#opendaylight-intern: jQuery/XPath for MD-SAL intern

Meeting started by colindixon at 13:30:45 UTC (full logs).

Meeting summary

  1. status update (colindixon, 13:30:50)
    1. https://github.com/neel1438/Opendaylight/ latest code is here (colindixon, 13:34:06)
    2. https://meetings.opendaylight.org/opendaylight-intern/2014/jquery_xpath_for_md_sal_intern/opendaylight-intern-jquery_xpath_for_md_sal_intern.2014-08-11-13.30.log.txt (colindixon, 13:35:58)
    3. colindixon will be on paternity leave from 8/15 to 9/1 (so my last day will be 8/14 and I’ll be back on 9/2) (colindixon, 13:38:36)
    4. the new patch has an empty NewElement class which is just stubs for the interface Element and NodeBuilderElement which appears to be the start of something that we could wrap around a NormalizedNode (colindixon, 13:47:07)

  2. next steps (colindixon, 13:56:38)
    1. ACTION: Neel_B should rework NodeBuilderElement to instead be backed by a single NormalizedNode, which is passed in via the constructor (colindixon, 13:57:17)
    2. https://gist.github.com/nilok/0fd811199aa4d71d3c14 this is NormalizedNode (colindixon, 14:02:56)
    3. we’re not 100% sure what to return for getNodeName(), but for now using NormalizedNode’s getIdentifier().toString() [later, we’ll trim it to be more readable] (colindixon, 14:10:11)
    4. for textContent, regXboi says “if getValue() is an iterator, set it to null, otherwise set it to getValue().toString” (colindixon, 14:10:57)

  3. dealing with children/siblings (colindixon, 14:11:53)
    1. there was a lot of discussion about how to build children/siblings, but for now devinavery returns us to sanity and says let’s just focus on toaster (colindixon, 14:33:29)

  4. next meeting and expectations (colindixon, 14:33:43)
    1. I think that the expectations is that Neel will have the new Element that uses the NormalizedNode to back it (colindixon, 14:34:18)
    2. and will have tested that with some really simple XPath query to see if it fails (colindixon, 14:34:53)
    3. ideally, Neel_B would debug any failures and try to fix them, but if he can’t, we’ll help based on what we’ve learned (colindixon, 14:35:53)
    4. http://www.timeanddate.com/worldclock/meetingdetails.html?year=2014&month=8&day=12&hour=15&min=0&sec=0&p1=43&p2=24&p3=505&iv=1800 we’ll plan on having the next meeting at this time (10a central, 11a eastern, 8:30p india) (colindixon, 14:40:39)


Meeting ended at 14:41:08 UTC (full logs).

Action items

  1. Neel_B should rework NodeBuilderElement to instead be backed by a single NormalizedNode, which is passed in via the constructor


Action items, by person

  1. Neel_B
    1. Neel_B should rework NodeBuilderElement to instead be backed by a single NormalizedNode, which is passed in via the constructor


People present (lines said)

  1. colindixon (100)
  2. regXboi (65)
  3. Neel_B (57)
  4. devinavery (32)
  5. odl_meetbot (3)


Generated by MeetBot 0.1.4.