#opendaylight-intern: jQuery/XPath for MD-SAL intern

Meeting started by devinavery at 13:36:34 UTC (full logs).

Meeting summary

    1. Neel_B uploaded new code for review. (devinavery, 13:36:58)
    2. Neel has some questions on how to implement siblings in the new normalized node. (devinavery, 13:39:39)
    3. Neel also commented that he had to use a local variable to hold the child nodes instead of calculating them on the fly (devinavery, 13:40:08)
    4. http://pastebin.com/RaG1d5AA (devinavery, 14:05:02)
    5. http://pastebin.com/RaG1d5AA Quick psudo code showing possible way to handle "next sibling" on the fly (devinavery, 14:06:28)
    6. devinavery posted psudo code for algorithm which *might* work to calculate the next sibling on the fly (link above). The idea is that you pass the iterator along to each child as get next sibling is called, which allows it to construct the next sibling on the fly. (devinavery, 14:07:45)
    7. Would need some serious unit testing ( which we would need anyways) to verify this works as desired. But seems plausible to me (devinavery, 14:08:11)
    8. Neel_B is trying out - has some clarifying questions (see full text log for specific discussion) (devinavery, 14:51:37)
    9. ACTION: Neel_B will attempt change and will upload code. Devinavery will review later and send e-mail to follow up (devinavery, 15:02:45)
    10. ACTION: - devinavery send out notes and invite to next meeting on IRC - same time tomorrow (devinavery, 15:03:10)


Meeting ended at 15:04:57 UTC (full logs).

Action items

  1. Neel_B will attempt change and will upload code. Devinavery will review later and send e-mail to follow up
  2. - devinavery send out notes and invite to next meeting on IRC - same time tomorrow


Action items, by person

  1. devinavery
    1. Neel_B will attempt change and will upload code. Devinavery will review later and send e-mail to follow up
    2. - devinavery send out notes and invite to next meeting on IRC - same time tomorrow
  2. Neel_B
    1. Neel_B will attempt change and will upload code. Devinavery will review later and send e-mail to follow up


People present (lines said)

  1. devinavery (43)
  2. Neel_B (32)
  3. odl_meetbot (4)


Generated by MeetBot 0.1.4.