#opendaylight-intern: jquery_xpath_for_md_sal_intern

Meeting started by devinavery at 13:39:04 UTC (full logs).

Meeting summary

  1. status (devinavery, 13:39:14)
    1. Devin sent e-mail with suggested next high level steps. Copying here for quick reference (devinavery, 13:40:13)
    2. 1.Change the unit tests to use the correct syntax etc. For example as we discussed �.� returns a node which is converted to a string some how which we then compare to �toaster�. In this case we really want the name of the node returned by �.� and should adjust our xpath as such �name(.)�. (devinavery, 13:40:49)
    3. 2. Do the same thing with the other evaluations (except in those cases you are looking for text). (devinavery, 13:41:00)
    4. 3. Once those tests are passing, we then need to define a new yang file which has multiple nested levels in it. I suggest taking the toaster yang file and modifying it to add multiple nested levels such as inner containers and lists. (note: A better idea might be to define a yang file that we could get to match our XML that we tested with originally in our hardcoding world. Either way, we need to start testing n (devinavery, 13:41:19)
    5. Create new unit tests to test this new functionality. (devinavery, 13:41:33)
    6. Make the code more robust and try to more closely mimic dom output etc. For example, I think if you were to return a string when querying �.� you would get combined output of everything below it. (devinavery, 13:41:48)
    7. http://pastebin.com/dFCY49aK (Neel_B, 14:42:18)
    8. http://pastebin.com/TqHP4qcY (Neel_B, 14:55:51)
    9. http://pastebin.com/zf63LHtD (devinavery, 16:24:19)
    10. regXboi, devinavery and Neel found the problem - we need to introduce text nodes (devinavery, 16:36:44)
    11. ACTION: devinavery to send out code bundle that provides for pretty print of XML from MD-SAL nodes (regXboi, 16:37:04)
    12. ACTION: devinavery will send out the code he pulled in to make this work. (devinavery, 16:37:06)
    13. ACTION: Neel_B to pull that into his code base and then check tests (regXboi, 16:37:18)
    14. main trick is that we need text nodes to be children of leaf nodes. (devinavery, 16:37:29)
    15. ACTION: regXboi to figure out why he can't run Junit tests (regXboi, 16:37:29)
    16. ACTION: we meet on Monday to work the xpath side of things (regXboi, 16:37:41)


Meeting ended at 16:39:51 UTC (full logs).

Action items

  1. devinavery to send out code bundle that provides for pretty print of XML from MD-SAL nodes
  2. devinavery will send out the code he pulled in to make this work.
  3. Neel_B to pull that into his code base and then check tests
  4. regXboi to figure out why he can't run Junit tests
  5. we meet on Monday to work the xpath side of things


Action items, by person

  1. devinavery
    1. devinavery to send out code bundle that provides for pretty print of XML from MD-SAL nodes
    2. devinavery will send out the code he pulled in to make this work.
  2. Neel_B
    1. Neel_B to pull that into his code base and then check tests
  3. regXboi
    1. regXboi to figure out why he can't run Junit tests


People present (lines said)

  1. regXboi (142)
  2. devinavery (90)
  3. Neel_B (60)
  4. odl_meetbot (4)


Generated by MeetBot 0.1.4.