#opendaylight-intern: jquery_xpath_for_md_sal_intern

Meeting started by devinavery at 13:33:51 UTC (full logs).

Meeting summary

    1. Neel_B has modified the toaster.yang to include list elements. Updated test code and presently that test code is failing (devinavery, 13:39:04)
    2. https://gist.github.com/neel1438/fd92e4c5d673f29d01ca (Neel_B, 13:41:38)
    3. Neel_B has a question about how to access the nodes in a list. <Neel_B> if the node is instance of org.opendaylight.yangtools.yang.data.api.schema.UnkeyedListNode (devinavery, 13:58:55)
    4. part 2 of question: <Neel_B> how to get the individual element from it i.e individual normalized node (devinavery, 13:59:10)
    5. : Answer from devinavery: according to javadocs it should just be a call to the getValue() method on the interface. (devinavery, 14:00:47)
    6. https://gist.github.com/neel1438/fd92e4c5d673f29d01ca (Neel_B, 14:06:41)
    7. when dealing with lists, the getValue returns an object which has to be cast to RegularImmutableList which then can be iterated through (regXboi, 14:29:21)

  1. next steps (devinavery, 14:55:02)
    1. ACTION: Neel_B will get the list xpath code working and tests passing. (devinavery, 14:55:26)
    2. ACTION: Neel_B will clean up the code by removing trailing whitespace, replacing tabs with spaces, etc (devinavery, 14:55:57)
    3. ACTION: Neel_B will add java doc comments to code that exists so far to explain what classes are doing and to explain any complex methods etc (devinavery, 14:56:24)
    4. ACTION: Neel_B will then check code into ODL gerrit (be sure to put [DO NOT MERGE] in the commit message so it is not merged) (devinavery, 14:56:59)
    5. ACTION: devinavery to send some info to Neel_B with some simple examples of javadoc comments (devinavery, 14:57:27)
    6. When checking code in devinavery suggest two bundles - a source bundle and a test bundle under the following paths: controller/opendaylight/md-sal/query/xpath and controller/opendaylight-md-sal/query/xpath-it (devinavery, 14:58:25)
    7. http://www.oracle.com/technetwork/java/javase/documentation/index-137868.html Oracle java doc introduction (devinavery, 14:59:58)
    8. Neel_B can check out the above link which is oracles site on java doc. Lots of info there, but if you focus on the "Format of a Doc Comment" that should be enough to get you started (devinavery, 15:00:44)
    9. Next meeting at the same time tomorrow (already scheduled) (devinavery, 15:02:55)


Meeting ended at 15:02:58 UTC (full logs).

Action items

  1. Neel_B will get the list xpath code working and tests passing.
  2. Neel_B will clean up the code by removing trailing whitespace, replacing tabs with spaces, etc
  3. Neel_B will add java doc comments to code that exists so far to explain what classes are doing and to explain any complex methods etc
  4. Neel_B will then check code into ODL gerrit (be sure to put [DO NOT MERGE] in the commit message so it is not merged)
  5. devinavery to send some info to Neel_B with some simple examples of javadoc comments


Action items, by person

  1. devinavery
    1. devinavery to send some info to Neel_B with some simple examples of javadoc comments
  2. Neel_B
    1. Neel_B will get the list xpath code working and tests passing.
    2. Neel_B will clean up the code by removing trailing whitespace, replacing tabs with spaces, etc
    3. Neel_B will add java doc comments to code that exists so far to explain what classes are doing and to explain any complex methods etc
    4. Neel_B will then check code into ODL gerrit (be sure to put [DO NOT MERGE] in the commit message so it is not merged)
    5. devinavery to send some info to Neel_B with some simple examples of javadoc comments


People present (lines said)

  1. Neel_B (90)
  2. devinavery (84)
  3. regXboi (33)
  4. odl_meetbot (4)


Generated by MeetBot 0.1.4.