#opendaylight-intern: md-sal-query
Meeting started by regXboi at 13:30:34 UTC
(full logs).
Meeting summary
- 
  - devinavery has comments on how to get to a
    NormalizedNode via DOMDataBroker (regXboi,
    13:31:44)
- code pattern follows in text file (regXboi,
    13:31:59)
- and then wrapping the normalized node within
    Neel_B's xpath node interfaces (regXboi,
    13:33:07)
- full path to DomDataBroker is
    org.opendaylight.controller.md.sal.dom.api.DOMDataBroker
    (regXboi,
    13:50:49)
- only dependency in project on CompositeNode is
    unit test code. (regXboi,
    13:56:45)
- devinavery suggests to confer to
    NormalizedNode (regXboi,
    13:57:11)
- https://meetings.opendaylight.org/opendaylight-intern/2014/md_sal_query/opendaylight-intern-md_sal_query.2014-08-07-13.30.log.txt
    (regXboi,
    14:04:47)
- ACTION: Neel_B to
    create a new yang (or modify the toaster) to have a child list (so
    our tree has some depth). (devinavery,
    14:10:57)
- ACTION: Neel_B to
    then query that yang using the generic data broker, and iterate the
    NormalizedNode values to try and figure out how the nodes are nested
    etc. (devinavery,
    14:11:31)
- ACTION: Neel_B should
    look at NormalizedNode and the values returned, and start to
    document how we might map the NormalizedNode to the XPath interfaces
    that we discovered in earlier tests. (devinavery,
    14:12:45)
- ACTION: we'll meet
    again at the time in the next link (regXboi,
    14:14:43)
- http://www.timeanddate.com/worldclock/meetingdetails.html?year=2014&month=8&day=8&hour=13&min=30&sec=0&p1=24&p2=43&p3=505&p4=283&iv=1800
    (regXboi,
    14:14:47)
- We will meet again Friday Aug 8th, 9:30 EST,
    8:30 CST,  7P India (devinavery,
    14:15:07)
- ACTION: regXboi to
    send mail with minutes and next meeting link (regXboi,
    14:16:35)
 
Meeting ended at 14:16:38 UTC
(full logs).
Action items
  - Neel_B to create a new yang (or modify the toaster) to have a child list (so our tree has some depth).
- Neel_B to then query that yang using the generic data broker, and iterate the NormalizedNode values to try and figure out how the nodes are nested etc.
- Neel_B should look at NormalizedNode and the values returned, and start to document how we might map the NormalizedNode to the XPath interfaces that we discovered in earlier tests.
- we'll meet again at the time in the next link
- regXboi to send mail with minutes and next meeting link
Action items, by person
  -  Neel_B 
    - Neel_B to create a new yang (or modify the toaster) to have a child list (so our tree has some depth).
- Neel_B to then query that yang using the generic data broker, and iterate the NormalizedNode values to try and figure out how the nodes are nested etc.
- Neel_B should look at NormalizedNode and the values returned, and start to document how we might map the NormalizedNode to the XPath interfaces that we discovered in earlier tests.
 
-  regXboi 
    - regXboi to send mail with minutes and next meeting link
 
People present (lines said)
  - regXboi (44)
- devinavery (31)
- Neel_B (15)
- odl_meetbot (4)
- djx (2)
Generated by MeetBot 0.1.4.