#opendaylight-intern: md-sal-query

Meeting started by devinavery at 13:54:29 UTC (full logs).

Meeting summary

    1. Neel has the normalized node printing out as discussed on Aug 7th. (devinavery, 13:54:54)
    2. ex: Normalized Node is : ImmutableContainerNode{nodeIdentifier=(http://netconfcentral.org/ns/toaster?revision=2009-11-20)toaster, value=[ImmutableLeafNode{nodeIdentifier=(http://netconfcentral.org/ns/toaster?revision=2009-11-20)toasterStatus, value=up, attributes={}}, ImmutableLeafNode{nodeIdentifier=(http://netconfcentral.org/ns/toaster?revision=2009-11-20)toasterManufacturer, value=Opendaylight, attributes={}} (devinavery, 13:55:06)
    3. http://pastebin.com/mSX2kcHb (regXboi, 13:55:07)
    4. see link for full detail paste. (devinavery, 13:55:24)
    5. question is now how to access the members of the list in the value (regXboi, 13:55:27)
    6. devinavery thinks we should do type checking via instanceof (regXboi, 13:55:43)
    7. Neel found that we can use instance of to check the types of the values and convert them to ContainerNode, or LeafNode etc (devinavery, 14:22:47)
    8. ACTION: Next step is to wrap the NormalizedNode with the xpath interfaces to map the classes together. (devinavery, 14:24:54)
    9. for example a ContainerNode would map to children in the XPath interfaces. A leaf node would map to Xpath Leafs. (regXboi, 14:32:04)
    10. there is an outstanding question about sibling relationships (regXboi, 14:32:31)
    11. regXboi is concerned we may have to build sibling information on the fly :-( (regXboi, 14:33:36)
    12. ACTION: modify previous action: wrap the container and leaf nodes into Xpath and test to see if lists get handled correctly automagically (regXboi, 14:40:38)
    13. https://meetings.opendaylight.org/opendaylight-intern/2014/md_sal_query/opendaylight-intern-md_sal_query.2014-08-08-13.54.log.txt (regXboi, 14:50:41)
    14. ACTION: regXboi to send email with minutes and next meeting (regXboi, 15:00:27)


Meeting ended at 15:00:30 UTC (full logs).

Action items

  1. Next step is to wrap the NormalizedNode with the xpath interfaces to map the classes together.
  2. modify previous action: wrap the container and leaf nodes into Xpath and test to see if lists get handled correctly automagically
  3. regXboi to send email with minutes and next meeting


Action items, by person

  1. regXboi
    1. regXboi to send email with minutes and next meeting
  2. UNASSIGNED
    1. Next step is to wrap the NormalizedNode with the xpath interfaces to map the classes together.
    2. modify previous action: wrap the container and leaf nodes into Xpath and test to see if lists get handled correctly automagically


People present (lines said)

  1. regXboi (42)
  2. devinavery (33)
  3. Neel_B (31)
  4. odl_meetbot (5)
  5. colindixon (4)
  6. edwarnicke (1)


Generated by MeetBot 0.1.4.