#opendaylight-intern: ODL Intern Meeting (jQuery/XPath for MD-SAL)

Meeting started by colindixon at 13:10:59 UTC (full logs).

Meeting summary

    1. per devinavery’s suggestion, Neel_B has built a shim for the Document class to figure out what functions XPath queries actually use (colindixon, 13:11:37)
    2. https://github.com/neel1438/Opendaylight/ the code so far can be found here (colindixon, 13:12:13)
    3. it appears as though the query only uses functions found in org.w3c.dom.Node (colindixon, 13:12:52)
    4. ACTION: Neel_B is going to make a version of MyNode like the MyDocument just to make sure we understand what’s going on (colindixon, 13:16:48)
    5. the XPath query will accept just a Node (rather than a Document), so that will likely be an easier path to implementation (colindixon, 13:17:46)
    6. after that, devinavery suggests implementing a version of Node that is hardcoded to return a fixed set of XML (colindixon, 13:23:35)
    7. (see full log for more details) (colindixon, 13:23:47)
    8. Neel_B will also have to get some practice bringing up a provider class in the MD-SAL, which should be another step (colindixon, 13:42:53)
    9. we’ll plan to meet again tomorrow at 8a centra/9a eastern/6:30p india unless we agree to something else via e-mail (colindixon, 13:47:53)
    10. ACTION: devinavery to send out a slightly revised next steps plan including a step getting a simple MD-SAL provider up (colindixon, 13:48:27)
    11. sent updated list of recommended next steps with pointer to the ping example. I think we can use the AbstractBindingAwareProvider, and the customer Rest API for prototyping MD-SAL interactions (devinavery, 13:48:53)


Meeting ended at 13:54:20 UTC (full logs).

Action items

  1. Neel_B is going to make a version of MyNode like the MyDocument just to make sure we understand what’s going on
  2. devinavery to send out a slightly revised next steps plan including a step getting a simple MD-SAL provider up


Action items, by person

  1. devinavery
    1. devinavery to send out a slightly revised next steps plan including a step getting a simple MD-SAL provider up
  2. Neel_B
    1. Neel_B is going to make a version of MyNode like the MyDocument just to make sure we understand what’s going on


People present (lines said)

  1. colindixon (44)
  2. Neel_B (42)
  3. devinavery (23)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.