12:03:57 <colindixon> #startmeeting dependency tracking
12:03:57 <odl_meetbot> Meeting started Fri Jun 26 12:03:57 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
12:03:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:03:57 <odl_meetbot> The meeting name has been set to 'dependency_tracking'
12:04:00 <colindixon> #topic demo
12:04:17 <colindixon> #link http://54.148.146.38/dnvtools/sidemenu/ the demo from abhi
12:07:34 <colindixon> #topic design ideas
12:07:53 <colindixon> #info we want to track bundles by their unique ID, which is artifactId, groupId, and version
12:08:07 <colindixon> #info after that, for bundles that are from opendaylight, we want to bin them by project
12:08:33 <colindixon> #info that means, if the groupId starts with org.opendaylight, we want to pull out the next segment in it’s groupId as the project
12:09:07 <colindixon> #info for example, if we have a bundle with groupId org.opendaylight.yangtools.models, we’ll put in the yangtools project, but we *still* want to track the bundle with it’s full unique ID
12:10:46 <colindixon> abhi: we lost you
12:11:02 <colindixon> #topic demo continued
12:11:48 <colindixon> #Info abhi shows his parsar.py
12:15:20 <colindixon> #info it parses pom files and shows the versions, but in many cases it’s still using variables because help effective-pom is slow
12:16:11 <colindixon> #info it’s taking a while to run mvn help effective-pom because abhi’s internet access is slow
12:16:42 <colindixon> #info colindixon suggests running the script via jenkins in the sandbox for now
12:18:00 <colindixon> #link https://wiki.opendaylight.org/view/RelEng/Builder/Jenkins#Jenkins_Sandbox instructions on getting a job to run in the jenins sandbox
12:19:58 <colindixon> #info to get this to work in jenkins we would just create a new JJB job that’s just a shell script that then runs this python
12:20:23 <colindixon> #info another option would be to curl the file down from github and then run it
12:22:17 <colindixon> #info the output will have to be declared as an artifact, there’s a post-build action where you need to basically say “archive artifact” and list the output file
12:22:55 <colindixon> #info zxiiro strongly suggests using jenkins job builder so you have an external backup of the job, probably also check that into github
12:23:47 <colindixon> #Info eventually, we’ll want to move the python script into some project and the JJB job into releng/builder
12:29:01 <colindixon> #info colindixon says that when we’re tracking the versions of a given dependency, we also want to track where that version number came from, e.g., what pom file
12:31:01 <colindixon> #topic including this in ODL
12:31:40 <colindixon> #info it might be worth pushign this as a change to gerrit in autorelease, so that we could clone it using it’s ref from gerrit
12:32:18 <colindixon> #info let’s look into that next week
12:34:52 <colindixon> #topic questions about parsing pom files
12:35:20 <colindixon> #info don’t look for dependency information in dependencyManagement, just in dependencies
12:39:24 <colindixon> #info colindixon notes that in the future we might actually need to also track dependencies inside plugin sections
12:40:09 <colindixon> #info for now, you could just look at the project/dependencies section
12:41:16 <colindixon> #info in the logn run, you’ll want to ignore dependencyManagement and look at everything else, e.g., also include dependencies from plugins
12:41:20 <colindixon> #topic for next week
12:41:59 <colindixon> #info colindixon would like to see this python script running in jenkins via jenkins job builder and also using the maven effective-pom to generate thigns with valid versions everywhere
12:42:30 <colindixon> #info if that’s easy, then we could start to produce reports, e.g., places where we have the same artifact with multiple version
12:43:19 <colindixon> #info also, we want to make sure we track the pom file where the versions came from so we can know where to go look when there’s version skew
12:43:50 <colindixon> #action colindixon will set up a trello board for this project
12:45:20 <colindixon> #endmeeting