12:10:35 <colindixon> #startmeeting dependency tracking
12:10:35 <odl_meetbot> Meeting started Thu Jul  2 12:10:35 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
12:10:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:10:35 <odl_meetbot> The meeting name has been set to 'dependency_tracking'
12:10:47 <colindixon> #topic review from last week
12:11:47 <colindixon> #link https://trello.com/b/SIRfdRVV/odl-dependency-tracking abhi_ seems to have done a lot of stuff on the trello board
12:11:59 <colindixon> #link https://github.com/abhishekmittal09/dnvtools the code on github
12:14:39 <colindixon> #info abhi_ says he got a lot of good stuff done, but is struggling jenkins
12:14:41 <colindixon> #topic jenkins
12:15:06 <colindixon> #link https://jenkins.opendaylight.org/releng/ this is where all of our jenkins jobs show
12:16:06 <colindixon> #link https://git.opendaylight.org/gerrit/gitweb?p=releng/builder.git;a=tree;f=jjb;hb=HEAD this is where all those jobs come from, there’s one directory for each project
12:16:26 <colindixon> https://git.opendaylight.org/gerrit/gitweb?p=releng/builder.git;a=tree;f=jjb/autorelease;h=9c743218b49a96db5a45e3c40a73908ed74c8019;hb=HEAD
12:17:57 <colindixon> #link https://jenkins.opendaylight.org/sandbox/ this is our sandbox which is a test jenkins server to avoid messing with our production stuff
12:18:24 <colindixon> #link https://wiki.opendaylight.org/view/RelEng:Jenkins#Jenkins_Sandbox here are the instructions for using the sandbox
12:18:54 <colindixon> #info importantly, note that you don’t need to install jenkins at all, just jenkins-job-builder, which is a tiny python script
12:19:11 <colindixon> #action abhi_ to send e-mail to helpdesk@opendaylight.org ot open a sandbox account
12:20:07 <colindixon> #info the last part (about using docker) is only if you want to be able to run it in on your computer
12:20:32 <colindixon> #info zxiiro also says that we have docker images that have jenkins-job-builder installed if you can’t install it on your machine, but it’s better if you can
12:24:06 <colindixon> #topic can somebody explain how to run a jenkins/JJB job
12:24:21 <colindixon> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/autorelease/autorelease-lithium.yaml this is the JJB YAML file for the lithium autorelease jenkins job
12:24:58 <colindixon> #info note that this is from our github mirror because color highlighting is nice, it’s actually hosted in git.opendaylight.org
12:25:29 <colindixon> https://github.com/opendaylight/releng-builder/blob/master/jjb/autorelease/autorelease-lithium.yaml#L71
12:27:33 <colindixon> #info abhi_ asks how do you know what directory you’re in, e.g., how do you know that line 71 works and ./script/list-project-dependencies will actually be in the right place?
12:27:37 <zxiiro> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-lithium/configure
12:28:13 <colindixon> #info that link is the jenkins job that is generated when you compile the above linked yaml file
12:30:34 <colindixon> #info in essence, the working directory in which your scripts of any script you run will be the root of the git repository you clone
12:30:39 <zxiiro> #info http://docs.openstack.org/infra/jenkins-job-builder/scm.html
12:30:46 <colindixon> #undo
12:30:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ce0c50>
12:32:00 <colindixon> #info that’s only if you clone *one* git repository, which would mean forking autorelease and putting your script in your fork on github
12:34:06 <colindixon> #info if you find that you need help with any of this, please reach out to Thanh aka zxiiro
12:34:35 <zxiiro> #info reach out to us in #opendaylight-releng for sandbox related help
12:34:46 <colindixon> #undo
12:34:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ce0790>
12:34:49 <colindixon> #undo
12:34:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ce0f50>
12:34:56 <colindixon> #info reach out to us in #opendaylight-releng for sandbox related help
12:38:29 <colindixon> #link https://github.com/opendaylight/releng-autorelease/ in the short-run, you probably want fork this on your github page and then clone it using your own JJB yaml file
12:39:48 <colindixon> #topic next steps for jenkins
12:40:07 <colindixon> #info first, fork the releng-autorelease project on github
12:40:12 <colindixon> #info second, put your scripts in the scripts directory there
12:40:44 <colindixon> #info third, copy the autorelease-lithium.yaml file from releng-buider on github and use it as your template for a jenkis job that you’ll play with in the sandbox
12:41:08 <colindixon> #info fourth, change the name and jobs section to dependecny-tracking or something
12:41:29 <colindixon> #info fifth, use the instructions on the releng/builder wiki page to make sure you can push that job to the sandbox
12:42:56 <colindixon> #info if you have issues with this step, reach out to people in #opendaylight-releng on IRC
12:43:25 <colindixon> #info sixth, change the scm section of the yaml file to point to your repo on github instead of the local autorelease repo
12:44:19 <colindixon> #info seventh, change the node type on line 18 to dynamic_verify (this will give you only 4GB insead 8GB)
12:45:25 <colindixon> #info eighth, change the project-type to freestyle insead of maven, this will stop it from building all of autorelease which will take forever
12:45:57 <colindixon> #info ninth, delete the maven block since it no longer applies
12:46:58 <colindixon> #info tenth, you want to rename prebuilders: to builders:
12:47:30 <colindixon> #info eleventh, you want to copy the shell syntax from postbuilers: into builders: and change it to use your script
12:47:45 <colindixon> #info twelfth, you want to delte the postbuilders block
12:48:19 <colindixon> #info thirteenth, delete the triggers block since we don’t want it to trigger based on time yet
12:49:07 <colindixon> #info fourteenth, under jobs: at the top, just leave one entry, e.g., depenency-tracking-lithium
12:50:09 <colindixon> #info zeroth (DO THIS BEFORE EVERYTHING ELSE) remove the other two complete copies of the job-template: section
12:54:40 <colindixon> #info fifteenth add whatever output file you have in the archive-artifacts: in publishers:
12:55:13 <colindixon> #topic next week
12:55:29 <colindixon> #Info colindixon will be out of the country next thursday, and I likely won’t make the meeting
12:55:54 <colindixon> #info zxiiro and abhi_will meet anyway to go over progress here
12:57:39 <colindixon> #info after getting this stuff working in jenkns, the next step is figuring out how to fold it’s output into the web-UI that abhi_ has been working on
12:58:58 <colindixon> #endmeeting