12:02:39 <colindixon> #startmeeting dependency tracking
12:02:39 <odl_meetbot> Meeting started Mon Jul 20 12:02:39 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
12:02:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:02:39 <odl_meetbot> The meeting name has been set to 'dependency_tracking'
12:02:44 <colindixon> #topic what happened last week
12:02:53 <colindixon> #chair zxiiro abhi_
12:02:53 <odl_meetbot> Current chairs: abhi_ colindixon zxiiro
12:03:37 <colindixon> #link http://54.148.146.38/dnvtools/sidemenu/
12:05:07 <colindixon> #info if you go to version skew tab, you see a list of modules with more than one version
12:06:00 <colindixon> #info right now, it’s the groupId and artifactId, the project which the dependencies were found in, and the versions
12:06:24 <colindixon> #info it would be easier if we had pom file instead of project
12:08:08 <colindixon> #info e.g., it would be nice to see the left column stay the same: the groupId and artifactId
12:08:38 <colindixon> #info the second column should be the version # and should list all of the unique version #s for that artifactId and groudId
12:09:00 <colindixon> #info the third colum would be a list of all the pom files that reference the given triple artifactId, groupId and version
12:09:21 <colindixon> #info ideally, across all projects, so the pom file will tell you what project you’re in
12:09:53 <colindixon> #info if you have to, you would prepent the project name e.g., pom.xml would become controller/pom.xml
12:13:08 <colindixon> #info darkdragon says that some of the pom files aren’t being generate properly with an outofmemory issue or something like that
12:13:48 <colindixon> #action darkdragon to send out the error he gets when generating effective pom flles
12:14:39 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Installation#1._Out_of_memory_error_-_java.lang.OutOfMemoryError:_PermGen_space usualy setting -Xmx to 1G or 2G and setting MaxPermSize to 512m or 1G, will help
12:15:46 <colindixon> zxiiro: http://54.148.146.38/dnvtools/sidemenu/#dependency
12:17:56 <colindixon> #topic next steps
12:18:39 <colindixon> #Info colindixon notes that the current dependency graph looks wrong, e.g., packetcable, nic, topoprocessing, reservatin, ttp, vpnservice, lispflowmapping and tsdr, all have no dependenices
12:19:29 <darkdragon> https://jenkins.opendaylight.org/sandbox/job/dependency-tracking-lithium/4/console
12:20:12 <colindixon> #info he was able to get a jenkins job, but it was throwing an error that it couldn’t find maven
12:20:20 <colindixon> #link https://jenkins.opendaylight.org/sandbox/job/dependency-tracking-lithium/4/console the error is here
12:20:32 <colindixon> #Info zxiiro says that you have to declare a “top-level maven target”
12:21:06 <colindixon> #info zxiiro says the simplest thing to do is to decare a maven action with the goal of clean, to set the maven version
12:23:13 <colindixon> #action darkdragon will try to get the jenkins script so that before the “execute shell” build action, it does a “invoke top-level Maven targets” with a goal fo clean and Maven version of Maven 3.3.3
12:44:10 <colindixon> #topic fixing the jenkins job
12:44:58 <colindixon> #info one idea is to make this a maven job instead of a freestyle job, which might give us a valid maven for the whole time
12:45:30 <colindixon> #info another idea is to actually do the maven help:effective-pom as part of the mavne top-level project, but we need it to run on every project
12:47:57 <colindixon> #info the last option would be to instead use the maven exec to run things, but that’s actually not likely to work either
12:48:12 <colindixon> #info for now, let’s just use this path: /opt/jenkins/tools/hudson.tasks.Maven_MavenInstallation/Maven_3.3.3/bin/mvn
12:48:34 <colindixon> #info that will change whenever the version of maven changes, but for now, it’s probably fine
12:51:20 <colindixon> #action abhi wil change line 39 of his parsar.py script to use that path instead
12:52:56 <zxiiro> should cleanup parser.py to conform to pep8
12:53:23 <colindixon> #topic actions for this week
12:53:53 <colindixon> #action abhi to modifiy the jjb file he has to first call maven clean with a maven goal and use maven 3.3.3 so that we get a maven executable to use
12:54:51 <colindixon> #action abhi to modify parsar.py and the web scripts to give the new table structure, i.e., (groupId, artifactId) => list ( versions => list of pom files)
12:55:17 <colindixon> #action abhi to work with zxiiro to figure what’s going on with help:effective-pom failing sometimes
12:55:31 <colindixon> #info after we can do those things, we can figure out if we belive the results
12:57:02 <colindixon> #info for what it’s worth, hard coding the maven executable path seems to be working
12:57:22 <colindixon> #link http://pastebin.com/xRckS4K9 the yaml file he’s using to generate the jenkins job
12:58:51 <colindixon> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/ttp/ttp.yaml#L101 if you copy that maven-target: section into the yaml file you have just before the shell builder, it shoudl work
12:59:51 <colindixon> #info obviously change the goals to just clean
13:00:23 <colindixon> #info you should be able to ignore the settings and global settings
13:00:48 <colindixon> #info we’ll meet on Thursday as usual
13:03:27 <colindixon> #endmeeting