12:01:33 <colindixon> #startmeeting dependency tracking
12:01:33 <odl_meetbot> Meeting started Thu Jul 23 12:01:33 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
12:01:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:33 <odl_meetbot> The meeting name has been set to 'dependency_tracking'
12:01:41 <colindixon> #topic review of last week
12:01:49 <colindixon> #link https://meetings.opendaylight.org/opendaylight-intern/2015/dependency_tracking/opendaylight-intern-dependency_tracking.2015-07-20-12.02.html last week’s meeting minutes
12:02:05 <colindixon> #link https://trello.com/b/SIRfdRVV/odl-dependency-tracking trello board
12:02:59 <colindixon> #info abhishek was able to get the jenkins job from last time running with tolerable errors
12:03:15 <colindixon> #link http://54.148.146.38/dnvtools/sidemenu/#version_skew new version skew table
12:04:03 <colindixon> #action abhi to make it easier to read the table by grouping the common versions
12:05:24 <colindixon> #info colindixon notes that we could account for ranges when they include the other people’s version, but that could still be bad because it’s possible version skew in the future
12:05:40 <colindixon> #info colindixon asks if we are getting all the effective poms now
12:05:54 <colindixon> #info abhi says that he things so now with zxiiro’s help
12:06:21 <colindixon> #info we provide a settings.xml file as a variable, and the memory issue was resolved by running in jenkins
12:11:17 <colindixon> #info abhi says that he things he’s resolved the issues with projects not depending on odlparent, the only ones left are toaster, reservation, packetcable and docs
12:12:59 <colindixon> #info colindixon looks into it: docs does not depent on odlparent, reservation appears to have a parent dependency on odlparent in it’s root pom.xml, packetcable has a dependency on odlparent in features-packetcable/pom.xml and features-packetcable-policy/pom.xml
12:13:41 <colindixon> #Info tutorial is a made up project in coretutorials, which likely needs to have it’s groupId changed
12:14:46 <colindixon> #action abhi to look into why packetcable and reservation don’t depend on odlparent in the diagram
12:16:45 <colindixon> #info colindixon asks if the Jenkins job is compiled from the YAML file or if it’s locally edited on the sandbox, e.g., will it get blown away on Sunday
12:16:51 <colindixon> #info abhi says no, it’s all in the YAML file
12:22:57 <colindixon> #link https://gist.github.com/anonymous/38fc0972d6c39de231c0 colindixon asks if we’re avoiding parsing unincluded pom files
12:23:03 <colindixon> #info abhi says yes
12:29:55 <colindixon> #topic future work
12:30:41 <colindixon> #info colindixon creates some new action items in the trello board
12:38:11 <colindixon> #info colindixon sorts them into the backlog and must have
12:38:24 <colindixon> #action colindixon to find time on the TWS call to have abhi present his stuff
12:38:36 <colindixon> #action colindixon to find a place for the web interface stuff to live
12:39:00 <colindixon> #link https://wiki.opendaylight.org/view/Tech_Work_Stream:Main the TWS call info is here and it’s at 10a pacific/10:30p india on Mondays
12:51:32 <colindixon> #topic odlsummit
12:51:37 <colindixon> #info it will be good to see everyone on Monday!
12:51:41 <colindixon> #endmeeting