17:01:10 <colindixon> #startmeeting dependency tracking
17:01:10 <odl_meetbot> Meeting started Tue Aug 18 17:01:10 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:10 <odl_meetbot> The meeting name has been set to 'dependency_tracking'
17:01:22 <colindixon> #topic review of last week’s progress
17:01:55 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/25265/ the script under review in github
17:02:28 <colindixon> #link https://trello.com/b/SIRfdRVV/odl-dependency-tracking the trello board
17:03:44 <colindixon> http://54.148.146.38/dnvtools/sidemenu/#version_skew
17:04:15 <colindixon> #info abhi_ says that the new code now groups by versions, but it isn’t updated in the hosted place
17:05:17 <colindixon> #link https://jenkins.opendaylight.org/sandbox/job/dependency-tracking-lithium/10/console abhi_ says that he’s having issues with the maven deploy-file goal
17:06:06 <colindixon> #ink [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy-file (default-cli) on project autorelease-root: Failed to deploy artifacts: Could not transfer artifact org.opendaylight.autorelease:dependencyInfo.json:json:1.0.0 from/to opendaylight-snapshot (https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/): Failed to transfer file:
17:06:07 <colindixon> https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/org/opendaylight/autorelease/dependencyInfo.json/1.0.0/dependencyInfo.json-1.0.0.json. Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1]
17:06:31 <colindixon> #info [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy-file (default-cli) on project autorelease-root: Failed to deploy artifacts: Could not transfer artifact org.opendaylight.autorelease:dependencyInfo.json:json:1.0.0 from/to opendaylight-snapshot (https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/): Failed to transfer file:
17:06:32 <colindixon> https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/org/opendaylight/autorelease/dependencyInfo.json/1.0.0/dependencyInfo.json-1.0.0.json. Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1]
17:07:00 <colindixon> #action abhi_ to ask zxiiro and/or tykeal about why this would give 401 unauthorized
17:07:41 <colindixon> #info maven site deploy is working for abhi_ in his local system, he needs to talk to zxiiro about how to deploy to the LF’s CI maven sites
17:15:22 <colindixon> #topic planning the next week
17:19:05 <colindixon> #info colindixon rearranges things on the trello board, there are 6 tasks that need to be done
17:19:35 <colindixon> #action abhi_ will create a gerrit patch to merge the HTML/JS into the autorelease project
17:20:04 <colindixon> #action abhi_ will work with zxiiro to figure out how to deploy the HTML/JS to a maven site in ODL infra
17:21:02 <colindixon> #action abhi_ will grey out a project when it’s pom file isn’t being parsed (but it’s still in other project’s as a dependency)
17:21:24 <colindixon> #action abhi_ and zxiiro will get the python script gerrit merged into autorelease
17:21:47 <colindixon> #info the above 5 #actions are the critical things
17:22:11 <colindixon> #info if we have time, we can also look at the backlog, colindixon will order in terms of his priroties
17:27:29 <colindixon> #topic demo of mave site
17:27:58 <colindixon> #info abhi_ shows that if you look at the last link (timeline) on the maven site it will take you to the version skew page
17:28:29 <colindixon> #Info for now the resources are coming from abhi_ manually pulling it in
17:30:20 <colindixon> #info abhi_ will committ the HTML as part of his gerrit patch(es)
17:30:23 <colindixon> #endmeeting