17:02:12 <colindixon> #startmeeting dependency tracking
17:02:12 <odl_meetbot> Meeting started Tue Aug 25 17:02:12 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:12 <odl_meetbot> The meeting name has been set to 'dependency_tracking'
17:02:15 <colindixon> #topic wrap up
17:02:33 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/25265/4 we’d like to converget on getting this merged
17:03:22 <colindixon> #info we’d like to get the HTML code into git somewhere even if it’s not being deployed by maven sites
17:03:24 <colindixon> #info we’d like to see it deployed as a mavent
17:03:32 <colindixon> #topic getting the parser merged
17:03:53 <colindixon> #info zxiiro says he’s willing to just merge it and move to using the xpath APIs (if possible) as an enhancement
17:04:07 <colindixon> #action zxiiro to merge the patch
17:04:27 <colindixon> #topic getting the HTML into gerrit
17:07:02 <colindixon> #info zxiiro says that right now we should just check the HTML/js into some place with instructions on how to bring it up
17:07:26 <colindixon> #link https://github.com/abhishekmittal09/dnvtools/tree/master/sidemenu the current HTML i shere
17:08:07 <colindixon> #info colindixon asks where actually loads the data.json
17:08:23 <colindixon> #action abhi to clean up the js folder ot only have the live code in it
17:10:26 <colindixon> #link https://github.com/abhishekmittal09/dnvtools/blob/master/sidemenu/index.html#L20 shows how it’s loading the data.json
17:11:06 <colindixon> #info colindixon says we have two options: (1) dynamically generate the HTML so it hard links to the most recent data.json, (2) look for the most recent data.json in nexus so that the HTML is truly static
17:11:43 <colindixon> #action abhi to submit exactly what he has working with maven sites along with instructions to for zxiiro to get it working
17:12:01 <colindixon> #info zxiiro says he’s mildly worried about third party libraries and licensing
17:12:26 <colindixon> #action abhi to get zxiiro a list of libaries he’s using so that zxiiro can make sure they’re EPL compatible
17:14:04 <colindixon> #topic
17:14:17 <colindixon> #topic trello board
17:14:23 <colindixon> #link https://trello.com/b/SIRfdRVV/odl-dependency-tracking the trello board
17:14:37 <colindixon> #action colindixon to update the trello board with the output of this meeting
17:14:50 <colindixon> #topic style guide for HTML and js/
17:15:08 <colindixon> #info abhi asks if we have a style guide, zxiiro says we don’t but he Drupal’s style guide
17:15:25 <colindixon> #info also js should go in a separate js file in a spearate js folder
17:16:12 <colindixon> #topic TWS presentation
17:16:19 <colindixon> #info colindixon asks if zxiiro will be there, he will be
17:17:46 <colindixon> #info colindixon will not be there, zxiiro will act as abhi’s wingman if needed
17:17:48 <colindixon> #endmeeting