17:02:06 <colindixon> #startmeeting dependency tracking
17:02:06 <odl_meetbot> Meeting started Tue Sep  8 17:02:06 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:06 <odl_meetbot> The meeting name has been set to 'dependency_tracking'
17:02:14 <colindixon> #topic status update
17:02:46 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/26631/ the web front end for dependency tracking is a patch
17:02:59 <colindixon> #action abhi to provide the JJB file he was using
17:03:33 <colindixon> #topic going forward
17:03:56 <colindixon> #info colindixon asks if there’s a best practice for important third-party javascript
17:04:27 <colindixon> #info zxiiro and abhi say that normally you import from the CDN URL so that you don’t replicate the code in your repo
17:05:07 <colindixon> #info another trick which zxiiro uses for projects that don’t have a CDN is to load them as a git submodule from their git repo
17:06:46 <colindixon> #undo
17:06:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3d850>
17:06:48 <colindixon> #undo
17:06:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3d550>
17:06:49 <colindixon> #undo
17:06:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3df90>
17:06:51 <colindixon> #undo
17:06:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1a2cfd0>
17:07:00 <colindixon> #topic the HTML/js patch
17:07:04 <colindixon> #info colindixon asks if there’s a best practice for important third-party javascript
17:07:08 <colindixon> #info zxiiro and abhi say that normally you import from the CDN URL so that you don’t replicate the code in your repo
17:07:12 <colindixon> #info another trick which zxiiro uses for projects that don’t have a CDN is to load them as a git submodule from their git repo
17:07:21 <colindixon> #topic the JJB file
17:07:37 <colindixon> #info right now master is broken, but it works a stable/lithium
17:09:02 <colindixon> #info zxiiro says to submit it to either one (but only one) for now and it will be cherry-picked after merging
17:09:33 <colindixon> #topic maven site files
17:09:49 <colindixon> #info zxiiro says that once he gets through the maven site stuff, he’ll probably have to change the maven site file here, but for now it’s fine
17:11:05 <colindixon> #topic back to the JJB file
17:11:37 <colindixon> #info it should be sumbitted to releng/builder in the jjb/autorelease folder
17:12:08 <colindixon> #info abhi asks about where the variables in JJB jobs come from
17:13:51 <colindixon> #info zxiiro says they come from a few different places, the maven settings (and version) come from the jjb/releng-defaults.yaml file in releng/builder
17:13:58 <colindixon> #link https://github.com/opendaylight/releng-builder/blob/74518c806171a73a6a9282cb9dea37c6c2cff252/jjb/releng-defaults.yaml here’s that file
17:14:12 <colindixon> #info for other things like project and branch they come from how the jobs are triggered and or the templates including stream
17:16:24 <colindixon> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/releng-macros.yaml the global macros are here which are used to help with things
18:03:10 <odl_meetbot> colindixon: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
18:03:18 <colindixon> #topic review of progress
18:04:15 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Controller-Cluster_Deployment radhika did some edits here
18:10:48 <colindixon> #info radhika says that the chose to leave in OpenFlow because that’s what people care
18:11:18 <colindixon> #action radhika to find a guinea pig to use these instructions
18:12:25 <colindixon> #info colindixon notes that coverign openflow is fine, but it doesn’t work right now, so we just need to figure out what the audience is: Lithium users, Beryllium users, or something else
18:13:22 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller radhika has listed understanding MD-SAL thin things you need to read
18:23:01 <colindixon> #topic action items
18:23:36 <colindixon> #info reviewing action items from Radhika’s e-mail
18:23:58 <colindixon> #info she feels like he clustering deployment wiki is pretty much done
18:24:15 <colindixon> #info she feels like all the MD-SAL arch and clustering docs are aggregated on the clustering main page
18:24:35 <colindixon> #action radhika to provide links to the applciation tutotials as well on the clustering main page
18:25:17 <colindixon> #action wiki gardening for clustering related documents
18:25:27 <colindixon> #action covert clustering wiki documentats to asciidoc
18:26:53 <colindixon> https://meetings.opendaylight.org/opendaylight-intern/
18:06:25 <colindixon> #endmeeting