16:57:25 <regXboi> #startmeeting 6/26/2014 TSC
16:57:25 <odl_meetbot> Meeting started Thu Jun 26 16:57:25 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:57:25 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:57:25 <odl_meetbot> The meeting name has been set to '6_26_2014_tsc'
16:57:39 <dmm> #info dmm
16:58:01 <regXboi> #topic TSC members please #info in
16:58:08 <regXboi> #info regXboi
16:58:20 * regXboi looks for chair volunteers :)
16:58:37 <dmm> Phil won't be here this week
16:58:39 <tbachman> dmm: do you have audio?
16:59:09 <dmm> I'm on the OPNFV call; give me 5
16:59:13 <tbachman> ah, k
16:59:14 <tbachman> thx
16:59:14 <regXboi> ah....
17:00:28 <dmm> #link https://wiki.opendaylight.org/view/TSC:Main
17:01:14 <edwarnicke> #link https://meetings.webex.com/collabs/meetings/join?uuid=MA3SRND964PIX06V2LS3SXX3RE-9VIB - webex link
17:01:45 <regXboi> edwarnicke you linking without infoing?
17:02:26 <kw_> #info Kent Watsen
17:03:06 <edwarnicke> #info Ed Warnicke
17:03:34 <ChrisPriceAB> #info Chris Price Joined
17:03:40 <regXboi> #info no phil today - recording started
17:04:48 <colindixon> hola
17:05:11 <regXboi> #topic creation review : TCP-MD5
17:05:29 <colindixon> regXboi: since you’re phil today,d o you want me to scribe?
17:05:40 <regXboi> #info delaying this to next week to ensure the two week period
17:05:53 <regXboi> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-June/000145.html
17:06:04 <RobDolin> #info Rob Dolin proxy for Rajeev Nagar (MSFT)
17:06:17 <regXboi> #info above link is TCP-MD5 email to project-proposals list
17:06:22 <regXboi> #chair colindixon
17:06:22 <odl_meetbot> Current chairs: colindixon regXboi
17:06:26 <regXboi> colindixon: thanks
17:06:37 <regXboi> #topic scala discussion
17:06:45 <regXboi> https://lists.opendaylight.org/pipermail/project-proposals/2014-June/000145.html
17:06:50 <tykeal> FYI I'm here (and on the phone) for the IT repo bits...
17:07:07 <regXboi> #link https://lists.opendaylight.org/pipermail/discuss/2014-June/002695.html
17:07:14 <regXboi> #link https://lists.opendaylight.org/pipermail/discuss/2014-June/002880.html
17:07:45 <regXboi> #info links are start of use of scala discussion
17:08:29 <colindixon> #info the people looking to use Akka to build clustering originally wanted to use Scala to provide the clustering (as Akka is written in Scala) and they asked if that would be OK
17:08:46 <edwarnicke> #link https://lists.opendaylight.org/pipermail/discuss/2014-June/002880.html - comprimise
17:10:11 <regXboi> edwarnicke: thanks
17:11:52 <regXboi> #info question about how to capture a community decision
17:12:15 <dbainbri> +1 for a formal way to record decisions with some context and background so things are revisited all the time.
17:12:31 <regXboi> #info that is ... the scala discussion comes to a question about how to capture a community decision
17:12:57 <colindixon> #info other examples of recording policy include: (a) checkstyle policy, e.g., trailing whitespace and (b) branching policy
17:13:09 <regXboi> #info colindixon thinks it is a good idea to have some way of recording decisions
17:13:27 <regXboi> #info edwarnicke talks about a possibility of using branching
17:13:44 <regXboi> is that kwatsen?
17:13:44 <colindixon> …I don’t think that’s what he was suggesting
17:13:48 <colindixon> yeah, I’m pretty sure
17:13:55 <tykeal> regXboi: that's what webex said
17:14:19 <regXboi> #info kwatsen suggests a current project status wiki page
17:14:42 <regXboi> #info dlenrow points out that some projects are updating the project proposal page and that should be discouraged
17:15:09 <regXboi> #info edwarnicke agrees that updating the project proposal page isn't a good thing
17:16:24 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Documentation_Group example of the facts sidebox
17:17:17 <regXboi> #action colindixon to make the project "facts box" a wiki template
17:20:59 <regXboi> #topic TSC Charter Update
17:21:23 <colindixon> #info there is some more discussion about how to keep the actual list of projects synchronized over the varioius places they are listed, e.g., the main page, the helium release page, etc.
17:21:59 <colindixon> #info there is hope that having a template would help automate this assuming we make sure people us the template (the last two lines belong in the previous topic)
17:26:08 <dbainbri> link to the options for all us not as much in the know?
17:26:20 <regXboi> #link https://lists.opendaylight.org/pipermail/tsc/2014-June/001309.html
17:26:33 <dbainbri> regXboi: thx
17:26:38 <regXboi> dbainbri: trying to catch up :)
17:27:35 <regXboi> #startvote which charter language proposal to take to the board? 0 1 2
17:27:35 <odl_meetbot> Begin voting on: which charter language proposal to take to the board? Valid vote options are 0, 1, 2.
17:27:35 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:27:35 <dbainbri> regXboi: y, last i heard about this topic there were issues about any single company have more representation than others (i.e. unequal representation). not sure if that issue has been addressed.
17:27:39 <edwarnicke> dbainbri: Sorry about the inside baseball... hope the link helps :)
17:27:56 <edwarnicke> #info 0 means abstain
17:28:00 <edwarnicke> #info 1 means option 1
17:28:04 <edwarnicke> #info 2 means option 2
17:28:09 <regXboi> edwarnicke: thanks
17:28:13 <kw_> #vote 1
17:28:16 <edwarnicke> #vote 1
17:28:19 <regXboi> #vote 2
17:28:33 <ChrisPriceAB> #vote 1
17:28:41 <dmm> #vote 1
17:28:51 <regXboi> #info dlenrow votes 1
17:28:56 <regXboi> #endvote
17:28:56 <odl_meetbot> Voted on "which charter language proposal to take to the board?" Results are
17:28:56 <odl_meetbot> 1 (4): dmm, edwarnicke, kw_, ChrisPriceAB
17:28:56 <odl_meetbot> 2 (1): regXboi
17:28:57 <RobDolin> #vote 1
17:29:08 <regXboi> #info RobDolin also voted 1
17:29:25 <regXboi> #info total (due to #infos) were option 1: 6, option 2: 1
17:29:33 <RobDolin> @regXboi - No worries; I'm good with result :)
17:29:40 <regXboi> #agreed send proposal #1 to board
17:30:07 <regXboi> #info question: should both charter and bylaws be modified?
17:30:31 <regXboi> #info answer: the vote above only covers the charter
17:35:16 <regXboi> #agreed to take the charter language modifications to the board with the recommendation that the by-laws be modified in accordance with the charter modifications and intent
17:36:25 <kw_> #action kwatsen to send dmm fully-updated charter/bylaw docs
17:36:36 <colindixon> thanks kw_
17:36:49 <lenrow> #info Lenrow
17:37:09 <colindixon> just for future reference if you #action with your actual IRC handle being listed there, it will appear as assigned to you in notes at the end
17:37:18 <regXboi> #topic helium packaging
17:37:44 <edwarnicke> #info pen is turned over to sombody
17:38:14 <regXboi> #chair edwarnicke
17:38:14 <odl_meetbot> Current chairs: colindixon edwarnicke regXboi
17:40:54 <regXboi> lenrow: welcome
17:41:41 <edwarnicke> dmm time management FTW! :)
17:41:44 <icbts> #info return to topic of discussing ‘pure karaf’
17:42:34 <RobDolin> Happy Canada day to those celebrating on Tue, 7/1 ;)
17:42:50 <icbts> :D
17:43:22 <regXboi> #info unclear how much will be accomplished based on the "swiss cheese" of next week
17:43:26 <colindixon> #link https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Upcoming_Meeting_Agendas future topics for TWS calls are listed here
17:43:33 <colindixon> #info this might be one such topic
17:43:40 <regXboi> #topic helium status issues
17:47:10 <regXboi> #info proposal to have a mailling list other than discuss for release email so that projects don't have to sort through on discuss
17:47:14 <dbainbri> so we would have a "release" list as opposed to a specific version release list?
17:47:24 <tykeal> that's what I would suggest
17:47:52 <dbainbri> or maybe just tag messages in the subject [release][foo][bar] so people can better filter?
17:47:55 <regXboi> dbainbri: already went there :)
17:48:29 <tykeal> release list with topics set...
17:49:21 <tykeal> I believe the list could be set to require topics
17:49:25 <edwarnicke> #info I am favor of a single release list
17:51:24 <regXboi> #info no disagreement with a single release list
17:51:29 <lenrow> #info HP will present our OF1.3 plugin  architecture/implementation and demo it running on ODL  on Monday TWS Call
17:52:29 <tykeal> sounds like an action for me...
17:52:37 <regXboi> #action tykeal to create a single release list
17:53:17 <regXboi> #action correction, regXboi to send email for creation of single release list to helpdesk
17:53:53 <regXboi> #topic it managed repository section in gerrit for holding sub-repositories
17:54:25 <regXboi> #info there have been requests for infrastructure pieces like Puppet, Jenkins Job builder, etc.
17:55:47 <tykeal> doh, I seem to have lost audio
17:55:56 <regXboi> #info request for a repository for holding this information with andy and aric as primary contacts
17:56:40 <regXboi> #info proposal from edwarnicke to have this be a project
17:57:48 <regXboi> #info tykeal considered that approach, but his thinking was that the outputs of this effort wouldn't be released as other projects released
17:59:44 <regXboi> #info more discussion about licensing
18:02:40 <regXboi> #info recommendation to tykeal to bring the idea to the mailing list along with a minimal form as an example
18:03:10 <regXboi> #info last note: US 0-1 GER, POR 2-1 GHANA
18:03:11 <RobDolin> Thanks regXboi for operating the meeting.
18:03:17 <regXboi> #endmeeting