15:31:33 <phrobb> #startmeeting Helium M5 developer meeting
15:31:33 <odl_meetbot> Meeting started Wed Aug 27 15:31:33 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:31:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:31:33 <odl_meetbot> The meeting name has been set to 'helium_m5_developer_meeting'
15:31:43 <edwarnicke> regXboi: You just missed Karaf Happy Hour :)
15:32:00 <phrobb> #topic Project Contacts please #info in
15:32:06 <edwarnicke> #info edwarnicke controller
15:32:18 <tbachman> #info tbachman for Group Based Policy
15:32:23 <hideyuki> #info Hideyuki for VTN
15:32:26 <rafat> #info rafat ODL-SDNi App
15:32:28 <oflibMichal1> #info oflibMichal
15:32:34 <paulq> #info paulq for SFC
15:32:44 <oflibMichal1> #info oflibMichal for openflowjava
15:33:14 <dkutenic> #info Dana for bgpcep
15:34:06 <regXboi> #info regXboi for nobody... so I can hold the pen if need be (I can't believe I just volunteered for that)
15:34:13 <Madhu> #info Madhu
15:34:14 <gzhao> #info George Zhao for release
15:34:32 <goldavberg> #info goldavberg for lispflowmapping
15:34:40 <phrobb> Madhu:  are you representing both dlux and ovsdb?
15:34:57 <phrobb> #chair regXboi edwarnicke gzhao
15:34:57 <odl_meetbot> Current chairs: edwarnicke gzhao phrobb regXboi
15:35:04 <Madhu> phrobb: good question... meeting conflict and am still figuring out :)
15:35:11 <ttkacik> #info ttkacik for Yangtools
15:35:12 <Madhu> at least until someone shows up in dlux
15:35:17 <Madhu> but definitely ovsdb
15:35:19 <phrobb> regXboi:  you are welcome to hold the pen :-)
15:35:32 * regXboi figures :)
15:35:48 <CASP3R> #info CASP3R for Integration
15:36:02 * phrobb checking who all we have and who is missing…
15:36:46 <abhijitkumbhare> #info abhijitkumbhare for OpenFlow plugin
15:37:54 <regXboi> did I miss aaa?
15:38:09 <phrobb> regXboi:  correct, I don't see anyone from AAA
15:38:18 <regXboi> well I think liemmn just arrived
15:38:19 <liemmn> sorry... ran late
15:38:25 <liemmn> #info liemmn for AAA
15:38:32 <catohornet> #info catohornet also for integration
15:38:52 <regXboi> how about defense4all?
15:39:01 <mlemay> #info mlemay for reservation
15:39:13 <regXboi> l2 switch?
15:39:28 <tbachman_> FYI -- having IRC client issues
15:39:31 <tbachman_> did I miss anything?
15:39:40 <gzhao> tbachman_: no
15:39:44 <phrobb> regXboi:  correct, I've not seen or heard from defense4all either
15:39:45 <tbachman_> thx
15:39:53 <phrobb> tbachman:  no, just finishing roll call
15:40:00 <regXboi> opflex?
15:40:02 <tbachman_> phrobb: gzhao thx!
15:40:11 <tbachman_> I guess I can cover opflex
15:40:17 <regXboi> PCMM?
15:40:21 <tbachman_> #info tbachman opflex
15:40:24 <phrobb> tbachman:  please #info that in
15:40:26 <regXboi> SNB-i?
15:40:48 <regXboi> opencontrail?
15:40:59 <regXboi> snmp4sdn?
15:41:10 <regXboi> table type patterns?
15:41:17 <edwarnicke> regXboi: We had someone turn up from SNBi last hour for Karaf Happy hour
15:41:19 <regXboi> toolkit?
15:41:22 <phrobb> arg
15:41:39 <regXboi> just looking at the #infos and the project list
15:41:43 <regXboi> and noting the differences
15:42:03 <phrobb> We are 11 after the start.  Let's get started.  If those here can ping those absent, please do
15:42:05 <regXboi> I think I'm at the end of the list now
15:42:21 <phrobb> #topic Status
15:42:22 <priyanka> #info for southbound plugin to OpenContrail platform
15:42:43 <regXboi> #info appear to be missing defense4all, l2switch, pcmm, snb-i snmp4sdn, tabletypepatterns and toolkit
15:42:47 <abhijitkumbhare> I am not most up-to-date with table type patterns status - but I can relay back info to Colin/Curt
15:42:54 <edwarnicke> regXboi: I'm chasing l2switch folks
15:43:10 <regXboi> thx all
15:43:17 <abhijitkumbhare> given that Colin is on a paternity leave
15:43:45 <harman_> #info here from dlux project
15:44:39 <phrobb> #info Let's start with the Code Freeze requirement of M5.  This should mean that no new features should be allowed by the committers starting on Monday.  Only errors/bugs that are also identified in bugzilla are allowed from Monday forward.  Is this an agreeable definition to the group and are there any projects that do not feel they can meet that requirement?
15:45:24 <edwarnicke> phrobb: Could we clarify that new *tests* are cool?
15:45:34 <tbachman_> edwarnicke: and what about packaging?
15:45:42 * tbachman_ putting his karaf hat on
15:45:46 <edwarnicke> tbachman_: Good question
15:45:56 <rovarga> #info rovarga for tcpmd5
15:45:58 <edwarnicke> tbachman_: I would *really* like to get everyone in for karaf by M5... but I'm also a realist
15:46:02 <phrobb> edwarnicke:  Yes edwarnicke, new tests are allowed and encouraged
15:46:06 <edwarnicke> phrobb: gzhao thoughts?
15:46:31 <edwarnicke> phrobb: Thanks :) Some folks had been asking :)
15:46:42 <edwarnicke> phrobb: Could we add that to our 'Code Freeze' statement so its clear to everyone?
15:46:54 <abhijitkumbhare> So should this be modified to only errors/bugs/additional tests/packaging/docs ?
15:47:06 <edwarnicke> abhijitkumbhare: Definitely also docs :)
15:47:08 <phrobb> Yes,… I'm make a note.
15:47:14 <mlemay> phrobb: For reservation we'll be late on Code Freeze... I'm trying to merge as fast as I can and we're getting to Yellow status..
15:47:18 <abhijitkumbhare> meant bug fixes (not bugs :) )
15:47:22 <edwarnicke> phrobb: Just to clarify... things like log cleanups would be bugs, right?
15:47:33 * edwarnicke has a list of crappy logs he wants to fix
15:47:46 <tbachman> mlemay: does that mean code freeze is still up to projects?
15:47:47 <edwarnicke> abhijitkumbhare: Definitely.  No committing new bugs after code freeze! :)
15:48:36 <regXboi> edwarnicke: I'd think log cleanups would be allowed if there is a defect filed in bugzilla
15:48:52 <edwarnicke> regXboi: I'm down with the bug in bugzilla... but man I want to scrub some logs :)
15:48:53 <phrobb> edwarnicke:  yes log clean up is a bug… the packaging one I'm still grappling with...
15:49:00 <tbachman> phrobb: I don't believe OpFlex is going to meet this requirement, btw
15:49:07 <edwarnicke> phrobb: Could you speak your thoughts and maybe folks will have ideas?
15:49:17 <edwarnicke> tbachman: Do we have opflex guys here?
15:49:28 <tbachman> edwarnicke: I think I'm representing
15:49:32 <tbachman> alagalah is out this week
15:49:46 <edwarnicke> tbachman: I am told he's at the happiest place on earth, having breakfast
15:49:49 <tbachman> lol
15:49:50 <tbachman> he is
15:50:04 <tbachman> with a pair of black ears on top
15:50:17 <evanz> edwarnicke: I'm headed to my next class, I see amit_mandke is here now
15:50:32 <phrobb> One of the major goals of code freeze is for integration testing and documentation to be allowed to go forward full steam.  If packaging isn't finished, the integration team has a tough time testing… and the docs team has a tough time documenting packaging and install..
15:50:36 <edwarnicke> evanz: That statements is *so* ODL :)
15:50:53 <mlemay> tbachman: I can code freeze a portion but I'd rather we have full functionality and was taking up by other dependency requirements that just have been going in (karaf etc..) now I can fully test end to end.. so we plan to stabilize that as soon as possible.. We'd like to flag ourselves as an experimental feature...
15:50:55 <phrobb> Thanks Evanz!
15:51:04 <Madhu> thanks for asking the basic question guys on code freeze :)
15:51:29 <tbachman> mlemay: not trying to be antagonistic... just trying to make sure we all come to an agreement :)
15:51:30 <phrobb> Madhu:  definitly best when we all start from the same place :-)
15:51:42 <edwarnicke> phrobb: So... I can see that for the 'high level' features being packaged
15:51:55 <edwarnicke> phrobb: the ones listed in integration
15:52:21 <Madhu> phrobb: shall we have 2 different discussions ?
15:52:25 <Madhu> 1. karaf related
15:52:25 <tbachman> phrobb: I'm assuming this is also a point where we decide what projects can or can't make the release?
15:52:29 <Madhu> 2. non-karat related ?
15:52:37 <phrobb> edwarnicke:  right, but you can't really build the high level features until the low levels are defined and constructed correct?
15:52:39 <tbachman> karat vs. stick
15:53:11 <Madhu> tbachman: M5 is approaching ... no times for jokes ;)
15:53:13 <phrobb> tbachman:  yes, this is the precursor to it…
15:53:19 <tbachman> sorry ;)
15:53:34 * edwarnicke puts on a very very serious face :)
15:53:54 * regXboi doesn't buy any of this for a second
15:53:58 <tbachman> lol
15:54:10 <edwarnicke> phrobb: Does everyone know what they need to do for packaging
15:54:25 <edwarnicke> phrobb: We had at least one person at Karaf Happy Hour still unclear there
15:54:27 <gzhao> there are projects have reported met M4 milestone yet
15:54:28 <phrobb> Projects that recognize they can't meet the requirements can DOR (Dropped on Request) whenever they choose.  The gate for the project is the TSC Release Review that will be scheduled for each project real soon noon post M5
15:54:49 <tbachman> phrobb: thx!
15:55:28 * edwarnicke looks distressed that regXboi doubts him
15:55:29 <phrobb> edwarnicke:  is there anything that is unclear in the karaf step-by-step that you wrote regarding what the projects need to do?
15:55:52 <edwarnicke> phrobb: I don't think so... we continue to add things like 'Common problems and their solutions' as we find them... but not sure everyone is working from that page yet
15:56:26 <tbachman> edwarnicke: do all the projects understand that they need to be karaf'd?
15:56:27 <edwarnicke> phrobb: And we've had folks work through it successfully
15:56:31 <tbachman> (i.e. this is a requirement)
15:56:36 <edwarnicke> tbachman: That's part of what I'm asking
15:56:42 <edwarnicke> tbachman: I think they should at this point
15:56:47 <edwarnicke> tbachman: But want to check in and be sure
15:56:50 <CASP3R> One question i have is yes i see that Karaf is slowly getting to a working solution, integration has kick off a job that deploy a karaf controller and test the base-of13 stuff
15:56:51 <tbachman> did we send emails or other form of contact?
15:57:10 <phrobb> edwarnicke:  is there anything you would like to say here about pkging and karaf work to add clarity?
15:57:11 <CASP3R> Now what if a project doesn't make it into karaf how do we package that?
15:57:19 <tbachman> CASP3R: good question
15:57:27 <amit_mandke> need to drop off Alex(alefan) would represent L2switch in this meeting
15:57:29 * tbachman worries we haven't made that 100% clear
15:57:57 <phrobb> I believe all projects understand the need to support Karaf and have acknowledged their committment to it.
15:58:03 <tbachman> phrobb: thx
15:58:31 <phrobb> gzhao:  is that correct?… are there any projects requesting to not support karaf (that are java based)?
15:58:32 * tbachman apologizes for re-covering already-covered ground
15:59:37 <gzhao> phrobb: there are four projects is N/A to karaf, such as opflex, documentation, toolkit
15:59:44 <edwarnicke> CASP3R:  do remember vtn and opflex have non java stuff
15:59:48 <phrobb> So it seems as though Reservation and OpFlex do not feel they will be at code freeze prior to Monday's M5.  Are there any others?
15:59:57 <CASP3R> VTN is a 3PP app so that's cool
16:00:04 <Madhu> i can second that for toolkit. it is a N/A
16:00:27 <CASP3R> last email i got from gzhao was no from SNB and SFC
16:00:38 <edwarnicke> phrobb: Let me say my piece on karaf stuff here:
16:00:52 <gzhao> phrobb: SNBi SFC initially requested not to support Karaf
16:01:03 <abhijitkumbhare> CASP3R: I am not sure SNBi last response was not ti support
16:01:20 <edwarnicke> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide Please read this and follow it through to get your project features into integration
16:01:37 <edwarnicke> #info If you need help, Karaf Happy Hour is 7:30am PST every morning this week on #opendaylight-meeting
16:01:48 <phrobb> I know that folks had reached out to SNBi and SFC to see if they could help them with their karaf work
16:01:56 <edwarnicke> gzhao: SFC folks have been seen working on features and asking good questions ...
16:02:12 <hideyuki> phrobb: I think VTN will be at code freeze prior to Monday'S M5 barely. If it will not, I'll tell you.
16:02:15 <paulq> I can check with Reinaldo and co. about Karak and report back
16:02:17 <edwarnicke> gzhao: And SNBi folks were at Karaf Happy Hour yesterday :)
16:02:22 <Madhu> just 1 thing... I think if folks work on it now... we can get Karaf working.
16:02:23 <paulq> karak --> karaf
16:02:31 <Madhu> but we might see bugs post M5
16:02:33 * edwarnicke things we are deep in our cups at this point
16:02:45 <edwarnicke> Madhu: You mean packaging bugs? Most def
16:02:47 <Madhu> and we should be ready to accept bug fixes to make it solid before the release
16:02:49 <gzhao> edwarnicke: Do you know what are the Karaf status for yangtools, controller, openflowjava, openflowplugin, ovsdb
16:02:55 <Madhu> edwarnicke: no. it could also be runtime issues
16:02:56 <edwarnicke> gzhao: Yes
16:03:01 <Madhu> gzhao: ovsdb is ready
16:03:07 <Madhu> yet to push to integration
16:03:13 <gzhao> edwarnicke: that is great, IMHO, those project should go Karaf
16:03:19 <phrobb> CASP3R:  what kind of issues will you see in integration testing as we move to RC0 if the karaf packaging is not completed at M5?
16:03:21 <edwarnicke> gzhao: yangtools is pulled in by controller.  No high level user visible features listed because its supporting stuff
16:03:25 <CASP3R> https://jenkins.opendaylight.org/integration/job/integration-master-csit-karaf-of13/4/robot/report/report.html
16:03:28 <Madhu> edwarnicke: phrobb it is just too last minute for getting all the tests done for karaf
16:03:32 <Madhu> don't u guys agree to that ?
16:03:41 <edwarnicke> gzhao: controller, the MD-SAL side stuff is done except for the clustering feature, which I'm working on
16:03:47 <Madhu> especially given the fact where we are at this stage
16:03:51 <CASP3R> thats the current work, but there few patch waiting to be merged both in testing and the karaf release, we have a good update for TSC tomorrow
16:04:17 <gzhao> Madhu: thanks
16:04:25 <edwarnicke> gzhao: I believe the AD-SAL side stuff is in, and the adsal-compatibility patch is awaiting review in integration (with fixed commit message, thanks Madhu for pointing out the previous deficiencies there)
16:04:37 <Madhu> sure edwarnicke .
16:04:41 <Madhu> as u guys can see...
16:04:52 <edwarnicke> gzhao: openflowplugin is in integration, but some of its servicability features, like test-provider and drop-test do not yet have features
16:04:53 <Madhu> both ADSAL and MDSAL controller base code came in last week
16:05:11 <edwarnicke> gzhao: openflowplugin nicera-extensions are not in as features at Madhu's request as he would like to do the features in ovsdb
16:05:14 <Madhu> it just doesn't give enough time for folks to write intgration tests with these
16:05:21 <edwarnicke> gzhao: openflowjava is pulled in by openflowplugin
16:05:29 <Madhu> edwarnicke: that is correct. it is being done there
16:05:49 <Madhu> so we have to clearly state the intent of code freeze for karaf.
16:06:00 <Madhu> get all the features in before M5
16:06:00 <edwarnicke> gzhao: I think that's what I now currently for the things you asked about
16:06:06 <Madhu> and expect bugs post M5 and fix them
16:06:24 <regXboi> "<edwarnicke> gzhao: openflowplugin nicera-extensions are not in as features at Madhu's request as he would like to do the features in ovsdb" <- can I ask why?
16:06:26 <gzhao> edwarnicke: looks major "core" projects are on track, next level are GBP, l2swtich, bpgcep, aaa
16:06:36 <phrobb> Madhu:  we talked about running minimal and maximal testing of karaf bundles in integration testing using the existing integration tests… what additional integration tests are needed?
16:06:50 <edwarnicke> regXboi: I can only speak for myself on that.  Madhu felt strongly, I didn't feel strongly, so I deferred.
16:06:58 <edwarnicke> regXboi: If other folks have strong feelings, I can reconsider
16:07:00 <Madhu> regXboi: thats because openfowplugin cannot depend on ovsdb (due to auto release dependencies)
16:07:00 <phrobb> Madhu:  to be written?
16:07:01 <tbachman> gzhao:  am working on GBP
16:07:09 <Madhu> edwarnicke: i didn't feel strong about that either :)
16:07:27 <Madhu> edwarnicke: because u pointed to the fact that it cannot be done on openflowplugin due to the auto release dependency stuff
16:07:39 <Madhu> edwarnicke: if it can be sorted out... i don't care where it resides
16:07:50 <edwarnicke> Madhu: Note, that doesnt' make it impossible to define the base nicera-extensions stuff in OFplugin, but I concur it would make it messy.
16:08:09 <Madhu> edwarnicke: regXboi am fully open to anything we decide guys
16:08:09 <regXboi> ok... got it
16:08:15 <Madhu> just that we need a clean way to do it.
16:08:26 <regXboi> the statement I saw looked a little backwards
16:08:28 <Madhu> and i volunteered to do it in ovsdb because that is the cleanest at this point
16:08:44 <regXboi> I'm ok with it being in ovsdb at this point while we figure a cleaner solution
16:08:44 <Madhu> regXboi: definitely not a project creep ;)
16:08:51 <edwarnicke> Just to be clear, I strongly feel, and I think Madhu concurs, that the nicera features should be named in a way that does not reference their current project of residence (either ovsdb or ofplugin) because its an open discussion where they should live and we don't want to bias future decisions
16:08:53 <tbachman> I think we need to address phrobb's earlier question about integration tests
16:09:00 <regXboi> Madhu: I wasn't thinking project creep - I was just confused :)
16:09:07 <tbachman> lol
16:09:25 <Madhu> regXboi: i make it a point to satisfy your valid scope creep pointers ;)
16:09:25 <edwarnicke> Madhu: Could you confirm or dispute that I represented your feelings accurately ?
16:09:40 <Madhu> edwarnicke: absolutely
16:09:54 <catohornet> We are also still waiting for netopeer netconf tool installation on LF integration server for testing netconf.
16:09:59 <edwarnicke> Madhu: Cool... I try to be careful representing other folks feelings and opinions, even when I'm pretty sure I got it right
16:10:05 <abhijitkumbhare> Madhu edwarnicke regXboi - I think the Nicira extension can be thought of as a consumer of OF plugin
16:10:08 <Madhu> edwarnicke: just to be clear... we discussed this offline but just for everyone's sake : odl-openflow-nxm-extensions :)
16:10:11 <edwarnicke> catohornet: Whats the blocker there?
16:10:14 <Madhu> abhijitkumbhare: it is
16:10:30 <edwarnicke> Madhu: LOL... here we go again (we've explained it a few times, but its worth explaining again :) )
16:10:32 <Madhu> (i know nxm has extensions ... but this seem way cleaner and readable)
16:11:01 <Madhu> guys back to the discussion on M5 code-freeze
16:11:10 <Madhu> lemme roll back to what phrobb has to say there
16:11:37 <Madhu> phrobb: karaf is a new runtime
16:11:48 <Madhu> phrobb: we have changed some start-levels
16:11:55 <Madhu> phrobb: we have changed some dependencies.
16:12:11 <Madhu> phrobb: and only after all the features are code-committed
16:12:24 <Madhu> we can do a meaningful testing on what happens when all the cooks are in the kitchen
16:12:45 <CASP3R> Also one thing is what feature/project don't play nicely with others
16:12:51 <gzhao> I know Ed et all working on l2swtich,  do bpgcep and aaa start Karaf process
16:12:53 <Madhu> CASP3R: +1
16:13:03 <edwarnicke> Madhu: start-levels? (I think I missed a beat... could you clarify?)
16:13:08 <mlemay> CASP3R: +1
16:13:09 <edwarnicke> gzhao: l2switch is in
16:13:24 <Madhu> edwarnicke: we have start-levels for the existing distribution (defined in config.ini)
16:13:28 <Madhu> with karaf we are removing it
16:13:31 <Madhu> (which is goodness)
16:13:35 <Madhu> we don't know how it is going to impact
16:13:37 <edwarnicke> CASP3R: Should we go over how that's being handled in the integration features.xml ?
16:13:50 <edwarnicke> Madhu: OK... cool, valid point :)
16:13:51 <CASP3R> That would be nice edwarnicke
16:13:57 <Madhu> also... in the legacy distribution... we load ALL the bundles by default
16:14:03 <edwarnicke> Let me find a link...
16:14:05 <catohornet> edwarnicke: without netopeer installed on the tools VM, Netconf is not part of the integration testing.
16:14:09 <Madhu> but in karaf, we let it be loaded at runtime by the user
16:14:19 <edwarnicke> catohornet: Who needs to do what to get it installed?
16:14:23 <Madhu> though Osgi provides that awesomeness... the bundles must behave
16:14:26 <mlemay> Madhu: that could be brought back if needed... but right now it will install based on the dependency tree but still it all is the same start-level from a bundle perspective...
16:14:33 <Madhu> who knows what is hiding behind that closet ?
16:14:45 <Madhu> mlemay: that is my point
16:14:54 <Madhu> there are lot of unknowns at this point
16:14:56 <mlemay> madhu: do you remember which bundles needed specific start levels
16:15:02 <Madhu> which can be known only after all the bundles are pulled in
16:15:11 <edwarnicke> #link https://git.opendaylight.org/gerrit/gitweb?p=integration.git;a=blob;f=features/src/main/resources/features.xml;h=e20c8dc750dfc53213ffcca4b003e9d3bdf225c9;hb=HEAD <- integration features file, with instructions :)
16:15:28 <Madhu> so my request is for this team to consider that Post-M5 there must be a bug fix phase for Karaf
16:15:33 <Madhu> that are identified post M5
16:15:46 <edwarnicke> Madhu: Yes, the issue with start-levels is that, in a situation like ours they basically make the project specifying them non-compatible reliably with the whole world :(
16:15:47 <mlemay> Madhu: +1 defnitely
16:15:48 <phrobb> Madhu:  Yes I understand we will find plenty of bugs once integration testing starts while using the karaf features.  I was trying to see if *new* integration tests are needed and if so, what, and how many are there?… or is it that we will run our existing integration tests on the new karaf runtime (and find plenty of dependency/conflict issues etc.
16:15:54 <edwarnicke> Madhu: They can even break the container :(
16:16:01 <tbachman> There are the RC dates
16:16:02 <tbachman> maybe we should have some goals there?
16:16:03 <phrobb> Madhu:  +1 as well… that makes good sense....
16:16:05 <tbachman> for the integration team?
16:16:20 <edwarnicke> Madhu: I totally agree, we will see some packaging bugs
16:16:35 <Madhu> edwarnicke: not just packaging. we will see runtime bugs
16:16:43 <Madhu> because no one here has got any time to do integration tests
16:16:45 <tbachman> Is the integration team following this?
16:16:46 <edwarnicke> Sure
16:16:48 <Madhu> sorry
16:16:50 <tbachman> b/c they're the ones most affected
16:16:51 <catohornet> edwarnke: we have a request open with helpdesk@opendaylight.org. I think they've been pretty busy of late.
16:16:54 <Madhu> i cannot talk for others..
16:16:57 <Madhu> i didn't do it myself.
16:17:00 <CASP3R> tbachman yes we're following this
16:17:04 <edwarnicke> CASP3R: What have you seen so far in your testing?
16:17:14 <CASP3R> https://jenkins.opendaylight.org/integration/job/integration-master-csit-karaf-of13/4/robot/report/report.html
16:17:16 * tbachman always feels sorry for those at the end of the whip
16:17:18 <phrobb> Madhu:  I aslo assume that you are mandating that all karaf packaging be completed by M5.. as the tests/bug-fix cycle you describe cannot really occur until that is all done correct?
16:17:18 <edwarnicke> catohornet: OK... so its just blocking on infra then?
16:17:23 <CASP3R> that the current report
16:17:29 <Madhu> phrobb: exactly
16:17:33 <tykeal> catohornet: I've got someone looking into that now. Hopefully we'll have it for you today
16:17:39 <Madhu> M5 is the gate for any new feature to be added to Karaf
16:17:42 <edwarnicke> phrobb: Could we add that to the TSC agenda for tomorrow?
16:17:49 <edwarnicke> But I would recommend most folks presume it is so
16:17:50 <Madhu> any bug fixing off there MUST be allowed post M5
16:18:01 <phrobb> edwarnicke:  yes… I'll make sure it is a topic for TSC
16:18:02 <edwarnicke> Madhu: Bug fixing of all kinds is fair game post M5 :)
16:18:11 <catohornet> edwarnicke: yes
16:18:18 <Madhu> edwarnicke: i mean those identified post M5 :)
16:18:29 <edwarnicke> Madhu: Again, same with every other kind of bug
16:18:39 <Madhu> edwarnicke: this is too abstract
16:18:40 <phrobb> although given the rapidfire irc here edwarnicke could you please define "that" for the TSC agenda for tomorrow?
16:18:45 <Madhu> shall we set some ground rules guys
16:18:49 <edwarnicke> Madhu: OK... feels concrete to me
16:18:52 <Madhu> we don't want arbitrary hand waves
16:19:11 <edwarnicke> Madhu: We did a lot of clarifying already
16:19:36 <Madhu> edwarnicke: maybe it is clear for u
16:19:43 <Madhu> can u please explain what are the ground rules ?
16:19:46 <Madhu> so everyone is clear too
16:19:47 <Madhu> ?
16:19:58 <edwarnicke> phrobb: Could you read back the stuff you did earlier in the meeting?
16:19:59 <xsited> #info Thomas Kee PacketCable PCMM
16:20:08 <edwarnicke> xsited: Welcome! :0
16:20:22 <xsited> thx
16:20:23 <regXboi> what I read is a statement that Karaf features be finalized at M5
16:20:41 <regXboi> and then a question of whether bugs found post M5 are allowed to be fixed?
16:20:51 <regXboi> did I miss something or did I distill that correctly?
16:21:06 <edwarnicke> regXboi: Yeah... I think the big point is: get your features in for M5!
16:21:09 <Madhu> regXboi: that is my request / hope
16:21:09 <abhijitkumbhare> Are bugs filed post M5 not allowed to be fixed (after M5 before the release)? Do we say anywhere?
16:21:24 <regXboi> so... my answer would be to the statement: +1
16:21:25 <edwarnicke> abhijitkumbhare: That's the confusion I'm trying to avoid
16:21:32 <edwarnicke> Post M5 we clearly are testing, finding bugs, and fixing them
16:21:57 <regXboi> to the question: I agree with what edwarnicke just said
16:22:04 <regXboi> and was going to say it myself
16:22:20 <edwarnicke> Which is part of the clarificaiton early in the meeting about new tests being acceptable post M5
16:22:22 <mlemay> ed: looking at the projects most of them will not have proper freatures in my monday unless some miracle happens
16:22:29 <Madhu> edwarnicke: u said this before : "[08:47am] edwarnicke: abhijitkumbhare: Definitely.  No committing new bugs after code freeze! "
16:22:30 <abhijitkumbhare> Yes - I would think bug fixes at any point should be a fair game - regardless when bug is found. I mean what if a blocker is found just before the release (due to some bad code pushed in of course)
16:22:32 <mlemay> ed: I just redid the list
16:22:32 <Madhu> what does that mean ?
16:22:50 <phrobb> abhijitkumbhare: edwarnicke Correct.  A bug is a bug regardless when it is found.  The gate through the RCs and final release if if a bug is critical enough to stop a release.
16:23:00 <tbachman> Madhu: I think he was joking there
16:23:02 <CASP3R> it mean don't create any new bugs
16:23:15 <Madhu> tbachman: lol. i wish
16:23:38 <edwarnicke> Madhu: it was a joke in response to abhijitkumbhare correcting himself from talking about "new bugs" to "new bug fixes" :)
16:23:41 <regXboi> phrobb: +1
16:23:58 <Madhu> edwarnicke: now i need a translator to find out what is a joke
16:24:08 <tbachman> lol
16:24:11 <Madhu> and what is being said seriously :)
16:24:12 <mlemay> lol
16:24:13 <abhijitkumbhare> yes - edwarnicke Madhu :)
16:24:23 <tbachman> Madhu: if it's from me, it's a joke, but it's not funny
16:24:25 <edwarnicke> Madhu: Apologies, I'll try adding <joke></joke> in the future :)
16:24:38 <edwarnicke> Madhu: because your point is quite valid
16:24:55 <Madhu> am just perpetually confused i think :)
16:25:00 <Madhu> since most of u got that as a joke
16:25:08 <Madhu> am a sinister sitting here and thinking about that ;)
16:25:27 <tbachman> Madhu: sleep will do us all good
16:25:40 <abhijitkumbhare> I will also add the <joke> </joke> :)
16:25:42 <edwarnicke> Madhu: Truly, apologies, I should be more cautious about not being misunderstood in this context
16:25:48 <Madhu> tbachman: wtf r u talking about ;)
16:25:51 <tbachman> lol
16:26:04 <Madhu> #joke in meetbot ?
16:26:05 <edwarnicke> tbachman: What is this sleep of which you speak?
16:26:06 <Madhu> anyways
16:26:13 <edwarnicke> Madhu: Totally #joke
16:26:16 <Madhu> phrobb: can u please summarize ?
16:26:21 <edwarnicke> Madhu: They could have their own section in the minutes :)
16:26:31 * tbachman notes how patient phrobb is with all of us
16:26:58 <edwarnicke> LOL... sometimes we are like hyperactive children :)
16:27:03 <phrobb> sorry too many meetings this morning… reading scrollback
16:27:06 <paulq> sometimes?
16:27:07 * edwarnicke looks around for pixie sticks...
16:27:17 <Madhu> paulq: lol...
16:27:38 <Madhu> paulq: we can hardly recognize folks here if they change their hyper activism :)
16:27:57 <gzhao> let's go back to Karaf status, any project has started Karaf at this time
16:28:10 <phrobb> madhu sorry, what do you want me to summarize?
16:28:15 <tbachman> gzhao: or is it better to be "has not"?
16:28:17 <edwarnicke> gzhao: I think you are the designated adult
16:28:44 <Madhu> phrobb: just the obvious :) on what is a code freeze ? LOL
16:29:02 <Madhu> sorry phrobb ... we need it because of all the API freeze confusions that happened post M4 ;)
16:31:19 * regXboi amazed at sixty seconds of IRC silence
16:31:23 <mlemay> hahaha
16:31:35 <phrobb> Code Freeze means that no new features/functionality are to be allowed into the Helium code base.  Only errors/bugs identified in the bugzilla system should be allowed.  The exceptions to this include new tests, and documentation.  Packaging, ie Karaf packaging must be completed by M5.  Errors/bugs found post M5 are still bugs and they may be created and worked on post M5
16:31:37 <mlemay> gzhao: I am going to have a list in a couple of minutes
16:31:40 <phrobb> That sound about right?
16:32:01 <regXboi> phrobb: one more loophole to close
16:32:05 <Madhu> phrobb: thanks.
16:32:39 <edwarnicke> phrobb: In response to Madhu's comments, could we make it clear that packaging bugs can be fixed post M5 as well?
16:32:48 <regXboi> by "errors/bugs" you mean filed defects, *not* a feature add masquerading as a bug :)
16:33:00 <phrobb> The committers on each project are responsible for adhering to the code freeze.  They must not allow new features in… no matter how much the contributor tries to spin the new feature as a bug fix.
16:33:05 <edwarnicke> I think Madhu raised the valid point that folks might be confused by 'packaging must be completed by M5' meaning 'you can't fix your packaging bugs' which I don't think was the intention.
16:33:09 <regXboi> phrobb: thx
16:33:43 <phrobb> Yes, bugs in packaging (which we expect plenty) found post M5 are still bugs and can be created and worked on Post M5 (Code Freeze)
16:33:43 <Madhu> i agree guys.
16:33:49 <Madhu> to me freeze is to help us
16:33:52 <Madhu> not threaten us :)
16:34:06 * mlemay is concerned by the current state of karaf features in majority of projects... all the core is in (level 2) priority but the level 3 is far from complete
16:34:10 <Madhu> so anything that works best for the developers must be considered
16:34:12 <tbachman> We  should info this stuff in
16:34:27 <edwarnicke> tbachman: Congratulations, you are now the designated adult ;)
16:34:30 <Madhu> phrobb: +1
16:34:32 <tbachman> lol
16:34:37 <abhijitkumbhare> Would a bug requesting additional debug/logs/specific troubleshooting tool be classified as a feature or a bug? Hypothetical question (don’t have anything in mind).
16:34:58 <Madhu> abhijitkumbhare: i would just use common sense in these cases
16:34:59 <edwarnicke> abhijitkumbhare: That's a really good question
16:35:07 <Madhu> if it is not going to impact anyone, we should
16:35:08 <edwarnicke> Madhu: I tend to agree with you
16:35:24 <Madhu> we are letting committers for each project to mature up :) and see things through
16:35:29 <edwarnicke> Madhu: But I would point out, folks should be cautious about overlogging as that *does* impact folks
16:35:32 <Madhu> including regXboi point
16:35:34 * edwarnicke stares guiltily at his shoes
16:35:41 * tbachman sees the good-intentioned print statement leading to NPEs in corner cases
16:35:53 <edwarnicke> tbachman: You bring up a good point
16:35:55 <edwarnicke> For Hydrogen
16:35:59 <edwarnicke> We did concerted log cleanup
16:36:10 <edwarnicke> Including rooting out System.out.println's outside of tests
16:36:12 <Madhu> tbachman: edwarnicke this is where common sense comes through :)
16:36:15 <edwarnicke> I think we may want to do that again
16:36:17 <tbachman> :)
16:36:22 <Madhu> code-reviews, committers, etc... can catch it
16:36:23 <edwarnicke> Madhu: Totally agree :)
16:36:33 <edwarnicke> Madhu: There is utility is reminding folks though :)
16:36:40 <Madhu> absolutely
16:36:45 * phrobb lightly tosses the elephant onto the table…. What is the sentiment of this group regarding holding the M5 date and release date (respectively next Monday 9/1 for M5 and 9/29 for release)?  Should we discuss a slip to accomodate completion of Karaf feature packaging by the projects and an introduction of a new karaf-feature test phase to the RC cycles post M5?
16:37:06 <edwarnicke> Madhu: I'd also say log pollution are valid bugs that should be filed if stuff is bothering folks... *please* do :)
16:37:17 <Madhu> edwarnicke: absolutely
16:37:36 <Madhu> phrobb: do we first #info on the code-freeze statement that you made ?
16:37:37 * tbachman stares agape at elephant
16:37:39 <Madhu> so that we agree
16:37:43 <Madhu> and move to the next topic ?
16:37:44 * edwarnicke stares guiltily at the editor window on his desktop where he's been accumulating the ones that are bugging him but has not yet filed bugs for :(
16:38:05 <Madhu> edwarnicke: make it +100 for me ;)
16:38:13 <Madhu> expect tons of bugs from me guys ;)
16:38:27 <edwarnicke> Madhu: I did fix the annoying sort order logging thing over the weekend :)
16:38:41 <edwarnicke> Madhu: Thank you :)
16:38:47 <phrobb> Madhu:  Sure, let me cobble that together again...
16:38:54 <Madhu> thanks phrobb
16:39:10 <edwarnicke> #link https://wiki.opendaylight.org/view/Logging_Best_Practices <- Logging Best Practices
16:39:11 * regXboi wondered when the elephant would stick it's trunk into the tent
16:39:28 * edwarnicke scratches behind elephants ears
16:39:43 * Madhu knows no fear... regXboi is here to defend us
16:40:22 <regXboi> so... the question has been asked
16:40:24 <edwarnicke> OK.. I'll call it out
16:40:30 <regXboi> do we hold up?
16:40:42 <edwarnicke> My gut feeling is we can get features in for M5 on Monday (with the possiblity that we define Monday quite late in that day)
16:40:50 <Madhu> regXboi: i will because we have to +1 phrobb 's #info :)
16:40:54 <edwarnicke> I am willing to do Karaf Happy Hour over the weekend if need be
16:41:00 <tbachman> This is just reducing the time for IT and cutting artifacts, etc.?
16:41:08 <phrobb> #agreed Code Freeze means that no new features/functionality are to be allowed into the Helium code base.  Only errors/bugs identified in the bugzilla system should be allowed.  The exceptions to this include new tests, and documentation.  Packaging, ie Karaf packaging must be completed by M5.  Errors/bugs found post M5 are still bugs and they may be created and worked on post M5.  This includes packaging bugs found as
16:41:11 <tbachman> (i.e. end date isn't moving)
16:41:24 <Madhu> edwarnicke: weekend 7.30 is a good time for me :) and for those who has kids to drop to school in PT :)
16:41:59 <edwarnicke> Madhu: LOL... I think continuity of time is probably good, but shutter at getting up early on weekend :(  Hoist on my own pitard :(
16:42:14 <edwarnicke> CASP3R: Are you going to be around this weekend to help with integration reviews?
16:42:19 <Madhu> edwarnicke: seriously u sleep ?
16:42:21 <CASP3R> yes :(
16:42:24 <Madhu> edwarnicke: am disappointed
16:42:39 <edwarnicke> Madhu: I have found in recent days that I am much more pleasant to be around when I do :)
16:42:41 <Madhu> thanks phrobb
16:42:51 <edwarnicke> Madhu: And I do try to sleep-to-completion on weekends :)
16:42:54 <Madhu> edwarnicke:  u always are ;)
16:43:05 <mlemay> hehehe
16:43:17 <edwarnicke> Madhu: I am glad others see it that way... *I* find me unpleasant when I don't get enough sleep ;)
16:43:18 <phrobb> We pause for this commercial interruption…. If you are attending the Dev Design Forum at the end of Sept, you need to register and book your hotel very soon… rate increases are imminent… now back to your regular scheduled programing….
16:43:34 * tbachman is registered and booked
16:43:42 * dfarrell07 tabs over to book now
16:43:43 * edwarnicke would like to thank our commercial sponsor, the ODL Dev Design Summit :)
16:43:55 <Madhu> phrobb: nice wedge :)
16:44:10 <Madhu> won't take that bait yet ;)
16:44:17 * edwarnicke the ODL Design Summit is both a floor wax *and* a desert topping!
16:44:23 * regXboi wonders if there will be any virual support @ design summit
16:44:27 <tbachman> $19.99
16:44:35 <Madhu> phrobb: regarding the elephant question :)
16:44:39 <edwarnicke> And if your register now...
16:44:40 <phrobb> edwarnicke:  LMAO
16:44:51 <Madhu> phrobb: i still believe that if we all prioritize karaf (i mean every single proejct)
16:44:54 <Madhu> we can hit the dates
16:44:59 <edwarnicke> Madhu: Agreed :)
16:45:07 <Madhu> but have enough ample room to fix bugs post M5
16:45:13 <Madhu> we all need that room.
16:45:20 <edwarnicke> Madhu: Also agree
16:45:22 <mlemay> Madhu: / Ed for all that is core yes.. but what about the less responsive projects
16:45:38 <tbachman> phrobb: just to make sure we understand -- are there requests outstanding to push?
16:45:38 <edwarnicke> mlemay: Who looks less responsive right now?
16:45:46 <Madhu> mlemay: we want to motivate those less responsive projects. don't we ?
16:45:59 <mlemay> ed: / madhu: I'm making the list
16:46:03 <mlemay> will ahve shortly
16:46:09 <edwarnicke> mlemay: I ask, because I have seen a bunch of folks turning up at Karaf Happy Hour... sometimes a bit confused, but striving hard :)
16:46:12 <mlemay> don't want to call out without full proof
16:46:17 <mlemay> but most have draft features in
16:46:19 <edwarnicke> mlemay: No worries :)
16:46:20 <abhijitkumbhare> phrobb - about the elephant (not speaking for the openflow plugin project - but a general point) - I am not sure about M5 should slip - but may be something to consider if the community wants a longer test cycle to stabilize karaf based distributions. At the same time - think we all should be able to hit the existing dates.
16:46:21 <phrobb> Madhu:  edwarnicke that is good to hear… I'm all for sprinting hard and keeping the dates.. I just don't want to come to Sept 28th and notice a huge elephant on the table then :-)
16:46:22 <mlemay> some have nothing
16:46:41 <Madhu> phrobb: am not talking about Sept28th yet :)
16:46:44 * edwarnicke dislikes elephant dung
16:46:48 <Madhu> am talking only about Sept1
16:46:59 <Madhu> i think Sept28th is purely based on the quality of the release.
16:47:01 <edwarnicke> Madhu: Lets keep our eyes on M5 for the moment, agreed
16:47:08 <tbachman> edwarnicke: even the coffee beans in it?
16:47:18 * tbachman hears those are expensive
16:47:20 <Madhu> tbachman: rofl.
16:47:25 <edwarnicke> tbachman: I am very picky about my coffee beans
16:47:26 <Madhu> tbachman: yep. very expensive
16:47:34 <mlemay> Madhu/ed: I think we should keep the get but I would bet (would like to be proven wrong) that we'll still have missing projects at M5...
16:47:36 <phrobb> Ah, fair enough.  Let's just worry about M5 and having all karaf features defined, implemented, and pushed to integration
16:47:40 <mlemay> (from a karaf point of view)
16:47:46 <edwarnicke> tbachman: Besides, most of those coffee beans are being force fed to mastadons these days
16:47:51 <tbachman> lol
16:48:04 <mlemay> s/get/date
16:48:20 <gzhao> mlemay: getting all projects to Karaf by M5 is a challenge.
16:48:38 <edwarnicke> gzhao: Agree, but I believe in us :)
16:48:59 <tbachman> Do we declare that, then re-evaluate on M5?
16:49:05 <tbachman> Or just make that decision now
16:49:15 <tbachman> and do we have such authority to do so?
16:49:19 <abhijitkumbhare> gzhao: not sure if extending the dates for M5 will make any difference for non-responsive projects
16:49:40 <Madhu> abhijitkumbhare: i agree.
16:49:40 <edwarnicke> tbachman: I don't think we have any formal authority... but as the guys doing the work, we can make it so :)
16:49:58 <Madhu> but i do se gzhao's point
16:50:01 <edwarnicke> tbachman: Lets focus on getting stuff in, helping each other, and getting it done
16:50:03 <Madhu> we don't want to leave anyone behind
16:50:22 <mlemay> one thing I need to say is sometimes even the draft featured didn't make it through
16:50:22 <gzhao> abhijitkumbhare: it helps, but that means slip in the milestone.
16:50:24 <edwarnicke> gzhao: Could you try to figure out which projects are at risk so we can get them helping hands?
16:50:30 <mlemay> some projects didn't merge the "skeleton"
16:50:33 <edwarnicke> gzhao: Not sure what to do about completely non-responsive though
16:50:43 <phrobb> Can we prioritize the challenge and divide and conquer the work?… ie what can we do to be as efficient as possible with the resources we have?… George and I for wrangling… Ed, Mathieu, Madhu for hand-holding, etc…
16:50:55 <mlemay> not that it mattters anymore but we need to review features everywhere
16:51:10 <mlemay> so we should at least tell all projects that this is coming and coming very hard at them
16:51:11 <phrobb> No one has ever been totally non responsive to me… it's just a matter/level of nagging
16:51:13 <edwarnicke> mlemay: We do have some review as they come into integration
16:51:18 <gzhao> edwarnicke: I need response from bgpcep, aaa
16:51:29 <mlemay> bgpcep is pending
16:51:31 <edwarnicke> mlemay: And we have a lot of... help in getting them right in the archetypes
16:51:31 <mlemay> (git review)
16:51:45 <edwarnicke> liemmn: Where is AAA on karaf?
16:51:50 <mlemay> aaa is not in integration
16:51:52 <gzhao> mlemay: great
16:51:53 <Madhu> phrobb: i think mlemay's view on karaf on projects must be taken seriously
16:51:55 <mlemay> but has karaf features
16:52:07 <Madhu> phrobb: as u know he is the guy who actively got the community behind it :)
16:52:28 <edwarnicke> gzhao: I think BGP is onboard, just taciturn:
16:52:35 <mlemay> Madhu: thanks but my view is we keep the date but I also see "latency" in the process
16:52:37 <edwarnicke> #link https://git.opendaylight.org/gerrit/#/c/10345/ <- BGP features patch for integration
16:52:53 <mlemay> not all projects are as fast as l2switch, dlux, etc... ;)
16:53:06 <Madhu> fwiw, ovsdb is not in yet :) but it is working on the ovsdb project :)
16:53:14 <Madhu> i will push it today to integration
16:53:20 <edwarnicke> Madhu: I have complete trust you'll get in by M5 :)
16:53:23 <Madhu> so mlemay what u mean by keep the date but latency ?
16:53:37 <Madhu> edwarnicke: that is one thing i trust myself on :)
16:53:45 <gzhao> edwarnicke: cool, then projects has others depend on are mostly on track.
16:53:46 <Madhu> dates are my nightmares. ;)
16:53:53 * phrobb scratches head on the introduction of the "latency" term within this deadline discussion… mlemay can you elaborate?
16:53:55 <Madhu> either way u see it. lol
16:53:57 <edwarnicke> Madhu: The Medjool ones are nice :)
16:54:13 <edwarnicke> phrobb: This is what you get for associating with network guys :)
16:54:14 <Madhu> oh there is a third meaning for that... edwarnicke thanks for point that
16:54:55 <mlemay> Madhu/Phil: I mean not all projects react at the same speed.. some were very quick at merging the propsed changes when I helped and others where still at loss... II'm sure this is still the case...
16:54:59 <edwarnicke> phrobb: What else do we need to work out here?
16:55:30 <Madhu> mlemay: agreed. so ? :)
16:55:37 <Madhu> am just waiting to hear the punch-line
16:55:57 <tbachman> are we coming up on 1-1/2 hrs?
16:56:01 * edwarnicke ponders various punchlines... and considers whether they need the <joke /> tag
16:56:02 <mlemay> I think it's a little unfair to give only a couple of days to folks for the switch.. (many are still using the old distro and controller just got mostly finalized) so I can see why (BTW I'm just playing devil's advocate here)
16:56:04 <mlemay> :P
16:56:31 <edwarnicke> mlemay: I think your argument is: shoot for M5, see where we are when we get there?
16:56:32 <Madhu> mlemay: yes. still waiting for that punch-line on what latency means ?
16:56:50 <phrobb> #info Docs are a very lagging activity… project contacts need to engage with the docs team on both transitioning existing wiki docs from hydrogen to helium asciidoc and also filling in all the new content.. and of course this is tied to the karaf features defined for each project…
16:56:53 <mlemay> ed: yup
16:57:11 <phrobb> Expect more on docs needs/activities from George and I soon
16:57:17 <edwarnicke> phrobb: many thanks :)
16:57:19 <Madhu> mlemay: keeping M5 a moving target u mean ?
16:57:22 <edwarnicke> gzhao: Many thanks :)
16:57:23 <Madhu> just to be clear :)
16:57:33 <edwarnicke> Madhu: I didn't hear it as such personally...
16:57:34 <mlemay> madhu: sorry for the latency terminology in there... why simply referring to the ping process with projects ;) from a docs and karaf perspective :P
16:57:44 * edwarnicke is really really allergic to moving targets after Hydrogen
16:57:51 <mlemay> we don't have <1ms all over the place ;P
16:58:04 <mlemay> people might still be on PTO this week too
16:58:05 <Madhu> mlemay: especially when controller jenkins take 8 hrs ... /ducks
16:58:15 <mlemay> Madhu: I think it's better now
16:58:16 <Madhu> mlemay: very very valid point on long weekend.
16:58:18 <edwarnicke> Madhu: I have sent out a proposed fix for that to controller-dev :)
16:58:21 <regXboi> all: I need to run to another meeting
16:58:35 <edwarnicke> Madhu: And I shaved of 15 minutes per job already :)
16:58:35 <Madhu> same here guys. have to run now
16:58:41 <edwarnicke> Me too
16:58:42 <edwarnicke> ttyl
16:58:48 <mlemay> ok latez
16:58:54 <abhijitkumbhare> OK - bye folks
16:58:57 <Madhu> phrobb: the elephant is still lurking
16:59:00 <tbachman> are we any closer?
16:59:12 <tbachman> do we need a post-pre-M5 meeting?
16:59:26 <Madhu> lol. i get this joke ;)
16:59:34 <mlemay> phrobb/gzhao I'll send you the excel with the current status I've gotten by looking all the projects this am
16:59:44 <gzhao> mlemay: thanks
16:59:45 <edwarnicke> tbachman: Only if its in a bar :)
16:59:51 <tbachman> lol
17:00:01 <tbachman> <joke>lol</joke>
17:00:15 <phrobb> Let's call this one for today.  We keep sprinting to M5 and use the status SS to wrangle as fast as we can.  Should I set up an IRC meeting for Monday so we can all chime in where we are?
17:00:18 <Madhu> phrobb: gzhao i have to jump now too.. shall we have an "emergency" meeting tomorrow on M5 ?
17:00:18 <mlemay> gzhao: the feature crawler doesn't work as I have issues because for some reason the feature file isn't deployed as a snapshot in integration
17:00:20 <Madhu> prior to TSC ?
17:00:22 <gzhao> phrobb: maybe it is time to raise the what if question
17:00:44 <gzhao> Madhu: I think we should
17:00:56 <Madhu> sorry guys. have to run.. later. maybe tomorrow. i strongly encourage an emergency meeting tomorrow
17:01:09 <Madhu> "preferably" between 9  - 10am PT :)
17:01:20 <Madhu> bye
17:01:24 <gzhao> Madhu: ok, will let you know
17:01:26 <abhijitkumbhare> phrobb: isn’t Monday long weekend?
17:01:27 <phrobb> thanks Madhu
17:01:37 <gzhao> abhijitkumbhare: yes, it is
17:01:53 <Madhu> ... and my family hates me for working during long weekend.
17:01:55 <phrobb> Arg!! did I seriously put M5 on Labor Day?
17:01:58 <Madhu> bad planning
17:02:32 <tbachman> phrobb: apparrently none of us noticed either
17:02:44 <Madhu> my wife did :)
17:02:45 <gzhao> phrobb: actually, that gives people one extra day
17:02:46 <Madhu> bye guys.
17:02:52 <tbachman> Madhu: l8r
17:02:55 <phrobb> Well, that was an error!  Sorry guys...
17:02:56 <gzhao> Madhu: bye
17:03:55 <phrobb> What for new meeting invitation… I heard either tommorrow or Next *Tuesday*… can I get a sense from the group which they prefer?
17:04:20 <phrobb> s/what/watch
17:04:32 <gzhao> phrobb: Madhu suggest a M5 emergency meeting before TSC tomorrow.
17:05:03 <phrobb> Can others make an emergency meeting tomorrow morning?… I'd like to get a sense of participation
17:05:18 <abhijitkumbhare> Are there going to be lot of new points coming up between today and tomorrow?
17:05:20 <mlemay> @phrobbs: sadly I'll be travelling tomorrow
17:05:21 <dkutenic> IRC only?
17:05:26 <phrobb> yes
17:05:47 <mlemay> but please bring up the status excel point if possible
17:05:49 <hideyuki> phrobb: I would like to extend Karaf happy hour rather than the M5 emergency meeting.
17:05:51 <mlemay> and keep me posted
17:05:57 <abhijitkumbhare> I mean new data points with respect to karaf?
17:06:24 <phrobb> abhijitkumbhare:  I don't think so…
17:06:44 <abhijitkumbhare> then agree with hideyuki
17:06:51 <mlemay> hideyuki: it's a good idea
17:07:13 <gzhao> hideyuki: Ed will be happy hearing this
17:07:22 <hideyuki> My work for karaf stops for this 1 hour.
17:07:44 <phrobb> Alright, for any interested we will discuss any karaf issues on the karaf happy hour tomorrow.  I will schedule an irc meeting for next Tuesday after the weekend so we can all assess where we are on code freeze for M5
17:07:59 <phrobb> Thanks everyone  for hanging on so long.  I'll end the meeting now....
17:08:03 <phrobb> #endmeeting