17:01:38 <colindixon> #startmeeting Helium Pre-RC0 meeting
17:01:38 <odl_meetbot> Meeting started Mon Sep  8 17:01:38 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:38 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:38 <odl_meetbot> The meeting name has been set to 'helium_pre_rc0_meeting'
17:01:44 <colindixon> #topic agenda bashing
17:01:52 <colindixon> phrobb: do you want to take it away?
17:02:00 <edwarnicke> #info edwarnicke
17:02:01 <phrobb> sure colindixon…
17:02:05 <tbachman> are we IRC only?
17:02:05 * edwarnicke ducks chair
17:02:11 <edwarnicke> tbachman: Yes :)
17:02:13 <tbachman> :)
17:02:21 <phrobb> Project representatives please #info in
17:02:33 <tbachman> #info tbachman for Group Based Policy
17:02:36 <gzhao> #info gzhao for release
17:02:40 <colindixon> #info colindixon for TTP
17:03:02 <hideyuki> #info Hideyuki Tai for VTN
17:03:15 <colindixon> #chair Madhu gzhao phrobb edwarnicke
17:03:15 <odl_meetbot> Current chairs: Madhu colindixon edwarnicke gzhao phrobb
17:03:27 * edwarnicke will duck chair harder next time :)
17:03:33 <tbachman> lol
17:04:11 <colindixon> tbachman: IRC only is the plan
17:04:19 <tbachman> colindixon: thx!
17:04:21 <phrobb> #info sorry for the short notice on this meeting folks.  I will send out another invitation for a pre RC0/RC1 meeting for this Wednesday at 8:30am PT shortly after we adjourn here…
17:04:50 <colindixon> thanks phrobb
17:05:15 <phrobb> I expect it would be good to get an update on activity toward the RC0.  edwarnicke I know you've been working hard on Karaf and autorelease to that end.  Could you provide the group with an update?
17:05:32 <abhijitkumbhare> #info abhijitkumbhare for OpenFlow plugin (looks like the meeting going to be on Wednesday)
17:05:49 <edwarnicke> phrobb: Yes
17:05:56 <colindixon> #topic karaf/autorelease update
17:06:08 <edwarnicke> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1991333031 <- gzhao 's wonderful tracking spreadsheet for autorelease
17:06:30 <edwarnicke> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=638121282 <- gzhao 's wonderful tracking spreadsheet for karaf
17:06:36 <gzhao> edwarnicke: thanks
17:06:48 <colindixon> awesome
17:06:50 * colindixon looks
17:07:03 <edwarnicke> gzhao: Could you take over summary of things there?  And I can fill in with some late breaking autorelease stuff as we go?
17:07:04 <gzhao> #info Karaf  last update 9/7/2014 6:00 pm PST
17:07:41 <gzhao> #info 16 project done and integrated, 3 WIP and 1 red
17:08:01 <edwarnicke> Do we have Christine from snmp4sdn?
17:08:17 <gzhao> I talked to Asaf Defense4All still not decide to go for Karaf or not for Helium
17:08:27 <edwarnicke> gzhao: I think the blocker there is that snmp4sdn is using -DskipTests in their merge job... and thus do not run the features tests and cannot reference them in their integration commit
17:08:41 <gzhao> I emailed snmp4sdn-dev not response yet
17:08:45 <edwarnicke> gzhao: The bloccker for snmp4sdn that is
17:08:57 <edwarnicke> gzhao: Could you take the action to try to get this cleared with them?
17:09:13 <edwarnicke> gzhao: You might also try emailing Christine directly
17:09:21 <gzhao> #action gzhao will follow up snmp4sdn for Karaf
17:09:25 <colindixon> so, looking at auto-release, it seems we’re blocked on the helpdesk?
17:09:32 <gzhao> edwarnicke:  I did
17:10:06 <gzhao> will follow up with Christine again
17:10:25 <gzhao> I don't have response from Plugin2OC
17:10:43 <gzhao> will send them email to follow up as well
17:10:56 <edwarnicke> gzhao: I have an email from them... I'll link you in
17:10:57 <tbachman> gzhao: I’ve just started working with them as well (or at  least sent them an email, offering help)
17:11:00 <phrobb> colindixon:  I believe the blocking issue on dlux (ticket 6945) was cleared about 45 minutes ago
17:11:37 <edwarnicke> phrobb: Yep... testing now :)
17:11:49 <colindixon> #Info we have 4 projects that we need to follow up with about karaf: sdni, reservation, plugin2oc, and defense4all
17:12:01 <edwarnicke> phrobb: Also blocking for opflex (6948) is also reported cleared (testing as well)
17:12:15 <phrobb> edwarnicke:  cool
17:12:17 <colindixon> #undo
17:12:17 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x249a7d0>
17:12:23 <edwarnicke> phrobb: Even 6846 (a nice to have request that will make things much easier) is also reported in :)
17:12:45 <colindixon> #Info we have 5 projects that we need to follow up with about karaf: sdni, reservation, plugin2oc, defense4all, and smp4sdn
17:12:47 <edwarnicke> gzhao: phrobb I am also trying to add packetcable now as they are merged in integration with their karaf stuff now
17:13:19 <colindixon> edwarnicke and gzhao, I saw above that we’re in touch with plugin2oc and I assume we’re in touch with reservation
17:14:00 <phrobb> #info I think it would be worthwhile to define what we all mean by "Release Candidate" similar to how we defined "Code Freeze" as part of the M5 meeting.  Does that sound like a worthwhile activity to those here?
17:14:22 <colindixon> I’d like to do that
17:15:04 <colindixon> my personal idea would be that it would be runs of the autrelease script that could then be tested as a distribution rather than per-project/per-bundle snaphsots
17:15:13 <colindixon> so maybe we should move to that topic
17:15:17 <colindixon> and we could talk about auto-release
17:15:30 <edwarnicke> colindixon: Yeah, I tend to think of it the same way: can we cut a testable thing to test.
17:15:38 * edwarnicke is evidently having a semi-circular morning
17:15:42 <colindixon> unless somebody else, e.g., edwarnicke, gzhao, or Luis, disagree
17:16:10 <gzhao> I agree
17:16:23 <colindixon> edwarnicke: well the difference between an RC and the rest fo the stuff we do is that with an RC there is a single version across all artifacts, across all projcts that can be built and tested
17:16:27 <colindixon> in my mind
17:16:36 <colindixon> #topic defining RC0
17:16:49 <edwarnicke> colindixon: I think you and I are violently agreeing
17:17:08 <edwarnicke> colindixon: And I think I can have the autorelease, at least for the stuff that is in integration for karaf doing that for tomorrow
17:17:32 <repenno> How can I get a project under Sonar?
17:18:00 <colindixon> #info colindixon proposes that what defines an RC vs. the previous milestones is that it is the result of a run of the auto-release scripts that assigns a single version, e.g., helium-rc0, to all the artifacts so that a specific stable version can be built and tested across *all* the projects
17:18:07 <colindixon> #info gzhao and edwarnicke largely agree
17:18:14 <colindixon> do others have differnet thoughts?
17:18:22 <colindixon> also, while we’re here, what’s the state of auto-release?
17:18:44 <phrobb> col
17:18:48 <abhijitkumbhare> I agree colindixon and edwarnicke (single version across artifacts) - but what are the criteria between RC0, RC1, etc.
17:18:59 <edwarnicke> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1991333031 <- current verified state of autorelease
17:19:05 <edwarnicke> There are a few addentums here
17:19:12 <colindixon> abhijitkumbhare: I think it’s just that we do it once a week until we release
17:19:23 <colindixon> I don’t think there are speicific goals for each one
17:19:26 <edwarnicke> As phrobb noted, the helpdesk cases that were blocking are cleared, and so the hope is the stuff blocking on them is also cleared
17:19:34 <abhijitkumbhare> OK - so for RC0 we say it can be built
17:19:37 <phrobb> colindixon:  My one big question is "must all projects in the release be code-frozen"?  That's where I am currently hung up because we still have projects not yet in code freeze.
17:19:42 <abhijitkumbhare> & tested
17:20:10 <xsited1> #info Thomas for packetcable
17:20:10 <abhijitkumbhare> RC1 - major projects tested to be working
17:20:22 <edwarnicke> Addentum 2 to the spreadsheet is that packetcable is now in integration with karaf, and so I am trying that as well
17:20:38 <colindixon> abhijitkumbhare: the thing is that RC0 freezes a version the code for all bundles, which means you can’t easily test again until you cut a new version, which is RC1
17:20:40 <edwarnicke> xsited1: Congratulations on getting your karaf stuff into integation :)
17:20:56 <colindixon> #info phrobb asks how the RCs interact with code freeze
17:20:57 <edwarnicke> xsited1: I was just pointing out that I'm trying to get you into autorelease now :)
17:21:30 <edwarnicke> I do have a question though... what's going on with toolkit?  Not quite sure what to do there or what's going on with it... anyone know?
17:21:40 <xsited1> ed: sweet.  thx for the caught up
17:21:44 <colindixon> phrobb: I think that it’s not strictly necessary (although it woudl be really good) for projects to be code-frozen for the RCs if they’re just a leaf project in dependency space and can thus be independently enabled/disable
17:22:04 <colindixon> edwarnicke, gzhao, phrobb: does that sound right
17:22:07 <colindixon> ?
17:22:40 <colindixon> I mean, as a matter of technicality, we can’t stop projects from merging code in a technical sense
17:22:44 <gzhao> colindixon: some projects are 6-10days delay
17:23:06 <gzhao> they plan to freeze code date beyond RC0
17:23:17 <abhijitkumbhare> colindixon - how about the following: RC0 built & tested; RC1 - some core projects (TBD) tested; RC2 - all projects verified (at least by the projects individually if not by the integration team)?
17:23:30 <colindixon> #info abhijitkumbhare asks about what should be accomplished for the different RCs
17:24:05 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Schedule this doens’t say anything specific about goals for each RC other than projects have to hold release reviews for RC2
17:24:34 <colindixon> abhijitkumbhare: so, we like to avoid the word “core” since it has technical meaning in the bylaws
17:24:38 <colindixon> but, I like the idea
17:24:52 <abhijitkumbhare> Yes - we can avoid core
17:25:05 <frankieonuonga> reminds me of the old days of fedora core
17:25:05 <edwarnicke> xsited1: Congratulations... packetcable builds in autorelease
17:25:13 <frankieonuonga> though that has nothing to do with this
17:25:20 <abhijitkumbhare> Just  interdependent projects may be
17:25:43 * edwarnicke now knows a *lot* about project interdependencies from the autorelease exercise ;)
17:25:52 <colindixon> that being said, since the release plan puts no requirements on projects for RC0 and RC1, I’m not sure we can force them to do anything
17:25:53 <hideyuki> Please don't forget that there are artifacts out of Karaf distribution, for example, VTN Coordinatoror OpFlex artifacts.
17:26:02 <abhijitkumbhare> edwarnicke - that's for sure
17:26:36 <colindixon> what do people think about having suggestions for what we want to get done for RC0, RC1 and RC2?
17:27:41 <colindixon> abhijitkumbhare: proposes RC0 is just getting the auto-release script to run for all projects once (although even that might be ambitious), RC2 is about getting projects which have people depending them (or at least a lot of them) test in some sense, and RC3 is about testing everything
17:27:50 <colindixon> thoughts?
17:28:13 * edwarnicke notes that he *did* promise at the hydrogen artifact cutting, that God as his witness, Monday would never happen again ;)
17:28:29 <edwarnicke> What happened to RC1?
17:28:29 <abhijitkumbhare> colindixon Yes - except RC0, RC1 & RC2 - not RC0, RC2 & RC3
17:28:54 <colindixon> edwarnicke, abhijitkumbhare: yeah
17:28:57 <colindixon> there is no RC3
17:29:07 <LuisGomez> RC3, is that new?
17:29:32 <colindixon> LuisGomez: no, typo
17:29:51 <colindixon> #info abhijitkumbhare proposes the following ideas for what we might have as goals for the RCs
17:29:56 <LuisGomez> ok, i believe we need to have at least 2 RCs fully tested before we release
17:29:57 <phrobb> colindixon:  Maybe I'm just old-fashioned in my use and understanding of the term RC in that it used to mean that it was truly a set of code that *could* be released.  The expectation being that when first generating this code base, it was expected that significant ship-blocking bugs would be found, fixed, then an RC1 would be cut (with a repeated cycle for RC2… RC3 as needed).
17:30:15 <colindixon> #undo
17:30:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2526f10>
17:30:16 <gzhao> #info hideyuki  mentioned there are artifacts out of Karaf distro. e.g VTN coordinator, opflex
17:30:16 <gzhao> colindixon: +1 for abhijitkumbhare's proposal for RC0, RC1
17:30:35 <colindixon> phrobb: I’m just not sure we can get there?
17:30:42 <colindixon> coordinated lists of bugs that get fixed and shipped again
17:30:47 <colindixon> but I’d love to try
17:31:46 <gzhao> phrobb:
17:32:23 <colindixon> #info phrobb says he’d been thinking of RCs in a more traditional sense, where it was really code that could be released, is then tested and the ship-blocking bugs are fixed resulting in the next RC
17:32:49 <edwarnicke> phrobb: I think some projects are there and some are not
17:33:18 <gzhao> phrobb: given today's project status and RC dates, one of the two needs to be altered.
17:33:40 <colindixon> #info abhijitkumbhare proposes some ideas for goals around RCs:
17:33:44 <colindixon> #Info RC0 is getting a full build of all (or at least the vast majority) of the artifacts by auto-release
17:34:10 <phrobb> colindixon:  edwarnicke I don't want to unduly hold up the release (ie slip schedule), but I would rather slip a week or two than not have adequate testing/bug-reporting completed.  Not having all projects at code freeze concerns me.  The potential for significant bugs and unforeseen interdependencies seems unacceptably high.
17:34:11 <colindixon> #info RC1 is incorporating testing and bug fixing for all (or at leas the vast majority) of the projects which others depend on 
17:34:31 <edwarnicke> colindixon: Could we hash out your #info a bit
17:34:58 <colindixon> #info RC2 is a full testing and bug fixing patch before the release
17:35:02 <edwarnicke> Right now what I have is the projects that have their karaf stuff integrated into karaf in integration, plus opflex (for which that makes no sense)
17:35:09 <edwarnicke> I am unclear what to do with toolkit
17:35:13 <colindixon> #info the above is a proposal from abhijitkumbhare, not agreed upon
17:35:40 <colindixon> edwarnicke: my intent was just to capture some of the discussion not imply it was truth
17:35:41 <frankieonuonga> ooooh now i get it...so rc0 1 and 2 are more like alpha beta and final candidate release
17:35:43 <edwarnicke> colindixon: I think what we need to agree on today is the RC0, correct?  I'd love to agree on other stuff... but am not sure we strictly have to, and might be better for the Wednesday timeslot
17:35:50 <colindixon> yeah
17:35:56 <colindixon> I think that’s right
17:36:10 <abhijitkumbhare> I am fine with that edwarnicke
17:36:11 <phrobb> gzhao:   I would agree.  Projects get dropped, we push back the dates, or we make the decision to have a very short, or non-exitent full final-code QA cycle.
17:36:34 <colindixon> #info edwarnicke proposes to focus on RC0 for right now, once we cut artifacts we can decide how to move forward
17:37:02 <edwarnicke> colindixon: Also... I think there are a bunch of folks in other timezones who are expecting us to do this in a more international friendly timezone on Wed
17:37:04 <colindixon> also, I think that devinavery, and some others from the MD-SAL area are planning to present their plans around how to do some of this during tomorrow’s TWS call
17:37:11 <colindixon> fair point
17:37:33 <colindixon> phrobb: are you OK with moving to near-term topic of blocking and tackling to get RC0 out the door?
17:37:41 <gzhao> shall we define a criteria when we have to decide that project cannot make Helium
17:37:54 <phrobb> colindixon:  yes, absolutely
17:38:00 <colindixon> #topic getting RC0 out the door
17:38:20 <edwarnicke> OK... not to sound all self centered and stuff... but I really need to know what to do about toolkit
17:38:26 <edwarnicke> Does anyone know its status?
17:38:31 <colindixon> #info as I understand it, this is really getting the auto-release to work for all participating projects
17:38:43 <edwarnicke> I suspect its makes no sense for it to go karaf
17:38:45 <colindixon> Madhu, you and I are committers
17:39:22 <colindixon> is andrew around?
17:39:36 <gzhao> TTP said N/A for Karaf
17:39:44 <gzhao> since M4 and confirmed in M5
17:40:03 <gzhao> sorry ToolKit
17:40:07 <colindixon> gzhao: I’m on the TTP project and we’re in karaf and working
17:40:10 <colindixon> ah
17:40:16 <colindixon> ok
17:40:54 <Madhu> sorry guys..
17:40:58 <Madhu> on calls.
17:41:16 <Madhu> Toolkit and code-freeze don't make sense. and I think it should be N/A
17:41:20 <Madhu> if that is the question :)
17:41:30 <colindixon> Madhu: it was about karaf
17:41:32 <colindixon> but yes
17:41:35 <Madhu> answer is same
17:41:43 <Madhu> N/A for karaf too
17:41:45 <colindixon> really, it’s not even clear to me why toolkit is participating in the release
17:41:53 <Madhu> +1 colindixon
17:42:04 <Madhu> toolkit is a kit for developers to build on top
17:42:04 <edwarnicke> Madhu: Could you help me understand why toolkit and code freeze don't make sense?  I get why karaf doesn't make sense... but am confused about code freeze.
17:42:07 <Madhu> nothing to release perse
17:42:19 <gzhao> #info ToolKit is N/A for Karaf and code freeze. - Madhu
17:42:29 <Madhu> edwarnicke: good point
17:42:42 <colindixon> I mean, I guess participating in the release makes sense just to indicate that it’s been tested and works with the Helium code release
17:42:54 * edwarnicke is not questioning what Madhu is saying... but is just having trouble wrapping his head around it ;)
17:42:56 <Madhu> edwarnicke: thats because toolkit and participation to Helium doesn't make sense
17:43:09 <Madhu> since code-freeze is for Helium release
17:43:14 <Madhu> it doesn't make sense and hence N/A
17:43:20 <gzhao> #info edwarnicke  Madhu added Toolkit code freeze is not release perse
17:43:31 <edwarnicke> Madhu: Oh... OK :)  I was operating from the presumption toolkit was participating in Helium... if not that simplifies the question a lot :)
17:43:36 <colindixon> (as a note, I want to come back to gzhao’s comment about when/if we drop projects from the He release based on missing deadlines and/or other concerns)
17:43:55 <colindixon> (my guess is that we can’t handle that here)
17:44:10 <edwarnicke> Madhu: Was trying to figure out how to do right by toolkit for Helium ;)
17:44:21 <gzhao> edwarnicke: does that mean toolkit no need to be included in autorelease
17:44:51 <colindixon> edwarnicke: so, if we ignore toolkit… what’s next on the getting something we can call RC0 out the door?
17:44:54 <colindixon> gzhao: good question
17:44:54 <edwarnicke> gzhao: If toolkit is not in Helium, I would say it shouldn't be in the autorelease for Helium.
17:45:09 <edwarnicke> colindixon: Next point of concern is defense4all
17:45:20 <edwarnicke> Or rather, point of confusion
17:45:21 <colindixon> I mean, it would be good of toolkit was tested and confirmed to work with helium code, but if people aren’t going to find the time to do it…
17:45:35 <edwarnicke> (there is also concern for the projects not in karaf in integration yet that logically should be there)
17:46:07 <edwarnicke> Do we have anyone here for defense4all?
17:46:08 <colindixon> #action colindixon and Madhu to follow up with Andrew Kim to make sure that we can actually remove toolkit from the helium release or figure out a better plan by the next pre-RC meeting
17:46:24 <colindixon> edwarnicke: also is there concern for projects that have yet to have code-freeze?
17:46:43 <edwarnicke> colindixon: I am still on the mechanics ;)
17:46:45 <colindixon> gzhao: have you been in touch with def4a?
17:46:53 <gzhao> colindixon: yes
17:47:26 <edwarnicke> Madhu: colindixon just so there is no confusion, currently I am leaving toolkit out of the autorelease till someone tells me something else...
17:47:28 <gzhao> colindixon: they upstream their code, I saw a spike check in in github
17:47:36 <colindixon> gzhao: and what’s their status w.r.t. to auto-release and karaf
17:47:41 <edwarnicke> gzhao: You mean the master branch at ODL?
17:47:44 <colindixon> edwarnicke: noted
17:47:56 <gzhao> colindixon: Assaf wants to keep the project yellow for some bug fixing
17:48:19 <gzhao> edwarnicke: github.opendaylight.org/defense4all
17:48:32 <edwarnicke> gzhao: That's pretty much meaningless in terms of ODL
17:48:47 <edwarnicke> Until code is checked in here: https://git.opendaylight.org/gerrit/ it doesn't matter
17:49:08 <colindixon> +1 to that
17:49:16 <gzhao> colindixon: their jenkins built successful, Karaf they are still thinking about it whether for Helium or future
17:49:50 <gzhao> edwarnicke: ok, I need let Assaf know that
17:50:02 <colindixon> #info aside from helpdesk tickets which have been fixed and should get most of the currently blocked projects out, we are only missing toolkit and defense4all from auto-release
17:50:13 <colindixon> #info the current plan is for toolkit to not take part in auto-release
17:50:14 <edwarnicke> OK... so next thing in my queue of concerns is plugin2oc, sdni, and reservation getting into integration karaf
17:50:33 <gzhao> #action gzhao Request Defense4All to check code in  https://git.opendaylight.org/gerrit/
17:50:34 <colindixon> #info gzhao is working with defense4all to get their code in so we can auto-release them
17:50:38 <edwarnicke> I've been kind of operating from the principle that things not in integration karaf that *should* be in integration karaf I've not been adding to autorelease yet
17:51:22 <colindixon> #info other than that, we have some projects listed as “not in karaf”: snmp4sdn, plugin2oc, reservation, and sdni (also def4a)
17:51:35 <edwarnicke> Oh... and snmp4sdn
17:51:47 <colindixon> edwarnicke: technically does not being in karaf prohibit being in auto-release?
17:51:51 <edwarnicke> colindixon: many thanks for taking better notes than I initially made statements
17:51:54 <colindixon> if we’re just talking mechanics
17:51:59 <edwarnicke> colindixon: Not sure
17:52:23 <edwarnicke> colindixon: I do know though that for most projects I've been pretty much copying how they build in their merge jobs
17:52:38 <edwarnicke> colindixon: But I do not feel good about doing that for snmp4sdn as they have their tests all turned off
17:52:39 <gzhao> edwarnicke: Madhu are you able to help D4A on Karaf?
17:53:27 <edwarnicke> gzhao: I've kind of moved my focus on to autorelease now... could someone else help them out?
17:53:27 <colindixon> #info edwarnicke notes that he’s been making auto-release work mostly by using projects’ merge jobs
17:53:41 <edwarnicke> colindixon: Well... copying the build part of them :)
17:53:44 <gzhao> edwarnicke: that is very smart way, I would like to make it a process, otherwise, autorelease will be a nightmare
17:53:47 <colindixon> #undo
17:53:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2638d90>
17:53:59 <colindixon> #info edwarnicke notes that he’s been making auto-release work mostly by using the build part of projects’ merge jobs
17:54:09 <edwarnicke> gzhao: Should be even clearer shortly as tykeal et al got me the 'nice to have' plugin that makes that easier :)
17:54:14 <colindixon> #info however, SNMP4SDN doesn’t run tests in their merge job
17:54:30 <colindixon> gzhao: can you follow up with snmp4sdn about that and cc edwarnicke?
17:54:39 <frankieonuonga> I would help but I am just starting off here so I need sometime to get to know what exactly is where and whats what so...sorry
17:55:05 <edwarnicke> frankieonuonga: No need to apologize, we are *delighted* to have you here and even more pleased you are looking to chip in :)
17:55:12 <gzhao> #info gzhao requested eadd old_meetbot for #opendaylight-release for release or future release purpose, wiki updated
17:55:15 <colindixon> frankieonuonga: normally, I’d have a wiki page to point you at to show you how to do it, but in this case def4a is sort of a special case
17:55:25 <colindixon> gzhao: good idea
17:55:27 <gzhao> colindixon: yes, already #action that
17:55:42 <gzhao> will follow up snmp4sdn
17:55:44 <colindixon> gzhao: about the fact that their merge job has no tests?
17:55:45 <frankieonuonga> colindixon: maybe after I learn I will be the one to write a wiki page to show other new users how to get started
17:55:45 <colindixon> ok
17:56:09 <colindixon> frankieonuonga: this is the “normal” instructions for getting karaf working: https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide
17:56:52 <colindixon> so, I want to step out for a second and wrap up by talking about projects that need to hit code freeze (less important?) and karaf (more important?) soon and what to do if they don’t?
17:57:00 <colindixon> does that make sense in the last 4-5 minutes?
17:57:15 <colindixon> edwarnicke, phrobb, gzhao, and others?
17:57:23 <colindixon> (am not meaning to exclude anyone)
17:57:58 <edwarnicke> colindixon: I think its a bit much for the 3 remaining minutes
17:58:05 <gzhao> colindixon: I only have one question who can help d4a in Karaf?
17:58:08 <edwarnicke> Wednesday?
17:58:14 <colindixon> edwarnicke: fair
17:58:28 <phrobb> Yes, Wednesday or on TSC call for Thursday
17:58:32 <colindixon> gzhao: I’d offer to help, but it’s not my area of expertise
17:58:37 <gzhao> actually another question, do we start RC0 tomorrow
17:58:40 <colindixon> hideyuki: could you help def4a with karaf
17:58:49 <frankieonuonga> is wed another meeting or what is happening then
17:58:50 <colindixon> since the VTN project has also had non-java features?
17:59:17 <colindixon> frankieonuonga: two more meetings: another pre-RC meeting at 8:30a pacific on wed and the TSC meeting at 10a pacific on thursday
17:59:25 <colindixon> #topic wrapping up
17:59:40 <phrobb> gzhao: Putting together what we have, and testing it with whatever tests we have available now makes sense to me… regardless of what we call it.
17:59:49 <frankieonuonga> oh ok. I will join mailing list so I am up to speed
17:59:51 <colindixon> #info we still need to work out getting all projects into the auto-release and whether/if we can include projects that should/will be using karaf, but aren’t yet
18:00:20 <colindixon> #info we need to work out what to do with projects that are still missign/unable to hit code freeze and/or karaf bundling and when we should do it
18:00:40 <colindixon> #info these and other topics will have to wait for the wednesday pre-RC meeting and/or the thursday TSC meeting
18:00:43 <gzhao> #info Phil: Putting together what we have, and testing it with whatever tests we have available now makes sense to me… regardless of what we call it.
18:00:45 <hideyuki> colindixon: Yes.
18:00:58 <gzhao> hideyuki: thank you
18:01:11 <colindixon> #action hideyuki to reach out to the defense4all people to help them with karaf (thanks a million)
18:01:13 <gzhao> #info hideyuki offers help for D4A on Karaf
18:01:18 <gzhao> #undo
18:01:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2526d50>
18:01:19 <edwarnicke> hideyuki: Many thanks :)
18:01:28 <colindixon> ok, we’re one minute past
18:01:35 <edwarnicke> Shall we #endmeeting ?
18:01:38 <colindixon> anything last minute people need to cover?
18:01:43 <colindixon> or I’m going to #endmeeting
18:01:45 <colindixon> going once
18:01:46 <phrobb> do it
18:01:48 <colindixon> going twice
18:01:50 <edwarnicke> DO IT! :)
18:01:51 <colindixon> #endmeeting