15:30:34 <phrobb> #startmeeting Helium Pre RC0/RC1
15:30:34 <odl_meetbot> Meeting started Wed Sep 10 15:30:34 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:30:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:34 <odl_meetbot> The meeting name has been set to 'helium_pre_rc0_rc1'
15:30:44 <edwarnicke> gzhao: You are in Dallas? Awesome :)  I'm in Austin :)
15:30:46 <colindixon> gzhao: you’re in dallas? you need to come down to Austin and hang out with us
15:30:49 <tbachman> regXboi: that sounds ominous!
15:30:52 <phrobb> #topic Roll Call
15:30:55 <goldavberg> #info davidg for lispflowmapping
15:30:57 * tbachman hands regXboi a bullet-proof-vesrt
15:31:01 <colindixon> #info colindixon for TTP (and mischeif)
15:31:01 <gzhao> edwarnicke: colindixon I was
15:31:01 <edwarnicke> #info edwarnicke
15:31:02 <tbachman> #info tbachman for Group Based Policy
15:31:03 <phrobb> Project contacts please #info in
15:31:06 <gzhao> #info gzhao
15:31:09 <abhijitkumbhare> #info abhijitkumbhare OpenFlow Plugin
15:31:20 <regXboi> #info regXboi for nothing in particular
15:31:20 <Rafat> #info rafat for sdni
15:31:21 <oflibMichal> #info oflibMichal for openflowjava
15:31:24 <ChristineH> #info ChristineH for SNMP4SDN
15:31:34 <dkutenic> #info Dana for bgpcep
15:32:00 <rovarga> #info rovarga for tcpmd5 and yangtools
15:32:09 <deepankar> #info deepankar for plugin2oc
15:32:57 <mlemay> #info for reservation
15:33:03 <mlemay> #info mlemayfor reservation
15:33:24 <phrobb> 2 minute warning for rollcall
15:33:44 <edwarnicke> phrobb: Who are we missing so far?
15:33:51 <colindixon> edwarnicke: working onit
15:33:57 <tbachman> sdni
15:33:58 <edwarnicke> colindixon: Many thanks :)
15:34:07 <tbachman> ovsdb
15:34:13 <tbachman> tho they both just joined
15:34:15 <abhijitkumbhare> colindixon - I like your mischief comment :)
15:34:19 <lori> goldavberg: do you want to #info in for us?
15:34:43 <LuisGomez> #info LuisGomez for integration
15:34:44 * edwarnicke <joke>is concerned that colindixon is now competing for role of trouble maker at large</joke>
15:34:52 <abhijitkumbhare> :)
15:35:03 <lori> goldavberg: sorry, I now see you were the first one :)
15:35:44 <phrobb> Currently missing AAA, dlux, d4a, docs, l2switch, ovsdb, packetCable, SNBI, and VTN
15:35:52 <colindixon> missing: AAA Service, Defense4All, dlux - openDayLight User eXperience, Documentation Project, L2 Switch, ODL-SDNi Application, OpFlex IProtocol Agent, OVSDB Open vSwitch Database Integration Project, PacketCable PCMM Project, Secure Network Bootstrapping Infrastructure (SNBI) project, Service Function Chaining, Virtual Tenant Network (VTN),
15:36:32 <edwarnicke> Just got a txt from Harman for dlux... traffic, should be here soon
15:36:33 <alagalah> Howdy all
15:36:44 <Madhu> #info madhu for OVSDB
15:36:45 <phrobb> you're right colindixon, SFC is missing too
15:36:51 <Madhu> sorry guys missed the memo on this meeting
15:37:05 <colindixon> #action colindixon to add a row in the table for TCPMD5 and remove toolkit
15:37:21 <colindixon> https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects
15:37:25 * alagalah remembers Memo pads (sigh)
15:38:42 <paulq> #info paulq for SFC
15:38:57 <tbachman> #link : https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects wiki page describing helium status
15:39:39 <phrobb> colindixon:  is TCPMD5 part of Helium?… I don't think anyone has been tracking them
15:40:04 <rovarga> phrobb: it got split off of BGPCEP with the intent to participate in Helium
15:40:12 <dkutenic> yes it should be
15:40:19 <edwarnicke> phrobb: They are, under the split-before-I-don't-remember-the-milsetone-rule... it was approved by the TSC as part of the creation review for tcpmd5
15:40:24 * tbachman notes phrobb’s 2 minute call was up 5 minutes ago
15:40:43 * edwarnicke notes tbachman is at severe risk of being appointed official timekeeper ;)
15:40:47 <tbachman> lol
15:40:58 <phrobb> Mmh, rovarga and edwarnicke who is the project contact?… Have you been working with them on karaf
15:41:18 <phrobb> #topic Status update on RC0 creation
15:41:25 <regXboi> regXboi notes that only means the frame of reference of the IRC channel is travelling at some measurable fraction of c and the rest of us are at rest... then 2 minutes can be however long we need
15:41:41 <phrobb> #info edwarnicke would you mind providing an update on RC0 creation?
15:41:45 <tbachman> regXboi: darn relativist!
15:42:02 * edwarnicke is a former physicists... regXboi has been warned ;)
15:42:07 <edwarnicke> phrobb: Sure, topic change?
15:42:10 <rovarga> phrobb: myself (as #infoed), and it has been integrated with Karaf (as it is used by BGPCEP)
15:42:16 <regXboi> topic has changed :)
15:42:16 <phrobb> topic change happened
15:42:27 <edwarnicke> Oh :)
15:42:28 <edwarnicke> Sorry :)
15:42:34 <edwarnicke> One moment while I marshall the links
15:43:12 <edwarnicke> #link https://lists.opendaylight.org/pipermail/release/2014-September/000352.html <- RC0 announcement
15:43:23 <regXboi> marshalling the links gives a whole new meaning to the idea of code by sausage factory
15:43:26 <edwarnicke> #info RC0 went out yesterday on time. We are now back on schedule.
15:43:40 <edwarnicke> #info http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC0/
15:43:56 <phrobb> rovarga:  thanks for the info.  As colindixon notes, we need to get it added to the Helium Release page on the wiki
15:44:08 * regXboi cheers for being back on schedule - there was much rejoicing
15:44:13 <edwarnicke> colindixon: Would you be willing to add it
15:44:22 <colindixon> edwarnicke: doing it now
15:44:28 <edwarnicke> I would like to discuss briefly thoughts on going fowrard on the autorelease stuff
15:44:35 <edwarnicke> My thought had been to do the following:
15:44:36 <regXboi> edwarnicke: I thought colindixon actioned himself earlier
15:44:50 <edwarnicke> a)  Run the autorelease *build* every few hours like clockwork, so we see any breakage there ASAP
15:45:05 <edwarnicke> b)  Publish nightlies from it so we have things to run long running tests against
15:45:09 <edwarnicke> And of course
15:45:26 <edwarnicke> c)  Use it to publish RC1... but I would like us to agree on the time to start the RC1 build, so folks have some predictability
15:45:28 <liemmn> #info liemmn for AAA
15:45:31 <liemmn> sorry for being late
15:45:32 <xsited1> #info Thomas packetcable
15:45:38 <xsited1> ditto
15:45:50 <hideyuki> #info Hideyuki Tai for VTN
15:46:22 <gzhao> edwarnicke: current a) is set to 5 hours
15:46:30 <colindixon> still missing: d4a, dlux, doc, l2switch, opflex, snbi,
15:46:40 * tbachman hears the dmm’s infamous words about ODL being a “notoriously tardy bunch” ;)
15:46:41 <edwarnicke> gzhao: Would it make sense to do it every 4 hours so we get an even 6 runs a day?
15:46:55 <tbachman> colindixon: opflex isn’t making Helium
15:46:55 <harman_> #info Harman for dlux
15:46:57 <tbachman> they’re out
15:47:01 <harman_> sorry for not adding info
15:47:06 <gzhao> edwarnicke: will change it
15:47:18 <colindixon> gzhao: got it
15:47:26 <phrobb> thanks harman_, that's why we keep posting who's "missing"
15:47:27 <colindixon> #action colindixon to also note that opflex has withdrawn
15:47:36 <harman_> :)
15:47:37 <edwarnicke> tbachman: We aren't tardy... we are just in a timezone all our own ;)
15:47:44 <tbachman> lol
15:47:45 <colindixon> so, ed
15:47:49 <colindixon> you were talking about autorelease
15:48:04 <phrobb> colindixon:  while you're in there you can note that toolkit has also dropped out of Helium
15:48:06 <edwarnicke> Yes
15:48:17 <colindixon> phrobb: that’s already done
15:48:20 <Madhu> phrobb: gzhao question on the release artifact
15:48:27 <Madhu> we see just the Karaf distribution.
15:48:29 <edwarnicke> So does running the autorelease build every four hours sound reasonable to folks to catch breakage there?
15:48:38 <Madhu> is that expected that Helium is Karaf-ONLY release ?
15:48:45 <lori> edwarnicke: qq about the Helium-RC0 tags: are they going to be pushed to the individual repositories?  otherwise the SHA-IDs are meaningless, since they don't point to an actual commit in the repos
15:48:52 <lori> edwarnicke: see https://lists.opendaylight.org/pipermail/release/2014-September/000353.html
15:49:04 <deepankar> SB plugin to OC has only karaf integration left, can we make cut to RC1
15:49:25 <gzhao> #action gzhao change RC build to every 4 hours
15:49:28 <edwarnicke> lori: The intent was to try to capture something that can be used for tagging the projects
15:49:36 <edwarnicke> lori: May need to do something smarter there
15:49:41 <edwarnicke> lori: As you pointed out
15:49:54 <edwarnicke> deepankar: That is excellent news :)
15:49:56 <Madhu> phrobb: gzhao is there a place it was noted that Helium will not have any of the Hydrogen distribution artifacts ?
15:49:57 <edwarnicke> deepankar: Glad to hear it
15:50:06 <gzhao> colindixon: I removed toolkit and opflex from https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects
15:50:08 <edwarnicke> Many thanks to tbachman for lending a hand
15:50:10 <lori> edwarnicke: ok
15:50:16 <tbachman> edwarnicke: np!
15:50:16 <colindixon> rovarga: I don’t see any milestone status updates from tcp-md5
15:50:16 <rovarga> edwarnicke: well, since we are talking git
15:50:39 <phrobb> Madhu:  Distribution packaging is still an open question.
15:50:58 <edwarnicke> phrobb: I thought release vehicles were already decided by the TSC
15:50:59 <Madhu> phrobb: if that is the case, then is it fair to say we are done with RC0 ?
15:51:04 <gzhao> deepankar: I think they can make RC0
15:51:06 <Madhu> without having those distributions in place ?
15:51:10 <rovarga> edwarnicke: I think it would make sense to cut the release branches now, so we have master unblocked and fixes delivered to release branch (and cherrypicked to master). that will give folk a heads up to the stable branch
15:51:25 <rovarga> and that also means the release release becomes a tag on the helium branch
15:51:25 <deepankar> ed: jenkins issue has been resolved, team is still working on Karaf...
15:51:41 <Rafat> Sdni is also pending only with Karaf...
15:51:44 <rovarga> colindixon: mmy fault entirely, it has fallen off my radar :-(
15:51:54 <edwarnicke> phrobb: Correct me if I'm wrong... the only proposed release vehicles for Helium are here: https://wiki.opendaylight.org/view/CrossProject:Helium_Release_Vehicle_Brainstorming
15:52:01 <edwarnicke> phrobb: And the TSC decided on Pure Karaf
15:52:01 <deepankar> will update as soon as karaf is fixed.
15:52:01 <lori> rovarga: that sounds good, other projects to that too
15:52:33 <Madhu> edwarnicke: can u point me to any specifics on TSC decision on that ?
15:52:33 <edwarnicke> What do other folks think about cutting stable/helium branches now
15:52:42 <rovarga> colindixon: anything in particular you want me to send out... the project is good to release as is :)
15:52:43 <phrobb> Madhu:  correct, and those were not agreed to by the TSC.  Instead, we pursued the use of Karaf to allow users an ala-carte selection of features they wanted
15:52:46 <Madhu> edwarnicke: i don't think we are ready yet
15:53:03 <Madhu> we need to get this answered cleared before declaring RC0 is done
15:53:19 <edwarnicke> Madhu: RC0 is done persuant to the TSCs decisions on release vehicles
15:53:20 <Madhu> IMHO, we need clear stands on these... not some vague recollections
15:53:39 <Madhu> phrobb: that was my understanding too
15:53:44 <tbachman> was there an email on this?
15:53:50 <tbachman> anyone have a link?
15:53:58 <Madhu> Karaf is one of the release-vehicles that we were targeting because of all the complexities we faced in Hydrogen
15:54:07 <Madhu> phrobb: if i recollect, it was NOT decided as the only onoe
15:54:08 <Madhu> one
15:54:34 <mlemay> The question is how are we doing that a-la-carte selection
15:54:34 * tbachman goes to look at TSC meetbot minutes
15:54:44 <mlemay> we can do it different ways
15:54:47 <edwarnicke> Madhu: We had only two proposals when the discussion took place, see the wiki page linked
15:54:58 <mlemay> bootstrap small then launch wizard at first start
15:54:59 <mlemay> or
15:55:01 <Madhu> edwarnicke: "THIS PAGE HAS NO FORMAL STANDING! " that is on the top of the page
15:55:04 <Madhu> just fyi.
15:55:06 <mlemay> have it done at download time
15:55:39 <mlemay> now that things are "packaged" it's really about what is started by default
15:55:42 <phrobb> edwarnicke:  and Madhu my recollection is that pursuing karaf was the only thing decided and it was not a mandate.  how to package the karaf bundles ala-carte or as release editiions is still an open question with the TSC
15:56:21 <gzhao> https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Proposed_Release_Vehicles <-- This needs to be updated as well
15:56:24 <Madhu> phrobb: all am looking for is some clear decision by TSC
15:56:33 <Madhu> or note suggesting that
15:56:42 <regXboi> looking for the links
15:56:47 <PriyankaChopra> For plugin2oc - We should be able to close integration tests for Karaf by tomorrow
15:56:50 <Madhu> especially because we just got done with Karaf (like 2-3 weeks before release)
15:56:57 <Madhu> and most of the testing is not even started on Karaf
15:57:09 * Madhu notes that he is not against Karaf only release :)
15:57:17 <Madhu> just that the clarity is missing
15:57:20 <colindixon> rovarga: I guess just send out an update or make sure my green, green, green is right? I was just expecting that if it was a project in it’s own right would have had the status update e-mails
15:57:30 <jmedved> putting my user’s hat on - having a single distro (which you can customize to emulate the distros we had in hydrogen) will be much simpler and much less confusing
15:57:33 <Madhu> and we have to give enough opportunity for folks to think it through and invest time on testing
15:58:00 <mlemay> jmedved: indeed but we haven'T decided how this is presented to the users just yet
15:58:15 <edwarnicke> mlemay: I think your point though is about how to present the choice within Pure Karaf to users
15:58:19 <jmedved> the multiple distros in hydrogen was not an ideal situation, we should not continue it if possible
15:58:32 <mlemay> edwarkicke: indeed
15:58:46 <regXboi> all:
15:58:50 <jmedved> the single karaf distor is a much better proposition (Again, from user’s perspective)
15:59:02 <regXboi> looking at the TSC minutes from the past month
15:59:05 <phrobb> Back to the topic at hand - RC0.  We have a code base that can be tested.  By many (including my own) this is not a real release candidate because A) Not all project have code-frozen, and B) Not all projects are complete with Karaf into integration.  Regardless, we have a block of code in integration with which Integration can begin to excersize their tests.
15:59:09 <regXboi> Karaf was necessary to define RVs
15:59:23 <regXboi> but there has been no agreed (that I've found) on RVs
15:59:34 * tbachman hasn’t found that in the minutes yet either
16:00:13 <tbachman> This is the most concrete thing I’ve found so far:
16:00:14 <mlemay> regXboi: correct... and that could be a "online" distro (with minimal download) or a offline one (with all packaged in) or with feature X,Y,Z started at boot or one that is gui-less or whatever
16:00:19 <edwarnicke> regXboi: But I am correct that the only two proposals made were Pure Karaf and the thing you did, correct?
16:00:27 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-07-31-16.59.log.html TSC minutes, where release vehicles are discussed
16:00:42 <edwarnicke> mlemay: We currently are packaging things up into a 'offline capable' release
16:00:42 <tbachman> <colindixon> #info the current most concrete proposed plan for release vehicles is to use karaf and let people build distributions out of features (or the component concept we’ve been developing)
16:00:44 <regXboi> mlemay: that's still to be decided
16:00:46 <phrobb> The Karaf testing agreed to was minimal testing (the karaf feature alone with only it's dependencies) and Maximal (the feature along with all other features that were not identified as conflicting).
16:00:49 <regXboi> edwarnicke: that is correct
16:00:56 <tbachman> <colindixon> #info dmm seeks feedback about this or alternatives from the TSC
16:01:04 <tbachman> (both of those from the minutes)
16:01:06 <mlemay> edwardnicke: I know :) I'm simply outlining possibilities
16:01:10 <tbachman> (sorry for the pollution there)
16:01:15 <edwarnicke> regXboi: And if memory serves nobody, not even you, was in favor of anything but Pure Karaf, correct?
16:01:21 <mlemay> regXboi: correct
16:01:38 <regXboi> yes, I said I was in favor of pure karaf
16:01:49 <tbachman> It ended in this:
16:01:49 <tbachman> #info dmm says we should start a thread on discuss or TSC to drive this forward so that we can make a decision about helium packaging next week
16:01:51 <regXboi> and I've not found anybody who said they were in favor of other RVs
16:01:54 <colindixon> #info phrobb notes that we have an RC0 drop (which isn’t what he and some others would call a release candidate as not all projects have code frozen or gotten karaf working)
16:02:07 <colindixon> #info phrobb says however, we have artifacts that can now start to be tested
16:02:22 <LuisGomez> I think we need clarify the RV asap, specially if we need to test this RV as part of RC
16:02:30 <hideyuki> It seems to me that distribution-kara for RC0 does not contain VTN Coordinator (C++ component).
16:02:55 <colindixon> #info MAJOR: it appears as though we agreed karaf should be the framework if at all possible, we did not agree on actual release vehicles and need to do that ASAP
16:03:08 <hideyuki> We need a patch to Integration group to put VTN Coordinator into distribution-karaf as we did in Hydrogen release.
16:03:10 <regXboi> so...
16:03:17 <regXboi> I'd argue *strongly*
16:03:22 <LuisGomez> colindixon: +1
16:03:30 <phrobb> #action phrobb to add RV discussion to TSC meeting for tomorrow (9/11)
16:03:36 <regXboi> that we continue with Pure karaf and answer RV tomorrow
16:03:37 <edwarnicke> hideyuki: Lets get that done :)
16:03:39 <dmm> @colin: we didn't decide on release vehicles
16:03:45 <regXboi> I don't want to lose the day
16:03:50 <regXboi> or the week
16:03:52 <regXboi> or the whatever
16:04:16 <phrobb> edwarnicke:  did you have more on the autorelease process that you wanted to discuss?
16:04:19 <colindixon> dmm: agreed
16:04:30 <regXboi> #info hideyuki's point about RC0 missing VTN components means there will be an RC1
16:04:33 <kwatsen> @regXboi +1
16:04:33 <edwarnicke> phrobb: I think that's about it... can we put out the call for folks to
16:04:36 <edwarnicke> a)  test RC0
16:04:46 <edwarnicke> b)  Check it to make sure their stuff is there and working
16:05:02 <edwarnicke> regXboi: There will be an RC1 no matter what :)
16:05:18 <phrobb> edwarnicke:  I believe you just did. :-)
16:05:34 <regXboi> edwarnicke: true, but I want the statement in the minutes
16:05:38 <edwarnicke> Let me be more emphatic then
16:05:41 <regXboi> not just in the logs :)
16:05:42 <edwarnicke> Please go
16:05:48 <edwarnicke> a)  Make sure your karaf features work
16:05:51 <edwarnicke> b)  Test them
16:05:55 <edwarnicke> With RC0
16:06:10 <colindixon> #topic next steps with RC0
16:06:11 <phrobb> LuisGomez:  On the testing responsibility of Karaf features, could you discuss what RC testing will be done by the integration team (maximal) and what will need to be done and reported by the projects (minimal)?
16:06:13 <edwarnicke> #info Please test with RC0 and make sure your karaf features work
16:06:30 <gzhao> #info edwarnicke RC steps; 1) build every 4 hour 2) publish nightly
16:06:30 <colindixon> oh
16:06:37 <colindixon> apparently I’m not chair :-p
16:06:52 <phrobb> #chair colindixon
16:06:52 <odl_meetbot> Current chairs: colindixon phrobb
16:07:00 <liemmn> Is there a system test team testing RC0, or is that dependent on individual projects?
16:07:00 <phrobb> poof, you are chair colindixon
16:07:11 <LuisGomez> phrobb, i sent mail for that but i can summarize here
16:07:20 <abhijitkumbhare> Madhu , edwarnicke, phrobb, LuisGomez  & jmedved - help me understand: the key issue seems to be most folks (at least those who have voiced opinion) prefers karaf only distribution - the disagreement seems to be whether more time is needed to get it baked in (and how much more time).
16:07:24 <phrobb> LuisGomez:  please do, thank you
16:07:43 <Madhu> let me make my point clear :)
16:08:00 <regXboi> colindixon: you are now
16:08:00 <Madhu> I like karaf only distribution. but it is NOT approved / decided by TSC
16:08:00 <colindixon> #topic next steps with RC0
16:08:05 <Madhu> and hence we need to make that sure
16:08:19 <Madhu> and without that RC0 is not complete because we have Karaf only distributions on that
16:08:20 <LuisGomez> 1) every project is responsible to test their individual features
16:08:31 <regXboi> Madhu: I'd argue that slightly differently
16:08:34 <colindixon> #info edwarnicke calls for people to please make use of the RC0 artifacts and test what they have
16:09:00 <regXboi> while it has not been officialy approved/decided, it has been the de facto approach as there hasn't been any serious alternatives
16:09:11 <regXboi> er *haven't been*
16:09:14 <colindixon> edwarnicke: do you have instructions for how to do that exactly?
16:09:19 <phrobb> #info LuisGomez says 1) every project is responsible to test their indivdual features
16:09:33 <LuisGomez> 2) integration will put all features together and pass existing suites from hydrogen + new contributions for helium
16:09:39 <regXboi> so while it needs to be officially blessed, I believe it is safe to continue with the defacto approach
16:10:01 <colindixon> #link http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC0/ the karaf RC0 distribution zip can be found here
16:10:26 <phrobb> #info LuisGomez says: 2) integration will put all features together and pass existing suites from hydrogen + new contributions for helium
16:10:55 <colindixon> #info you should be able to download the zip file, extract it and run it as you would any other karaf distribution (that is run target/assembly/bin/karaf)
16:11:08 <colindixon> #info from there load/test your features as normal
16:11:28 <gzhao> LuisGomez: how do we track status of testing if every project is doing their own feature testing
16:11:46 <colindixon> gzhao: we could ask for an RC1 status update
16:12:08 <tbachman> spreadsheet?
16:12:08 <LuisGomez> 3) integration suites as of today: AD-SAL and MD-SAL NSF, openflow, vtn, l2switch, performance, ovsdb-neutron (in progress)
16:12:09 <colindixon> where projects say that they have tested their code and note any bugs found and resulting patches to be included in RC1
16:12:18 <tbachman> emails?
16:12:32 <colindixon> #info LuisGomez says 3) integration suites as of today: AD-SAL and MD-SAL NSF, openflow, vtn, l2switch, performance, ovsdb-neutron (in progress)
16:12:51 <LuisGomez> gzhao: i do not have a clear answer for that
16:13:16 <colindixon> tbachman, gzhao, LuisGomez: my take is that we use the normal milestone status update e-mail mechanism to get people to report what each project has/hasn’t done
16:13:18 <phrobb> thanks colindixon
16:13:36 <tbachman> sounds good
16:14:03 <colindixon> ideally it would be short (see above)
16:14:12 <LuisGomez> colindixon, thats probably the only way
16:14:42 <LuisGomez> projects need to repot whether they have tested their individual features
16:14:43 <colindixon> just (i) have you tested yourself in the RC0 karaf distro (yes/no) (ii) did you find any bugs? if so, list them. if you have patches, list them.
16:16:03 <colindixon> can we agree on that, if so I’ll #action gzhao to ask for that update
16:16:05 <jmedved> all: do we need a version tag in bugzilla for rc0? i don’t see it there
16:16:08 <regXboi> all: I've got 5 more minutes before I have to wander away to the dr office
16:16:25 <colindixon> jmedved: we have it in target milestone I think
16:16:33 <phrobb> Any more discussion of RC0 before we move to what we need to do in preparation for RC1?… Which Monday (9/15)
16:16:43 <gzhao> We need document of this step "extract it and run it as you would any other karaf distribution " and each project should have a karaf section of how to load each individual project
16:16:48 <jmedved> colindixon: rc0 is version now
16:16:57 <gzhao> colindixon: thanks
16:16:58 <abhijitkumbhare> LuisGomez: Testing new features or regression testing all the features (for projects like OFPlugin - there are a huge number of the Hydrogen features)
16:17:26 <colindixon> #action gzhao to send out a request for an RC1 status update that should include at least “(i) have you tested yourself in the RC0 karaf distro (yes/no) (ii) did you find any bugs? if so, list them. if you have patches, list them.”
16:17:35 <colindixon> jmedved: fair enough, I don’t know how that gets doen
16:17:46 <edwarnicke> gzhao: Are you saying we need good docs on how to download and test the RC0 ?
16:18:09 <colindixon> #info jmedved asks if we need to create a version in bugzilla for Helium-RC0 now that it exists as a release version
16:18:15 <gzhao> edwarnicke: no, end user documents, just a memo for us
16:19:23 * regXboi wanders off to dr office to see how he's messed himself up this time
16:19:24 <LuisGomez> abhijitkumbhare: any test is valid, for openflow we have system test support but you may want to test any feature not included in our tests
16:19:27 <regXboi> bye all
16:19:31 <colindixon> edwarnicke: somebody should write up a simple how to test your RC0 stuff
16:19:31 <edwarnicke> gzhao: Ah... OK :)
16:19:39 <abhijitkumbhare> OK LuisGomez
16:19:44 <colindixon> I captured it a bit in the minutes
16:19:44 <phrobb> good luck regXboi_awa
16:20:06 <colindixon> I think we can move to RC1 issues at this point though
16:20:06 <jmedved> colindixon: +1 on the writeup
16:20:08 * tbachman hands regXboi_awa some asprin
16:20:47 <colindixon> #action colindixon to produce very short pointers about how a project should test their stuff in the RC0 karaf distribution (mostly pointing to the karaf step by step guide)
16:20:55 <phrobb> #topic Preparation for RC1 - Monday Sept 15th
16:21:00 <colindixon> thanks
16:21:31 <colindixon> #info as noted above, all projects need to send out a status update e-mail (request and template to come from gzhao) by the RC1 date
16:21:33 <dkutenic> edwarnicke: isn't the writeup exactly that what you've sent me earlier?
16:21:41 <mlemay> ok
16:21:53 <colindixon> dkutenic: if it is, great, I’d love to not have to do the work :p
16:22:03 <colindixon> dkutenic, edwarnicke: forward it to me if you want
16:22:09 <dkutenic> https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Guidance_for_testers_once_your_Feature_is_in_Integration
16:22:32 <colindixon> dkutenic: except that does it from the gerrit/git version not the RC0 release zip
16:22:38 <colindixon> here: http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC0/
16:22:46 <phrobb> #info We have some projects that have not code-frozen and other projects that have not finished their Karaf feature work and pushed it to Integration.  Can we agree that for RC1 we need both of those tasks completed for all projects to have a valid RC1 candidate?
16:23:00 <colindixon> so, edwarnicke, gzhao, phrobb, and others what do we need to cover on RC1 here?
16:23:29 <colindixon> phrobb: I’d +1 the crap out of that, but I’m not sure anyone but the TSC has any powers to take action if people don't
16:23:39 <gzhao> phrobb: +1, we should have a clear definition on RC1 and forward
16:24:12 <phrobb> colindixon:  Agreed, but I'm looking to set the sane expectation for RC1 in this forum prior to the TSC meeting tomorrow :-)
16:24:23 <abhijitkumbhare> phrobb +1
16:24:28 <colindixon> #info the goal for RC1 should also be for all projects that are in karaf in RC0 to identify and fix all blocking bugs (or all that they can) for RC1
16:24:28 <LuisGomez> phrobb +1
16:24:29 <gzhao> colindixon: code freeze, karaf merged in integration, feature test started
16:24:39 <colindixon> when exactly is RC1 bieing cut?
16:24:43 <colindixon> the artifacts?
16:24:46 <phrobb> Monday 9/15
16:24:55 <edwarnicke> colindixon: I'd like to get a time to kickoff the RC1 build so we have clarity
16:25:04 <colindixon> I mean, when and where does a patch need to be so that it gets into RC1
16:25:07 <colindixon> edwarnicke: exactly
16:25:20 <colindixon> there’s a when and a where which we both need to have clarity
16:25:24 <gzhao> edwarnicke: you will change label to RC1?
16:25:36 <gzhao> edwarnicke: or pre RC1
16:26:36 <phrobb> colindixon:  I see your question now.. edwarnicke would you like to make clear your when and where for the RC1 build?
16:26:36 <edwarnicke> gzhao: I was thinking of having he labels for the nightlies by RC0-<timestamp>
16:26:52 <edwarnicke> gzhao: But I am not averse to RC1-Pre-<timestamp>
16:26:58 <edwarnicke> gzhao: We just need to decide :)
16:27:32 <colindixon> #info everyone who expressed an opinion (colindixon, abhijitkumbhare, and LuisGomez) agreed with phil’s request that everyone be code frozen and in karaf by RC1 and we will take that idea to the TSC where they can bless it and maybe establish what the consequences for missing are
16:27:45 <phrobb> +1 to RC0<timestamp>
16:28:02 <colindixon> edwarnicke: yeah, I’d tend to agree
16:28:29 <colindixon> I wish that RC0 was RC-RELEASE or something though
16:28:40 <colindixon> but it’s fine
16:28:48 <edwarnicke> colindixon: LOL... what did we decide about me and naming again ? ;)
16:28:54 <colindixon> first cut of RCs is “-RC#”
16:29:18 <colindixon> subsequent nightly/4-hourlies are “-RC#-<timestamp>”
16:29:32 <gzhao> edwarnicke: phrobb LuisGomez : question: does integration use rc0-timestamp to test? or they just use RC0, pre-RC1 is for project them self to test and fix RC0 bugs
16:29:34 <colindixon> I’d propose “-RC#-YYYYMMDD-HHMM”
16:29:59 <colindixon> gzhao: good question
16:30:11 <edwarnicke> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_RC0 <- Do these help in figuring out how to test RC0 ?
16:30:38 * edwarnicke just wrote them while we were chatting
16:30:47 <colindixon> #info gzhao asks “will integration use rc0-timestamp to test? or will they just use RC0, until RC1 is cut?”
16:30:58 <LuisGomez> gzhao, we can use any given name to trigger the integration test, just need to adapt our jenkins job
16:31:20 <edwarnicke> LuisGomez: Thoughts?  I was thinking of cutting the nightlies for you guys for long running tests
16:31:21 <colindixon> edwarnicke: yes
16:31:37 <colindixon> that helps a lot
16:31:38 <gzhao> LuisGomez: yes, I am asking the process.
16:31:53 <phrobb> #info Another question in preparation for RC1:  Given that everyone is testing RC0 and (hopefully) finding bugs, should we start a standing, daily irc meeting at 8:30am PDT to report issues, ask questions, etc. from now until we ship?
16:32:03 <edwarnicke> gzhao: I'd also like us to figure out how to handle projects that produce breakage in autorelease
16:32:14 <gzhao> LuisGomez: if your testing cycle is less a day, you can take daily build and re-run test
16:32:19 <colindixon> phrobb: probably, do we want to have it during the karaf happy hour? that seemed to work well
16:32:29 <edwarnicke> phrobb: I would be in favor of a daily candence... it helped us a lot in getting stuff done for Hydrogen
16:32:40 * edwarnicke notes we are in so much better shape than Hydrogen
16:32:43 <LuisGomez> gzhao: yes
16:33:01 <colindixon> so, is 8:30a the right time? or is 7:30a? or 8-9 to catch some of both?
16:33:02 <abhijitkumbhare> colindixon & edwarnicke - I think instead of timestamp should be a number (-RC#-minor#) - as it can be tricky just based on the build for people to know whether there are additional builds that were predating a particular -RC-timestamp
16:33:13 <gzhao> phrobb: +1
16:33:31 <colindixon> abhijitkumbhare: we could do both
16:33:32 <edwarnicke> abhijitkumbhare: Could you say more... I don't quite follow you
16:33:54 <colindixon> abhijitkumbhare is saying the first post-RC0 build would be RC0-1
16:33:56 <colindixon> and then RC0-2
16:33:58 <colindixon> and so on
16:34:01 <colindixon> I’m sying do both
16:34:06 <colindixon> RC0-1-<timestamp>
16:34:10 <edwarnicke> colindixon: Hmm...
16:34:11 <abhijitkumbhare> yes (what colindixon said)
16:34:20 <colindixon> or rather, you could do both
16:34:26 <tbachman> RC<major>-<minor>-YYYYMMDD-HHMM
16:34:31 <colindixon> it makes comparisons a litte faster
16:34:34 <colindixon> tbachman: yes
16:34:36 <edwarnicke> colindixon: So not saying no to that suggestion... but it will require either some more sophisticated scripting or daily intervention to reset the base label
16:34:50 <colindixon> fair enough
16:34:56 <edwarnicke> colindixon: Which is to say: doable, but work
16:35:14 <abhijitkumbhare> don't want to make it too complicated (and too much effort to do i)
16:35:32 <colindixon> edwarnicke: I know that you can get the job run # out of jenkins pretty easily via a curl command
16:35:38 <edwarnicke> colindixon: Would you and abhijitkumbhare be satisfied with "I'll try if its not to much work" ?
16:35:45 <colindixon> you could probably add `curl …`
16:35:46 <abhijitkumbhare> yes edwarnicke
16:35:51 <colindixon> edwarnicke: I’d be more than happy with that
16:35:58 <edwarnicke> colindixon: Yes... but build number is not going to be the clean 1,2,3 we want :)
16:36:18 <colindixon> fair
16:37:18 <colindixon> #info the plan is to have post-RC0, pre-RC1 versions to be either “-RC0-<minor>-YYYYMMDD-HHMM” or “RC0-YYYYMMDD-HHMM” if the first is hard
16:37:24 <colindixon> ok, this meeting is 7 minutes past
16:37:39 <colindixon> #topic wrapping up
16:37:42 <colindixon> any last items?
16:37:44 <phrobb> #info What other topics do we have for this morning?
16:37:57 <phrobb> colindixon:  we were on the same page :-)
16:38:08 <edwarnicke> phrobb: Have we closed on daily candence?
16:38:09 <colindixon> phrobb: it’s almost like we’ve run these things a few times :p
16:38:17 <edwarnicke> colindixon: Can't be that ;)
16:38:18 <abhijitkumbhare> would it make it simpler - if we drop RC from builds (just have it something like 2.1.4.4 & 2.1.4.5)
16:38:45 <abhijitkumbhare> That's the way most software versions are
16:38:53 <colindixon> edwarnicke, phrobb: we did not
16:39:09 <colindixon> what time did we want
16:39:10 <colindixon> ?
16:39:13 <edwarnicke> colindixon: Could we?
16:39:20 <colindixon> edwarnicke: are you OK with 8:30a
16:39:26 <colindixon> when did we do karaf happy hour?
16:39:30 <colindixon> how did that work?
16:39:34 <edwarnicke> colindixon: We did it at 7:30am
16:39:39 <rovarga> so ... what is wrong with reusing just timestamps we use for autobuild? :-) what is the magic difference between an RC and an autobuild? :)
16:39:57 <edwarnicke> colindixon: It seems like it worked really well.. we converged fast... what do other folks think?
16:40:10 <abhijitkumbhare> 7:30 am is fine with me
16:40:11 <colindixon> so, we could split the difference and do 8-9a PST
16:40:21 <phrobb> #info phrobb proposed daily candence mtgs to allow projects to "check in" on IRC at 7:30am PDT daily starting 9/11 through Helium Final Release
16:40:35 * colindixon is in Texas and so 7:30a PST is ok with him :p
16:40:38 <colindixon> phrobb: sounds good
16:40:52 <edwarnicke> edwarnicke: I can do that
16:40:54 <colindixon> any last minute things
16:41:01 <colindixon> ?
16:41:05 <colindixon> going once
16:41:10 * colindixon counts to 10
16:41:13 <abhijitkumbhare> I will not make it tomorrow (too many other meetings I got pulled into)
16:41:17 * edwarnicke holds breath
16:41:19 <colindixon> going twice
16:41:22 * colindixon counts to 10
16:41:33 <colindixon> sold!
16:41:36 <colindixon> #endmeeting