14:31:57 <gzhao> #startmeeting Helium Release Review
14:31:57 <odl_meetbot> Meeting started Wed Sep 24 14:31:57 2014 UTC. The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:57 <odl_meetbot> The meeting name has been set to 'helium_release_review'
14:32:20 <gzhao> #topic TSC roll in
14:32:36 <gzhao> TSC member please #info in
14:32:47 <colindixon> #info colindixon
14:32:53 <phrobb> #info Phil Robb
14:32:57 <LuisGomez1> info LuisGomez1 for integration
14:33:00 <edwarnicke> #info edwarnicke
14:33:18 <gzhao> #chair colindixon regXboi phrobb edwarnicke
14:33:18 <odl_meetbot> Current chairs: colindixon edwarnicke gzhao phrobb regXboi
14:33:20 <phrobb> sorry, didn't see it was for TSC member
14:33:25 <LuisGomez1> #info LuisGomez
14:33:34 <vjanandr_> #info Vijay for SNBI
14:33:43 <colindixon> phrobb: it apparently isn’t at this point :p
14:33:50 <edwarnicke> gzhao: I think you may have lost control of roll call ;)
14:34:04 <gzhao> phrobb: I guess it is for all now
14:34:14 <regXboi> #info regXboi
14:34:19 <dkutenic> #info Dana (dkutenic) for bgpcep
14:34:20 <tbachman> #info tbachman for groupbasedpolicy
14:34:26 <oflibMichal> #info oflibMichal for openflowjava
14:34:32 <alagalah> #info alagalah for groubasedpolicy
14:34:36 <gzhao> #info gzhao for release
14:34:46 * edwarnicke wonders if regXboi is for mischief
14:35:15 <gzhao> #topic BPGCEP Release Review
14:35:25 <rovarga> #info rovarga for tcpmd5
14:35:28 <ttkacik> #info ttkacik for yangtools
14:35:46 <dkutenic> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Helium_Release_Review
14:35:56 <dkutenic> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Helium_Release_Notes
14:36:10 <vina_ermagan> #info vina_ermagan for lispflowmapping
14:36:25 * colindixon reads
14:38:44 * colindixon is impressed
14:39:00 <dkutenic> :-D
14:39:04 <colindixon> the docs look really good, the release review page is very, very detailed
14:39:06 <phrobb> Docs question: From the docs team, I thought that the plan for docs was to move from wiki to structured docs for Helium. I noticed yesterday that D4A docs were in wiki, and now BGPCEP is also. Are we going to have half our docs in structured PDFs and the other half in wiki?
14:39:18 <gzhao> colindixon: +1
14:39:56 <colindixon> phrobb: I think the goal was to get documentation that was designed for people outside the immediate ODL community into asciidoc
14:40:08 <colindixon> I’m not sure if that’s going to happen for this release though
14:40:35 <colindixon> it probably *does* make sense to put a link to the wiki documentation from the asciidoc if it’s not going to be migrated though
14:40:42 <regXboi> um
14:41:09 <phrobb> Yes, agree colindixon that was the goal.. non ODL-developer docs to be in structured docs
14:41:34 <LuisGomez1> Docs question 2: how will users access Helium docs? LF portal? it comes with Helium package?
14:41:39 <regXboi> do we have commit #s for the structures doc?
14:41:47 * regXboi doesn't see them
14:42:29 <regXboi> LuisGomez1: IIRC the plan is to deploy the non ODL-developer docs via site deploy
14:42:39 <regXboi> I don't remember what the URL they will be at is
14:42:58 <gzhao> #info phrobb asks should docs move from wiki to structured docs for Helium
14:43:36 <regXboi> #info regXboi asks for structured docs commit #s
14:43:58 <colindixon> regXboi: what do you mean by “sttructured docs”?
14:44:08 <xsited1> #info thomas packetcable
14:44:41 <gzhao> dkutenic: are these docs checked in ?
14:44:47 <regXboi> colindixon: I mean the asciidoc commits
14:44:50 <colindixon> #Info colindixon says that for at least some projects getting their documention off the wiki into structure docs (asciidoc) may not happen by monday
14:44:57 <dkutenic> how 'checked in?'
14:45:08 <colindixon> #info at the very least, we shoudl probably add a hyperlink from the asciidoc section to the wiki though
14:45:11 <gzhao> in github/doc.git
14:45:36 <dkutenic> if that doesn't happen automatically, then no
14:45:38 <colindixon> dkutenic: there are decent notes here: https://meetings.opendaylight.org/opendaylight-meeting/2014/tws/opendaylight-meeting-tws.2014-09-15-17.04.html
14:46:00 <phrobb> dkutenic: have you been able to have someone from your team engage with the docs team?
14:46:25 <colindixon> dkutenic: probably (just so people can use your stuff easily) you should at least put a hyperlink to your appropriate wiki pages so it ends up in the unified docs
14:46:40 <dkutenic> I was contacted by Divya Shetty
14:46:54 <phrobb> dkutenic: yes, she is part of the docs team
14:47:14 <dkutenic> but she asked about user guide, etc... no word was about release review documents
14:47:37 <colindixon> dkutenic: that’s what’s being asked, I see that you have lots of user guide, etc. stuff on the wiki
14:47:47 <colindixon> do you know if that made it into the asciidoc in the docs.git repo?
14:48:32 <dkutenic> I can check it in then...
14:49:04 <gzhao> #action dkutenic will commit asciidoc into doc.git
14:49:08 <gzhao> we need to move on, any question regarding to BGP release review
14:49:13 <colindixon> yeah
14:49:22 <colindixon> i think this all looks good
14:49:36 <phrobb> same here. Nice job dkutenic!
14:49:45 <gzhao> #topic Controller Release View
14:49:56 <dkutenic> thanls
14:50:04 <edwarnicke> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Helium_Release_Review
14:50:28 <colindixon> dkutenic: I sent you some private messages with pointers
14:50:32 * colindixon reads
14:50:38 <regXboi> edwarnicke: any ETA on the asciidocs ;)
14:50:52 <edwarnicke> regXboi: Not sure at this point... trying to gather that info
14:51:11 * rovarga notes that the asciidoc requirement was probably not well circulated
14:52:39 <colindixon> edwarnicke: I know it’s annoying, but I think the End-of-life information is going to be important since I think we’re stopping shipping a lot of hydrogen components,r ight?
14:53:21 <edwarnicke> colindixon: Yes, but they are all still present in the controller project... they have not yet been removed, and doing so with due care is going to have to wait till after Helium goes out
14:53:30 <regXboi> edwarnicke: after you answer colindixon, in the bug list, I see four blocker and four critical bugs listed - we are willing to go out with those?
14:53:44 <gzhao> release note, user guide, dev guide, how to and op guide
14:54:02 <gzhao> are in each sub project?
14:54:23 <colindixon> edwarnicke: fair enough, it’s probably worth noting that in the End-of-life section
14:54:27 <edwarnicke> regXboi: I think the blockers are closed, two of them are mine
14:54:35 <edwarnicke> regXboi: Let me get that list cleaned up
14:54:51 <regXboi> edwarnkicke: that would be appreciated :)
14:55:55 <colindixon> regXboi: I think it’s 3 blockers: 1860, 1920 and 2007, but they are all either fixed or awaiting review
14:56:13 <edwarnicke> 2007 is fixed
14:56:19 <regXboi> 1064
14:56:25 <regXboi> is the fourth blocker
14:56:47 <phrobb> gzhao: they get aggregated by asciidoc into a single pdf… hence part of ascii doc's value
14:57:29 <tbachman> 1064?
14:57:40 <tbachman> Hydrogen-era?
14:57:46 <gzhao> phrobb: link for the pdf?
14:57:46 <colindixon> 1064 looks like it’s for hydrogen
14:57:47 <edwarnicke> regXboi: 1860 was fixed
14:58:00 <colindixon> gzhao: you have to build it from the docs repo
14:58:12 <gzhao> colindixon: gotcha
14:58:45 <gzhao> so the action is to add asciidoc?
14:59:00 <edwarnicke> regXboi: Anything else you spot that needs urgent attention there?
14:59:11 * regXboi looks
14:59:28 <regXboi> tell me about 1064 and 1920
14:59:41 <colindixon> #action edwarnicke to add pointers to asciidoc when/if it is availble
15:00:17 <moizer> asciidocs are in the works for clustering - I saw a draft
15:00:33 <colindixon> #action edwarnicke to put a quick note in under end-of-life noting that some features are not shipping in the release vehicles, but they are still present as controller artifacts
15:00:42 <ttkacik> 1920 was caused by statistics manager doing uncessary operations during flow removal (sending stats collection for each removed flow)
15:01:04 <colindixon> regXboi: bugs are being tracked here: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit?pli=1#gid=670022163
15:01:10 <colindixon> and here: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit?pli=1#gid=1622731782
15:01:20 <ttkacik> fix for 1484 removed uncessary operations and messages from stats manager which caused huge traffic to openflow switch from controller
15:01:34 <regXboi> colindixon, edwarnicke: then I'm answered
15:01:44 <regXboi> with the two actions from colindixon, I'm good
15:01:50 <colindixon> we’ve been *very* aggressively tracking blocking bugs
15:02:10 * edwarnicke notes that aggressively may be to mild a term... stalking might be more appropriate
15:02:44 <gzhao> colindixon: edwarnicke should people verify bugs used last night's build?
15:02:56 <colindixon> gzhao: yes
15:03:22 <gzhao> it has all the fixes merged before 3:00am PST
15:03:51 <edwarnicke> gzhao: Folks can use last nights build
15:03:57 <gzhao> http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC2/
15:04:08 <edwarnicke> gzhao: However I borked the job start (sleepy) and thus have restrated it without the -RC2 suffix this morning
15:04:27 <gzhao> edwarnicke: I saw it -:)
15:04:27 <edwarnicke> gzhao: But I think folks shoul start testing the one you referenced there ASAP
15:04:37 <colindixon> edwarnicke: mail already sent
15:04:52 <colindixon> ok, next release review? (hopefully it will be easier than controller)
15:04:59 <gzhao> shall we move to yang tools? any more questions for controller's release review
15:05:01 <colindixon> everything has to be easier than controller
15:05:24 <phrobb> yes, let's move on
15:05:42 <gzhao> #topic Yangtools Release Review
15:05:43 <phrobb> Nice job Ed and the Controller team!
15:06:02 <ttkacik> #link https://wiki.opendaylight.org/view/YANG_Tools:Helium:Release_Review
15:06:17 <ttkacik> #link https://wiki.opendaylight.org/view/YANG_Tools:Helium:Release_Notes
15:08:35 <regXboi> same asciidoc comment applies here
15:09:29 <colindixon> this mostly looks good
15:09:56 <colindixon> developer documentation is really just about how to check out and build the code so that you can help develop yangtools, rather than to develop with yangtools
15:10:29 <colindixon> how to/tutorial is really about how to use it to compile yang to java in your project
15:11:05 <colindixon> which are both fine, we should figure out what the target audience for each kind of docs is in the future
15:11:14 <colindixon> so that we’re consistent
15:11:49 <ttkacik> e.g. contributors doc vs. developers doc (users)
15:12:08 <colindixon> ttkacik: are the eoled things removed from the code or just deprecated?
15:12:19 <colindixon> ttkacik: exactly (not trying to pick on you) just making mental notes
15:12:43 <ttkacik> currently deprecated... will be removed after Helium is out and affected code will be migrated
15:13:14 <colindixon> #info colindixon notes that for Helium the features marked as end-of-lifed here are actually present but deprecated
15:13:23 * phrobb notes that we need an EOL-plans section in the release plans so we can project user impact at the start of a dev cycle
15:13:49 <regXboi> phrobb: +1
15:13:51 <colindixon> #action ttkacik will add pointers to commits for asciidoc (even if it’s just a note with a hyperlink to wiki documentation)
15:13:52 <edwarnicke> phrobb: that is a very good idea
15:14:45 <gzhao> #info phrobb notes we need an EOL-plans section in the release plans so we can project user impact at the start of a dev cycle
15:16:02 <gzhao> two questions, 1) do docs build and ship with Helium 2) when will those actions need to be completed
15:16:13 <colindixon> ok, otherwise, I’m good
15:16:27 <colindixon> gzhao: no, docs will be built and posted to the website separately from the helium code
15:16:34 <colindixon> at least that’s my understanding
15:16:53 <gzhao> colindixon: ok
15:17:03 <phrobb> I'm good here too, and I added the EOL topic to Colins list of things-learned
15:17:33 <gzhao> any more questions for yang tools
15:17:34 <regXboi> I would say we need asciidoc commits by EOW
15:17:56 <gzhao> thank you ttkacik
15:18:00 <phrobb> Nice job ttkacik and the yangtools team
15:18:12 <gzhao> #topic TCPMD5 Release Review
15:18:14 <rovarga> #link https://wiki.opendaylight.org/view/TCPMD5:Helium_Release_Review
15:18:23 <rovarga> #link https://wiki.opendaylight.org/view/TCPMD5:Helium_Release_Notes
15:18:31 <rovarga> (very bare-bones, sorry)
15:18:51 * regXboi notes the developer guide wiki page doesn't exist?!?!
15:19:22 <rovarga> it does
15:19:32 <rovarga> #link https://wiki.opendaylight.org/view/TCPMD5:Helium_Developer_Guide
15:19:44 <regXboi> ok, it does
15:19:47 <regXboi> that's weird
15:20:07 <rovarga> mediawiki caching or something, it's *very* fresh
15:20:17 * colindixon sees the same issue, but it’s there
15:21:02 <colindixon> #action rovarga will do migrate the wiki stuff to asciidoc in docs.git or at least put a hyperlink to the wiki docs
15:22:18 <colindixon> ok, it’s minimal, but looks ok to me
15:22:55 <phrobb> wiki link to dev guide fixed…
15:23:08 <phrobb> missing underbars
15:23:32 <rovarga> phrobb: thanks
15:23:42 * colindixon tries to gain time :p
15:23:50 <gzhao> thanks rovarga
15:24:09 * phrobb agrees with colindixon. This looks good
15:24:12 <gzhao> #topic L2Swtich Release Review
15:24:26 <phrobb> Thanks rovarga!
15:24:39 <alefan> Hi everyone, #link https://wiki.opendaylight.org/view/L2_Switch:Helium:Release_Review
15:24:47 <colindixon> #link https://wiki.opendaylight.org/view/L2_Switch:Helium:Release_Review
15:25:35 <regXboi> can we have the commit # for the asciidoc in the relase review document in the future?
15:25:49 <alefan> Sure, I can add that now.
15:25:49 <regXboi> and can we get them here now (so I can look?)
15:25:55 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/11258/ commit for asciidoc
15:26:19 <alefan> Thanks colindixon.
15:26:22 <gzhao> #info regXboi suggests to have the commit # for the asciidoc in the relase review document in the future
15:26:30 <colindixon> +1
15:27:06 <colindixon> probably want to remove this line: “Your project / feature should be included in the appropriate Helium Release Guides and Documentation: “
15:27:11 <phrobb> alefan: is there no more host-tracker or Arp Handler in the core controller?… have they been moved to L2 Switch?
15:27:56 <alefan> Those components were part of AD-SAL. I'm honestly not sure of whether they are still in the Helium release or not for AD-SAL.
15:28:02 <colindixon> phrobb: the host tracker (and I think arp handler) are are still technically present in the controller project, but I dont’ think can be run as part of the karaf distribution
15:29:01 <phrobb> colindixon: a karaf dist. with L2 switch, or without it?
15:29:11 * regXboi pads off to get ice
15:29:35 <colindixon> phrobb: I think there is no karaf feature to load the controller host tracker and controller arp handler
15:29:36 <phrobb> that was the basis of my question… did we lose compatible functionality from hydrogen to helium by putting those functions in l2switch?
15:30:07 <phrobb> … as l2switch is not "compatible with all"
15:30:12 <edwarnicke> phrobb: We actually gain functionality
15:30:23 <edwarnicke> phrobb: because we can handle l2 traffic in the absence of arps
15:30:35 <phrobb> edwarnicke: way cool… if this isn't an issue, I don't need to learn about it here…
15:30:40 <edwarnicke> phrobb: the legacy arphandler wasn't compatible with all either
15:31:24 <edwarnicke> phrobb: Until we solve the apps-getting-along issue... I don't think there is any way to do 'all packets are switched' with a 'compatible-with-all' thing
15:31:35 <colindixon> phrobb: what ed said
15:31:44 <alefan> phrobb: to provide more detail, when the l2switch feature is installed on karaf, it doesn't deploy any adsal components -- meaning no leagcy arphandler & hosttracker
15:31:58 <alefan> phrobb: but that doesn't help with the compatibility question ;)
15:32:08 <colindixon> to get pingall to work you need to load the l2switch feature, and that will inherently conflict with some other modules that don’t want anyone messing with the forwarding but them
15:32:24 <colindixon> this looks good to me
15:32:34 <gzhao> #info alefan notes when the l2switch feature is installed on karaf, it doesn't deploy any adsal components -- meaning no leagcy arphandler & hosttracker
15:32:48 <phrobb> yep, me too.. and thanks for the education alefan, colindixon, and edwarnicke
15:33:04 <edwarnicke> phrobb: :)
15:33:06 * colindixon fixed the link to the initial schedule
15:33:17 <gzhao> any actions for l2swtich?
15:33:44 <colindixon> #action alefan will add a link to the gerrit for the asciidoc patch in the release review
15:33:46 <colindixon> done
15:33:47 <colindixon> that’s it
15:33:54 <colindixon> you guys are way ahed
15:33:57 <colindixon> only 15 minutes behind
15:34:07 <edwarnicke> colindixon: victory!
15:34:15 <alefan> Just continuing to kill bugs, that's about it.
15:34:17 <colindixon> #topic OpenFlow Protocol Library
15:34:40 <alefan> Thanks everyone.
15:34:48 <phrobb> Thanks alefan!
15:34:52 <colindixon> alefan: note that at some point (possibly now) we will stop pulling new code since we stop creating release artifacts
15:35:03 <gzhao> thanks alefan
15:35:23 <colindixon> alefan: we’ll provide instructions on how to correctly set up master for further development and stable/helium for later helium releases later
15:35:25 <colindixon> thanks
15:35:32 <colindixon> is oflibMichal here?
15:35:35 <phrobb> who is here for OpenFlow Protocol Library?
15:35:40 <oflibMichal> colindixon: yes i am
15:35:45 <alefan> colindixon: Sounds good, thanks.
15:35:46 <oflibMichal> oh sorry
15:35:53 <colindixon> release release review and release notes? :p
15:35:57 <colindixon> just #link them in
15:35:57 <phrobb> can you share a link to your release review?
15:35:59 <oflibMichal> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes#For_Development
15:36:17 <oflibMichal> $link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes
15:36:24 <oflibMichal> second one is correct
15:36:32 <colindixon> #undo
15:36:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x251f750>
15:36:38 <colindixon> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes
15:36:51 <colindixon> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Helium_Release_Review
15:37:02 <colindixon> the release review was linked from release notes
15:37:20 <ypahuja> Hi Vijay
15:39:08 <colindixon> #actoin oflibMichal to move openflowjava docs to asciidoc in the docs.git (or at least provide hyperlinks to the wiki docs)
15:39:39 <colindixon> #undo
15:39:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x24f8b90>
15:39:47 <colindixon> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Helium_Release_Review
15:39:54 <colindixon> #action oflibMichal to move openflowjava docs to asciidoc in the docs.git (or at least provide hyperlinks to the wiki docs)
15:40:02 <colindixon> sorry, I fix my mistakes :p
15:40:11 <colindixon> this looks good to me
15:41:24 <dkutenic> sorry for jumping in, just to scratch AIs
15:41:27 <dkutenic> #link https://git.opendaylight.org/gerrit/#/c/11533/ - added ascii doc for BGPCEP
15:41:35 <dkutenic> #link https://git.opendaylight.org/gerrit/#/c/11535/ - added ascii doc for TCP-MD5
15:42:04 <colindixon> dkutenic: thanks
15:42:15 <regXboi> dkutenic: +1 and thank you
15:42:35 * colindixon notes that they developer guide has links to javadoc and yang model docs which is nice
15:43:32 <colindixon> phrobb, edwarnicke, regXboi any other comments?
15:43:44 <regXboi> i'm good
15:44:06 <phrobb> nope, I'm good
15:44:24 <colindixon> #topic Lisp Flow Mapping
15:44:38 <vina_ermagan> https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Helium_Release_Review
15:44:47 <vina_ermagan> #link https://wiki.opendaylight.org/view/OpenDaylight_Lisp_Flow_Mapping:Helium_Release_Review
15:44:57 <oflibMichal> colindixon: added links to wiki for openflowjava here: https://git.opendaylight.org/gerrit/#/c/11536/
15:45:12 <colindixon> oflibMichal: thanks
15:45:31 <regXboi> what's the status of 2058?
15:45:36 <regXboi> oh ... that think
15:45:38 <colindixon> regXboi: thanks!
15:45:52 <regXboi> er thing .... edwarnicke: do you have cycles to move this mountain?
15:45:57 <lori> regXboi: fix is merged, doing functional test
15:46:15 <gzhao> vina_ermagan: do we have release notes link?
15:46:37 <regXboi> is 11505 the fix?
15:46:37 <colindixon> #info regXboi asks about bug 2058, lori says the fix is merged and being tested
15:46:38 <vina_ermagan> gzhao: no, just release review
15:46:40 <blbalaji> #info blbalaji for SNBI
15:46:49 <lori> regXboi: yes
15:46:49 <regXboi> lori: what's the link for the fix?
15:47:30 <lori> #link https://git.opendaylight.org/gerrit/11505
15:47:50 <regXboi> um
15:47:58 <regXboi> developer guide for hydrogen?
15:48:19 <colindixon> I was going to ask that
15:48:22 <lori> regXboi: we now read properties from bundle context for Karaf, but also from system context for people not using Karaf
15:48:31 <vina_ermagan> developer guide for Helium is in ASCIIDoc Developer Guide
15:48:45 <regXboi> can we get commit links for the asciidoc?
15:49:06 <regXboi> #info we really need to add having asciidoc commit links to the release review template for lithium
15:49:43 <vina_ermagan> latest commit for asciidoc #link https://git.opendaylight.org/gerrit/#/c/11534/
15:50:00 <regXboi> thx
15:50:14 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/11534/ latest asciidoc commit
15:50:39 * regXboi notes that commit didn't build
15:50:46 <vina_ermagan> regXboi: more updates on the ascii do will soon be pushed,
15:51:56 <colindixon> #action vina_ermagan will push more updates to the lispflowmapping asciidoc and post links to gerrits to the relase review page
15:52:39 <gzhao> snmp4sdn is next
15:52:50 <gzhao> any more question for lisp
15:52:55 <phrobb> none from me
15:53:04 <regXboi> yes - we need to make sure the commits actually build
15:53:15 <gzhao> #topic SNMP4SDN
15:53:17 <phrobb> this looks good. Thank you vina_ermagan!
15:53:18 <colindixon> #action vina_ermagan to clean up release review for lisp flow mapping so that it’s clear what’s for hydrogen vs. helium (notably, is the developer guide for hydrogen or helium)
15:53:26 <gzhao> #undo
15:53:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x282fd50>
15:53:27 <regXboi> um
15:53:29 <gzhao> #undo
15:53:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x282f950>
15:53:34 <vina_ermagan> regXboi: yes, working on it now
15:53:46 <regXboi> #action vina_ermagan to clean up release review for lisp flow mapping so that it’s clear what’s for hydrogen vs. helium (notably, is the developer guide for hydrogen or helium)
15:53:46 <gzhao> #action vina_ermagan to clean up release review for lisp flow mapping so that it’s clear what’s for hydrogen vs. helium (notably, is the developer guide for hydrogen or helium)
15:53:52 <colindixon> #undo
15:53:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x258da10>
15:53:52 <gzhao> #undo
15:53:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x282f050>
15:53:54 <colindixon> lol
15:53:56 <gzhao> colindixon: you drive
15:53:58 <colindixon> gzhao: take it
15:53:59 <phrobb> lol
15:54:04 <colindixon> take it
15:54:06 <colindixon> I step down
15:54:12 <colindixon> I’ll drive next
15:54:14 <regXboi> ok I'll drive this fix
15:54:18 <gzhao> #topic SNMP4SDN
15:54:19 <regXboi> #action vina_ermagan will push more updates to the lispflowmapping asciidoc and post links to gerrits to the relase review page
15:54:23 <regXboi> ARGGGH!
15:54:25 <colindixon> just keep going
15:54:28 <colindixon> just keep going
15:54:33 <gzhao> multithread
15:54:34 <regXboi> #action vina_ermagan to clean up release review for lisp flow mapping so that it’s clear what’s for hydrogen vs. helium (notably, is the developer guide for hydrogen or helium)
15:54:38 <gzhao> race condition
15:54:45 <ChristineH_> #info ChristineH_ for SNMP4SDN
15:54:45 <colindixon> ChristineH: you here?
15:54:49 <colindixon> ok
15:54:50 <ChristineH_> yes
15:54:52 <vina_ermagan> regXboi, gzhao : action noted
15:54:57 <regXboi> #action vina-ermagan to ensure asciidoc commits successfully pass jenkins
15:54:59 <ChristineH_> Release review link: https://wiki.opendaylight.org/view/SNMP4SDN:Helium_Release_Review
15:55:03 <regXboi> vina_ermagan: thx :)
15:55:06 <gzhao> vina_ermagan: multiple times -:)
15:55:08 <colindixon> #link https://wiki.opendaylight.org/view/SNMP4SDN:Helium_Release_Review
15:55:44 <regXboi> no bugs? cool, but we should say that
15:55:44 <colindixon> vina_ermagan: and if you could add a short release notes page as well, that would be good
15:56:11 <vina_ermagan> colindixon: will do.
15:56:18 <ChristineH_> SNMP4SDN's documentation is upgrading from Hydrogen's verison... Mainly need to add the part of VLAN configuration.
15:56:28 <regXboi> and the now standard asciidoc comment applies as well
15:56:31 <colindixon> #action ChristineH to add a link and a summary showing that snmp4sdn has no bugs
15:56:33 <gzhao> ChristineH_: those picture are not from dlux right?
15:57:03 <ChristineH_> gzhao: yes. I'll add the dlux picture later.
15:57:03 <colindixon> #action ChristineH to migrate wiki docs to the asciidoc in docs.git (or at least add a hyperlink to the wiki documentation)
15:57:40 <colindixon> #info ChristineH notes that the docs are currently for hydrogen and so use the old web GUI for images and need to be fixed where they talk about VLANs
15:58:33 * colindixon notes that there are no release notes
15:58:44 <gzhao> ChristineH_: release notes?
15:59:26 <ChristineH_> gzhao: oh, I miss it... but can come out very quickly
16:00:01 <colindixon> #action ChristineH will add snmp4sdn helium release notes something like this from Hydrogen https://wiki.opendaylight.org/view/SNMP4SDN:Hydrogen_Release_Note
16:00:09 <colindixon> other than that, this looks fine to me
16:00:17 <regXboi> ditto
16:00:25 <gzhao> thanks ChristineH_
16:00:35 <phrobb> ChristineH: do you document anywhere the SNMP devices/MIBs you support and have tested with?… assuming that would be handy for users…
16:00:35 <gzhao> #topic SNBI
16:00:44 <gzhao> #undo
16:00:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x24a34d0>
16:00:51 <vjanandr_> #link https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:HeliumReleaseReview
16:01:00 <phrobb> sorry gzhao
16:01:07 <gzhao> phrobb: np
16:01:15 <ChristineH_> phrobb: thanks for the suggestion. Okay, I can provide it.
16:01:22 <regXboi> #undo
16:01:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x24a34d0>
16:01:33 <phrobb> thanks ChristineH, no more questions from me
16:01:37 <regXboi> now we can switch topics :)
16:01:47 <gzhao> #topic SNBI
16:01:57 <regXboi> and now we can link the review
16:02:02 <vjanandr_> #link https://wiki.opendaylight.org/view/SecureNetworkBootstrapping:HeliumReleaseReview
16:03:01 <regXboi> the architecture overview and developer's guide both should migrate to asciidoc (or at least a link)
16:03:17 <vjanandr_> regXboi working with the docs team..
16:03:20 <regXboi> while the user gudie does the same
16:03:26 <regXboi> vjanandr_: thx
16:03:37 <colindixon> #action vjanandr_ will move the wiki docs for SNBI to the asciidoc in docs.git or at least provide a hyperlink to the wiki docs
16:03:52 <vjanandr_> colindixon: sure will do
16:03:58 <colindixon> it sounds like you’re already doing that
16:04:22 <vjanandr_> the asciidoc is still in review..
16:04:24 <regXboi> I've got nothing else
16:04:29 <colindixon> looks like no blocking bugs
16:04:32 <colindixon> no release notes here
16:04:36 <regXboi> do we have a link for the asciidoc?
16:04:38 <colindixon> are we requiring release notes?
16:04:47 <vjanandr_> this is the first release :)
16:05:06 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/11513/ gerrit for asciidocs (but doesn’t build)
16:05:23 <gzhao> vjanandr_: release note?
16:05:37 <colindixon> #action vjanandr_ to add simple release notes
16:05:40 <colindixon> #undo
16:05:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2481c50>
16:05:43 <vina_ermagan> regXboi, gzhao: updated ascii docs with successful build : #link https://git.opendaylight.org/gerrit/#/c/11538/
16:06:01 <regXboi> vina_ermagan: thx!
16:06:03 <vjanandr_> gzhao: do we require release notes for first timers ?
16:06:36 <colindixon> #action vjanandr_ to add a short release notes page for SNBI basing it off this https://wiki.opendaylight.org/view/Sample_Release_Notes
16:06:52 <vjanandr_> regXboi: https://git.opendaylight.org/gerrit/#/c/11477/
16:06:57 <gzhao> vjanandr_: for all that releases, including first timer -:)
16:07:04 <colindixon> vjanandr_: it’s just basically any known issues, what it’s known to work with,etc.
16:07:16 <colindixon> with those action items, I’m good
16:07:17 <vjanandr_> gzhao: sure let me take a look... thanks.
16:07:37 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/11477/ link to review of SNBi asciidoc
16:07:38 <gzhao> any more questions on SNBI?
16:07:45 <phrobb> no other comments from me
16:07:51 <regXboi> ditto
16:08:05 <colindixon> #topic PacketCable PCMM
16:08:08 <colindixon> xsited: you there?
16:08:17 <xsited1> good morning
16:08:22 * colindixon takes the driver’s seat
16:08:27 <gzhao> xsited1: morning
16:08:32 <xsited1> #link https://wiki.opendaylight.org/view/PacketCablePCMM:ReleaseReview
16:08:32 <xsited1> #link https://wiki.opendaylight.org/view/PacketCablePCMM:ReleaseNotes
16:08:34 <colindixon> link to release review (and ideally release notes)
16:08:35 <colindixon> perfect
16:09:41 * regXboi reads
16:10:18 * colindixon notes that xsited1 provides links to asciidoc gerrits (that build) :-)
16:10:19 <regXboi> I don't see much to comment on
16:10:33 <regXboi> this looks pretty darn good
16:11:07 <gzhao> even with commit #
16:11:07 <regXboi> anybody else?
16:11:17 <colindixon> looks good to me
16:11:22 <colindixon> phrobb:
16:11:33 <phrobb> no comments
16:11:37 <colindixon> #topic OVSDB
16:11:48 <colindixon> Madhu_offline or networkstatic or dave_tucker?
16:11:50 <gzhao> is Madhu back?
16:11:50 <regXboi> xsited1: thx!
16:11:57 <gzhao> thanks regXboi
16:12:02 <xsited1> thanks, team.
16:12:12 <dave_tucker> colindixon: can I help?
16:12:16 <phrobb> thanks xsited1
16:12:21 <colindixon> OVSDB release review?
16:12:28 <gzhao> let's go to next one first
16:12:34 <dave_tucker> colindixon: so we are good. all blockers closed
16:12:45 <colindixon> dave_tucker: do you have links to your release review and release notes on the wiki?
16:13:08 <dave_tucker> colindixon: probably not, i'll follow up with Madhu_offline as soon as I can get hold of him
16:13:22 <regXboi> colindixon: lets move OVSDB to tomorrow?
16:13:34 <gzhao> #undo
16:13:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x259c5d0>
16:13:34 <colindixon> #info couldn’t find Madhu_offline and dave_tucker didn’t know what was going on with the release review
16:13:44 <colindixon> #undo
16:13:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2589c50>
16:13:47 <colindixon> let’s go with that
16:13:47 <colindixon> ok
16:14:00 <regXboi> #action moving OVSDB to Thursday review
16:14:10 <colindixon> #undo
16:14:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x259cdd0>
16:14:14 <colindixon> #topic OVSDB
16:14:26 <colindixon> #action gzhao and phrobb to work with Madhu_offline to reschedule OVSDB to thursday
16:14:27 <phrobb> huh?
16:14:30 <regXboi> 9:00 am review?
16:14:45 <regXboi> phrobb: huh, what?
16:14:57 <colindixon> #topic group-based policy
16:15:01 <phrobb> topic back to OVSDB… I was expecting GBP
16:15:09 <alagalah> I am here for GBP
16:15:11 <regXboi> oh, just cleaning the minutes
16:15:17 <alagalah> Shall I start ?
16:15:23 <colindixon> alagalah: sorry for the delay, please start
16:15:24 <gzhao> let's see if Madhu will be on line later
16:15:44 <alagalah> 1. No Release Notes... didn't realise it was a requirement... will address ASAP
16:15:49 <alagalah> #link https://wiki.opendaylight.org/view/Group_Policy:Helium-Release-Review
16:16:29 <colindixon> #action alagalah to add release notes for GBP (they should be short and sweet :-) )
16:16:38 <alagalah> colindixon: well.. .short
16:17:07 * colindixon notes they have a link to a gerrit for asciidoc (which builds) :-)
16:17:44 <gzhao> GBP should have user guide, dev guide and how to
16:17:46 <colindixon> bugs, how are we dooing on 2019 and 2051?
16:17:59 <alagalah> gzhao: The Tutorial is a how to for now since we are at POC stage
16:18:10 <alagalah> gzhao: Will ensure its part of this afternoon's docs discussion
16:18:32 <alagalah> colindixon: Its being worked around the clock by tbachman edwarnicke michal_rehak
16:18:48 <alagalah> colindixon: intermittent, no defined trigger to consistently reproduce
16:19:10 <colindixon> #action alagalah to work on getting docs (including user, dev, and howto) for GBP into asciidoc
16:19:16 <alagalah> colindixon: ack
16:19:28 <colindixon> #info alagalah notes that bugs 2019 and 20151 are still unresolved at this time
16:19:43 <alagalah> colindixon: ETA is 9/26 correct? How much leeway do we have? (9/29 gives us the w/e)
16:19:59 <gzhao> alagalah: thanks
16:20:03 <abhijitkumbhare> #info abhijitkumbhare for OpenFlow plugin
16:20:19 <colindixon> alagalah: you mean for gus?
16:20:22 <colindixon> bugs?
16:20:30 <alagalah> colindixon: Sorry, apologies, asciidocs
16:20:32 <colindixon> hey abhijitkumbhare
16:20:51 <colindixon> alagalah: for asciidocs, my guess is we’re going to build them sometime sunday night or monday morning and shi what we have
16:20:53 <abhijitkumbhare> have been around - but doing multiple things colindixon
16:21:03 <alagalah> colindixon: Since these bugs are intermittent, and we are POC, I would like to move ahead with being part of the release
16:21:07 <alagalah> colindixon: Ack on docs...
16:21:47 <colindixon> #info alagalah notes that their bugs may not be “blockers” because they are intermittent and they are only a PoC in Helium, so even if unresolved they would like to be shipped
16:21:48 <alagalah> colindixon: If not resolved prior to release, would a note in the Release Notes suffice of the existance of these issues?
16:21:48 <colindixon> good to know
16:21:58 <colindixon> alagalah: yeah
16:22:01 <alagalah> colindixon: ack
16:22:02 <colindixon> that would be the perfect place
16:22:06 <regXboi> +1
16:22:12 <colindixon> we need to figure out how to aggregate release notes
16:22:14 <colindixon> like yesterday
16:22:36 <colindixon> #action colindixon to figure out how to get aggregate release notes into the docs somewhere :-/
16:22:51 <colindixon> ok, I’m good with those actions here
16:23:16 <gzhao> last one
16:23:18 * colindixon notes we’re only 3-4 minutes behind
16:23:23 <colindixon> #topic OpenFlow Plugin
16:23:23 <alagalah> am I don ?
16:23:25 <alagalah> done ?
16:23:30 <colindixon> thanks alagalah :-)
16:23:31 <alagalah> I take that as a yes :) thanks all
16:23:34 <gzhao> alagalah: thanks
16:23:36 <alagalah> ttfn
16:23:39 <phrobb> thanks alagalah
16:23:46 <colindixon> abhijitkumbhare: release review page and release notes?
16:23:47 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Review
16:24:06 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Notes
16:24:44 <regXboi> colindixon
16:24:49 <regXboi> 1772 isn't on your list
16:24:59 <colindixon> you sure it’s not 1722?
16:25:15 <regXboi> yes I'm sure
16:25:35 <colindixon> target milestone is Helium-1
16:25:39 <colindixon> so stable release
16:25:46 <colindixon> and its supposedly user error
16:26:00 <abhijitkumbhare> Yes
16:26:00 <regXboi> then we need a note about this in the release notes?
16:26:34 <regXboi> and usual asciidoc comment applies
16:26:39 <colindixon> #action abhijitkumbhare to add a page for release notes (use this as inspiration: https://wiki.opendaylight.org/view/Sample_Release_Notes )
16:26:42 <colindixon> #undo
16:26:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x24a4b10>
16:26:51 <colindixon> #action abhijitkumbhare to add a page for openflow plugin release notes (use this as inspiration: https://wiki.opendaylight.org/view/Sample_Release_Notes )
16:27:59 <colindixon> #action abhijitkumbhare to migrate openflow plugin docs to asciidoc or at least provide a hyperlink to the wiki docs (note, not just a hyper link but an english phrase like: “The current <kind-of-docs> documentation for the <project> can be found on the OpenDaylight wiki here: <url>”)
16:28:11 * colindixon may have been -1ing docs patches that have just a bare url
16:29:05 <colindixon> otherwise this looks good to me
16:29:22 <abhijitkumbhare> OK - I have the release notes at https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Notes - but I think I do not have some parts of it from the sample
16:29:41 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Notes
16:29:47 <phrobb> yep, no other comments from me
16:30:00 <regXboi> yeah, I need to run
16:30:03 <colindixon> abhijitkumbhare: that looks good enough for me
16:30:06 <regXboi> see folks tomorrow
16:30:14 <colindixon> I think we’re done on time
16:30:28 <colindixon> 10 minutes early (but that’s attributable to not doing OVSDB)
16:30:29 <regXboi> yea!
16:30:30 <phrobb> Thanks very much to all the projects that went today!!
16:30:37 <regXboi> phrobb: +1
16:30:41 <abhijitkumbhare> the wiki docs are present (in the release review) - the ascii docs are not there
16:30:55 <colindixon> #info colindixon notes that the openflow plugin release notes seem good enough tohim
16:30:59 <colindixon> #endmeeting