14:31:38 <gzhao> #startmeeting Helium Release Review
14:31:38 <odl_meetbot> Meeting started Thu Sep 25 14:31:38 2014 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:38 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:38 <odl_meetbot> The meeting name has been set to 'helium_release_review'
14:31:50 <gzhao> #topic roll call
14:32:05 <gzhao> #info gzhao for release
14:32:09 <Rafat> #info Rafat and Radhika for SDNi
14:32:10 <hideyuki> #info Hideyuki for VTN
14:32:23 <colindixon> #info colindixon for, you know, things
14:32:32 <edwarnicke> #info edwarnicke for everything
14:32:41 <tbachman> #info tbachman for groupbasedpolicy
14:33:26 <regXboi> #info regXboi for mischief, gadflyness, and general mayhem
14:33:34 <phrobb> #info Phil Robb
14:34:03 <gzhao> #chair colindixon phrobb regXboi edwarnicke
14:34:03 <odl_meetbot> Current chairs: colindixon edwarnicke gzhao phrobb regXboi
14:34:09 <regXboi> and maybe even some help :)
14:34:21 <regXboi> ok, let's link the google page?
14:34:51 <colindixon> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=972372068 the schedule for today (and yesterday)
14:35:15 <colindixon> are we ready for SDNi?
14:35:18 <Rafat> SDNi Release Review: https://wiki.opendaylight.org/view/ODL-SDNiApp:Release_Review
14:35:21 <Rafat> SDNi Release Note: https://wiki.opendaylight.org/view/ODL-SDNi_App:Helium_Release_Notes
14:35:23 <colindixon> #topic SDNi
14:35:25 <Rafat> Yes
14:35:30 <colindixon> #link https://wiki.opendaylight.org/view/ODL-SDNiApp:Release_Review
14:35:36 <colindixon> #link https://wiki.opendaylight.org/view/ODL-SDNi_App:Helium_Release_Notes
14:35:39 * colindixon reads
14:36:17 <regXboi> #info while this isn't on the specific release agenda, can you all fix your Jenkin's merge job?
14:37:04 <colindixon> #action Rafat to migrate SDNi docs from the wiki to asciidoc (or at least put a hyperlink from the asciidoc to the appropriate wiki pages)
14:37:24 <Rafat> Yes Colin..Unfortunately I am not aware of the process...
14:37:29 <Rafat> Any link I can follow
14:38:04 <colindixon> Rafat, this is an example with content
14:38:06 <colindixon> https://git.opendaylight.org/gerrit/#/c/11560/
14:38:43 <colindixon> Basically, you’ll want to replace the stuff thats there in the sdni.adoc files
14:38:53 <colindixon> at least with links to relevant wiki content
14:39:33 <colindixon> reach out to me if you need help later
14:39:40 <regXboi> #info  question on the jenkins merge job
14:40:06 <regXboi> #info how is origin/$GERRIT_BRANCH getting resolved?
14:40:18 <colindixon> other than regXboi’s question I’m happy
14:40:46 <tbachman> lol
14:41:20 <regXboi> sorry folks, I know that isn't on the requirements list, but we've found a couple of broken configurations and so I'm checking it on everybody today
14:41:54 <Rafat_1> Sure Colin.Will take this up
14:42:09 <regXboi> did we lose Rafat?
14:42:17 <colindixon> can you speak to regXboi’s question?
14:42:22 <Rafat_1> No..I just joined back. :-)
14:42:23 <edwarnicke> To second regXboi this isn't a 'You haven't met a stated requirement thing' its a 'mechanically bad shit breaks if this isn't done right' thing
14:42:43 <colindixon> “while this isn't on the specific release agenda, can you all fix your Jenkin's merge job?”
14:42:52 <colindixon> “how is origin/$GERRIT_BRANCH getting resolved?"
14:43:30 <colindixon> Rafat_1?
14:43:45 <regXboi> if you can explain how it resolves to origin/master, it's all good
14:43:58 <Rafat_1> Can you elaborate the question please
14:44:04 <colindixon> ok
14:44:11 <regXboi> so... in https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-merge/configure
14:44:14 <colindixon> regXboi: can you I have you two take this offline?
14:44:16 <colindixon> so we can keep going?
14:44:28 <regXboi> colindixon: well, I have to ask it of everybody
14:44:33 <regXboi> so...
14:44:35 <colindixon> ok
14:44:51 <regXboi> the branches to build is origin/$GERRIT_BRANCH
14:45:20 <regXboi> I'm asking how you get that to resolve to origin/master - if your are specifying the GERRIT_BRANCH as master by hand when running the build, that's fine
14:45:38 <colindixon> regXboi: it’s listed here: https://wiki.opendaylight.org/view/GettingStarted:Jenkins_Verify_Job_Setup
14:45:55 <colindixon> it’s step 8.6
14:45:57 <regXboi> colindixon: yes, but that used to be wrong
14:46:42 <regXboi> ok, I looked in the console output of #12 and it's correct, so I'm good
14:46:53 <Rafat_1> Ok..I got the query.We can change it.Will have to confirm once since was working Ed all along
14:46:54 <regXboi> i.e. https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-merge/12/consoleFull has a reference to origin/master
14:47:04 <regXboi> Rafat_1: no need - I'm satisfied
14:47:11 <Rafat_1> ok..thank you
14:47:14 <colindixon> it gets populated by the gerrit trigger
14:47:19 <regXboi> #info regXboi satisfied sdni has a valid verify job
14:47:20 <rovarga> https://jenkins.opendaylight.org/yangtools/job/yangtools-merge/configure works just fine and works correctly with multiple branches (just make sure you have your versions right)
14:47:32 <edwarnicke> regXboi: verify job or merge job?
14:47:39 <gzhao> https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-merge/12/parameters/
14:47:44 <regXboi> #undo
14:47:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x282f210>
14:47:49 <colindixon> Rafat_1: reach out to me about docs if you’re lost
14:48:03 <regXboi> #info regXboi satisfied sdni has a valid merge job
14:48:05 <colindixon> #topic VTN
14:48:09 <regXboi> edwarnicke: thanks
14:48:12 <colindixon> hideyuki, you’re up
14:48:14 <Rafat_1> We will do it and update accordingly
14:48:17 <colindixon> thanks Rafat_1
14:48:22 <Rafat_1> thanks Colin
14:48:33 <hideyuki> #link https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Helium_Release_Notes
14:48:37 <hideyuki> #link https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Helium_Release_Review
14:49:06 <regXboi> #info VTN's merge job is hardcoded to origin/master - it's fine
14:49:52 <regXboi> #info standard asciidoc comment applies
14:50:14 <colindixon> #undo
14:50:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2579210>
14:50:47 <colindixon> #action hideyuki to move VTN’s wiki docs to asciidoc (or at least put links to the right wiki pages in)
14:51:13 <hideyuki> colindixon: Ok. We are working on this.
14:51:33 <gzhao> one general questions: should release notes only contains major features in this release
14:52:14 <gzhao> and major bug fixes for previous releases?
14:52:23 <colindixon> gzhao: as a general rule, yes, but we haven’t really figured out what “major” is, so it’s basically what people choose to put
14:52:26 <hideyuki> gzhao: I'm not sure. So we've written both previous features and new features.
14:52:53 <colindixon> the release notes is haphazard at best, which is likely my fault
14:53:11 <colindixon> the key things I’m looking for are known limitations and the target environment
14:53:36 <gzhao> colindixon: ok, this will be lithium
14:53:55 <colindixon> I’d like to see none or n/a in the empty sections of the release review, but that’s a really minor nit
14:54:12 <colindixon> do we need to talk about the bugs?
14:55:30 <hideyuki> Bug 2074 is a really critical bug for VTN project. I would be happy if the bug is fixed quickly.
14:56:14 <hideyuki> I think many other project faces issues by this Bug 2074.
14:56:25 <regXboi> that isn't on the list
14:56:30 <colindixon> it is
14:56:41 <colindixon> it’s a controller bug
14:56:53 <colindixon> it’s under bugzilla in the release review
14:56:53 <hideyuki> That's all what I would like to say about bugs in this meeting.
14:57:13 <colindixon> is it a show-stopping bug?
14:57:26 <edwarnicke> hideyuki: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163 is in the showstoppers list
14:57:51 <colindixon> #info hideyuki notes that but 2074 is a show-stopper bug for him, it’s being worked on
14:57:53 <regXboi> colindixon: it's not in the "All Blocking He Bugs" tab
14:58:01 <regXboi> that's what confused me
14:58:02 <hideyuki> colindixon: It is not a show-stopping, because it is not happen everytime. It happens about 50%.
14:58:05 <dkutenic> are there any restrictions on who can edit the spreadsheet? I was unable to do that
14:58:13 <hideyuki> colindixon: Thank you.
14:58:26 <hideyuki> colindixon: I think it is ok we call it show-stopper bug :)
14:58:39 <regXboi> I'd agree 50% is too often
14:58:49 <gzhao> dkutenic: give me your email  I will add you
14:58:57 <hideyuki> regXboi: +1
14:59:13 <gzhao> dkutenic: because it is a tab in a huge spreadsheet
14:59:18 <colindixon> #action colindixon to add show stopping bugs after 2058 to the spreadsheet
14:59:24 <colindixon> ok
14:59:29 <colindixon> otherwise, this looks really good hideyuki
14:59:32 <colindixon> docs look good
14:59:38 <hideyuki> colindixon: Thank you very much.
14:59:39 <colindixon> anyone else? phrobb? edwarnicke? regXboi?
15:00:10 <regXboi> I'm good
15:00:20 <colindixon> #topic TTP
15:00:36 <colindixon> #link https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Review
15:00:41 <colindixon> #link https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes
15:00:42 * edwarnicke waits for colindixon to ask himself questions
15:00:50 <regXboi> does TTP have a jenkins job?
15:01:00 <colindixon> regXboi: it does, merge specifies master
15:01:17 <regXboi> colindixon: found it
15:01:42 <colindixon> #link https://jenkins.opendaylight.org/ttp/job/ttp-merge/configure specifies origin/master under “Branches to build”
15:02:04 * regXboi doublechecks :)
15:02:21 * regXboi and nods
15:02:32 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Cutting_Stability_Branches colindixon notes that the cutting stable branches instructions are what actually talks about doing this for the merge job
15:02:46 <colindixon> presumably with the assumption that prior to that there was *only* master
15:02:59 <gzhao> Do you have commit #
15:03:08 <gzhao> for doc.git
15:03:12 <regXboi> #info regXboi thanks TTP for the gerrit asciidoc commit :)
15:03:37 <colindixon> #action colindixon to fix the jenkins merge instructions for new projects to only build origin/master
15:03:41 <colindixon> gzhao: it’s there
15:03:55 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/11560/ gerrit for docs in asciidoc
15:03:55 <regXboi> gzhao: I see it in the review docs :)
15:04:06 <regXboi> and show stoppers?
15:04:07 <colindixon> merged even
15:04:12 <colindixon> nope
15:04:14 <colindixon> everything is good
15:04:23 <regXboi> then I'm happy :)
15:04:37 <gzhao> colindixon: thanks
15:04:37 * regXboi thanks colindixon and thinks he took some hints :)
15:04:47 <colindixon> me, never!
15:04:59 <colindixon> #topic dLux
15:05:00 <colindixon> xsited1: you there?
15:05:12 <harman_> #info here for dlux
15:05:23 <harman_> release review doc link
15:05:24 <colindixon> hey harman_, go for it
15:05:24 <gzhao> colindixon: xsited is PCMM
15:05:25 <harman_> https://wiki.opendaylight.org/view/OpenDaylight_dlux:Helium_Release_Review
15:05:30 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_dlux:Helium_Release_Review
15:05:37 <harman_> https://wiki.opendaylight.org/view/OpenDaylight_dlux:Release_Notes_Helium
15:05:44 <harman_> this is release note link
15:05:48 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_dlux:Release_Notes_Helium
15:05:54 <regXboi> #info dlux-merge has origin/master - that's good
15:06:32 <colindixon> I wish that empty sections instead said “none” or “n/a”, but that’s a minor nit
15:06:49 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/11562/ dev ascii doc commit
15:06:52 <harman_> ok, i can update that
15:07:01 <regXboi> user guide ascii doc is in works
15:07:05 <harman_> yes, one commit is still pending for user guide
15:07:14 <harman_> document is complete
15:07:24 <harman_> but not in gerrit, Divya is working on some reviews
15:07:35 <regXboi> other than 2011 any other issues?
15:07:48 <harman_> nothing major
15:07:53 <harman_> we have couple of small ones
15:07:54 <regXboi> and is 2011 a show stopper?
15:08:15 <colindixon> I don’t see 2011
15:08:20 <harman_> no, its fixed
15:08:25 <harman_> by AAA
15:08:35 <regXboi> have you verified that fix then?
15:08:45 <gzhao> user guide is still in progress?
15:08:46 <edwarnicke> Many thanks to liemmn in aaa for a quick fix for 2011 :)
15:08:52 <harman_> yes, i tried
15:08:54 <regXboi> colindixon: I'm looking at the blocking issue tab
15:08:56 <harman_> it works fine
15:09:04 <harman_> and user guide is in progress
15:09:06 <regXboi> ok, then let's move that from "to be verified" to "fixed"
15:09:17 <regXboi> harman_: thx, I'm good
15:09:32 <harman_> alright then
15:09:34 <harman_> thanks
15:09:39 <colindixon> #action gzhao to move 2011 from to be verified to fixed
15:09:53 <regXboi> anybody else?
15:10:13 * regXboi trying to get us back on time, having derailed us up front
15:10:32 <gzhao> colindixon: I also tried to verify 2011, but encounter the same build issue as LuisGomez
15:10:36 <colindixon> #action harman_ to add some description of the requirements to run and develop for dlux to the rlease notes (I know it’s different than other projects)
15:10:55 <harman_> sure, i can do taht
15:10:58 <harman_> *that
15:11:02 <gzhao> harman_: what is status for user guide?
15:11:04 <harman_> i have those in wiki page
15:11:13 <harman_> so user guide is 90% complete
15:11:22 <colindixon> I’m good otherwise
15:11:32 <harman_> divya is working on review comments from team members
15:11:46 <gzhao> harman_: also dlux should have dev guide as well
15:11:48 <harman_> it should be in gerrit today/tomorrow
15:11:58 <harman_> dev guide commit is in gerrit
15:12:09 <colindixon> gzhao: https://git.opendaylight.org/gerrit/#/c/11562/
15:12:14 <regXboi> #info quesiton: who maintains https://jenkins.opendaylight.org/?
15:12:26 <gzhao> can you add a link of user guid, dev guide to release review?
15:12:33 <colindixon> regXboi: that would be the linux foundation
15:12:39 <colindixon> gzhao: deve guide link is there
15:12:50 <harman_> release review already have commit for dev guide
15:13:01 <harman_> i’ll add user guide link, as sonn as i get it
15:13:04 <regXboi> #action LF needs to update https://jenkins.opendaylight.org to list all OF jenkins jobs in there (e.g. docs is not there)
15:13:16 <regXboi> #undo
15:13:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2728950>
15:13:17 <colindixon> regXboi: neither is ttp
15:13:27 <colindixon> you just have to browse directly
15:13:33 <colindixon> you can open a helpdesk ticket
15:13:34 <regXboi> colindixon: ttp IS there as "negotiable datapath models"
15:13:42 <gzhao> harman_: ok, thanks
15:13:44 <colindixon> I was waiting until after the release
15:13:59 <colindixon> #topic docs
15:14:05 <regXboi> #action regXboi to open help ticket with LF to update https://jenkins.opendaylight.org/ to list all ODL jenkins job there (after release)
15:14:11 <regXboi> colindixon: how's that ?
15:14:16 <colindixon> regXboi: :-)
15:14:24 <colindixon> do we have somebody from docs here?
15:14:34 <regXboi> #info docs uses parameterized merge job with parameter set to master - that's ok :)
15:14:59 * regXboi hears crickets
15:15:47 <regXboi> shall we move on?
15:15:55 <colindixon> #info it appear as though nobody is here for docs
15:16:10 <colindixon> #action gzhao and phrobb to figure out if we can do a release review for docs at a different time
15:16:17 <colindixon> #topic integration
15:16:21 <regXboi> honestly, can we *do* a review of docs before everybody else is done?
15:16:22 <colindixon> LuisGomez: you’re up
15:16:40 <LuisGomez> I am finishing integration call
15:16:40 <colindixon> regXboi: yeah, I think it’s going to be special cased
15:16:47 <colindixon> #undo
15:16:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2219910>
15:16:50 <colindixon> we’ll come back
15:16:54 <colindixon> LuisGomez: we’ll come back
15:16:59 <colindixon> #topic SFC
15:17:28 <colindixon> who’s the SFC contact?
15:17:49 <gzhao> colindixon: paul
15:18:00 * regXboi looks at edwarnicke who looks back at regXboi
15:18:19 * edwarnicke looks up queue
15:18:21 <LuisGomez> ok, i am here for the integration release review whenever is my turn
15:18:27 <colindixon> ok
15:18:29 <colindixon> #undo
15:18:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x251f850>
15:18:32 <colindixon> #topic integration
15:18:34 <edwarnicke> regXboi: Isn't SFC scheduled for 8:30am PST?
15:18:45 <LuisGomez> let me post link
15:18:53 <regXboi> regXboi: yes, but schedules are .... flexible ...
15:18:57 <LuisGomez> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Helium_Release_Review
15:19:25 <regXboi> #action: we should instruct folks to be on the channel 10 minutes early in case we run ahead...
15:19:33 * colindixon chuckles at the result of “feature” being a name collision
15:19:43 <LuisGomez> any question on integration?
15:20:06 <colindixon> #info colindixon notes that while the docs are all in the wiki, it seems like integration might be the *one* case where the docs don’t need to be in asciidoc
15:20:07 * regXboi reads
15:20:32 <regXboi> #info regXboi +1 colindixon's comment
15:20:40 <LuisGomez> we have 2 kind of documentation:
15:20:45 <colindixon> #info colindixon notes that the hydrogen edition tests should probably be flagged as being EOLed unless we intend to turn them back on
15:21:00 <regXboi> um
15:21:17 <LuisGomez> 1) test guides, how to test this or that is on wiki
15:21:24 <regXboi> what is our EOL policy on hydrogen?
15:21:36 <LuisGomez> 2) test case documentation will be automated using robot plugin
15:21:46 <colindixon> if you project had a feature X in Hydrogen and doesn’t in Helium, you’re supposed to note it
15:21:49 <LuisGomez> #2 is targeted for Lithium
15:21:54 * regXboi shudders at the thought of free hydrogen running around
15:22:18 <regXboi> colindixon: I"m ok with all of this
15:22:20 <colindixon> ok, integration is kind of a special case, but this looks good
15:22:28 <colindixon> LuisGomez: any major blockers you need to report?
15:22:35 <manny_> #info Manny here. sorry i'm late. i didn't know which channel i needed join.
15:22:36 <LuisGomez> Nop
15:22:45 <LuisGomez> No blockers
15:22:47 <colindixon> manny_: you’re up next
15:22:48 <colindixon> ok
15:22:49 <colindixon> cool
15:22:53 <colindixon> #topic docs
15:23:03 <colindixon> manny_: do you have a release review or  release notes
15:23:05 <regXboi> #info regXboi notes that we should schedule integration and docs at the *END* of the review in the future
15:23:18 <colindixon> #undo
15:23:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2593a50>
15:23:20 <manny_> here's the url to the docs release review—https://wiki.opendaylight.org/view/Docs:Helium_Release_Review
15:23:20 <colindixon> #undo
15:23:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2593a10>
15:23:28 <colindixon> #info regXboi notes that we should schedule integration and docs at the *END* of the review in the
15:23:30 <colindixon> #topic docs
15:23:37 <colindixon> #link https://wiki.opendaylight.org/view/Docs:Helium_Release_Review
15:23:42 <colindixon> manny_: cool
15:23:44 * colindixon reads
15:24:00 <manny_> i don't know how to get at the release notes once they've been checked into the repository. i'll need to follow up with mathieu on that.
15:24:20 <colindixon> #info colindixon notes that the release review is sparse, but this probably makes sense for docs
15:24:28 <regXboi> manny_: they are generated by the jenkins build, I or colindixon can help you with that
15:25:06 <colindixon> so, manny_, what are the big outstanding issues you need help with?
15:25:08 <regXboi> docs-merge uses parameterized build with GERRIT_BRANCH set to master - ok
15:25:14 <manny_> i need to work with ed to figure out what needs to documented in the core release notes, but that won't take long to put together.
15:25:20 <regXboi> #info docs-merge uses parameterized build with GERRIT_BRANCH set to master - that's ok
15:25:22 <colindixon> I think developers are finally wrapping up and have cycles
15:25:59 <manny_> i'm going to ask mathieu to check in the core doc files so i know that they'll get in on time.
15:26:10 <manny_> jsut for this release, anyway
15:26:30 <phrobb> manny_:  many of the teams have updated their wikis for their documentation and have not come to you with asciidocs.  In the release reviews we've been requiring each team to put their documentation into asciidoc or at least provide a pointer to their wikis.  You should see an uptick in folks coming to you asking about their asciidocs
15:26:35 <colindixon> #action manny_ will work with edwarnicke, mlemay_away, and  colindixon to figure out what core docs we still need and see if we can farm some of that out to free agents
15:27:03 <colindixon> phrobb, manny_: I’m willing to help out with some of tha
15:27:07 <regXboi> manny_: as well as an uptick in contributions
15:27:15 <manny_> thanks, phil
15:27:34 * colindixon notes that docs will need attention from now until the release (with no offense meant to the docs team or manny)
15:27:44 <colindixon> #info colindixon notes that docs will need attention from now until the release (with no offense meant to the docs team or manny)
15:27:47 <colindixon> ok
15:27:57 <regXboi> #info docs-merge job doesn't actually upload site information that regXboi can see - wasn't that the plan?
15:28:05 <manny_> sorry, meant thanks, colin
15:28:27 <colindixon> manny_: also thank phrobb, he’s doing a lot for us here :-)
15:28:37 <colindixon> regXboi: we still need a plan for how to publish the docs
15:28:40 <manny_> goes without saying ;-)
15:28:41 <colindixon> not clear what it is
15:29:11 <regXboi> #action we actually NEED a plan for how to publish the docs
15:29:22 <colindixon> #undo
15:29:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2593090>
15:29:23 <colindixon> #action manny_, regXboi, edwarnicke, phrobb, and mlemay_away to work on a plan to publish docs either as a site deploy or manually copying pdfs and html docs to the website
15:29:32 <regXboi> colindixon: +1
15:29:43 <phrobb> colindixon:  +1
15:29:43 <colindixon> paulq is still awol
15:30:06 * colindixon notes the biggest risk with the release now are the custom downloader and publishing docs
15:30:21 <regXboi> edwarnicke: can you dig up paulq?
15:30:27 <colindixon> PriyankaChopra: you there?
15:30:32 <PriyankaChopra> Yes
15:30:37 <colindixon> #topic plugin2oc
15:30:37 <edwarnicke> regXboi: No, but I can dig up repenno
15:30:40 <colindixon> shoot
15:30:50 <PriyankaChopra> #topic plugin2oc
15:30:57 <repenno> I’m representing SFC
15:31:01 <PriyankaChopra> #link https://wiki.opendaylight.org/view/Southbound_Plugin_to_the_OpenContrail_Platform:Helium_Release_Review
15:31:11 <colindixon> repenno: ok, we’ll do that next thanks for letting me know
15:31:13 <PriyankaChopra> #link https://wiki.opendaylight.org/view/Southbound_Plugin_to_the_OpenContrail_Platform:Helium_Release_Notes
15:31:22 <colindixon> PriyankaChopra: using meetbot commands like a pro
15:31:50 <colindixon> we have an L3 ODL neutron driver?
15:32:08 <regXboi> not that I know of
15:32:16 <PriyankaChopra> Yes..
15:32:38 * regXboi pads off to find mestery to get to the bottom of this
15:33:01 <colindixon> #action PriyankaChopra to migrate plugin2oc docs to asciidoc in the docs.git (or at least put in hyperlinks to the right wiki pages)
15:33:22 <PriyankaChopra> sure.. will do that..
15:33:24 <regXboi> #info plugin2oc-merge uses parameterized build with master set - ok for now, but will need to be revisited when we cut stable/helium branch
15:33:56 <colindixon> ok, other than being confused about us having an L3 driver and the docs being in asciidoc, I’m happy
15:34:01 <PriyankaChopra> okay..
15:34:25 <tbachman> have we been asking projects about stable/helium?
15:34:27 <colindixon> PriyankaChopra: I thought ODL relied on the OpenStack neutron L3 driver
15:34:37 <colindixon> tbachman: we have not, but should have been
15:34:43 <gzhao> tbachman: not yet
15:34:46 <tbachman> k
15:35:27 <regXboi> #action colindixon and regXboi to powwow with mestery about ODL neutron L3 driver
15:35:30 <colindixon> so, yeah, PriyankaChopra you’re aware that there will be a few stability releases of helium for which you’ll have to do tests and make sure thing still work and fix bugs if not
15:35:36 <colindixon> ?
15:35:43 <regXboi> coz I'm pretty sure that isn't in J
15:35:52 <regXboi> colindixon: you got delegated :)
15:36:29 * colindixon notes that since we haven’t asked everyone, we’re going to need to follow up on the participating stable releases anyway
15:36:39 <PriyankaChopra> Sure... I can do that.. If something specific needs to be tested please let me knoe
15:36:43 * regXboi +1's that comment
15:36:45 <colindixon> also, we can’t require it I don’t think
15:37:02 <regXboi> colindixon: unfortunately, no... but we WILL for lithium
15:37:07 <colindixon> #info colindixon notes PriyankaChopra says plugin2oc will be able to participate in stable releases
15:37:44 <regXboi> ok, I'm good
15:37:44 <phrobb> At least two versions of stable release have been in the Helium Release plan from the beginning so it should not be a surprise
15:37:53 <colindixon> #action gzhao to connect with projects to make sure they know stable releases are coming and what will be expected of them (probably do this after the He release)
15:37:55 <colindixon> ok
15:37:59 <colindixon> anything else on plugin2oc?
15:38:04 <phrobb> not from me
15:38:09 <colindixon> otherwise I’m putting repenno and SFC on the spot
15:38:10 <regXboi> next!
15:38:12 <colindixon> #topic SFC
15:38:15 <colindixon> repenno: you’re up
15:38:25 <PriyankaChopra> No I am done..
15:38:53 <gzhao> PriyankaChopra: thanks
15:38:55 <colindixon> repenno:
15:38:56 <colindixon> ?
15:38:58 <repenno> Yes
15:39:04 <repenno> https://wiki.opendaylight.org/view/Service_Function_Chaining:Helium_Release_Review
15:39:11 <colindixon> #link
15:39:15 <colindixon> #undo
15:39:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2524950>
15:39:17 <colindixon> #link https://wiki.opendaylight.org/view/Service_Function_Chaining:Helium_Release_Review
15:39:42 <regXboi> #info sfc-merge uses parameterized build with master set - ok for now, but will need to be revisited when we cut stable/helium branch
15:39:52 <colindixon> repenno: do you have release notes?
15:40:04 <repenno> No
15:40:17 <repenno> Any template or anything relevant I should say?
15:40:19 <regXboi> colindixon: need the standard #action for asciidocs
15:40:39 <colindixon> #action repenno to add a release notes page for SFC something like this: https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes
15:40:56 <gzhao> repenno: when will user guide and dev guide be ready?
15:40:57 <repenno> okay, will do
15:41:06 <colindixon> #action repenno to migrate docs to asciidoc in docs.git (or at least put hyperlinks pointing to any wiki page documentation that is there)
15:41:10 <repenno> how do I get SFC into Sonar?
15:41:25 <repenno> “People keep me asking about Sonar and I keep asking how to get SFC into Sonar....and nobody can tell me how to get SFC into Sonar. Vicious cycle “
15:41:52 <colindixon> do we have good docs on getting projects into sonar?
15:41:54 <phrobb> colindixon:  I'm not sure this is a "migrate" docs as I'm not seeing any docs (wiki or otherwise) to migrate.
15:41:55 <colindixon> I haven’t don it yet
15:42:00 <colindixon> phrobb: noted
15:42:33 <colindixon> #info phrobb notes that there appears to be no docs except a single git clone command
15:42:54 <colindixon> repenno: Madhu_offline and dave_tucker gave a TWS bit on getting things into sonar
15:43:05 <colindixon> you might try looking for it here: https://wiki.opendaylight.org/view/Tech_Work_Stream:Main
15:43:12 <tbachman> repenno: there’s a TWS on it
15:43:13 <tbachman> yeah
15:43:14 <tbachman> lol
15:43:17 <tbachman> colindixon: beats me to it ;)
15:43:47 <colindixon> #info repenno asks about any information about getting sonar working, colindixon doesn’t know that we have it but there was a TWS from Madhu_offline and dave_tucker at some point
15:43:47 <repenno> Which meeting?
15:44:09 <colindixon> #info it was the august 11th TWS call
15:44:22 <colindixon> there is a recording and minutes
15:44:22 * edwarnicke notes many folks have been complaiing there is no documentation about how to get stuff into sonar
15:44:23 <colindixon> that might help
15:44:27 <tbachman> colindixon: thx for the reference!
15:44:46 * colindixon notes he turns into a pumpkin in 10 minutes
15:45:01 * edwarnicke is afeared
15:45:06 * regXboi also
15:45:19 * regXboi ripping through rest of linear walk if he can
15:45:24 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/tws/opendaylight-meeting-tws.2014-08-11-17.00.html the meeting minutes from when Madhu_offline and dave_tucker presented stuff on sonar
15:45:26 * tbachman wonders what this magic is that turns ODL folks into pumpkins at seemingly deliberately-timed moments
15:45:32 <repenno> just skimmed the meeting notes. Is there something on the recording that tells me how to actually get into Sonar as opposed to telling me what Sonar is?
15:45:39 <colindixon> #link https://meetings.webex.com/collabs/url/DoaLWeoQ9KV-38qIuh042PUxbmlCDAJMFlXkP6_aOl400000 webex recording of same place
15:45:41 <gzhao> I think we need another round of review for SFC
15:45:59 <regXboi> gzhao: +1
15:46:01 <colindixon> repenno: I think it’s in the webex, but that’s the best I’ve got we need to write that up
15:46:23 <tbachman> repenno: yeah — also, have a look at the OVSDB coverage jenkins
15:46:26 * tbachman goes to get that link
15:46:27 <colindixon> gzhao, regXboi: why?
15:47:09 <gzhao> colindixon: pretty empty for me
15:47:12 <regXboi> colindixon: the sonar issue has me worried
15:47:19 <tbachman> #link https://jenkins.opendaylight.org/ovsdb/job/ovsdb-code-coverage/configure <== OVSDB teams code coverage jenkins job, which does SONAR reporting
15:47:36 <tbachman> repenno: ^^^
15:47:36 <colindixon> regXboi: I think many  projects don’t have sonar set up
15:47:48 * tbachman tiptoes quietly away
15:48:11 <regXboi> colindixon: do what you think is best - I need to finish my linear walk
15:48:13 <repenno> okay, I will give it a try
15:48:24 <colindixon> I think SFC did a fine job except that they need *some* docs and release notes, but we’re not going to stop them for it
15:48:31 <colindixon> and I don’t think we need to require them to be in sonar
15:48:43 <colindixon> in fact, I think docs are more important than sonar
15:48:55 <colindixon> phrobb, gzhao, regXboi: feel free to overrule me
15:49:05 <gzhao> colindixon: can use tomorrow's 7:30am time
15:49:14 <phrobb> colindixon:  +1, but everyone in sonar is a good thing to drive for next release.  I think the majority of projects are not yet in sonar
15:49:51 <edwarnicke> phrobb: controller has been trying to get in for months and hitting various issues with developer infra...
15:49:53 <colindixon> so, other than docs and release notes, which many other projects still need to do, we’re fine
15:50:40 <colindixon> #info colindixon notes that gzhao and regXboi would like to re-review SFC, but colindixon feels as though the issues they have are the same as other projects, e.g., get docs together and get release notes written
15:50:48 <colindixon> and they already have actions on those two
15:50:54 <colindixon> I’d like to try to do AAA
15:51:03 <liemmn> #info liemmn for AAA
15:51:06 <colindixon> #topic AAA
15:51:09 <colindixon> liemmn: go for it
15:51:10 <phrobb> edwarnicke:  I know, I talked to Andy about it yesterday… he thinks your last reported issue was resolved a bit ago but I'm assuming you've been to busy to see if you can make further progress
15:51:35 <edwarnicke> phrobb: In fairness, Andy has been great at resolving the reports...
15:51:44 <liemmn> hold on... sorry.. lost my browser
15:51:45 <phrobb> thanks edwarnicke
15:51:50 <edwarnicke> phrobb: I just only get a chance to check in on it every couple of days
15:52:06 <colindixon> liemmn: sure
15:52:22 <phrobb> edwarnicke:  i figured… we'll address it with focus once Helium is out (along with the long list of other infra todos)
15:52:51 <gzhao> colindixon: the main reason I want to review SFC is to make sure all actions are taken care of, unlike other projects, SFC is always not responding to status related report, for example, https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1408765403
15:52:55 <liemmn> https://wiki.opendaylight.org/view/AAA:Helium_Release_Review
15:53:07 <gzhao> colindixon: they haven't reported required document type for long time
15:53:12 <colindixon> #undo
15:53:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x259ca10>
15:53:39 <phrobb> gzhao:  that's a good reason for require a follow up
15:54:07 <gzhao> phrobb: that is why want a re-review on SFC
15:54:10 <colindixon> #action gzhao and phrobb to schedule a second release review with repenno for SFC tomorrow (hopefully during the normal release sync time), largely because they have been unresponsive to request for information
15:54:12 <colindixon> done
15:54:12 <regXboi> #info aaa-merge uses parameterized build with master set - ok for now, but will need to be revisited when we cut stable/helium branch
15:54:16 <colindixon> #undo
15:54:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2484910>
15:54:19 <colindixon> #topic AAA
15:54:34 <colindixon> #info regXboi notes aaa-merge uses parameterized build with master set - ok for now, but will need to be revisited when we cut stable/helium branch
15:54:39 <colindixon> liemmn: you there?
15:54:42 <liemmn> yes
15:54:48 <colindixon> nm
15:54:49 <colindixon> found it
15:54:57 <liemmn> https://wiki.opendaylight.org/view/AAA:Helium_Release_Review
15:54:59 <colindixon> #link https://wiki.opendaylight.org/view/AAA:Helium_Release_Review
15:55:03 <liemmn> thx
15:55:04 <colindixon> do we have release notes?
15:55:07 * colindixon reads
15:55:22 <colindixon> liemmn: do we have a link for the dev guide?
15:55:27 <colindixon> to a gerrit?
15:55:36 <liemmn> yes, currently under review... holdon
15:56:00 <liemmn> https://git.opendaylight.org/gerrit/#/c/11515/
15:56:03 <colindixon> #action liemmn to add a link to the gerrit for the asciidoc dev guide to the AAA release review page
15:56:23 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/11515/ is the link
15:56:37 <colindixon> #info colindixon notes that the patch has been -1ed awaiting revision
15:56:48 <colindixon> liemmn: do we have any release notes
15:56:57 <colindixon> something like this: https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes
15:57:26 <liemmn> thx, will add that in!
15:57:39 <colindixon> #action liemmn will add a release notes page for AAA something like https://wiki.opendaylight.org/view/Table_Type_Patterns:Helium_Release_Notes
15:57:46 <colindixon> liemmn: about the HTTPS
15:58:01 <colindixon> does it not support HTTPS or just we need to enable it in tomcat (or whatever)
15:58:19 <liemmn> yes...  It is just a matter of enabling https on the jetty connector, which we can document...
15:58:39 <liemmn> security token is kinda out of the door over plain http :)
15:59:02 <colindixon> ok good to know
15:59:26 <regXboi> ok... I'm out... talk to folks later
15:59:28 <colindixon> #info colindixon would love to see how the schedule slipped listed, but it’s fine
15:59:49 <phrobb> thanks regXboi
16:00:00 <colindixon> otherwise this looks OK to me
16:00:09 <regXboi> phrobb: is tykeal around on IRC?  I have a question for him
16:00:25 <tykeal> regXboi: what's up?
16:00:40 <phrobb> regXboi:  there's your answer ;-)
16:01:51 <colindixon> ok
16:01:54 <phrobb> colindixon:  are we moving on?… are we finished until 9:30am?
16:01:54 <colindixon> I think AAA is done
16:02:03 <gzhao> Madhu: hello
16:02:09 <Madhu> gzhao: hi.
16:02:17 <gzhao> Madhu: are you abel to do ovsdb now?
16:02:18 <colindixon> thanks liemmn
16:02:19 <liemmn> ok, thanks... I will get the release notes done asap
16:02:21 <phrobb> ah great!  hi Madhu
16:02:26 <gzhao> liemmn: thanks
16:02:26 <colindixon> I think he’s not ready until 9:30
16:02:33 <colindixon> want to leave this open until then?
16:02:35 <phrobb> thank you liemmn
16:02:49 <colindixon> #topic OVSDB (at 9:30 PST in ~30 minutes)
16:02:53 <phrobb> no need if madhu is here and can go now for OVSDB
16:03:03 <Madhu> phrobb: nope. 9.30am Guys :)
16:03:09 <Madhu> i am getting the wiki ready
16:03:10 <colindixon> phrobb: he doesn’t have the stuff on the wiki yet
16:03:11 <gzhao> colindixon: yeah, forgot he mentioned he has conflict at 9:00
16:03:12 <phrobb> ah, Ok, sorry, did n't understand
16:03:19 <colindixon> so, I’ll hold this open
16:03:22 <phrobb> 9:30 then
16:03:28 <colindixon> unless we want to shut it down and reopen
16:03:28 <phrobb> yup'
16:04:03 <gzhao> we can discuss blocking bugs
16:04:15 <gzhao> it seems we got several new ones
16:05:58 <colindixon> #topic blocking issues
16:06:29 <tbachman> colindixon: gzhao: folks may not be online?
16:06:41 <tbachman> we probably should have set something up in advance
16:06:43 <colindixon> likely, but we can still go through a few
16:06:51 <tbachman> that, or we rabble-rouse the crew
16:06:53 <tbachman> k
16:07:27 <gzhao> do we have snbi people look at 2085?
16:07:55 <edwarnicke> gzhao: I think I fixed 2085 with them this morning
16:08:05 <edwarnicke> gzhao: The issue wasn't in their code but in their Jenkins setup
16:08:05 <gzhao> wow amazing
16:08:20 <gzhao> yeah, cool,
16:08:27 <mlemay_away> @all: I am seeing actions for me.. Will catch up on these in 1h
16:08:55 <tbachman> gzhao: I’ve gone ahead and marked 1984, 1985, 2019, and 2051 as verified
16:09:16 <gzhao> in order to release on 9/29, we need to respin sometime today, that will give LuisGomez etc one day to do regression.
16:09:17 <abhijitkumbhare> where is the list of the blocking bugs?
16:09:27 <gzhao> tbachman: thanks, I will do the update
16:09:32 <tbachman> np!
16:09:46 <gzhao> abhijitkumbhare: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163
16:10:04 <gzhao> abhijitkumbhare: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1622731782
16:10:37 <edwarnicke> gzhao: We had significant issues with folks unable to test show stopper bugs for the last couple of days due to 2085... you literally couldn't build integration against a clean .m2
16:10:51 <abhijitkumbhare> thanks gzhao
16:10:54 <edwarnicke> gzhao: So we lost about 2 days of bug fixing and testing show stopper bugs
16:11:36 <LuisGomez> edwarnicke: are we still good to respin something today?
16:11:43 <gzhao> edwarnicke: do they have a build can test now?
16:11:46 <edwarnicke> LuisGomez: I think we should try :)
16:12:00 <edwarnicke> gzhao: I think I fixed the 2085 issue this morning with the help of the snbi committers
16:12:10 <edwarnicke> So folks should be unblocked
16:12:18 <edwarnicke> But this morning for me is late at night for some in the community
16:12:26 <LuisGomez> yes, it looks like 2085 is fixed now
16:13:30 <gzhao> cool, the last build that push to nexus was: 98
16:14:17 <gzhao> it may not pick up edwarnicke 's fix for 2085
16:14:23 <tbachman> gzhao: I don’t think 2075 will be a blocker for groupbasedpolicy
16:14:28 <tbachman> it’s extremely hard to reproduce
16:15:14 <edwarnicke> tbachman: Do you have extra logs to help debug if it does manifest?
16:15:23 <tbachman> Also - not sure what to do about 2049. I think they catch the exception now, and print a log message, so it’s “fixed” in that sense, but am not sure whether to resolve it or leave it open, as it seems like there still needs to be something done to address the root cause
16:15:33 <tbachman> edwarnicke: they’re instrumented :)
16:15:40 * tbachman is spending his time today running tests :)
16:17:02 <tbachman> gzhao: I think it’s safe to say that 2049 doesn’t have to be considered blocking at this point.
16:17:20 <tbachman> but I think we might want to leave it open
16:18:02 * tbachman is going to disappear for a bit
16:30:04 <colindixon> gzhao: I’ve been updating this: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit?pli=1#gid=1622731782
16:32:04 <phrobb> Is Madhu ready?
16:32:20 <Madhu> phrobb: res.
16:32:25 <Madhu> whenever u guys
16:32:27 <Madhu> is this IRC only ?
16:32:28 <edwarnicke> colindixon: I was unaware of that spreadsheet and havre been tracking and driving to resolution: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163
16:32:33 <phrobb> yes irc only
16:32:42 <Madhu> okay. whenever u r ready...
16:32:49 <Madhu> and the topic still says blocking issues ;)
16:32:52 <Madhu> is that the intention ?
16:33:27 <phrobb> colindixon:  edwarnicke gzhao are you ready for OVSDB Release Review?
16:33:37 <colindixon> I’m a bit distracted
16:33:38 <phrobb> dmm is here now too?
16:33:45 <gzhao> yes
16:34:01 <Madhu> phrobb: gzhao will the topic be changed ?
16:34:08 <colindixon> #topic OVSDB
16:34:14 <Madhu> thanks colindixon  :)
16:34:14 <colindixon> go ahead and #link things
16:34:14 <phrobb> thanks colindixon
16:34:20 <Madhu> #link https://wiki.opendaylight.org/view/OVSDB_Integration:Helium_Release_Review
16:34:21 <gzhao> colindixon: you types faster than me
16:34:35 <Madhu> #link https://wiki.opendaylight.org/view/OVSDB_Integration:Helium_Release_Notes
16:37:08 <colindixon> is somebody looking at this
16:37:10 * colindixon is in another meeting
16:37:35 <colindixon> #info colindixon notes that the asciidoc gerrit doesn’t build
16:37:53 <colindixon> Madhu: any remaining blocking bugs?
16:38:09 <Madhu> colindixon: nope. we had 1 in controller 2002. but we have a workaround
16:38:43 <gzhao> do we have links for how to and dev guide?
16:39:47 <colindixon> gzhao: dev guide is here: https://git.opendaylight.org/gerrit/#/c/11528/
16:40:10 <colindixon> Madhu: are you planning to provide any other docs than that in the main docs place?
16:40:23 <gzhao> gotcha, it is all in the adoc
16:40:25 <Madhu> yes. flaviof is working with Sujatha on that.
16:40:40 <Madhu> Installation, User and Dev guides
16:40:48 <colindixon> #info flaviof is working with the docs team on more docs, including install and user guides
16:41:14 <Madhu> colindixon: i think this gerrit also contains install guide
16:41:16 <colindixon> #Info colindixon notes that ovsdb jenkins merge builds from origin/master
16:41:28 <colindixon> Madhu: https://git.opendaylight.org/gerrit/#/c/11528/
16:41:32 <colindixon> I see dev and that’s it
16:41:45 <Madhu> colindixon: right. but it is supposed to have also installation guide
16:41:51 <Madhu> I will check with flaviof and sujatha
16:42:01 <Madhu> and is there a requirement to move to stable/helium by today ?
16:42:06 <Madhu> i thought it was on 09/29 ?
16:42:28 <colindixon> Madhu: it’s on 9/29, and we’ll probably waive it
16:42:42 <edwarnicke> colindixon: delay... delay... not waive ;)
16:42:44 <colindixon> we need to figure out how we want people to cut to stable/helium
16:42:48 <colindixon> edwarnicke: noted
16:42:57 <Madhu> we will cut it certainly today/tomorrow
16:43:08 <Madhu> #info OVSDB project will switch to stable/helium shortly ;)
16:43:35 <Madhu> colindixon: gzhao phrobb anything else guys ?
16:43:43 <colindixon> no, I think I’m good
16:43:45 <gzhao> I am fine now
16:43:50 <colindixon> you know you need to participate in stable releases
16:43:52 <phrobb> Not from me Madhu, this looks good
16:43:53 <colindixon> but that’s fine
16:43:54 <Madhu> gzhao: we are on the green :)
16:43:57 <colindixon> thanks!
16:44:01 <colindixon> #endmeeting