15:43:48 <edwarnicke> #startmeeting Helium Weekly
15:43:48 <odl_meetbot> Meeting started Wed Aug  6 15:43:48 2014 UTC.  The chair is edwarnicke. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:43:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:43:48 <odl_meetbot> The meeting name has been set to 'helium_weekly'
15:43:59 <edwarnicke> Please #info in
15:44:01 <edwarnicke> #info edwarnicke
15:44:02 <goldavberg> #info goldavberg for lispflowmapping
15:44:09 <dkehnx> #info dkehnx - opflex
15:44:11 <liemmn> #info liemmn for aaa
15:44:12 <oflibMichal> #info oflibMichal for openflowjava
15:44:13 <regXboi> #info regXboi for <nothing> :)
15:44:17 <paulz> #info paulz for docs
15:44:17 <LuisGomez> #info Luis for integration
15:44:21 <edwarnicke> #chair regXboi LuisGomez tbachman
15:44:21 <odl_meetbot> Current chairs: LuisGomez edwarnicke regXboi tbachman
15:44:24 <rafat> #info Rafat for ODl-SDNi App
15:44:26 <tbachman> :)
15:44:28 <tbachman> guys
15:44:33 <tbachman> have to cut out soon
15:44:35 <tbachman> :(
15:44:35 <brockners> #info brockners for SNBI
15:44:41 <tbachman> will get someone else for rep
15:44:41 <LuisGomez> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Project_Expectations
15:44:56 <LuisGomez> #info link for project expectations
15:45:01 <edwarnicke> LuisGomez You seemed to be driving something... if so, please set the topic :)
15:45:26 <LuisGomez> #topic Q&A on M4 deliverables
15:45:28 <priyanka_> #info  priyanka for southplugin for opencontrail
15:46:02 <LuisGomez> #info so far we are asking projects to fill karaf features
15:46:26 <abhijitkumbhare> #info abhijitkumbhare for Openflow plugin
15:46:44 <LuisGomez> #info there will be also components to cover those parts cannot be defined in Karaf
15:47:05 <gzhao__> #info George Zhao for RM
15:47:29 <edwarnicke> gzhao__: :) Thank you so much for the Release Management work :)
15:47:29 <ChristineH> #info ChristineH for snmp4sdn
15:48:14 <LuisGomez> so is there any other questions on deliverable?
15:48:56 <LuisGomez> #info Madhu will explain more in detail thr java test documentation and report we expect projects to fulfill
15:49:33 <LuisGomez> #info basically we are asking for some Junit test coverage
15:49:46 <liemmn> Is there any coverage % expectation?
15:49:59 <edwarnicke> LuisGomez: Until Sonar is fixed (or someone can explain how to work with the installed version) that is mechanically impossible for many projects
15:50:03 <LuisGomez> #info there is no % expectation yet
15:50:27 <LuisGomez> #info there is wiki on Sonar coverage:
15:50:44 <goldavberg> We can't seem to get unit and integration test coverage in sonar...
15:50:53 <LuisGomez> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Code_Coverage_using_Jacoco
15:51:05 <edwarnicke> goldavberg: We have the same issues in controller and yangtools and bgpcep have also reported similar
15:51:23 <LuisGomez> #info unit test should work with this instruction
15:51:29 <ttkacik> @edwarnicke bgpcep should be fixed
15:51:30 <Madhu> LuisGomez: hi. am in.
15:51:48 <edwarnicke> ttkacik: So bgppcep is reporting in sonar?
15:51:57 <LuisGomez> #info there are issues reporting PAX-EXAM test to Sonar but Madhu has workaround for that
15:52:20 <edwarnicke> Madhu: Do you have a pointer to your workaround?
15:52:27 <goldavberg> +1
15:52:30 <LuisGomez> Madhu: I am talking about java test report already
15:52:37 <Madhu> LuisGomez: okay
15:52:43 <Madhu> after the sonar upgrade
15:52:52 <Madhu> we have the fix for both UT, IT and Pax-Exam
15:52:58 <edwarnicke> Does anyone know if there is a way to break down reporting from a project in sonar into logical units?
15:53:11 <edwarnicke> In controller it would be very helpful to be able to report by subsystem...
15:53:12 <LuisGomez> Madhu: excellent!
15:53:14 <Madhu> edwarnicke: define logical unit
15:53:26 <edwarnicke> adsal, mdsal, configsubsystem...
15:53:39 <edwarnicke> Logical unit being a collection of projects
15:53:48 <edwarnicke> (maven projects)
15:53:53 <Madhu> edwarnicke: its the way you organize the tests.
15:54:00 <edwarnicke> Madhu: Can you say more?
15:54:09 <Madhu> edwarnicke: looking for examples to talk :)
15:54:12 <Madhu> gimme a second
15:54:18 <edwarnicke> Madhu: Thank you :)
15:54:22 <Madhu> #info ovsdb sonar reporting : https://sonar.opendaylight.org/dashboard/index/14975
15:54:37 <LuisGomez> #info madhu says Sonar is now ready to handle UT and IT (PAX-EXAM) tests
15:54:39 <Madhu> in the above link it reports UT, IT and Pax-Exam results
15:54:41 <ttkacik> edwarnicke: yes, it is
15:54:44 <alagalah> Folks, filling out the template now for GBP
15:54:52 <ttkacik> yang tools patches were merged in
15:55:05 <edwarnicke> alagalah: Many thanks :)
15:55:11 <Madhu> #info https://sonar.opendaylight.org/drilldown/measures/14975?metric=tests shows all the tests being run
15:55:13 <alagalah> edwarnicke: Bloody traffic
15:55:46 <Madhu> #link https://sonar.opendaylight.org/drilldown/measures/14975?metric=tests is an example from ovsdb project which shows all the tests including UT, IT and Pax
15:56:04 <Madhu> to answer edwarnicke the logical subsystem can be grouped using pax-exam tests
15:56:34 <Madhu> #link https://sonar.opendaylight.org/drilldown/measures/14975?metric=tests&rids[]=15977 is an example of pax-exam tests for 3 subsystems in ovsdb logically grouped
15:56:45 <Madhu> neutron, plugin and library
15:56:51 <edwarnicke> OK... and what for unit tests
15:56:52 <mlemay> Sorry all.. Is meeting over?
15:57:03 <Madhu> under these groupings, the tests (cases) can be written to cover them all up
15:57:06 <edwarnicke> Madhu: How do I group unit tests?
15:57:12 <Madhu> edwarnicke: unit tests are unit tests :)
15:57:21 <Madhu> the definition of unit test is for a given unit.
15:57:31 <Madhu> that can go as granular as it wants to.
15:57:51 <edwarnicke> Madhu: How do I define that?
15:58:00 <Madhu> edwarnicke: define what ?
15:58:02 * edwarnicke is trying to figure out how to do it so it reports pretty :)
15:58:27 <Madhu> edwarnicke: unit tests by definition is granular per class/method.
15:58:38 <Madhu> so am not sure what you mean by grouping
15:58:42 <edwarnicke> OK
15:58:46 <Madhu> is your question purely from a reporting stand point ?
15:59:04 <edwarnicke> I want to take a bunch of maven projects, and put some in them into a 'group' in sonar
15:59:08 <edwarnicke> So I can see a group of them there
15:59:11 <Madhu> edwarnicke: in that case, Junit provides a concept called listeners
15:59:14 <edwarnicke> Reported as a unit
15:59:24 <edwarnicke> Madhu: Purely from a reporting standard
15:59:26 <Madhu> edwarnicke: yes. you can define your own groups in the listeners
15:59:33 <edwarnicke> How?
15:59:37 <Madhu> and the listeners can group it the way  you want
15:59:46 <Madhu> edwarnicke: i will give a tutorial on that offline :)
15:59:53 <edwarnicke> Madhu: Thank you :)
16:00:09 <edwarnicke> LuisGomez: Where were we before we diverged :)
16:00:19 <LuisGomez> Madhu: does a PAX-EXAM IT test covers more or less a karaf feature? would you recommend that?
16:00:47 <Madhu> #link https://git.opendaylight.org/gerrit/#/c/9482/ fix to enable pax-exam results in sonar
16:00:55 <Madhu> please use that fix in other projects and start capturing results
16:01:02 <LuisGomez> Ed: we are discussing java test deliverables
16:01:40 <Madhu> LuisGomez: yes. pax-exam works very well with Karaf
16:01:44 <Madhu> and highly recommend it
16:01:55 <edwarnicke> Madhu: I haven't tried it... but it looks *very* sane :)
16:01:58 <Madhu> #info pax-exam and karaf features go really well together
16:02:18 <Madhu> #info pax-exam without karaf is a disaster :( and the following link will explain why
16:02:49 <LuisGomez> #info thats why we set PAX-EXAM IT in release check list
16:02:56 <edwarnicke> Madhu: second the pax-exam without karaf being a disaster :)
16:04:00 <Madhu> #link https://git.opendaylight.org/gerrit/gitweb?p=ovsdb.git;a=blob;f=integrationtest/src/test/java/org/opendaylight/ovsdb/integrationtest/ConfigurationBundles.java;h=f43dea7f331640a2f45f1505fe9efb2b1c2a5a5f;hb=master example of pax-exam without karaf definition
16:04:22 <Madhu> #info its literally a train wreck and it is very difficult to debug even a single missing dependency for the entire IT
16:04:49 <Madhu> #info Based on our "not-so-happy-experience" highly highly recommend Pax-exam with Karaf.
16:05:08 <Madhu> #info but ... highly recommend doing pax-exam testing. especially in a OSGi environment like ours
16:05:25 <Madhu> #info mere FailSafe UT & SureFire IT will not help
16:05:30 <Madhu> #undo
16:05:32 <goldavberg> #Madhu is there a wiki for that?
16:05:50 <Madhu> goldavberg: wiki for pax-exam and karaf ?
16:05:58 <edwarnicke> Madhu: Are you going to provide instruction on the Docker based stuff you guys are doing at TWS this week?
16:06:00 <Madhu> mlemay: was owning that wiki i believe :)
16:06:10 <Madhu> edwarnicke: is it related to this discussion ?
16:06:25 <gzhao__> #info 6 projects don't participate PAX-EXAM based on M4 status out of 20 reported.
16:06:28 <goldavberg> #Madhu yes
16:07:05 <Madhu> goldavberg: mlemay will add the wiki for pax-exam with karaf i believe. if he cannot, i certainly will
16:07:38 <edwarnicke> Madhu: Will you be covering the dockerish tests on Mondays TWS?
16:07:43 <goldavberg> #Madhu thx
16:07:48 <LuisGomez> there something already written here: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Integration_Tests
16:08:08 <Madhu> LuisGomez: thanks
16:08:19 <LuisGomez> I added a Karaf paragraph i copied from MAthieu
16:08:23 <Madhu> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Integration_Tests wiki on using pax-exam
16:08:24 <LuisGomez> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Integration_Tests
16:09:30 <edwarnicke> LuisGomez: Could that be cleaned up to at least have the karaf part show up in the Table of Contents?
16:09:32 <LuisGomez> gzhao__: some projects might not need PAX-EXAM
16:10:17 <edwarnicke> gzhao__: We do have some projects with significant non-osgi C code
16:10:30 <edwarnicke> gzhao__: So maybe its not YES/NO but rather YES/NO/NA
16:10:45 <LuisGomez> edwanicke: clean up possible but I would like Mathieu to review the Karaf section too
16:10:53 <Madhu> gzhao__: the tests are highly recommended for every project to be a matured project
16:10:54 <edwarnicke> LuisGomez: Yep :)
16:11:10 <edwarnicke> LuisGomez: Can we put in the topic queue that we need someone to look after the autoreleases
16:11:12 <Madhu> those who don't have a reasonable coverage (which has to be defined) will not be considered matured enough ... i hope.
16:11:17 <edwarnicke> So we don't have issues with that at the very end
16:11:34 <liemmn> +1 Madhu
16:11:45 <edwarnicke> Madhu: The Simultaneous Release Plan specifically *forbids* that kind of last minute change in expectations
16:11:55 <edwarnicke> Because its not OK to change requirements at the last minute
16:12:01 <Madhu> edwarnicke: what requirements ?
16:12:04 <edwarnicke> And we couldn't work out reasonable requirements at time of plan
16:12:10 <edwarnicke> And we *still* don't have them
16:12:15 <Madhu> edwarnicke: we are talking only about project maturity
16:12:21 <edwarnicke> Oh
16:12:24 <Madhu> not about simultaneous release :)
16:12:28 <edwarnicke> You mean the discussion about promotion to mature?
16:12:31 <Madhu> edwarnicke: how did u get that impression ?
16:12:33 <edwarnicke> Totally fair discussion :)
16:12:47 <edwarnicke> Madhu: I did... but I may have been reading to fast :)
16:12:47 <Madhu> edwarnicke: glad u c it as fair :)
16:13:00 <Madhu> we have to encourage good behaviour
16:13:03 <edwarnicke> Fair discussion... haven't thought enough about it to have a position for or against :)
16:13:17 <Madhu> and having a solid coverage and test results must be rewarded
16:13:20 <edwarnicke> Madhu: Agree... the question is smart ways to do it :)
16:13:21 <Madhu> with a cookie ;)
16:13:28 <edwarnicke> Chocolate chip?
16:13:37 <LuisGomez> edwarnicke: sorry, what is the autorelease topic?
16:14:10 <edwarnicke> LuisGomez: We have autorelease that are trying to do the weekly builds
16:14:17 <edwarnicke> and that we hope to use for the Helium Release
16:14:28 <edwarnicke> Currently, they include only the Hydrogen Projects
16:14:37 <LuisGomez> right
16:14:48 <edwarnicke> Additionally.. they will fail for reasons like version skew and other badness that is not obvious to the projects in isolation
16:14:53 <edwarnicke> So someone needs to:
16:15:03 <edwarnicke> 1)  Start bringing the new Helium projects in
16:15:18 <edwarnicke> 2)  Push fixes to them for the hygiene breakage
16:15:35 <edwarnicke> 3)  Make sure that when the dry runs on Thursdays break, that gets fixed by the projects on Friday
16:15:39 <edwarnicke> Does that make sense?
16:15:43 <edwarnicke> (its work... )
16:16:01 <LuisGomez> who is in charge of all this?
16:16:06 <edwarnicke> Right now... no one
16:16:09 <edwarnicke> Which is why the ask
16:16:17 <edwarnicke> We need someone to take ownership of it
16:16:21 <LuisGomez> interesting  :)
16:16:25 <gzhao__> I will see if I can work on it
16:16:34 <edwarnicke> GiovanniMeo has been very helpful... but he doesn't have the cycles for it
16:16:45 <edwarnicke> gzhao__: How is your maven-fu ? :)
16:17:02 <gzhao__> who is doing this for Hydrogen
16:17:22 <Madhu> LuisGomez: did i cover everything u wanted me to cover ?
16:17:26 <edwarnicke> gzhao__: GiovanniMeo was looking after it
16:17:28 <xsited> #info PacketCable PCMM Thomas Kee
16:17:33 <LuisGomez> Madhu: sure
16:17:35 <edwarnicke> And regXboi and I were sort of helping
16:17:42 <edwarnicke> (for very liberal values of help ;) )
16:17:57 <Madhu> and i have been supporting :)
16:18:03 <Madhu> moral support. lol
16:18:06 <edwarnicke> Madhu: :)
16:18:26 <edwarnicke> Madhu: They also serve who encourage :)
16:18:46 <Madhu> i really wish I can help on Helium auto releaase
16:18:59 <edwarnicke> gzhao__: Shall we action around getting you linked up with GiovanniMeo on this?
16:19:00 <Madhu> but M5 is going to be extremely challenging for us
16:19:07 <edwarnicke> Madhu: Me too... there's only so much time in the day
16:19:41 <Madhu> #info on the Test documentation front, i will append to the existing wiki.
16:19:48 <Madhu> LuisGomez: can u #action me on that ?
16:20:32 <edwarnicke> Madhu: When will you provide it by
16:20:33 <edwarnicke> ?
16:20:35 <LuisGomez> #action Madhu to publish java test documentation recommendations
16:21:31 <Madhu> asap :)
16:21:57 <Madhu> #info the test documentation recommendations are merely javadocs on the test cases
16:21:58 <LuisGomez> #action mlemay,madhu and luis to clean up PAX-EXAM documentation in general
16:22:53 <Madhu> #info the recommendations on test documentations will include Test plan (logical grouping) organization and Test case (individual  @Test test-cases) organization and Javadocs for them
16:23:33 <Madhu> #info sonar will be the single source of truth for Code coverage, Test execution and Test Documentation.
16:23:34 <edwarnicke> LuisGomez: By when?
16:23:51 <LuisGomez> this week?
16:23:51 <edwarnicke> Madhu: Once we can get it working :)  I have high hopes for your fixes :)
16:23:52 <Madhu> edwarnicke: don't we have Milestones just to track the when part ?
16:24:13 <Madhu> edwarnicke: it is working already and ovsdb-master sonar project is a living example :)
16:24:14 <edwarnicke> Madhu: If we have to wait for M5 for the helpful wiki page we may have a problem ;)
16:24:24 <edwarnicke> Madhu: Yep... hoping to emulate it :)
16:24:35 <Madhu> edwarnicke: fair enough and we are working on it. :)
16:25:01 <Madhu> highly recommend folks to please publish their UT/IT/Pax results to Sonar.
16:25:18 <edwarnicke> Madhu: We are all pulling in the same direction :0
16:25:20 <edwarnicke> :)
16:25:51 <LuisGomez> it is almost time
16:25:59 <LuisGomez> any other question?
16:26:14 <edwarnicke> gzhao__: Did we get you actioned on autorelease?
16:27:49 <LuisGomez> gzhao__, should we put you and action on you to investigate what is needed for autorelease?
16:27:58 <HelenYChen> edwarnick: on part of gzhao_, yes, we will do it.
16:28:23 <gzhao__> Documentation is in red status,  do all the project contacts provide document contacts to Paul
16:29:17 <paulz> I have the project contacts, will be sending some new doc instructions out shortly
16:29:43 <edwarnicke> #action gzhao__ HelenYChen to pick up autorelease
16:29:44 <gzhao__> LuisGomez, ok, I will work with GiovanniMeo
16:30:19 <Madhu> btw this is on M4 deliverable discussions ? or towards M5 ?
16:30:37 <edwarnicke> gzhao__: gzhao__ I sent an email introducing you
16:30:41 <edwarnicke> And setting the context
16:30:49 <Madhu> i have a question on how the project dependencies and missing the delivery deadlines are handled.
16:30:58 <gzhao__> edwarnicke, thanks
16:31:14 <edwarnicke> gzhao__: Thank you :)
16:31:27 <edwarnicke> I can't tell you how happy it makes me that you are willing to pick this up
16:32:00 <LuisGomez> Madhu: go ahead with your question
16:33:48 <Madhu> if Project A is dependent on Project B's deliverable say in M4. and Project B missed M4 deadline
16:34:05 <Madhu> and Project A is completely blocked on that... how should we handle it ?
16:34:25 <LuisGomez> I believe if a project miss deadlines and deliveries, the community should help first and if this is not possible TSC is final responsble
16:34:28 <edwarnicke> Madhu: We work to fix it
16:34:32 <edwarnicke> Madhu: Hit me offline
16:34:33 <Madhu> its a possibility that Project A might and most certainly will slip M5 due to this...
16:34:34 <gzhao__> LuisGomez, There are 2 projects API not frozen by M4, should we get a time set when it should be frozen
16:34:40 <edwarnicke> Madhu: I think I have a workaround for you
16:34:53 <Madhu> edwarnicke: it is not about me or ovsdb or openflowplugin :)
16:35:05 <Madhu> its a generic question that everyone should understand how to address such problems
16:35:09 <edwarnicke> OK :)  Thought I have some good news there
16:35:19 <edwarnicke> Madhu: I would say the following minimally would be good practice
16:35:26 <Madhu> edwarnicke: it can be a good news ONLY if we can roll back 48 hrs
16:35:30 <edwarnicke> Project B need to communicate to Project A the situation
16:35:33 <Madhu> if u have a solution.. the entire world will be happy :)
16:35:47 <edwarnicke> And they need to work together to figure out the best thing they can
16:36:01 <LuisGomez> Madhu, Ed, do you really havea question here or you can fix this offline?
16:36:14 <Madhu> LuisGomez: the question is
16:36:30 <Madhu> if Project A is totally blocked by some other missing delivery
16:36:44 <Madhu> then should we extend the subsequent milestones for Project A alone
16:36:49 <Madhu> so that it has time to catch up ?
16:37:07 <Madhu> i like to honor the milestones to plan correctly
16:37:12 <Madhu> not do things willy nilly
16:37:40 <edwarnicke> Madhu: It depends on what you mean by honoring the Milestones
16:38:11 <edwarnicke> Madhu: If you mean "There are certain things like API freeze that the Simultaneous Release Plan puts at M4" thats doable
16:38:28 <edwarnicke> Madhu: But I don't magically know how to make things happen that haven't happened yet ;)
16:38:40 <Madhu> edwarnicke: thats exactly my question
16:38:52 <Madhu> anyways. i guess we have eaten up 10 more minutes
16:39:01 <Madhu> LuisGomez: if u want to call the meeting, am fine
16:39:04 <Madhu> lets take it to TSC
16:39:06 <Madhu> and get it resolved
16:39:16 <LuisGomez> i think project blocks should be reported to TSC who should make a decision
16:39:41 <LuisGomez> or recommendation at least
16:39:44 <edwarnicke> LuisGomez: A decision on what?
16:40:07 <LuisGomez> if a milestone needs to be moved for example
16:40:21 <edwarnicke> LuisGomez: I still haven't heard a crisp articulation of what is meant by 'Milestone should be moved' ?
16:40:59 <LuisGomez> we delayed the entire hydrogen last release
16:41:17 <edwarnicke> LuisGomez: I still haven't heard a crisp articulation of what is meant by "Milestone should be moved"
16:41:21 <edwarnicke> Could someone please provide one
16:41:23 <Madhu> LuisGomez: not just last releast.. we are doing it on stable/hydrogen as well
16:41:34 <edwarnicke> As its impossible to discuss the issue without it
16:41:44 <Madhu> edwarnicke: lets take it to TSC
16:41:47 <Madhu> to get a better voice
16:41:50 <edwarnicke> Madhu: Take what to the TSC?
16:41:55 <edwarnicke> I literally don't know what the question is
16:41:57 <Madhu> i have to run guys
16:42:00 <edwarnicke> And that's germaine
16:42:06 <Madhu> edwarnicke: u know the question... but i have to run now.
16:42:06 <Madhu> bye
16:42:12 <edwarnicke> Madhu: No I don't
16:42:19 <edwarnicke> You have not been clear about it
16:45:02 <LuisGomez> Ed, I think the question is how do we handle situation when a project gets blocked by another
16:45:12 <LuisGomez> maybe this has not happened yet
16:45:26 <LuisGomez> but I do not know the answer anyway
16:45:41 <edwarnicke> LuisGomez: OK... rereading I think I see Madhu's question
16:46:08 <abhijitkumbhare> will write on OF plugin my interpretation of Madhu’squestion
16:46:18 <edwarnicke> Madhu: Where you asking about whether subsequent milestones should be moved (ie... move M5) for a particular project alone (just trying to understand the question, not suggesting thats a good idea)
16:46:24 <abhijitkumbhare> as it is specific to OF plugin / OVSDB
16:47:12 <LuisGomez> Madhu is gone i think
16:47:46 <LuisGomez> anyway, should we close the meeting?
16:47:49 <edwarnicke> LuisGomez: Basically though... we have two kinds of things at Milestones: Requirements from the TSC (like API freeze) and a projects own plans ( deliverables )
16:48:06 <edwarnicke> Holding the line on TSC requirements is a TSC thing
16:48:15 <edwarnicke> But I don't know what it can do about planned release deliverables
16:49:10 <gzhao__> LuisGomez, I still need Helium M4 status from 5 projects.
16:49:29 <LuisGomez> Ed, my understanding is TSC is final responsible for simoultaneous release
16:50:08 <LuisGomez> so in the end, they can recommend the best way out in a block situation if it does not resolve by itself
16:50:14 <edwarnicke> LuisGomez: Setting mechanical requirements, yes
16:50:46 <edwarnicke> But there's literally nothing it can do other than distract on delivering actual code
16:50:55 <edwarnicke> It can say 'Don't change APIs going forward'
16:50:57 <edwarnicke> And that's good
16:51:05 <edwarnicke> But it can't magically make code appear
16:51:17 <edwarnicke> It can distract the folks who are writing code from writing code with politics
16:51:21 <edwarnicke> But it can't make code appear
16:51:34 <LuisGomez> thats true
16:51:54 <edwarnicke> So mechanical items like the M4 API Freez
16:51:58 <edwarnicke> That it can do something with
16:54:54 <LuisGomez> ok, i believe Madhu will rise his question next TSC call so we can have more discussion there
16:55:01 <LuisGomez> anything else?
16:55:37 <LuisGomez> gzhao__, have you reached the projects with no status?
16:55:56 <gzhao__> I will follow up
16:56:28 <LuisGomez> for those they have not frozen API please ask them when
16:57:06 <gzhao__> LuisGomez, will put that on my action list
16:57:32 <LuisGomez> #action gzhao__ to pursue projects with no status
16:57:58 <LuisGomez> ok, can we close the meeting now?
16:59:12 <LuisGomez> thanks everybody, we meet again next week
16:59:21 <ChristineH> thanks, Luis
16:59:21 <LuisGomez> #endmeeting