14:31:48 <edwarnicke_> #startmeeting Karaf Happy Hour
14:31:48 <odl_meetbot> Meeting started Sat Aug 30 14:31:48 2014 UTC.  The chair is edwarnicke_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:48 <odl_meetbot> The meeting name has been set to 'karaf_happy_hour'
14:31:53 <edwarnicke_> #topic Roll Call
14:32:08 <edwarnicke_> #info edwarnicke_
14:32:13 <edwarnicke_> Please #info in :)
14:32:50 <xsited1> #info packetcable tk
14:33:03 <edwarnicke_> xsited1: Welcome :)
14:33:04 <xsited1> *yaaaaawn*
14:33:08 <edwarnicke_> LOL
14:33:26 <edwarnicke_> Lets give 2 more minutes for roll call and then we can move on to status :)
14:33:31 <edwarnicke_> vjanandr: Could you #info in?
14:33:52 <vjanandr> #info done with local karaf.. and I am able to install the features..
14:33:56 <Madhu> #info Madhu
14:34:00 <mlemay> #info mlemay
14:34:07 <Madhu> morning guys :)
14:34:08 <edwarnicke_> vjanandr: That's fantatstic news ;)
14:34:23 <vjanandr> and I am done with the integration branch changes as well..
14:34:24 <Madhu> vjanandr: replied to your email with some tips i use to test the features
14:34:40 <edwarnicke_> Madhu: Thank you for keeping on top of email :)
14:34:43 * edwarnicke_ is terrible at email
14:34:48 <vjanandr> it was not clear how to test the feature.. just now checked Madhus mail..
14:34:58 <vjanandr> I will do what Madhu suggested..
14:34:59 <edwarnicke_> vjanandr: How were you testing your feature before?
14:35:20 <vjanandr> we use CLI to do unit testing..
14:35:39 <edwarnicke_> Ah...
14:35:40 <vjanandr> we are one commit away from getting our REST CONF + Yang working..
14:35:46 <edwarnicke_> One moment... have a good link that may help
14:36:18 <edwarnicke_> #link http://icodebythesea.blogspot.com/2011/11/creating-your-own-apache-karaf-console.html <- porting to karaf commands is pretty easy :)
14:36:49 <mlemay> yes it is
14:36:49 <edwarnicke_> #topic Status
14:37:05 <mlemay> and they work better. what is pretty cool is completers however
14:37:07 <edwarnicke_> OK... lets get status ( vjanandr is a bit ahead of the game there ;) )
14:37:30 <vjanandr> :)... excited to see it working :)
14:37:33 <edwarnicke_> xsited1: What is your karaf status?
14:38:03 <edwarnicke_> vjanandr: I agree :)
14:38:09 <mlemay> hum looks like he got disconnected
14:38:13 <edwarnicke_> mlemay: yep
14:38:24 <edwarnicke_> vjanandr: How can we help you today?
14:38:43 <vjanandr> I will try out what Madhu and the link you suggested..
14:39:02 <edwarnicke_> Cool :)
14:39:03 <vjanandr> and ones I am done with functionality testing is done.. I think I should be good to go..
14:39:09 <edwarnicke_> vjanandr: Awesome :)
14:40:21 <edwarnicke_> gzhao_r: Good morning :)
14:41:51 <gzhao_r> edwarnicke_: morning
14:42:09 <gzhao> I am trying for snmp4sdn project
14:42:45 <gzhao> here is the command I entered, after input groupId, artifactId etc, I got error like http://pastebin.com/8cQ64K81
14:42:47 <edwarnicke_> gzhao_r: Have they gotten back to you?
14:43:10 <edwarnicke_> gzhao_r: Looking
14:43:30 <gzhao_r> edwarnicke_: I am still waiting for snmp, oc's response
14:44:02 <gzhao_r> edwarnicke_: I am confident Colin will complete ttp
14:45:08 <edwarnicke_> gzhao_r: Just poked someone about oc
14:45:14 <edwarnicke_> gzhao_r: We'll see if that helps
14:45:22 <edwarnicke_> gzhao_r: Back to looking at your error :)
14:46:12 <edwarnicke_> gzhao_r: What directory did you execute this in?
14:46:12 <mlemay> ed: any chance we can look into getting the features.xml published to nexus in integration?
14:47:36 <xsited1> sorry about that … not sure what happen.   damn cable….  ed, the project has been integrated for a while now, but recent changes require me to rename a bundle and add one based on our restructuring.
14:48:15 <gzhao> edwarnicke_: /home/gzhao/opendaylight/snmp4sdn/snmp4sdn
14:48:15 <edwarnicke_> xsited1: Welcome back :)
14:48:20 <edwarnicke_> xsited1: How can we help you?
14:48:46 <edwarnicke_> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide <- Step by Step guide
14:48:52 <edwarnicke_> xsited1: Have you see: https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide
14:49:33 <edwarnicke_> gzhao: OK... I think we want features/ at /home/gzhao/opendaylight/snmp4sdn/features ... so you would want to execute the archetype in /home/gzhao/opendaylight/snmp4sdn/
14:49:35 <xsited1> i have seen that and most of the live videos
14:49:46 <edwarnicke_> And give archetypeId features-snmp4sdn
14:49:55 <edwarnicke_> xsited1: Cool :)
14:50:04 <edwarnicke_> xsited1: Just wanted to make sure we were all on page :)
14:51:27 <xsited1> and there might be a new dependency on openflow(java) plugin, but that is not clear at the moment
14:51:41 <edwarnicke_> xsited1: We can sort it out :)
14:51:51 <xsited1> the augmentation of that model is per last monday's presentation
14:51:55 <edwarnicke_> xsited1: If the tests pass for your feature, you should be good at the OSGI level
14:52:37 <xsited1> let me try to at least bring the features.xml up to date right now.
14:53:53 <gzhao> edwarnicke_: tried it gives me different prompt, is it because it already has snmp4sdn in the directory, I saw a new folder got created with pom.xml when I run in the sub directory, error http://pastebin.com/tjat3Dc7
14:54:21 <edwarnicke_> gzhao: That's because you need to use artifactId: features-snmp4sdn
14:54:45 <edwarnicke_> You are using artifactId snmp4sdn
14:54:45 <gzhao_r> also, I have a question is how to keep this https://docs.google.com/spreadsheets/d/12MWfLYNG_YO8pnUt5CrFD2xL1vHUXcmnUNrH-m6EdC0/edit#gid=0 as living document
14:55:05 <gzhao_r> is there a way I can check a project's karaf feature in the integration or not
14:56:37 <mlemay> you can look in the file..
14:56:42 <vjanandr> edwarnicke_: will it still be possible to do debug code in Karaf env.. using eclipse ?
14:57:24 <edwarnicke_> gzhao: You mean how to update it automatically?
14:57:35 <edwarnicke_> gzhao: You can see if their repo is included, yes
14:57:44 <edwarnicke_> gzhao: Do you have a checkout of the integration project?
14:58:02 <Madhu> vjanandr: yes
14:58:13 <edwarnicke_> vjanandr: yes
14:58:16 <edwarnicke_> ./karaf debug
14:58:32 <edwarnicke_> #link http://karaf.apache.org/manual/latest-2.2.x/developers-guide/debugging.html
14:58:41 <vjanandr> edwarnicke_:Madhu:  ok.. thanks
14:58:55 <gzhao> edwarnicke_: it prompts me Choose a number or apply filter (format: [groupId:]artifactId, case sensitive contains), and always complain about Your filter doesn't match any archetype (hint: enter to return to initial list)
14:59:05 <Madhu> vjanandr: i set my env variable as suggested in my email
14:59:11 <edwarnicke_> gzhao: What command line are you executing?
14:59:15 <gzhao> edwarnicke_: yes, I do have integration check out, let me check
14:59:40 <Madhu> vjanandr: and from there on.. the steps are the same
14:59:41 <gzhao> edwarnicke_: http://pastebin.com/8cQ64K81 the command
15:00:04 <edwarnicke_> gzhao:
15:00:05 <edwarnicke_> grep repository integration/features/src/main/resources/features.xml
15:00:09 <vjanandr> Madhu: understood thanks
15:00:13 <edwarnicke_> Will give you a list of the included repos
15:00:32 <edwarnicke_> vjanandr: Do read the link though... as the steps for debugsuspend are a bit different
15:01:12 <edwarnicke_> gzhao: Could you pastebin the output of:
15:01:13 <edwarnicke_> pwd
15:01:17 <edwarnicke_> And then the command run?
15:01:25 <edwarnicke_> gzhao: It still looks like you are running this in the wrong directory
15:01:32 <edwarnicke_> pantelis__: Welcome :)
15:01:41 <edwarnicke_> #topic Troubleshooting
15:01:49 <edwarnicke_> #chair Madhu mlemay
15:01:49 <odl_meetbot> Current chairs: Madhu edwarnicke_ mlemay
15:01:56 <edwarnicke_> #chair gzhao
15:01:56 <odl_meetbot> Current chairs: Madhu edwarnicke_ gzhao mlemay
15:02:50 <gzhao> edwarnicke_: this time I run from /home/gzhao/opendaylight/snmp4sdn
15:03:43 <Madhu> #info i typically use  export JAVA_DEBUG_OPTS='-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=6000' for debugging
15:03:57 <edwarnicke_> gzhao: That's odd... because the packaging type of the pom.xml in that directory is pom
15:03:58 <edwarnicke_> https://www.irccloud.com/pastebin/3F6iqLTC
15:05:22 <gzhao> #action gzhao update Karaf project status based on repository integration/features/src/main/resources/features.xml
15:06:33 <mlemay> ed: FYI https://git.opendaylight.org/gerrit/#/c/10516
15:07:02 <mlemay> Madhu: you can't use ./karaf debug ?
15:07:04 <edwarnicke_> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:integration+message:feature,n,z <- gzhao Should list not yet merged additions
15:07:26 <mlemay> it has similar arguments
15:07:54 <edwarnicke_> mlemay: Which URL do I use to see dlux for https://git.opendaylight.org/gerrit/#/c/10516
15:08:37 <Madhu> mlemay: i typically want to suspend during boot up
15:08:53 <Madhu> especially because of the problems i was facing
15:09:06 <edwarnicke_> Madhu: I frequently (though not always) want to suspend during startup too
15:09:06 <mlemay> latest changes are merged in.. so would be at localhost:8181/dlux/index.html I believe
15:09:25 <edwarnicke_> Madhu: I have even contempated sending the karaf guys a patch with a debugsuspend option
15:09:28 <Madhu> mlemay: by default suspend=n with the karaf debug option
15:10:08 <mlemay> yea
15:10:17 <mlemay> makes sense
15:10:51 <edwarnicke_> vjanandr: You have everything you need?
15:10:56 <edwarnicke_> vjanandr: For now ;)
15:12:30 <gzhao> edwarnicke_: great, for info of pending merge features.
15:12:41 <vjanandr> edwarnicke_: pretty much yes..
15:12:43 <edwarnicke_> gzhao: Glad to help :)
15:12:56 <edwarnicke_> vjanandr: Cool :)  If you need anything else, we'll be here tommorow morning same time :)
15:13:07 <edwarnicke_> mlemay: Building the dlux feature patch
15:13:13 <vjanandr> edwarnicke_: sure.. will try to get this working by tonight..
15:13:17 <vjanandr> will update tomorrow..
15:13:35 <edwarnicke_> :)
15:13:50 <edwarnicke_> gzhao: Any new data on the stuff you are doing for snmp4sdn ?
15:14:27 <gzhao> edwarnicke_: snmp folks would see the same error as I do,
15:14:45 <gzhao> edwarnicke_: when I run second time, it shows this error http://pastebin.com/ef2dXEKp
15:14:54 <gzhao> edwarnicke_: do you want me to turn on -e flag?
15:15:18 <edwarnicke_> gzhao: Please include both the output of pwd and the actual command run :)
15:15:47 <gzhao_r> vjanandr: thanks for coming, do you have your issue resolved?
15:16:57 <vjanandr> gzhao_r: very much yes.. thanks to Ed and Madhu :)
15:17:52 <edwarnicke_> Madhu: Could you review https://git.opendaylight.org/gerrit/#/c/10515/ (its a fix for autorelease breakage... basically version skew)
15:18:05 <gzhao> edwarnicke_: full screen capture http://pastebin.com/8WzrBh39
15:18:34 <edwarnicke_> gzhao: Trying it myself locally now :)
15:20:04 <gzhao> edwarnicke_: we encounter an auto-release error in yangtools, will this CL fix it?
15:20:32 <edwarnicke_> gzhao: What autorelease error did you hit there?
15:20:45 <edwarnicke_> gzhao: And do you have a link to a patch for it?
15:21:09 <gzhao> edwarnicke_: let me pull it out
15:23:08 <edwarnicke_> gzhao: Copy and pasting your command I can reproduce your error
15:23:11 <edwarnicke_> gzhao: Investigating
15:23:22 <edwarnicke_> dvorkinista: Welcome to Karaf Happy Hour :)
15:26:43 <gzhao> edwarnicke_: sometimes I wonder you have ten hands and multiple monitors to do so many things simultaneously
15:26:54 <edwarnicke_> gzhao: I do have two monitors :)
15:27:02 <gzhao> edwarnicke_: here is the error I got for autorelease http://pastebin.com/MkmW2nNn
15:27:07 <edwarnicke_> gzhao: Just wait till I have time to figure out the vagrant amazon plugin :)
15:27:53 <edwarnicke_> gzhao: Let me check... but I don't think most projects have an integrationtests profile...
15:28:15 <vjanandr> edwarnicke_:  gzhao: stepping out for dinner :) thanks for all the help..
15:28:24 <gzhao> ouch, I only got permission for one hour from my wife, weekend morning is a great time.
15:28:31 <gzhao> vjanandr: you are very welcome
15:28:37 <vjanandr> will come back tomorrow.. and update..
15:28:40 <edwarnicke_> gzhao: Yep... the issue is the autorelease is asking for profiles to be used that aren't present
15:28:53 <edwarnicke_> gzhao: thank you for coming :)
15:28:55 <mlemay> Bye vjanandr
15:28:57 <edwarnicke_> vjanandr: Thank you :)
15:29:03 <mlemay> Thanks for coming
15:29:49 <gzhao> edwarnicke_: no thank you and Mathieu and Madhu for doing this on weekend. I learn a lot
15:30:30 <edwarnicke_> xsited: Welcome back :)
15:30:36 <edwarnicke_> xsited: Where were we...
15:33:23 <Madhu> edwarnicke_: merged.
15:33:25 <Madhu> brb...
15:33:30 <edwarnicke_> Madhu: Many thanks :)
15:35:21 <gzhao> edwarnicke_: I will go with my wife for her check up, if I can get wifi at hospital I will be online, otherwise I will check the log
15:35:26 <gzhao> thanks everyone
15:40:32 <mlemay> Your welcome George . font hesitate if you have more questions
15:43:59 <edwarnicke> Anyone object to closing the meeting?
15:44:34 <edwarnicke> #endmeeting