16:05:49 <edwarnicke> #startmeeting MD-SAL call
16:05:49 <odl_meetbot> Meeting started Tue May 20 16:05:49 2014 UTC.  The chair is edwarnicke. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:05:49 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:49 <odl_meetbot> The meeting name has been set to 'md_sal_call'
16:05:56 <edwarnicke> #chair tbachman
16:05:56 <odl_meetbot> Current chairs: edwarnicke tbachman
16:05:59 <edwarnicke> #chair CASP3R
16:05:59 <odl_meetbot> Current chairs: CASP3R edwarnicke tbachman
16:06:34 <edwarnicke> #topic What was done last week
16:06:44 <edwarnicke> #info Big memory reductions
16:06:51 <edwarnicke> #info stability improvements
16:07:33 <edwarnicke> #link https://jenkins.opendaylight.org/integration/job/integration-csit-base-of13/ - all OF13 integration tests passing
16:08:14 <tbachman> #link  https://docs.google.com/spreadsheets/d/1O5PxEM1eLszMuWf9M11AD5w7siT9vHOkzR85gjCB-6c/edit#gid=322436364 edwarnicke provided a spreadsheet to track these items
16:08:42 <tbachman> #topic What will be don (what's planned)
16:09:03 <tbachman> #info bug 1010, Return from Restconf the errors as definied in the IETF draft
16:09:25 <tbachman> #info /modules and /streams failing, fix should be coming as well
16:10:09 <alagalah> HAVING ISSUES getting into webex
16:10:52 <edwarnicke> #question could we get the gerrit link for the Bug 1010 patch to controller ?
16:11:40 <tbachman> #info Netconf connector - return the netconf errors back in the RPC result (allow the RPC errors to be passed through). waiting on a parent patch.
16:12:36 <devinavery> #info Ask question needs some focus: https://ask.opendaylight.org/question/99/how-does-request-routing-works/
16:12:55 <devinavery> #info Tony - is writing down the explanation
16:13:36 <edwarnicke> #link https://ask.opendaylight.org/question/99/how-does-request-routing-works/ - question no how request routing works
16:13:37 <tbachman> #info bug 990 and one other, where union types aren't getting translated in binding independent and binding aware correctly
16:13:42 <edwarnicke> #action Tony to answer https://ask.opendaylight.org/question/99/how-does-request-routing-works/
16:14:09 <icbts> alagalah: https://cisco.webex.com/ciscosales/j.php?MTID=m0eb4cb04a905e37f06081fbe5c974624
16:14:15 <icbts> alagalah: try that to join
16:15:45 <edwarnicke> #question could we get a link for the gerrit that fixes bug 990
16:15:52 <tbachman> #info ttkacik merged fix for 990
16:18:00 <tbachman> #info rovarga has about 10 patches to address the data store
16:18:31 <tbachman> #info devinavery et. al. have stuff in the works to add mount points, etc. to all plugin of 3rd party protocols
16:21:21 <tbachman> #topic Other Topics upcoming
16:21:32 <tbachman> #info clustering in the MD-SAL
16:23:34 <colindixon> #info there are discussions happening on the discuss list about this now
16:24:20 * tbachman wishes you could apply regex fixes to "pound-info" :)
16:24:26 <tbachman> s/all/allow/
16:25:20 <tbachman> #info MD_SAL Status call minutes have been sent to the controller-dev and yangtools-dev mailing lists
16:27:11 <tbachman> #info edwarnicke recommends using balance of time to cover the email that tkacik was prreparing
16:27:28 <tbachman> #info clustered data store discussion moved to next week's MD-SAL meeting
16:28:20 <tbachman> #info tkacik covers How does request routing works
16:28:39 <tbachman> #info Question was how does request routing work on a per node/host basis
16:30:02 <tbachman> #info How does ODL invoke the right plugin for the right node?
16:30:27 <tbachman> #info Confusion comes from looking at AD-SAL vs. MD-SAL
16:30:51 <tbachman> #info MD-SAL doesn't have the notion of node type.
16:31:21 <tbachman> #info MD-SAL instead allows you to register an RPC in the context of a node.
16:31:43 <tbachman> #info For example, the OpenFlow plugin registers RPCs for flow programming for a given node.
16:31:53 <tbachman> That causes flow programming for that node to be routed to the OpenFlow plugin
16:31:56 <tbachman> oops
16:32:10 <tbachman> #info That causes flow programming for that node to be routed to the OpenFlow plugin
16:34:16 <tbachman> #info edwarnicke asks what is the problem that is being solved
16:34:53 <tbachman> #info Solaris doesn't support OVS, so they want to provide their own plugin so that it handles Solaris nodes differently
16:36:42 <tbachman> #info Using the example of configuring a VLAN, edwarnicke recommends creating a set-vlan RPC in the NB model, and the solaris plugin would register itself to create VLAN RPCs for nodes discovered by the solaris plugin.
16:39:26 <tbachman> #info Can mutliple SB plugins register for the same property change on the same node?
16:39:55 <tbachman> #info Only one SB can register for the implementation per RPC.
16:40:25 <tbachman> #info devinavery notes that this is exactly what they're putting together in their example.
16:44:06 <devinavery> #info New example we are working on is tracked with bug 1050
16:46:20 <tbachman> #info rovargo notes that there needs to be a unified view of the topology.
16:53:34 <tbachman> time check: 7 minutes left in the meeting folks.
16:53:53 <edwarnicke> Who is the original questioner about the solaris thing?
16:54:02 <edwarnicke> I'd like to make sure we follow up and get him what he needs :)
16:54:24 <tbachman> edwarnicke: I don't think he's on this IRC atm
16:54:53 <edwarnicke> Did anyone catch his name?
16:55:02 <tbachman> shoaib maybe (on WebEx)?
16:55:03 <Madhu> edwarnicke: lets ask him on the call :)
16:56:45 <colindixon> so, I’ll probably wind up following up on this later, but it seems like people are expecting the MD-SAL to be more than a unified datastore/data change router
16:56:51 <colindixon> which is causing the confusion
16:58:02 <tbachman> #endmeeting