15:05:18 <tbachman> #startmeeting md_sal_hackers
15:05:18 <odl_meetbot> Meeting started Mon Oct 27 15:05:18 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:05:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:18 <odl_meetbot> The meeting name has been set to 'md_sal_hackers'
15:05:21 <tbachman> #chair alagalah_
15:05:21 <odl_meetbot> Current chairs: alagalah_ tbachman
15:05:33 <tbachman> anyone else?
15:05:34 <tbachman> :P
15:06:05 <tbachman> #info devinavery asks if anyone has looked at/considered the ping example when generating the pain points list
15:06:22 <tbachman> #info alagalah_ says he put the ping example up on the wiki but that’s as far as he’s gotten
15:06:57 <tbachman> #info devinavery says he wanted to make it evident that the ping example uses the AD-SAL, and uses the abstractbindingaware classes
15:07:36 <tbachman> #info devinavery asks if we’re going to continue supporting the abstractbindingaware classes
15:08:49 <tbachman> #info rovarga says that we either deprecated or meant to deprecate those classes, with the reason being that they rely on OSGI for activation, which we’re trying to free ourselves from being dependent on
15:09:40 <tbachman> #info devinavery says they’re not yet deprecated, and these classes are currently activated “out of band” from the MD-SAL
15:10:25 <tbachman> #info ttkacik says these classes don’t allow for custom broker injections, and takes the first broker they find in the OSGI registry
15:10:44 <tbachman> #info ttkacik recommends deprecating these APIs and helping folks migrate off of them
15:11:46 <tbachman> #info devinavery says there may still be simple use cases woth keeping these classes around for
15:11:59 <tbachman> #topic MD-SAL pain points
15:12:57 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/md_sal_hackers/opendaylight-meeting-md_sal_hackers.2014-10-20-15.07.html Last week’s MD-SAL hackers call minutes
15:14:26 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review alagalah_’s WIP for helping folks with the MD-SAL
15:15:10 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Config_SubSystem alagalah_’s WIP for the config subsystem
15:16:31 <tbachman> #info alagalah_ says that folks can add things to these, such as links to outside tutorials, youtube videos, etc.
15:18:27 <tbachman> #info jmedved and rovarga say that alagalah_’s template is good
15:19:31 <tbachman> #info jmedved says we could add the component map, which maps out all the components
15:20:10 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Component_Map  Config subsystem component map
15:20:45 <tbachman> #info https://wiki.opendaylight.org/view/YANG_Tools:Component_Map  YANG tools component map
15:21:02 <tbachman> #undo
15:21:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2728a10>
15:21:11 <tbachman> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Component_Map  BGP-PCEP component map
15:21:20 <tbachman> #link https://wiki.opendaylight.org/view/YANG_Tools:Component_Map  YANG tools component map
15:21:46 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Component_Map  OpenFlow plugin component map
15:22:04 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Netconf:Component_Map  Controller component map
15:22:44 <alagalah_> #action alagalah to update sub-project wiki with component map links and recommend this be part of all projects as per jmedved suggestion either in Docs project or as part of Li RP
15:23:13 <tbachman> #info jmedved asks what the next steps are, and who are the owners?
15:27:20 <alagalah_> https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Config_SubSystem
15:27:45 <tbachman> #info rovarga will take on the config subsystem documentation (with help from maros)
15:29:00 <tbachman> #info ttkacik will take on the MD-SAL, and devinavery will help out, time permitting
15:29:15 <tbachman> #info tpatelis will also help out with the MD-SAL
15:30:16 <tbachman> #info alagalah_ says he wasn’t sure if YANG should be it’s own subproject
15:30:33 <tbachman> #info jmedved and rovarga will take on the overall architecture
15:30:38 <tbachman> I’ll change those to actions
15:30:52 <tbachman> #action rovarga will take on the config subsystem documentation (with help from maros)
15:31:05 <tbachman> #action tkacik will take on the MD-SAL, and devinavery will help out, time permitting, and tpatelis
15:31:16 <tbachman> #action jmedved and rovarga will take on the overall architecture
15:31:39 <tbachman> #info devinavery says we may want to make YANG and clustering sub-items of the MD-SAL template
15:33:05 <tbachman> #info devinavery recommends statting with config subsystem and MD-SAL, and then look to the other pieces later
15:33:34 <tbachman> #info alagalah_ agrees that we should start with MD-SAL and config subsystem for this week
15:34:26 <tbachman> #info alagalah_ asks if there’s anything major missing here
15:34:58 <tbachman> #info jmedved says he’d like to see several others added — BGP/PCEP, Group Based Policy, OpenFlow Plugin, etc.
15:35:19 <tbachman> #info alagalah_ agrees - but wants to start with these.
15:36:13 <tbachman> #info uchau says she would help review any of the documentation/write-ups
15:37:05 <tbachman> jmedved: you’re breaking up, you’re breaking up!
15:37:34 <tbachman> jmedved: can you type it into IRC?
15:37:52 <tbachman> :)
15:39:47 <jmedved_> sorry, my internet crapped out
15:39:51 <tbachman> jmedved_: can you type your suggestins into IRC?
15:39:51 <jmedved_> trying to rejoin
15:39:58 <jmedved_> please go ahead with uyen’s list
15:40:07 <jmedved_> be rigth there (hopefully)
15:40:12 <tbachman> #topic Uyen Chau’s Pain Points List
15:41:02 <tbachman> #info uchau says that this list is the feedback from their engineers
15:41:07 <tbachman> #info the examples were helpful
15:41:16 <tbachman> #info The documentation describes how to do things, but not why
15:41:34 <tbachman> #info this makes it tough to understand how to do anything but the example at hand
15:42:11 <tbachman> #info The config subsystem has been particularly challenging to understand what it does (e.g. how does it relate to bundle dependencies in OSGI)
15:42:51 <tbachman> #info There are also questions on how the config .xml’s work - what are the relationships between them
15:45:30 <tbachman> #info uchau says that the other sections asks things like “why are we using the config subsystem”, and “what alternatives are out there and what did we consider?”
15:47:58 <tbachman> #info Lots of questions about what types of functionality we’re providing, where we’re providing it (e.g. config subsystem, karaf)
15:49:17 <tbachman> #info uchau asks if they can use the MD-SAL without YANG?
15:49:49 <tbachman> #info For example, can MD-SAL be used for infrastructure (e.g. pub/sub), without having to use YANG
15:50:44 <tbachman> #action uchau to take her list and add it to the pain points wiki page
15:52:19 <tbachman> #info jmedved asks if there are any other things we should add to alagalah_’s list (e.g. logging, RESTCONF, etc.) that needs explaining/adjusting?
15:52:41 <tbachman> #info devinavery says RESTCONF for sure, but those may be sub-elements of other things.
15:53:30 <tbachman> #info uchau asks about security
15:53:40 <tbachman> #info alagalah_ says that could be addressed as part of the architecture
15:53:59 <tbachman> #info jmedved says that security is a lot more in flux than the other subsystems
15:54:51 <tbachman> #info we may want to treat security slightly different because of this
15:55:33 <tbachman> #info devinavery says he took the action item for seaching the MD-SAL, and has sent an email to the community to solicit feedback on this topic
15:56:07 <tbachman> #info devinavery asks if others on the call could provide feedback on searching the MD-SAL
15:56:28 <tbachman> #info uchau  says to have a look at the services platform that HP presented at the dev summit
15:57:05 <tbachman> #info jmedved asks devinavery to involve sharon, as he’s doing work in this area too
15:57:34 <uchau> https://wiki.opendaylight.org/view/File:ODL_Net_Svcs_APIs_v1.pptx
15:58:18 <tbachman> #link https://wiki.opendaylight.org/view/File:ODL_Net_Svcs_APIs_v1.pptx HP’s presentation on Network Services
15:58:24 <tbachman> uchau: thx!
15:59:06 <tbachman> #info devinavery asks if we want to move this call to the Tuesday time slot, or kill the Tuesday time slot?
16:00:13 <tbachman> #info alagalah_ says that we should keep that timeslot so we can do things like present our templates once their ready
16:00:43 <tbachman> #info devinavery says that the TWS might be the better place for this, and have the Tuesday call be available as an overflow for TWS topics
16:01:50 <tbachman> #endmeeting