16:02:59 <tbachman> #startmeeting md_sal_hackers
16:02:59 <odl_meetbot> Meeting started Mon Nov 10 16:02:59 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:59 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:59 <odl_meetbot> The meeting name has been set to 'md_sal_hackers'
16:03:13 <tbachman> #chair edwarnicke_
16:03:13 <odl_meetbot> Current chairs: edwarnicke_ tbachman
16:03:24 * tbachman wonders where colindixon has gone to :(
16:04:41 <tbachman> #topic agenda
16:06:01 <tbachman> anyone else for chair?
16:07:27 <tbachman> #info jmedved asks if anyone’s reviewd the notifications API from ttkacik and rovarga
16:07:42 <tbachman> #info rovarga says there have been a few comments
16:08:14 <tbachman> #info jmedved asks if it makes sense to do anything with the documentation review
16:08:21 <tbachman> #topic Documentation review
16:09:07 <tbachman> #chair alagalah
16:09:07 <odl_meetbot> Current chairs: alagalah edwarnicke_ tbachman
16:12:14 * tbachman is lookoing for links here
16:13:49 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:MD_SAL Link describing MD-SAL documentation review
16:14:08 * tbachman wonders if we can standardize on either “-“ or “_” for MD-SAL, but not both :P
16:15:15 <tbachman> #info ttkacik reviews the updates he’s provided on the MD-SAL documentation (see recording)
16:17:12 <alagalah> #info jmedved to remove specifics from the Architecture overview and reference specifics in MD-SAL
16:17:19 <tbachman> alagalah: thx!
16:18:10 <tbachman> #info jmedved asks if the MD-SAL documentation satisfies alagalah’s criteria for documentation
16:18:55 <tbachman> #info alagalah says it’s a fantastic start, but he needs to go through it in detail, to make sure it provides the background context that allows folks to approach the examples, etc.
16:19:39 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Explained MD-SAL explained wiki page created by ttkacik
16:20:39 <tbachman> #info jmedved asks the rest of the participants on the call to review the documentation so we can comment it on next week’s call (and provide feedback using the “Discussion” tab on the wiki)
16:21:16 <tbachman> #agreed participants on the call to review the documentation so we can comment it on next week’s call (and provide feedback using the “Discussion” tab on the wiki)
16:22:08 <tbachman> #info ttkacik says that relationship between YANG tools and the MD-SAL needs to be explained, and ttkacik is probably the best person to do that
16:22:31 <tbachman> #action ttkacik to put this as a placeholder in the MD-SAL arch page
16:24:11 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Config_SubSystem Wiki page documenting the config subsystem
16:25:09 <tbachman> #info jmedved says that the activity diagram would be really helpful
16:25:46 <tbachman> #action rovarga to provide the activity diagram for the config subsystem
16:26:24 <tbachman> rovarga: do you know maros’s nick?
16:27:06 <alagalah> #action rovarga to get Maros to put in Education/tuturial section for config subsystem
16:27:14 <alagalah> #action rovarga to get Maros on IRC :)
16:28:14 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Architecture MD-SAL documentation architecture wiki page
16:29:27 <tbachman> #info jmedved added background on the decisions that are used in the architecture
16:29:58 <tbachman> #info the architecture needs to be expanded to include clustering or other components (i.e. living wiki page to be augmented by others)
16:31:12 <tbachman> #info The controller is both a platform and an SDN Application Development environment
16:34:16 <tbachman> #info alagalah says he sees the Architecture page as the “landing page”, and clustering being something that’s linked off of it
16:34:51 <tbachman> #info moiz says we should mention something about clustering on the Architecture page
16:36:58 <tbachman> #info alagalah asks if we should indicate that this page is in reference to the Helium release?
16:37:13 <tbachman> #info jmedved says yes, this should probably indicate that it’s covering the Helium and Lithium architecture
16:37:51 <tbachman> #action moizer to write up a section on clustering and add it to the architecture wiki page
16:38:28 <tbachman> #action ttkacik to add a parts on YANG Tools to the architecture wiki page
16:38:40 <tbachman> #info jmedved asks if there’s anything else that’s needed in the architecture page
16:39:26 <tbachman> #info colindixon says we should summarrize that the MD-SAL is: 1) RPC, 2) Notifications, and 3) a Data Store
16:40:36 <tbachman> #info edwarnicke_ agrees, and says we’ve made the mistake in the past of introducing folks to all the more helpful and complex features of the MD-SAL before understanding the simpler aspects first
16:42:00 <tbachman> #info alagalah says he’d like to understand how the config subsystem, MD-SAL, OSGI, and Karaf all relate to each other
16:42:18 <tbachman> #info jmedved agrees
16:43:14 <tbachman> #action colindixon to write the 10k ft view of the config subsystem
16:44:04 <tbachman> #info edwarnicke_ offers his help to colindixon if he has any q’s
16:45:34 <tbachman> #info rovarga says that edwarnicke_ is probably the only person who understands the relationship between the config subsystem and the karaf runtime
16:46:17 <tbachman> #action edwarnicke_ to write up the interaction between the config subsystem and karaf
16:47:11 <alagalah> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:KARAF_OSGI
16:50:59 <tbachman> #action alagalah to try writing up the karaf and OSGI interaction
16:53:14 <tbachman> #info maros requests feedback on the config subsystem wiki page
16:54:41 <tbachman> #info alagalah says that the education/tutorial section was removed
16:54:51 <tbachman> #info maros says he took it out by accident
16:55:02 <tbachman> #info jmedved requests to make the figures smaller in the wiki
16:55:29 <tbachman> time check: 5 minutes
16:56:16 <tbachman> #info uchau asks when we expect this to be done
16:56:45 <tbachman> #info maros says he thinks he can get the first version done in a couple of days, and will send an email when it’s ready
16:58:09 <tbachman> #info jmedved says the one big one we don’t have covered is the RESTCONF/NETCONF section
16:58:20 <tbachman> #info alagalah says he wasn’t sure there was agreement that this did have it’s own section
16:58:45 <tbachman> #info ttkacik says he’d go with it as a subsection, since it is the northbound of the controller
16:59:24 <tbachman> #action josef will provide the RESTCONF documentation
17:00:49 * tbachman notes that edwarnicke_ has quite the vocabulary ;)
17:02:06 <tbachman> #action team to identify non-Slovakian speaker to review the docs (non-English speaking reviewers)
17:02:09 <tbachman> #endmeeting