16:00:33 <tbachman> #startmeeting md_sal_hackers
16:00:33 <odl_meetbot> Meeting started Mon Nov 17 16:00:33 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:33 <odl_meetbot> The meeting name has been set to 'md_sal_hackers'
16:02:13 * tbachman notes the play on words with call-in vs. colin
16:02:15 <tbachman> ;)
16:03:37 <tbachman> #chair jmedved
16:03:37 <odl_meetbot> Current chairs: jmedved tbachman
16:03:42 <tbachman> #chair alagalah_
16:03:42 <odl_meetbot> Current chairs: alagalah_ jmedved tbachman
16:05:35 <tbachman> #action colindixon to update architecture wiki page for MD-SAL by next week
16:06:33 <tbachman> #topic agenda bashing
16:06:53 <tbachman> #info Topic: archetype vs. template
16:07:03 <alagalah> #info Config Subsystem Documentation
16:07:16 <alagalah> #topic Config Subsystem Doc
16:07:49 <alagalah> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review:Config_SubSystem
16:08:21 <tbachman> #info alagalah says he recommends folks look at the config subsystem wiki page, says it’s very very good
16:08:52 <tbachman> #info alagalah minor nits include missing how it fits into the controller (diagram)
16:09:12 * colindixon is continously impressed with how much and how well tbachman takes notes
16:09:18 <tbachman> :)
16:09:26 <tbachman> call-in is now colin :)
16:09:33 <tbachman> colindixon: thx!
16:10:39 <tbachman> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Examples:Sample_Project Sample Project for config subsystem wiki page
16:11:26 <tbachman> #info alagalah would like to change this to include where the dependency elements should be added
16:12:09 <tbachman> #link https://wiki.opendaylight.org/view/Talk:OpenDaylight_Controller:Config:Examples:Sample_Project comments on the Sample Project for config subssystem
16:12:38 <tbachman> #info ttkacik says for any examples, we should never use the parent poms of the controller project
16:12:51 <colindixon> #info edwarnicke agrees in a huge way
16:12:58 <tbachman> colindixon: beat me to it ;)
16:13:03 <tbachman> colindixon: thx!
16:13:07 * colindixon tries once in a while
16:13:17 <colindixon> #info this is the job of odlparent, please do that
16:13:21 * tbachman notes that colindixon operates at a 5x tempo of tbachman
16:14:29 <tbachman> #action alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step
16:14:47 <tbachman> #action alagalah to send email to rovarga to kick that off
16:14:54 <tbachman> #undo
16:14:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x272e650>
16:15:10 <tbachman> #action alagalah tosend email to rovarga to initiate going through the proposal step-by-step
16:15:26 <tbachman> #info jmedved says that hte MD-SAL archetype works but can’t be loaded by karaf
16:16:02 <tbachman> #info ttkacik says that rovarga’s proposal makes it easy to start a new application
16:16:20 <tbachman> #info jmedved says we need to have a ready-made application that people can download and run
16:17:00 <tbachman> #info mlemay asks if this is related to the features-parent
16:17:03 <tbachman> #info ttkacik says partly
16:18:12 <tbachman> #info alagalah says we should put deprecated in big red letters on the existing config exmamples wiki pages
16:18:39 <tbachman> #info pantelis asks if the toaster is sufficient?
16:19:03 <tbachman> #info ttkacik says it can’t be part of the controller project, which is one of the most confusing things to new folks
16:19:52 <tbachman> #info ttkacik says that the snapshots archetype doesn’t work with all systems
16:20:16 <tbachman> #info pantelis asks if it makes sense to make the toaster example the way we want it (e.g. outside the controller)
16:20:26 <tbachman> #info jmedved says he’d love to see that, in addition to other examples
16:21:15 <tbachman> #info edwarnicke says the toaster should also be changed to just wire in a broker, which is simpler to understand, rather than wire it in service by service
16:21:49 <tbachman> #info jmedved says maybe we can start that way (simple), then add to it
16:22:02 <tbachman> #info alagalah says that’s valuable, but we still need to be able to build from scratch
16:22:57 <tbachman> #undo
16:22:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2641310>
16:23:03 <alagalah> step by step
16:23:22 <tbachman> #info alagalah says that’s valuable, but we need to start with the simple step which builds from scratch, and then add to it step by step
16:23:26 <tbachman> jmedved: better ^^?
16:24:16 <tbachman> #info alagalah says that whatever we use as the example, we need to decide on the call what the next steps are
16:24:49 <tbachman> #info alagalah would like to walk through the example with the author, in order to have direct assistance to understand what needs to be changed/improved
16:25:33 <tbachman> #info jmedved feels whatever we do should be based on rovarga’s proposal
16:25:49 <alagalah> +1 Toaster
16:26:30 <tbachman> #info jmedved says the first example could be just a provider, with the next one adding a consumer, the next adding the configuration, the next one extending the model
16:27:42 <tbachman> #info edwarnicke says that the things that are missing is that the intermediate steps aren’t there for download, isn’t based on rovarga’s proposal, and doesn’t include edwarnicke’s requirement for simple config subsystem
16:27:57 <alagalah> +1
16:28:35 <tbachman> #action jmedved to email invites for working on this example
16:28:53 <tbachman> #info plan is for a 7am PST invite
16:29:55 <tbachman> #info ttkacik says he sent an email to the TSC on changing the download page for opendaylight (i.e. remove hydrogen references)
16:30:37 <tbachman> #action colindixon to bring up removing hydrogen artifacts from main download page
16:30:39 <alagalah> #action colindixon to follow up on " ttkacik says he sent an email to the TSC on changing the download page for opendaylight (i.e. remove hydrogen references)"
16:31:18 <tbachman> #info phrobb says that he’s been talking with the web site people to try to get the design changed to address this issue
16:31:44 <tbachman> #topic example vs. archetype
16:32:08 <tbachman> #info jmedved asks if we need an archetype or a bunch of downloadable examples
16:32:22 <tbachman> #info moizr and edwarnicke say we need an archetype
16:33:05 <tbachman> #info jmedved says he had to clone a bunch of projects to see what they did in the future; isn’t very useful to complete n00bies
16:33:16 <tbachman> oops
16:33:17 <tbachman> #undo
16:33:17 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x247d950>
16:33:33 <tbachman> #info jmedved says he had to clone a bunch of projects to see what they did in their features; isn’t very useful to complete n00bies
16:33:56 <tbachman> #info colindixon says we need the Julia Child effect, where you have the completed product available (“right out of the oven")
16:35:44 <tbachman> #info moizr asks where these tutorials will live
16:36:02 <tbachman> #info ttkacik recommends having asciidoc/markdown in the same dir
16:37:16 <tbachman> #info jmedved asks if we should have a new “samples” project with its own maintainer? Or us ODL Forge?
16:37:55 <tbachman> #info edwarnicke says we tried the samples with toolkit, as we had to chase down committers, and strongly urges to keep them in controller but not have them in the pom parent hierarchy of the controller
16:38:12 <tbachman> #info moizr says he’d like to see it in a separate repo so that folks can’t mess things up
16:38:52 <tbachman> #info mlemay says there example of how to do the tasks and the sample project itself (how to structure your repo)
16:40:38 <tbachman> #info colindixon says the only way he’s seen stuff maintained if it’s kept in the project that’s most likely to break it
16:40:54 <tbachman> #info There also needs to be a test associated with it to check that it’s broken
16:41:16 <tbachman> #info colindixon says the archetype should include both the step-by-step and the resulting artifact
16:43:16 <colindixon> #info colindixon notes that (as a committer on toolkit) he’s willing to try to help re-invent that project if people wanted to
16:43:26 <tbachman> #info ttkacik says there is a step-by-step tutorial starting from scratch, which can start with the wiki, and later migrate to asciidoc; there is also a set of tutorials which after each major step you have a working product, where the user can check out the code for the next step;
16:44:04 <tbachman> #info ttkacik says there can also be a step-by-step, commit-by-commit in the repo
16:44:15 <tbachman> #info This allows you to clone the repo and are ready to go
16:45:18 <tbachman> #info moizr says each step could have a separate folder
16:45:29 <tbachman> #info ttkacik says you could also do this commit-by-commit
16:45:38 <tbachman> #info jmedved says he feels separate folders is better
16:46:11 <colindixon> I don’t know if we should #info this, but you can actually embed a file which can be cloned for people that want to use git stuff
16:46:27 <tbachman> #info decision is to create step-by-step using folder-by-folder
16:46:43 <colindixon> tbachman: you can #agreed that if you want it to stand out
16:46:55 <tbachman> #agreed decision is to create step-by-step using folder-by-folder
16:46:59 <tbachman> colindixon: thx1
16:47:00 <tbachman> :)
16:47:27 <colindixon> there’s two kinds of tests, (i) tests that should be part of the project, and (ii) tests to make sure the tutorial works
16:47:58 <colindixon> note that if (i) is done well, then (ii) just needs expand the archetype/tutorial and then run the tests from (i)
16:48:19 <tbachman> +1k to tests :)
16:48:26 <tbachman> good way for folks to run and learn
16:48:34 <colindixon> in my mind if you’ve done this right, you literally run the archetype command, then cd into it and then run mvn clean install”
16:49:01 <jmedved> colindixon: that’s the idea
16:49:08 <jmedved> but that’s the finished product
16:49:09 <tbachman> #info ttkacik says we are addressing the samples and tutorials for the controller project — we should be more specific
16:49:25 <colindixon> my suggestion would be to do it *in* controller or use toolkit
16:49:31 <jmedved> you also need the step-by-step. the archetype creates the last step of the step-by-step
16:49:57 <tbachman> #info alagalah recommends either controller_tutorials or controller_education
16:50:07 <tbachman> #info uchau asks if the tutorials are focused on the controller or MD-SAL?
16:50:39 <colindixon> jmedved: yes, the cool part of having one directory per step is that when you ran the tests, you can test each step just by running “mvn clean install”
16:50:52 <jmedved> colindixon: yes :-)
16:51:53 <tbachman> #info jmedved says that’s a good question, but maybe that’s a “step 2” thing
16:53:23 <tbachman> #info jmedved says we need to put this on the list of things to do (i.e. to develop the other tutorials as well)
16:54:03 <tbachman> #info edwarnicke says do we want things like openflowplugin tutorials considered as well
16:54:21 <tbachman> #info jmedved would like to see these as individually loadable features in karaf
16:54:58 <tbachman> #info alagalah says we need to define the project scope, and recommends starting with tutorials for the controller, namely things that are offset 0 projects
16:55:41 <tbachman> #info offset 0 projects are odlparent, yangtools, and controller project
16:56:39 <tbachman> #action alagalah to come up with a project proposal for this effort
16:58:10 <tbachman> #action jmedved to include uchau in the 7am PST calls
16:59:01 <tbachman> #endmeeting