16:00:23 <tbachman> #startmeeting md_sal_hackers
16:00:23 <odl_meetbot> Meeting started Mon Nov 24 16:00:23 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:23 <odl_meetbot> The meeting name has been set to 'md_sal_hackers'
16:00:33 <tbachman> #topic agenda
16:06:44 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/md_sal_hackers_meeting/opendaylight-meeting-md_sal_hackers_meeting.2014-10-13-15.08.html minutes from previous week
16:07:32 <tbachman> #topic Action Items from last week
16:07:42 <tbachman> #info alagalah to set up meeting with Devin, Tom, John Burns, Maros, and whoever wants to join, to walk through the links in the "how tos", with a consistent template style structure, incorporating alagalah's recommendations + other's input: done
16:07:58 <tbachman> #chair jmedved
16:07:58 <odl_meetbot> Current chairs: jmedved tbachman
16:08:01 <tbachman> #chair alagalah
16:08:01 <odl_meetbot> Current chairs: alagalah jmedved tbachman
16:08:05 <alagalah> tbachman: "DONE" is a generous description
16:08:14 <tbachman> alagalah: you set up the meeting ;)
16:08:29 <alagalah> tbachman: LOL technically jmedved did but... :)
16:08:55 <tbachman> alagalah: best of both worlds — none of the work and all the credit ;)
16:08:56 <tbachman> lol
16:12:06 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/md_sal_hackers/opendaylight-meeting-md_sal_hackers.2014-11-17-16.00.html correct link to last week’s meeting
16:12:56 <tbachman> #topic action items (revisited)
16:13:36 <tbachman> #action colindixon to update arch wiki page by the end of the day
16:13:55 <tbachman> #action alagalah, jmedved, john, and rovarga to go through rovarga’s proposal step-by-step (continued from last week)
16:14:21 <tbachman> #info alagalah tosend email to rovarga to initiate going through the proposal step-by-step:DONE
16:17:07 <tbachman> #link https://github.com/alagalah/odl-tutorial-toaster alagalah’s github account that’s tracking proposed documentation of pom architecture, etc.
16:17:57 <tbachman> #info jmedved says we’re achieving 2 things with one activity: correct directory and pom structure, and a tutorial for new projects to follow.
16:18:23 <alagalah> #link origin	https://github.com/alagalah/odl-tutorial-toaster.git (fetch)  --- tutorial link WIP
16:19:08 <tbachman> #info edwarnicke says it would be even better if we can tie the tutorial to a maven generated site
16:19:22 <alagalah> ttkacik: ack
16:19:27 <alagalah> edwarnicke: ack
16:19:29 <tbachman> #info ttkacik recommends moving all documentation to a maven site, since this is a Lithium release plan requirement
16:19:43 <alagalah> The audio is particularly heinous today
16:20:00 * tbachman thinks jmedved VOIP is not jitter-free :)
16:20:21 <tbachman> #undo
16:20:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2845fd0>
16:20:58 <tbachman> #info ttkacik says that the Lithium release plan requires things to be in asciidoc format, and recommends moving all documentation to a maven site for all offset 0 projects
16:21:56 <tbachman> #info jmedved to email invites for working on this example: DONE
16:22:50 <tbachman> jmedved: https://wiki.opendaylight.org/view/Meetings
16:23:17 <tbachman> #action colindixon to bring up removing hydrogen artifacts from main download page (continued from last week)
16:25:28 <tbachman> #info for the project proposal, alagalah asks if we want this to be a separate project, or if it should live in documentation
16:26:28 <tbachman> #info colindixon says ODL forge may help here
16:26:48 <tbachman> #info ttkacik suggests having this as part of the release, as once you release, you’d have all the tutorials attached to the release
16:27:17 <tbachman> #info colindixon says it would be good to bring up how to have things tied to the release but not part of it
16:27:47 <tbachman> #info edwarnicke asks what offset we’d want it to be in
16:28:05 <tbachman> #info ttkacik says that since it’s part of the controller, it’s at least offset 1
16:28:38 <ttkacik> tbachman: should read since it uses controller
16:28:46 <tbachman> ttkacik: thx!
16:28:47 <tbachman> #undo
16:28:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24815d0>
16:29:00 <tbachman> #info ttkacik says that since it usese the controller, it’s at least offset 1
16:29:10 * tbachman is glad that folks are reading and checking his work ;)
16:30:35 <tbachman> #info colindixon says that without clear ownership of the cross-project efforts, they turn into dumping grounds
16:31:40 <tbachman> #info alagalah says that for the scope for the project proposal, he can list the things he wants to document over time, and would reach out to contacts who would provide that input.
16:35:31 <tbachman> #action alagalah to come up with a project proposal for a “documentation and tutorial for new projects” project
16:35:58 <tbachman> #info jmedved to include uchau in the 7am PST calls: DONE
16:36:14 <tbachman> next topic?
16:39:26 <tbachman> #topic release plan for M1
16:40:50 <tbachman> #info ttkacik says they’ve started looking into automation of the release process
16:41:45 <tbachman> #info ttkacik says the controller project is using bugzilla to help with release planning
16:42:19 <tbachman> #info ttkacik every enhancement is prefixed with a milestone in bugzilla
16:44:25 <tbachman> #info this allows bugzilla to provide structured information about the individual milestones
16:44:54 <tbachman> #info ttkacik says there are overarching themes that aren’t tied to milestones, but are part of the overall release. These get tied to topics
16:47:51 <tbachman> #info There is an issues-maven plugin which can create release notes, link it to the bugs and issues that are fixed, based on the data exported by bugzilla
16:48:11 <tbachman> #info The same plugin can be used to export the release plan
16:51:52 <tbachman> #info edwarnicke asks when we can get to the point where we can publish a maven site
16:54:03 <tbachman> #info ttkacik says to fully replace the release plan wiki pages, it will be a few months effort
16:55:33 <tbachman> #info edwarnicke asks what can we do to document this style of approach so that projects could adopt it
16:55:52 <tbachman> #info ttkacik says he’d need help from a native english speaker to help
16:56:24 <tbachman> #info edwarnicke to help with the effort
16:56:53 <tbachman> #info edwarnicke asks if this would be a good thing to present on the TWS
16:58:29 <tbachman> #action ttkacik to send an email with a concrete/specific example of how bugzilla can be set up to use for automation of release planning and tracking
17:03:36 <tbachman> #info jmedved would like to see a review of the notifications and associated documentation on the wiki
17:04:08 <tbachman> #info jmedved asks what we should focus on next week
17:07:24 <tbachman> #action jmedved to send email to the mailing list to let folks know that next week’s meeting will be review on the notifications API
17:07:32 <tbachman> #endmeeting