16:03:34 <colindixon> #startmeeting MD-SAL interest call
16:03:34 <odl_meetbot> Meeting started Tue Aug 12 16:03:34 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:34 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:03:38 <colindixon> #topic agenda bashing
16:04:33 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/md_sal_interest_call/ if we call the meeting “MD-SAL interest call” every time the meeting minutes end up at that link
16:05:40 <colindixon> #topic status update
16:06:55 <colindixon> #info around SchemaContext scalability, the yangtools part is done, but there may be some bugs in the netconf part which are being resolve and should be merged soon
16:09:42 <colindixon> #info the DataObject to JSON/XML conversion is waiting on the biding codecs coming in, there’s one remaining patch that needs to be merged
16:11:31 <colindixon> #info otherwise, in the MD-SAL most things are testing and hunting down bugs
16:14:40 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/9068/ this gerrit fixed the swagger RESTCONF explorer to allow posts to work
16:15:29 <colindixon> #undo
16:15:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x24160d0>
16:15:36 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/9068/ this gerrit fixes the swagger RESTCONF explorer to allow posts to work
16:17:27 <colindixon> #info it also makes post broken out in terms of the different models that can be posted to the same URI
16:19:55 <colindixon> #info there is some discussion about this with carol sanders and colindixon voting for the broken up version
16:21:47 <colindixon> #info kent watsen says that the current RESTCONF draft (and REST semantics) for POST would make him think this is illegal
16:25:24 <colindixon> #info loosely, POST means “create” and PUT means “replace” (for the entire document located at this URI)
16:35:40 <colindixon> #info a lot of discussion about how this could work better or not (some of them are that swagger might not be the right tool in the end)
16:37:00 <colindixon> #info ramkumar and andrew kinard say that they find this stuff is incredibly useful because mapping YANG to REST calls is incredibly difficult otherwise
16:38:35 <colindixon> #info in particular they also vote for the breakout by the different things that can be posted
16:40:15 <colindixon> #info everyone agrees that we should be consistent between POST and PUT (which we are not)
16:46:36 <colindixon> #info after (probably way too much) discussion, we basically say we’d like to fix the defect without having to change the swagger layout and we can deal with changing the layout later
16:46:45 <colindixon> #topic questions
16:49:59 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=1514 bug around getting warnings/errors when building pretty much anything today, I’m not sure what the resolution is
16:51:57 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=1512 bug around builders for unions which wind up in src/main/java (it turns out that this is because you need to actually write code for that to work right)
16:53:15 <colindixon> #info the solution to that is likely to add a comment or something else in that fie to make it clear what’s going on
16:53:47 <colindixon> #action colindixon to amend that bug to suggest the fix
16:53:53 <colindixon> #endmeeting