16:14:58 <devinavery> #startmeeting MD-SAL Status Call - July 15th, 2014
16:14:58 <odl_meetbot> Meeting started Tue Jul 15 16:14:58 2014 UTC.  The chair is devinavery. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:14:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:14:58 <odl_meetbot> The meeting name has been set to 'md_sal_status_call___july_15th__2014'
16:15:09 <devinavery> tbachman: Thanks. :) Realized that after I typed it
16:15:12 <tbachman> :)
16:15:18 <devinavery> #topic Status Sync
16:15:40 <devinavery> #info Toaster example updated with example async programming
16:16:29 <devinavery> #info upcoming: Simplify WriteTransaction by changing signature - deprecating old method adding new one
16:16:47 <devinavery> #info Colin asks if using "asyncCommit" instead of "Ready" would make more sense to  others.
16:16:57 <colindixon> oh, thanks
16:17:01 <colindixon> I can help here if you want
16:17:05 <devinavery> #info Robert explains that "ready" means that the transaction is "ready to submit"
16:17:39 <devinavery> #info another suggestion is to use "submit". Looking for opinions on this call.
16:19:46 <devinavery> #info Does "submit" generally apply to transactions?
16:20:41 <devinavery> #info Robert: Transactions which are "Ready" is well known in transaction processing, so it really depends where we get our vocabulary from
16:22:01 <devinavery> #action Tom P to send an e-mail to controller dev to get opinion on submit vs ready. Keep open for 24 hours
16:23:34 <devinavery> #info Question about MD-SAL Clustering - colindixon is providing a quick update
16:24:10 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/status:open+topic:akka-raft,n,z akka raft related commits
16:24:26 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/status:open+topic:clustering,n,z clustering related commits
16:28:40 <devinavery> #topic general questions
16:29:10 <devinavery> #info Can you provide some pointers on the possible query languages being developers for MD-SAL?
16:29:26 <colindixon> #link https://www.youtube.com/watch?v=UihFZpi8E-s youtube video of xsql query stuff from Sharon
16:29:41 <devinavery> #info There is a NO-SQL type language being developed. See notes from previous calls.
16:30:48 <devinavery> #info Also an effort ongoing with an intern to get xpath working with MD-SAL - colindixion, devinavery regXboi, jan medev are working on that
16:31:25 <harman_> #question : or clustering of notification, i need to know what all binding independent interfaces i need to implement to plug akka code with md-sal
16:32:05 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:XSQL this the wiki page which walks through the XSQL (nosql-style) query language and how you can play with it
16:32:45 <devinavery> #info Question about consolidating data models - is anyone working on this?
16:34:02 <devinavery> #info Tony - the model colindixon mentioned is used by the topology exporter.
16:34:33 <devinavery> #info Colindixon: in general there is a desire to move towards having only one inventory/topology. Ask to Tony - do you know if it is on the roadmap?
16:34:55 <devinavery> #info Tony there are some on going discussions. Heavily depends on the community
16:36:01 <devinavery> #info Colin: topology stores hosts, inventory is the root for flows. So you have to translate from topology to inventory and back and forth because of the varying models.
16:36:48 <colindixon> #info topology does not not actually have hosts (at least not at the moment) it stores the links betwee switches
16:37:23 <devinavery> #info Tony: we would need someone to focus on a migration strategy and so far there is no one actively working it.
16:38:18 <devinavery> #info Jan: The open flow call discussed these models and we need to kick off the conversation about the common models. We need to start the discussions within open daylight and then move on to IETF.
16:39:36 <devinavery> #info colindixon: suggestion we need some group of people   (really light way) who can review and track models going into the code and can provide some comments on yangs to help standardizing them
16:40:26 <devinavery> #info colindixon: that group could provide suggestions when models are similar etc.
16:40:44 <devinavery> #info: devinavery: question: should the MD-SAL call start the modeling discussions?
16:41:18 <devinavery> #info colindixon: we should at least open a bug to merge the two models together.
16:41:30 <tbachman> yang doctors
16:41:34 <tbachman> :)
16:41:46 <colindixon> #action colindixon will open a bug for a feature enhancement to merge the inventory and topology models so we can at least track it
16:43:27 <devinavery> #info Next MD-SAL call - we can revisit this discussion about a body of people to review the yang models as they come in. Not proposing a a rigid review body... need to brain storm
16:43:32 * tbachman listens in
16:44:05 <devinavery> #info Question from Colin: If I have a DataObject, is there an easy way to convert that to JSON or XLM without going through restconf
16:44:36 <devinavery> #info Answer: you would need to replicate what resting does under the hood, which is not exposed in a friendly API right now. Question from Colin - should we open an enhancement?
16:45:24 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=1360 this is the bug to track
16:45:27 <devinavery> #info Enhancement 1360 is open and tracking this. Colindixon is willing to start working if he can
16:47:44 <colindixon> sorry
16:48:25 <colindixon> #action robert varga to add some feedback on 1360
16:48:27 <dbainbri> concerned that transform from data object to JSON/XML must be performant, in that if it has to go through 3 services this seems like a lot of overhead.
16:49:19 <devinavery> #endmeeting