16:02:00 <edwarnicke___> #startmeeting MD-SAL Weekly Meeting
16:02:00 <odl_meetbot> Meeting started Tue Apr 22 16:02:00 2014 UTC.  The chair is edwarnicke___. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:00 <odl_meetbot> The meeting name has been set to 'md_sal_weekly_meeting'
16:02:41 <edwarnicke___> #topic Akka Framework discussion and demo
16:04:15 <edwarnicke___> #topic Prototyping Akka in ODL
16:06:27 <edwarnicke___> #info Mathieu Lemay presenting
16:08:49 <edwarnicke___> #info Concerns raised: "Why Datastore?" and "Scala in codebase?"
16:09:25 <jmedved> #info talking about fixing the runtime - werk done with Giovanni and Jamie and about how to port it to Karaf
16:09:28 <edwarnicke___> #info Current status - fixing the runtime (Mix and Match, Karaf Runtime Port, Releases and Features, Need for common underlay (AD-SAL and MD-SAL)
16:10:09 <edwarnicke___> #topic Why DataStore?
16:12:22 <edwarnicke___> #info Datastore prototype useful to test Akka's clustering store in ODL
16:12:49 <edwarnicke___> #info Would like to be able to have partial features running within different controller cluster nodes and have proper messaging
16:13:48 <edwarnicke___> #info Many options for datastore (inside/outside the controller etc)
16:13:56 <edwarnicke___> #info purpose is to drive more efficient message handling in ODL
16:14:52 <edwarnicke___> #topic Scala in the codebase?
16:15:37 <jmedved> 3info put scala code into the code base or wrap scala code in java apis?
16:15:37 <edwarnicke___> #info How should we handle scala in ODL?
16:15:57 <jmedved> #info put the scala code into their own repos, or put them into ODL repos?
16:16:53 <jmedved> #info ewarncike echoes conrerns avbobut scala: 1 yet another language, 2. support scala also means you have to support the scala compiler, which is a bigger issue
16:17:15 <jmedved> #info mlemay talked to chris wright about this as well
16:17:35 <jmedved> #info ewarncike is personally excited about scala, but there are concerns
16:18:13 <jmedved> #info mlemay : there is already impedance for new comers to grok the codebase, and scala just adds to it. akka support the java environment, so why not use it?
16:19:20 <jmedved> #info ewarnicke says that there are tradeoffs, e.g. are the some core pieces to which we limit ourselves? mlemay says that why want to discuss it now; there are different ways to wrap it up or hide it
16:21:27 <jmedved> #info mlemay says there are different ways to address akka - one is to make it fully separate and not in core ODL, which is the direction in which we seem to be going now; mlemay wants to make sure the issue is addressed  the rigth way
16:21:57 <jmedved> #info david bainbridge voices conerns about supporting scala - there is not much expertise out there
16:24:24 <jmedved> #info question is akka linked to scala? mlemay: akka is written in scala, so introducing akka will introduce scala into ODL one way or another
16:24:55 <jmedved> #info dbainbridge we need one implementation behind java libraries
16:25:32 <jmedved> #info ashish chirputkar: how idfferent is this from having an external componet such as a DB which is written in a different language?
16:27:46 <jmedved> #info rvarga: having swappable data store is good, and we do not have to have a swappable data store within a distribution
16:28:04 <jmedved> #info different distributions can use different data stores
16:29:37 <edwarnicke___> #topic Controller Runtime
16:29:42 <jmedved> #info mlemay: prototype implementation well underway, should be done within a day or two
16:29:54 <edwarnicke___> #info mix and match from felix, virgo, gemini and different OSGI versions
16:30:10 <jmedved> #info mlemay: current runtime a “mix and match” to meed needs & requirements in ODL
16:30:21 <icbts> yes
16:30:51 <jmedved> #info mlemay: runtime being ported to Karaf with help of Jamie Goodyear
16:31:38 <jmedved> # info Karaf has a nicer shell and fucntionality such as features; all components of the controller are being turned into Karaf features
16:31:51 <jmedved> #info projects will follow the same pattern
16:32:15 <jmedved> #info what you get: nicer console, noicer loggin, admin & security features, blueprints, etc
16:32:42 <icbts> Please share the gerrit id :)
16:32:49 <edwarnicke___> #info karaf gerrit should be coming shortly from mlemay :)
16:32:52 <jmedved> #info Karat ditro will be in the distributions folder, it will be pusehd as a set of patches
16:34:36 <dbainbri> I missed the beginning of the meeting and didn't see this in the notes. when is this targeted for release? Helium ?
16:34:43 <jmedved> #info ewarnicke: more to karaf not a radical shift, it’s just a better OSGI container
16:35:54 <jmedved> #info other projects in production that may be using Karaf? jboss, opennms, apache service mix, other companies
16:37:21 <jmedved> #info rovarga brings out a point that migrating will not be easy. a barebones distro should be build into which apps can be moved into
16:38:48 <jmedved> #info dbainbridge are we expecting projects APIs changes?
16:39:11 <jmedved> #ino mlemay: no api changes, just packages changes, maybe changes to shell/cli
16:40:27 <jmedved> #info ewarnicke: for example, if somebody has a cli based on current container, it needs to be ported; then features need to be introduced into project; this has impact on versioning, bundles can have their own version, features follow release versioning
16:40:42 <jmedved> #info will this help unifying the sals?
16:40:57 <jmedved> #info karaf is just a container, nothing to do with the SALs
16:41:52 <jmedved> #info madhu happy to move ovsdb onto feature, multiple oriject running in veritualization ed twhere certain bundles are filtered out a feature w/o breaking things?
16:42:52 <jmedved> #info jamie: generally design a feature as subfeatures, a bundle can be part of multiple features
16:43:30 * icbts Jamie == icbts
16:47:16 <Madhu> #action can we make sure the release management for karaf distribution and existing distribution are compatible
16:50:29 <jmedved> #info rovarga: for migraton start with a new base edition which gives us a playground for experimenting with new things
16:52:55 <jmedved> #info concern about forking too much, too many editions, must have one edition that everybody can use
16:53:23 <jmedved> #info erwarnicke: project must have space to sort this out;
16:57:50 <dbainbri> #question so for teams coming into ODL, do they now develop their code against, AD-SAL, MD-SAL? Base Edition? Karaf Edition? It gets real confusing for people attempting to on board. I agree we need a playground.
20:00:31 <tykeal> #endmeeting