16:07:39 <alagalah> #startmeeting MDSAL call
16:07:39 <odl_meetbot> Meeting started Tue Jul 29 16:07:39 2014 UTC.  The chair is alagalah. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:07:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:07:39 <odl_meetbot> The meeting name has been set to 'mdsal_call'
16:07:47 <alagalah> #chair tbachman edwarnicke
16:07:47 <odl_meetbot> Current chairs: alagalah edwarnicke tbachman
16:07:53 <alagalah> #link https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call#Agenda
16:08:20 <alagalah> #topic Status update (as per Agenda)
16:08:49 <alagalah> #info edwarnicke is chairing meeting on webex
16:09:00 <edwarnicke> alagalah: LOL...
16:09:19 <tbachman> #info  rovarga_ says that there was a renaming of the binding independent instance identifier to a yang instance identifier
16:09:38 <alagalah> tbachman: Thanks mate
16:09:45 <tbachman> alagalah: np :)
16:09:58 <alagalah> #info edwarnicke to share code to describe what rovarga_ just mentioned
16:10:03 <rovarga_> #link https://git.opendaylight.org/gerrit/#/c/9427/
16:10:19 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/9427/ gerrit for the instance identifier change
16:10:29 <tbachman> rovarga_: I think only the chairs can do the links, maybe?
16:10:35 <tbachman> (wasn’t trying to steal your thunder :) )
16:10:43 <alagalah> tbachman: No
16:10:51 <tbachman> or is it just actions?
16:11:03 <alagalah> tbachman: Chairs are the only ones who can do topics, actions, voting
16:11:08 <tbachman> ah, k
16:11:08 <tbachman> thx
16:11:10 <alagalah> tbachman: At least thats my understanding
16:11:45 <tbachman> #info edwarnicke says that most people are using the binding aware versions, rather than the binding indepndent versions
16:12:24 <alagalah> #info edwarnicke explains that binding aware version is java class specific, but binding independent allows you to describe restconf etc
16:13:22 <alagalah> edwarnicke: Silence is acquiescence in my book
16:13:59 <tbachman> #info This change has to do with renaming the case that most don’t use (binding independent case) and the more popular case be just “binding” (discussed on last week’s call).
16:14:29 <edwarnicke> tbachman: Don't use directly
16:14:39 <tbachman> edwarnicke: thx
16:15:35 <tbachman> #info rovarga_ says that the change is already in to both yangtools and the controller
16:17:47 <flaviof> #link https://gist.github.com/anonymous/790487c28a4dbf8b7dc3
16:17:51 <tbachman> #info xsql is broken by this change, but that’s because it’s not part of the default build
16:19:27 <tbachman> #info colindixon points out that setting up integration jobs for the projects they depend on
16:19:40 <tbachman> #info edwarnicke says that this was part of the M3 criteria
16:20:23 <LuisGomez> #link https://wiki.opendaylight.org/view/GettingStarted:Jenkins_Integration_Job_Setup
16:20:47 <tbachman> #info edwarnicke submitted a patch yesterday that wired up the restconf subsystem to the config subsystem
16:23:13 <rovarga_> #link https://git.opendaylight.org/gerrit/#/c/9443/ should fix XSQL
16:25:31 <flaviof> #link https://git.opendaylight.org/gerrit/#/c/9322/
16:25:58 <tbachman> #info flaviof asks a question about using the createparent flag in the databroker
16:26:27 <tbachman> #info edwarnicke asks if it is more work to use an API like this, or to test for the existence directly
16:27:55 <tbachman> #info edwarnicke recommends for flaviof to push a patch implementing what he’d like to see for an API
16:28:18 <tbachman> #info ttkacik recommends implementing this as a utility function on top of the API
16:28:51 <flaviof> sounds good, Ed
16:28:53 <flaviof> thanks
16:29:09 <edwarnicke> flaviof: Excellent :)
16:29:28 <colindixon> queue: {colin, ramkumar}
16:29:32 <colindixon> #link https://lists.opendaylight.org/pipermail/yangtools-dev/2014-July/000334.html
16:29:42 <tbachman> #topic yangtools
16:29:57 <tbachman> #link https://lists.opendaylight.org/pipermail/yangtools-dev/2014-July/000334.html
16:30:18 <tbachman> #info colindixon says that if you have a singleton list it gets converted to an element, and not a list
16:30:30 <tbachman> #info colindixon asks if this is intentional, or if this is a bug
16:31:00 <tbachman> #info ttkacik says that this is a bug, but needs to look into the API that specifies this behavior. It could be a regression introduced by restconf
16:31:34 <tbachman> #action colindixon will open a bug on this for tracking purposes
16:31:56 <tbachman> #info colindixon asks if there is an RFC for this
16:32:43 <rovarga_> #link http://tools.ietf.org/html/draft-bierman-netconf-restconf-02 is the current spec we implement
16:32:52 <tbachman> rovarga_: thx!
16:33:02 <colindixon> rovarga_: thanks I’m looking
16:33:24 <rgowrishankar> Bug 1418 https://bugs.opendaylight.org/show_bug.cgi?id=1418
16:33:31 <tbachman> #topic bug 1418
16:33:52 <tbachman> #link https://bugs.opendaylight.org/show_bug.cgi?id=1418 bug for notifications on data change
16:34:14 <tbachman> #info rgowrishankar filed this bug last week, and found that this worked in older versions of ODL
16:34:59 <tbachman> #info rovarga_ says that ttkacik is looking into this
16:35:26 <tbachman> #info ttkacik says that 1418 that data change notifications are empty if leafs are augmentations
16:35:36 <tbachman> #info ttkacik says that there may be a fix for this by Friday
16:36:02 <tbachman> #info rgowrishankar says that he’s working off an older version of ODL for now
16:37:35 <tbachman> #info rgowrishankar says that there were QName issues when going back to this version
16:37:50 <tbachman> #info edwarnicke mentions that there are weekly releases
16:38:14 <edwarnicke> #link https://nexus.opendaylight.org/content/repositories/opendaylight.weekly/
16:40:17 <edwarnicke> #info maven clean install -nsu
16:40:18 <tbachman> #info edwarnicke says to also be careful with mvn, as it may pull in versions of things that are more recent than what you want
16:40:46 <marcbe-sel> Is there a wiki page for the weekly builds?
16:41:01 <tbachman> #info edwarnicke recommends using -nsu (no snapshot updates)
16:43:19 <tbachman> #info colindixon says that the weekly releases still have the problem where other bundles pull in newer dependencies than are needed
16:43:46 <tbachman> #info and that tracking down all these dependencies and fixing them isn’t scalable
16:45:07 <tbachman> #info dbainbri asks if there is a way to parameterize this?
16:45:39 <tbachman> #info edwarnicke says that this would not save you in cases where you have pointers up to the parent project
16:46:00 <flaviof> marcbe-sel: +1  (Is there a wiki page for the weekly builds?)
16:46:38 <tbachman> flaviof: marcbe-sel: edwarnicke put this link in above: https://nexus.opendaylight.org/content/repositories/opendaylight.weekly/
16:46:41 <tbachman> Is that not it?
16:47:35 <flaviof> tbachman: that looks like a build repo (to me): https://www.dropbox.com/s/kebwrq1jvzqg3rw/Screenshot%202014-07-29%2012.47.30.png
16:48:11 <tbachman> :)
16:48:18 <marcbe-sel> Yeah, that is just the maven repo
16:48:27 <tbachman> #topic name generation from yang
16:48:40 <marcbe-sel> I was hoping for a git branch or tag to point to.
16:49:07 <edwarnicke> marcbe-sel: We have a known need to backhaul the tags to the projects
16:49:15 <edwarnicke> If you would like, I could explain to you the state of getting that done
16:49:22 <tbachman> #info colindixon provides an example where you have a container with a list
16:49:28 <edwarnicke> And would *love* it if someone would be willing to drive it forward.
16:49:56 <marcbe-sel> Sure, thanks.
16:49:56 <tbachman> #info even though it’s a list in yang, it’s instead a single item (using TTP code as an example)
16:50:17 <tbachman> colindixon: do you have a link for the code to look at here?
16:50:36 <tbachman> #info colindixon asks if this was done intentionally
16:51:03 <tbachman> #info ttkacik says this is covered in the yang specification. The keyword after a list is the name of one item.
16:53:08 * edwarnicke mourns the decline of the genitive case :(
16:53:44 <tbachman> #info rovarga_ says that yang is XML-centric, and the way you represent lists in XML is lay out the individual items. There’s no container for the list itself.
16:54:40 <tbachman> #info kwatsen says that there is a best practice in using a container
16:55:29 <tbachman> #info colindixon says that we really could use a style-guide for YANG
16:56:35 <flaviof> colindixon: +1
16:57:12 <tbachman> #info kwatsen says that a style guide is being created
17:03:01 <tbachman> #info kwatsen says that there are also “yang doctors”, somewhat “on call”, to help with yang modeling
17:03:20 <tbachman> edwarnicke: time check?
17:03:54 <tbachman> #endmeeting