#opendaylight-meeting Meeting

Meeting started by colindixon at 17:46:40 UTC (full logs).

Meeting summary

    1. the google doc of release tasks can be found here: https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 (colindixon, 17:47:23)
    2. ACTION: Madhu will push a patch to integration which generates a new target to build the list of version skew so that we can track daily skew in the release (colindixon, 17:55:44)
    3. in order to build per project version out-of-sync messages we will need to great jenkins jobs per project (colindixon, 17:57:55)
    4. ACTION: Madhu will work with cdub and tykeal to migrate the *purely information* versions job to all projects participating with in the simultaneous release (colindixon, 17:58:47)
    5. great phrobb, that means we can get started with the actual insertion on it's 1/15 start date (colindixon, 18:01:42)
    6. suggested copyright headers can be found here https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files (colindixon, 18:02:17)
    7. ovsdb project uses author tag as well (Madhu, 18:09:13)
    8. ACTION: phrobb to consult legal counsel to make sure that we can adopt https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files as formal practice for copyright notices (colindixon, 18:12:29)
    9. AGREED: to use the template for copyright headers at https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files pending phrobb checking with legal counsel (colindixon, 18:14:18)

  1. bundle versions for release (colindixon, 18:14:50)
    1. we're talking about line 39 for now, we'll go back to the top of the spreadsheet later (colindixon, 18:16:55)
    2. HELP: anyone wanting to help with the user manual template and/or developers' guide template should e-mail RobDolin at RobDolin@microsoft.com (colindixon, 18:24:30)
    3. tabling the discussion of synchronized versions for a later date (colindixon, 18:25:42)
    4. ACTION: Madhu will send out a sequence in which projects can fix their hydrogen release version numbers and will coordinate with team leads to do that starting on 1/15, moving from SNAPSHOT -> RELEASE will happen later and artifacts won't be cut until 1/27 (colindixon, 18:28:22)

  2. release notes (colindixon, 18:29:11)
    1. I have written up sample release notes, put them here: https://wiki.opendaylight.org/view/Sample_Release_Notes#Known_Issues_and_Limitations and asked for feedback on the mailing list. (colindixon, 18:29:48)
    2. I have made some effort to root out scala (edwarnicke, 18:35:05)
    3. ACTION: colindixon will look into creating a section for project and edition release notes for hydrogen (colindixon, 18:35:36)
    4. ACTION: edwarnicke will help colindixon to produce a list of required tools for running based on the used languages in the release for the release notes (colindixon, 18:36:11)
    5. HELP: anyone who wants to shape the release notes should provide feedback to my e-mail to discuss or reach out to me, or maybe even just edit the wiki page (colindixon, 18:36:52)

  3. testing for JVM and OS platforms (line 36) (colindixon, 18:38:58)
    1. ACTION: anees and/or shague_ to add fedora to the list of OSes, also to add JVM columns and decide which JVMs we're testing (colindixon, 18:45:00)
    2. on the mailing list, somebody was saying that they had out of memory errors with the Oracle JVM on Ubuntu (colindixon, 18:45:32)
    3. I have used openjdk successfully on ubuntu, and Oracle JDK successfully on MacOS X Maverick (and Mountain Lion before that... but its been a while) (edwarnicke, 18:46:24)
    4. I'm going to try to focus the topics on things due tomorrow for a while (colindixon, 18:46:53)

  4. documenting how to cut release artifacts (colindixon, 18:49:34)
    1. HELP: we need somebody to volunteer to write up documentation about how to do this (colindixon, 18:49:46)

  5. investigate signing of release docs (colindixon, 18:50:31)
    1. ACTION: tykeal to talk to kernel.org about their code signing process to see if we could use it, sounds not totally promising (colindixon, 18:53:05)

  6. download page (colindixon, 18:55:09)
    1. phrobb and others are meeting today about the download page (colindixon, 18:57:25)

  7. switching meeting to 9a PST for india (colindixon, 18:59:42)
    1. AGREED: on moving the morning meeting to 9a for india since there were no objections (colindixon, 19:00:00)


Meeting ended at 19:00:04 UTC (full logs).

Action items

  1. Madhu will push a patch to integration which generates a new target to build the list of version skew so that we can track daily skew in the release
  2. Madhu will work with cdub and tykeal to migrate the *purely information* versions job to all projects participating with in the simultaneous release
  3. phrobb to consult legal counsel to make sure that we can adopt https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files as formal practice for copyright notices
  4. Madhu will send out a sequence in which projects can fix their hydrogen release version numbers and will coordinate with team leads to do that starting on 1/15, moving from SNAPSHOT -> RELEASE will happen later and artifacts won't be cut until 1/27
  5. colindixon will look into creating a section for project and edition release notes for hydrogen
  6. edwarnicke will help colindixon to produce a list of required tools for running based on the used languages in the release for the release notes
  7. anees and/or shague_ to add fedora to the list of OSes, also to add JVM columns and decide which JVMs we're testing
  8. tykeal to talk to kernel.org about their code signing process to see if we could use it, sounds not totally promising


Action items, by person

  1. colindixon
    1. colindixon will look into creating a section for project and edition release notes for hydrogen
    2. edwarnicke will help colindixon to produce a list of required tools for running based on the used languages in the release for the release notes
  2. edwarnicke
    1. edwarnicke will help colindixon to produce a list of required tools for running based on the used languages in the release for the release notes
  3. Madhu
    1. Madhu will push a patch to integration which generates a new target to build the list of version skew so that we can track daily skew in the release
    2. Madhu will work with cdub and tykeal to migrate the *purely information* versions job to all projects participating with in the simultaneous release
    3. Madhu will send out a sequence in which projects can fix their hydrogen release version numbers and will coordinate with team leads to do that starting on 1/15, moving from SNAPSHOT -> RELEASE will happen later and artifacts won't be cut until 1/27
  4. phrobb
    1. phrobb to consult legal counsel to make sure that we can adopt https://wiki.opendaylight.org/view/Project_Proposals:Code_Prep_Suggestions#Copyright_and_license_headers_in_source_code_files as formal practice for copyright notices
  5. shague_
    1. anees and/or shague_ to add fedora to the list of OSes, also to add JVM columns and decide which JVMs we're testing
  6. tykeal
    1. Madhu will work with cdub and tykeal to migrate the *purely information* versions job to all projects participating with in the simultaneous release
    2. tykeal to talk to kernel.org about their code signing process to see if we could use it, sounds not totally promising


People present (lines said)

  1. colindixon (139)
  2. Madhu (94)
  3. edwarnicke (72)
  4. tykeal (24)
  5. ashaikh (19)
  6. phrobb (13)
  7. GiovanniMeo (8)
  8. abhijitkumbhare (6)
  9. dmm (4)
  10. RobDolin (3)
  11. goldavberg (3)
  12. shague_ (3)
  13. odl_meetbot (2)
  14. michal_rehak (1)
  15. LuisGomez (1)
  16. Konstantin (1)


Generated by MeetBot 0.1.4.