01:49:02 <colindixon> #startmeeting
01:49:02 <odl_meetbot> Meeting started Tue Jan 21 01:49:02 2014 UTC. The chair is colindixon. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:49:02 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
01:49:11 <colindixon> #topic roll call and agenda
01:49:19 <tykeal> #info Andrew Grimberg for infrastructure support
01:49:30 <hideyuki> #info Hideyuki Tai for VTN Project
01:49:32 <Christine_> #info Christine for SNMP4SDN
01:49:33 <dbainbri> #info present just being a chicken
01:49:37 <colindixon> so, if people who are here can pound info their name, that would be great!
01:49:40 <colindixon> dbainbri: lol
01:49:41 <colindixon> thanks!
01:49:44 <suchiraman> #info suchiraman for affinity
01:50:02 <tykeal> things that end up in the minutes...
01:50:12 <colindixon> #link https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf I used this as an agenda for this morning's meetings and I think it also is going to be useful here
01:50:27 <colindixon> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=13 is the spreadsheet we're using to track everything as always
01:50:28 <hideyuki> colindixon: ok.
01:51:09 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-20-17.00.html are the minutes from the earlier meeting and they have a bunch of useful information including a long discussion about cutting artifacts
01:51:27 * colindixon just tries to get all the useful links out to people
01:51:41 <Christine_> thanks, colin
01:51:55 <hideyuki> colindixon: Thank you. I've already read the minutes.
01:52:09 <colindixon> #topic cutting release artifacts (both dry run and scheduling)
01:52:28 <colindixon> so, as you can see in the agenda I put up as a PDF
01:52:46 <colindixon> we're looking for people to try to go through the process of cutting release artifacts before the 27th so it doesn't blindside us too badly
01:52:51 <colindixon> https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf
01:53:22 <colindixon> Christine_ signed up to try to do this with SNMP4SDN
01:53:45 <colindixon> hideyuki and suchiraman, I didn't seen anything for VTN and affinity
01:54:02 <suchiraman> Late to this discussion. Where can we find a how-to on this?
01:54:16 <networkstatic> #info networkstatic for ovsdb
01:54:27 <colindixon> #link https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/configure there's a lot of other info in the minutes from the earlier meeting but this is the link to the job which does a dry run for controller
01:54:32 <Christine_> colindixon: do you mean #agreed that?
01:55:29 <hideyuki> Does "dry run" mean run the Jenkins job "*-bulk-release-prepare-only"?
01:55:30 <colindixon> #action Christine_ will work to do a dry run of cutting release artifacts for SNMP4SDN this week in preparation for the 1/27 real cutting
01:55:46 <colindixon> hideyuki: yes to the best of my knowledge
01:55:49 <colindixon> networkstatic: welcome
01:55:54 <networkstatic> hi sir
01:55:55 <hideyuki> colindixon: thank you.
01:56:08 <colindixon> really, this is just trying to find bugs early if we can
01:56:16 <hideyuki> Shigeru Yasuda or I will work on the "dry run" for VTN Project.
01:56:32 <Christine_> sure, thanks, colin.
01:56:36 <colindixon> #action hideyuki or Shigeru Yasuda will do the dry run for VTN project and update the spreadsheet
01:56:44 <suchiraman> I will do a dry run for affinity.
01:56:49 <colindixon> if you could fill in an owner and maybe an eta that would be great
01:56:50 <colindixon> tahnks!
01:56:55 <hideyuki> colindixon: I will update the spreadsheet later.
01:56:59 <colindixon> thanks
01:57:03 <colindixon> I can do it for you if that's easier hideyuki
01:57:15 <colindixon> #action suchiraman will run a dry run for cutting release artifacts for affinity
01:57:37 <colindixon> #info feel free to reach out to GiovanniMeo_Away, edwarnicke and others for help on this if you run into snags
01:57:42 <colindixon> perfect!
01:57:44 <hideyuki> colindixon: thank you! Due to the corporate firewall, I can not access the spreadsheet from the office.
01:58:20 <colindixon> hideyuki: done
01:58:28 <colindixon> networkstatic: I think I already know the answer for OVSDB
01:58:40 <colindixon> #topic 1/27 cutting of release artifacts schedule
01:59:18 <colindixon> #info in the earlier meeting we decided that we would try to start this at 9a PST and try to have as many people as possible on IRC to be able to fix problems as we cut releases and do integration tests
01:59:29 <networkstatic> +1
02:00:07 <colindixon> Knowing that the time is *awful* for Taipei and Tokyo, I was wondering if there will be people from these project available then
02:00:12 <colindixon> and if not what a good second time would be
02:00:14 <colindixon> maybe this slot
02:00:29 <networkstatic> same for plugin folks in EU
02:00:43 <hideyuki> colindixon: give me a second to talk with my colleagues.
02:00:53 <colindixon> #info phrobb is going to follow up with project individually to try to coordinate this as well, but I wanted to bring it up here so you were aware
02:01:08 <colindixon> hideyuki: perfect
02:01:32 <colindixon> suchiraman and Christine_ does the 9a PST time work for you?
02:01:50 <colindixon> I don't even know what time zone suchiraman
02:01:52 <Christine_> colindixon: ok
02:01:54 <colindixon> networkstatic: yeah
02:02:11 <colindixon> the other kink is that edwarnicke estimates that it will take ~4 hours
02:02:13 <suchiraman> Time is ok for me.
02:02:15 <suchiraman> I'm in EST
02:02:31 <hideyuki> colindixon: Ok. I will discuss with my colleagues about it later, and reply our opinion on it.
02:02:35 <colindixon> which means being awake from 1a-5a taipei (ugh) or 2a-6a tokyo (double ugh)
02:03:02 <hideyuki> I have one question.
02:03:12 <colindixon> #action hideyuki to check with his colleges and let phrobb know whether anyone can make the 9a PST time for cutting release artifacts or if we should schedule a second time as well (which seems likely)
02:03:16 <colindixon> hideyuki: sure
02:03:25 <hideyuki> I think any project does not depend on VTN project.
02:03:32 <colindixon> #info suchiraman can make the time pretty easily
02:04:08 <colindixon> hideyuki: yes, so I think that that pushing your artifact cutting back might be easier, but it means if we hit integration tests we might not have all the people on that we would need to fix if they have a bug causing problems for you
02:04:11 <colindixon> if that' make sense
02:04:12 <hideyuki> So is it needed to cut release artifacts of VTN Project in the same time with other project?
02:04:38 <hideyuki> colindixon: ok. it makes sense to me!
02:05:02 <colindixon> Christine_ so the 1a-5a time slot is ok for you? or we wait to see what VTN choose to do as well?
02:05:03 <Madhu> suchiraman: 1 question
02:05:15 <Madhu> last time i checked Affinity is the only project where the dependency convergence was not done
02:05:18 <Madhu> is it done now ?
02:05:41 <Madhu> https://docs.google.com/spreadsheet/ccc?key=0Anypq0z_rOtOdE1YOUFSejQ0TGk0TkFhbVdEZ0d0VHc#gid=0
02:05:57 <suchiraman> There is one unresolved issue, yes.
02:06:31 <suchiraman> We're currently using felix file filter to de-select some bundles.
02:06:33 <Madhu> ok thanks. this is the first criteria for starting the release version
02:06:41 <hideyuki> My colleagues are not in the office right now. So please go next topic. We (VTN Project) answer about it after this meeting.
02:06:52 <colindixon> #info Christine_ says that the 9a PST time slot should work for her, but if we decide to have a second slot for VTN (and maybe others), we might move SNMP4SDN to that time as well
02:06:59 <colindixon> #topic dependency convergence
02:07:01 <Madhu> suchiraman: felix file filter is runtime. this dependency convergence is build time
02:07:17 <Christine_> colindixon: yes, thanks
02:07:20 <colindixon> Madhu: you can #info things for this topic if you want
02:07:21 <suchiraman> In that case I'm not familiar with the issue. Apologies for no show at previous meetings.
02:07:32 <suchiraman> Please provide some background.
02:07:51 <colindixon> Madhu: the floor is yours
02:08:01 <Madhu> sure.
02:08:22 <colindixon> suchiraman: I think Madhu is looking for the link, but basically there's a jenkins job which you can copy and run that will produce a list of your dependencies and their versions
02:08:31 <colindixon> for internal OpenDaylight dependencies we're trying to get in sync
02:08:37 <Madhu> #info https://docs.google.com/spreadsheet/ccc?key=0Anypq0z_rOtOdE1YOUFSejQ0TGk0TkFhbVdEZ0d0VHc#gid=0 tracks all the changes needed across the projects
02:08:45 <Madhu> to have same internal dependencies
02:09:06 <colindixon> it will then produce a gerrit patch that updates to the most recent versions and you can then see if there are any bugs you need to fix
02:09:12 <Madhu> only after all the projects have consistent dependency, release artifacts of them can be cut to make sure there are no dependency mismatches
02:09:22 <Madhu> and testing must be done on that version of the bundle.
02:09:32 <colindixon> Madhu, pound linking works better than pound info for links
02:09:43 <colindixon> Madhu: also, do you have the link to the jenkins job she can use?
02:09:44 <suchiraman> I'll take an action on this.
02:09:46 <Madhu> #info https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:DependencyConvergence
02:09:58 <Madhu> this link will give u all the details on what is to be done
02:10:15 <colindixon> #action suchiraman will run the dependency version jobs on affinity
02:10:22 <Madhu> #info this is a sample jenkins job in controller branch : https://jenkins.opendaylight.org/controller/job/controller-version-changes/configure
02:10:34 <colindixon> thanks Madhu
02:10:36 <colindixon> thanks suchiraman
02:10:36 <Madhu> suchiraman: if u need help, i can lend my hand.
02:10:47 <suchiraman> Thanks Madhu.
02:10:50 <Madhu> but i don't have privilege to change affinity jenkins
02:10:58 <Madhu> we can be in a meeting and get this done
02:11:05 <suchiraman> I'll create the jenkins jobs asap.
02:11:07 <Madhu> hangout maybe
02:11:10 <Madhu> thanks suchiraman
02:11:10 <suchiraman> ok
02:11:28 <colindixon> #topic testing with the open flow 1.3 plugin
02:11:58 <colindixon> so, if projects are planning to test against the new OF1.3 plugin
02:12:01 <colindixon> we'd like to start doing so
02:12:17 <networkstatic> who is using 1.3 Colin?
02:12:23 <networkstatic> i asked on the TWS
02:12:27 <colindixon> if you're not planning to support it, that's fine, but it's useful to konw
02:12:28 <networkstatic> for hydrogen
02:12:43 <colindixon> networkstatic: I think it's OVSDB + Controller and that's it, but I'm not sure
02:12:52 <networkstatic> rogr, what it sounded like earlier
02:12:57 <hideyuki> VTN Project does not support OF 1.3.
02:13:12 <networkstatic> ty hideyuki just looking for people to trade notes w/
02:13:17 <colindixon> Christine_, hideyuki, suchiraman are you planning to use the new plugin
02:13:31 <colindixon> hideyuki: I will mark that in the spreadsheet
02:13:48 <colindixon> #info VTN will not make use of and thus not test against OF1.3 (updating spreadsheet to account for this)
02:13:56 <hideyuki> We are interested in the new OF plugin, but do not have any plan to implement it so far.
02:14:01 <hideyuki> colindixon: thank you!
02:14:03 <suchiraman> I'm hoping it's minimal effort to qualify of1.3 vs. affinity.
02:14:32 <colindixon> suchiraman: it's basically just adding a -of13 to the run script and making sure things still work I think
02:14:44 <suchiraman> Any internal changes? We use FRM.
02:14:56 <Christine_> colindixon: no
02:15:04 <Madhu> colindixon: its not that simple
02:15:05 <suchiraman> Cool. We'll do that for 1/27.
02:15:11 <suchiraman> Oops.
02:15:23 <Madhu> suchiraman: if the features are 1.0 compatible
02:15:25 <colindixon> Madhu go on, you know this better than I do
02:15:35 <Madhu> then I hope FRM will do.
02:15:50 <Madhu> there is 1 open item with the nodeid:node type which needs attention.
02:15:55 <Madhu> Ed said he will take care of that.
02:15:57 <colindixon> #info Christine_ states that SNMP4SDN doesn't use (or plan to use) the OF1.3 plugin
02:16:10 <colindixon> Christine_ I'll update the spreadsheet to note that
02:16:19 <Madhu> suchiraman: if you need OF1.3 specific feature. then FRM will not work
02:16:26 <Christine_> colindixon: ok, thank you :)
02:16:36 <Madhu> because there are no APIs in FRM that will get u to 1.3 (such as multiple tables)
02:16:45 <Madhu> so you have to use the MDSAL flow programmer APIs
02:16:46 <suchiraman> No, affinity uses only 1.0 features.
02:17:00 <colindixon> I think that suchiraman was saying that affinity is not planning to use any new OF1.3 features, but would like to know if they work with the openflowplugin backing the NSFs
02:17:35 <Madhu> suchiraman: okay. if u r not planning on 1.3 features, then sure you should try the FRM backed with MDSAL APIs
02:17:38 <colindixon> in which case I think they need to run their tests with both, which they're probably only testing against the OF1.0 plugin
02:17:43 <Madhu> i haven't tried it myself
02:17:43 <colindixon> right
02:17:58 <colindixon> Madhu: do you know how to do that easily?
02:18:05 <colindixon> Luis is the master of that
02:18:05 <Madhu> yes.
02:18:06 <suchiraman> Is there a sample application using mdsal_frm?
02:18:15 <Madhu> -of13 should take care of it ideally
02:18:20 <Madhu> because of the FRM adaptors
02:18:22 <colindixon> Madhu: if you can pound link a pointer to how to do it, that would be great
02:18:29 <Madhu> the MDSAL / OF13 should hide it
02:18:29 <Madhu> sure.
02:18:30 <suchiraman> ok, will try it.
02:18:50 <hideyuki> Madhu: let me confirm this.
02:19:17 <Madhu> #info with FRM adaptors, the MDSAL (and the OF1.3 plugin) must be hidden behind the FRM APIs. and hence applications can make use of the FRM apis to make use of the new API. (I haven't tried it myself. but this is the theory)
02:19:18 <hideyuki> Does FRM hide the difference between the new OF plugin and old Plugin?
02:19:41 <hideyuki> i see.
02:19:45 <suchiraman> How about stats manager - does -of1.3 adapt all interfaces from ad -> md.
02:19:45 <hideyuki> Madhu: thank you!
02:19:50 <Madhu> hideyuki: yes. that is the theory and hand the adaptors should take care of it.
02:19:58 <colindixon> #action suchiraman will get the normal tests for aftinity running both with the old and new openflow plugins to make sure no new bugs show up
02:20:16 <colindixon> suchiraman: in theory all the NSFs should be adapted
02:20:18 <Madhu> #info there are some finer points about OF1.0's short port numbers vs OF1.3 long
02:20:31 <Madhu> #info also the OF1.0 and OF1.3 reserved ports range.
02:20:31 <colindixon> but we want to test with both backing implementations to make sure we don't get bitten by anything
02:20:39 <Madhu> yep.
02:20:55 <Madhu> action is on all of us who are planning to use the new plugin to back the FRM APIs
02:21:07 <Madhu> networkstatic: we have this as well :(
02:21:20 <colindixon> hideyuki: does that mean that you would like to work with the adaptation layer for the new openflow driver and test it?
02:21:36 <Madhu> #info ovsdb team is currently using old OF plugin for OF1.0 and new plugin for OF1.3. (no adaptor usage still)
02:22:05 <hideyuki> colindixon: I'm interested in it. I will discuss about it with my colleagues.
02:22:14 <colindixon> ok
02:22:18 <colindixon> but you do use the OF1.0 plugin now?
02:22:26 <hideyuki> colindixon: correct.
02:22:58 <colindixon> #action hideyuki will confer with his colleagues as to whether they intend to support working with the OF1.3 plugin backing the AD-SAL NSFs
02:23:11 <colindixon> ok
02:23:19 <colindixon> this has been useful
02:23:32 <colindixon> Madhu: do we have a link that explains how to set up those tests yet?
02:23:44 <colindixon> or an example jenkins job?
02:24:04 <Madhu> hmm.. it is no different
02:24:22 <Madhu> am info'ing it now
02:24:28 <colindixon> link it
02:24:30 <colindixon> not info
02:24:42 <Madhu> i don't have a link. but will try to find it :)
02:24:48 <colindixon> ok
02:24:50 <colindixon> if you do great!
02:24:50 <tykeal> yay I've got someone else saying to do that now ;)
02:25:00 <colindixon> #topic download page
02:25:18 <colindixon> #info just so people know phrobb and shague_ are working on this stuff and good progress is being made
02:25:20 <Madhu> #info use integration branches's base edition and use the -of13 option to load the new plugin and then use the FRM apis as normal
02:25:27 <Madhu> got to go guys. bye
02:25:35 <networkstatic> see u buddy
02:25:37 <colindixon> #topic signing release artifacts
02:26:04 <colindixon> there was a lot of discussion about this with tykeal and other this morning
02:26:22 <colindixon> it seems as though we might not sign release artifacts for this edition unless somebody plans to step forward
02:26:43 <colindixon> otherwise, I think that's what I had wanted to get through
02:27:01 <colindixon> Christine_, networkstatic, tykeal, suchiraman, hideyuki, were there any other topics you wanted to cover
02:27:03 <colindixon> or questions you have
02:27:09 <tykeal> no, I'm good
02:27:18 <networkstatic> no sir, appreciate it
02:27:44 <Christine_> colindixon: no, thank you
02:27:46 <hideyuki> A question about this page: https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:ReleaseRecommendations
02:28:15 <hideyuki> I saw this notion "Please review these & ask any questions you might have. Dont copy it yet to your projects." under the links to Jenkins jobs.
02:28:17 <colindixon> oh, I will post to the wiki and e-mail out about getting release notes, release review documents, user manuals and developer guides soon so that we can start on that in a good place
02:28:48 <colindixon> hideyuki: that's only for the "final publish"
02:28:57 <hideyuki> So should we wait copy these jenkins job yet?
02:29:17 <hideyuki> Oh, I see!
02:29:33 <colindixon> I think that the "prepare only" is the dry run and that you can copy that
02:29:42 <colindixon> tykeal: do you know
02:29:53 <colindixon> or anyone else?
02:29:56 <tykeal> colindixon: I think you're correct on that
02:30:08 <hideyuki> colindixon: tykeal : thank you!
02:30:08 <tykeal> I'm honestly not certain as I haven't looked over either job
02:30:36 <colindixon> hideyuki: if you wanted to wait until edwarnicke, Madhu_offline, or GiovanniMeo_Away could comment on that, that would be OK too, but I'm pretty sure that's the case
02:30:40 <colindixon> networkstatic: do you know?
02:30:51 <tykeal> but I believe the prepare-only was the one that GiovanniMeo_Away was linking in the meeting earlier today
02:30:58 <colindixon> it was
02:31:07 <colindixon> I know surprisingly little. I'm just a good person to connect people.
02:31:15 <networkstatic> not sure boss :(
02:31:18 <colindixon> ok
02:31:24 <hideyuki> ok.
02:31:55 <colindixon> hideyuki: based on this morning's meetings, I'm 99% sure that it's fine to copy it and that it's designed to have no repercussions, but there was an extensive discussion of it in the logs if you want to go look
02:32:40 <hideyuki> colindixon: thank you! I'll check the logs, and review the configuration of the jenkins job.
02:32:53 <colindixon> ok
02:32:56 <colindixon> perfect
02:33:09 <colindixon> #topic dry runs of cutting releases
02:33:53 <colindixon> #info hideyuki asked if the prepare-only jenkins job was ready to copy to projects, colindixon said he was 99% sure it was but referred to GiovanniMeo_Away, edwarnicke, or Madhu_offline for a 100% answer
02:34:08 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-20-17.00.log.html#l-104 the answer may also be in the logs from the earlier meeting around this point
02:34:10 <colindixon> perfect
02:34:18 <colindixon> I'll let everyone get back to real work then
02:34:35 <tykeal> thanks colindixon
02:34:41 <networkstatic> thanks buddy, night guys
02:34:42 <suchiraman> bye
02:34:43 <colindixon> #endmeeting