#opendaylight-meeting Meeting

Meeting started by colindixon at 17:00:13 UTC (full logs).

Meeting summary

  1. roll call and agenda (colindixon, 17:00:18)
    1. Madhu here (Madhu, 17:00:33)
    2. Phil Robb here (phrobb, 17:00:57)
    3. rovarga for bgpcep and yangtools (rovarga, 17:00:59)
    4. Anees / opendove (ashaikh, 17:01:10)
    5. Konstantin for defense4all (Konstantin_, 17:01:18)
    6. dkutenic for bgpcep (dkutenic, 17:01:50)
    7. oflibMichal for the openflowjava (oflibMichal1, 17:02:09)
    8. Andrew Grimberg for infrastructure support (tykeal, 17:02:44)
    9. https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf that was the agenda for last time and includes the things that were due yesterday or earlier (colindixon, 17:02:56)
    10. goldavberg for lispflowmapping (goldavberg, 17:02:59)

  2. external dependencies (colindixon, 17:03:42)
    1. actually internal and external dependencies (colindixon, 17:04:22)
    2. Madhu managed to connect with such about affinity which was the last project to start synching on internal dependences (colindixon, 17:04:47)

  3. testing with the new openflowplugin (the -of13 option) (colindixon, 17:05:19)
    1. michal_rehak / openflowplugin (michal_rehak, 17:05:56)
    2. Abhijit Kumbhare / openflowplugin (abhijitkumbhare, 17:06:13)
    3. projects that want to use OF1.3 features from the new openflow plugin should start testing with it immediately, I think that's just controller and OVSDB (colindixon, 17:07:52)
    4. projects that use the old openflow plugin and want to see if they also work via the adaptor bundles on the new one should also test (colindixon, 17:08:14)
    5. Madhu and OVSDB are experiences some issues and are debugging (colindixon, 17:08:30)
    6. https://lists.opendaylight.org/pipermail/discuss/2014-January/001096.html this e-mail from Luis explains how to do the testing if you want (colindixon, 17:10:08)
    7. Madhu to connect with prasanna about issues with OVSDB (colindixon, 17:11:09)
    8. Ed Warnicke for controller (edwarnicke, 17:11:51)
    9. https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 (colindixon, 17:13:13)
    10. ACTION: goldavberg will update the spreadsheet to say they aren't' testing with -of13 because they don't use openflow (colindixon, 17:14:44)
    11. ACTION: edwarnicke to update the spreadsheet to say that controller is already doing this (colindixon, 17:14:54)

  4. dry run cutting of releases (colindixon, 17:15:03)
    1. : I am told that the correct job to copy is: https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/ (edwarnicke, 17:16:20)
    2. there is a easy to miss option in Git Advanced Checkout/merge to local branch (optional) (edwarnicke, 17:16:31)
    3. https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/ providing a clickable link to the job (colindixon, 17:16:42)
    4. rovarga states that yangtools is up and working with -Dpush=fals (colindixon, 17:18:20)
    5. Konstantin__ says that Defense4All is already on RELEASE pom files and wants to know how to proceed (colindixon, 17:19:11)
    6. ACTION: Konstantin__ to connect with GiovanniMeo, Madhu and/or edwarnicke over IRC or e-mail to resolve issues of RELEASE vs. SNAPSHOT for Defense4All (colindixon, 17:22:23)
    7. regXboi has done the dry run for opendove for java bundles but not fore the other stuff (colindixon, 17:25:13)
    8. Madhu says "dry-run will start to succeed end to end only after the dependent projects are done completely, but it is good to try anyways" (colindixon, 17:26:59)
    9. ACTION: abhijitkumbhare to discss dry runs with michal_rehak and prasanna about openflowplugin and openflowjava (colindixon, 17:28:26)
    10. edwarnicke "ashaikh: I remember seeing the VTN guys doing something that looked very smart in their mvn pom.xml files around the non-java bits" regarding open dove and regXboi (colindixon, 17:28:59)

  5. documentation (colindixon, 17:30:56)
    1. ACTION: colindixon to push this stuff to the wiki *today* (colindixon, 17:31:05)


Meeting ended at 17:32:10 UTC (full logs).

Action items

  1. goldavberg will update the spreadsheet to say they aren't' testing with -of13 because they don't use openflow
  2. edwarnicke to update the spreadsheet to say that controller is already doing this
  3. Konstantin__ to connect with GiovanniMeo, Madhu and/or edwarnicke over IRC or e-mail to resolve issues of RELEASE vs. SNAPSHOT for Defense4All
  4. abhijitkumbhare to discss dry runs with michal_rehak and prasanna about openflowplugin and openflowjava
  5. colindixon to push this stuff to the wiki *today*


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to discss dry runs with michal_rehak and prasanna about openflowplugin and openflowjava
  2. colindixon
    1. colindixon to push this stuff to the wiki *today*
  3. edwarnicke
    1. edwarnicke to update the spreadsheet to say that controller is already doing this
    2. Konstantin__ to connect with GiovanniMeo, Madhu and/or edwarnicke over IRC or e-mail to resolve issues of RELEASE vs. SNAPSHOT for Defense4All
  4. GiovanniMeo
    1. Konstantin__ to connect with GiovanniMeo, Madhu and/or edwarnicke over IRC or e-mail to resolve issues of RELEASE vs. SNAPSHOT for Defense4All
  5. goldavberg
    1. goldavberg will update the spreadsheet to say they aren't' testing with -of13 because they don't use openflow
  6. Konstantin_
    1. Konstantin__ to connect with GiovanniMeo, Madhu and/or edwarnicke over IRC or e-mail to resolve issues of RELEASE vs. SNAPSHOT for Defense4All
  7. Konstantin__
    1. Konstantin__ to connect with GiovanniMeo, Madhu and/or edwarnicke over IRC or e-mail to resolve issues of RELEASE vs. SNAPSHOT for Defense4All
  8. Madhu
    1. Konstantin__ to connect with GiovanniMeo, Madhu and/or edwarnicke over IRC or e-mail to resolve issues of RELEASE vs. SNAPSHOT for Defense4All
  9. michal_rehak
    1. abhijitkumbhare to discss dry runs with michal_rehak and prasanna about openflowplugin and openflowjava


People present (lines said)

  1. colindixon (88)
  2. edwarnicke (32)
  3. Madhu (28)
  4. Konstantin__ (14)
  5. GiovanniMeo (11)
  6. rovarga (7)
  7. abhijitkumbhare (7)
  8. goldavberg (6)
  9. ashaikh (5)
  10. michal_rehak (2)
  11. tykeal (2)
  12. odl_meetbot (2)
  13. phrobb (1)
  14. Konstantin_ (1)
  15. oflibMichal1 (1)
  16. dkutenic (1)


Generated by MeetBot 0.1.4.