01:45:20 <edwarnicke> #startmeeting
01:45:20 <odl_meetbot> Meeting started Thu Jan 23 01:45:20 2014 UTC. The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:45:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
01:45:31 <edwarnicke> #topic rollcall
01:45:36 <edwarnicke> Please #info in :)
01:45:55 <ChristineH> #info Christine for SNMP4SDN
01:46:21 <hideyuki> #info Hideyuki Tai for VTN Project
01:46:55 <edwarnicke> Anyone else?
01:47:06 <phrobb> #info Phil Robb
01:47:13 <edwarnicke> :)
01:47:47 <suchiraman> affinity here
01:47:53 <suchiraman> #info affinity her
01:47:57 <suchiraman> (here)
01:48:02 <edwarnicke> :)
01:48:50 <edwarnicke> #topic agenda bashing
01:49:55 <edwarnicke> I was thinking of going reviewing a few things from this mornings meeting, and then going through release items
01:50:01 <edwarnicke> Is there other stuff folks would like on the agenda?
01:50:04 <hideyuki> edwarnicke: ok.
01:50:36 <edwarnicke> #info https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-22-17.04.html is this mornings meeting minutes
01:50:37 <hideyuki> edwarnicke: no stuff from me.
01:50:55 <edwarnicke> #topic quick review from the 9am
01:51:54 <edwarnicke> Most importantly, this morning a decision was reached we need to either concur with or indicate our issues with regard to
01:51:55 <edwarnicke> AGREED: it seems as though we have critical mass for moving from 9a PST to 7a PST for cutting as a one-off shift on 1/27, but we will check at 5:45 and phrobb will follow up with people as part of his getting attendance promises from people
01:52:26 <edwarnicke> How would folks feel about cutting release artifacts on Monday Jan 27 at 7am PST instead of 9am PST?
01:52:37 <edwarnicke> Welcome cdub :)
01:52:47 <cdub> thanks
01:53:02 <cdub> #info Chris Wright for dripping dinner on keyboard
01:53:07 <hideyuki> edwarnicke: it's fine with me. and I think it's fine with other folks from Tokyo.
01:53:39 <ChristineH> edwarnicke: 7a is better than 9a for me:)
01:53:46 <edwarnicke> hideyuki: We were hoping it would make things easier for you guys :)
01:53:53 <edwarnicke> ChristineH: We were hoping that :)
01:54:04 <hideyuki> edwarnicke: Thank you!
01:54:15 <ChristineH> thx a lot!
01:54:21 <edwarnicke> suchiraman: Are you OK with the 7am PST Mon Jan 27 for cutting release artifacts?
01:54:33 <suchiraman> no prob.
01:54:37 <edwarnicke> :)
01:54:49 <edwarnicke> #agreed Concur: AGREED: it seems as though we have critical mass for moving from 9a PST to 7a PST for cutting as a one-off shift on 1/27, but we will check at 5:45 and phrobb will follow up with people as part of his getting attendance promises from people
01:54:52 <hideyuki> ChristineH: are you from Taiwan?
01:55:12 <ChristineH> hideyuki: yes
01:55:46 <edwarnicke> phrobb: Do you have names for participants for Monday from all the projects present here?
01:56:16 <phrobb> edwarnicke: I believe so… will go off and check…
01:56:23 <edwarnicke> phrobb: Thanks :)
01:57:17 <edwarnicke> We also has a question as to whether it seemed a good thing to add logging at level info the connecting and disconnecting of things (like OF switches) to the logging recommendations
01:57:18 <phrobb> Yes, I have confirmation from everyone on this meeting
01:57:47 <edwarnicke> #link https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings
01:57:51 <edwarnicke> phrobb: Thank you :)
01:58:27 <edwarnicke> How do folks feel about logging connection/disconnection at level INFO (just like module start/stop)
01:58:43 <ChristineH> agree
01:58:58 <hideyuki> edwarnicke: I'm fine with this.
01:59:18 <edwarnicke> suchiraman: How do you feel about it?
01:59:28 <suchiraman> Ok with me.
02:00:19 <edwarnicke> #agreed to add connec/disconnect of devices to the list of things that could be logged at level INFO in https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings
02:01:07 <edwarnicke> #topic upcoming release task deadlines
02:01:26 <edwarnicke> Just to bring them to the fore front of folks minds, I was going to list out the things due by Jan 24
02:01:42 <edwarnicke> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet again, I'm just going to read off things with 1/24 as the date in the "last finish date" column on the "activities" tab
02:01:58 <edwarnicke> #info we need to erradicate and have tests to check for all System.out.print(), System.out.println(), System.err.print(), and System.err.println()
02:02:08 <edwarnicke> #info related to that, we need to sanity check log levels
02:02:22 <edwarnicke> #link https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings log level guidelines are here
02:02:36 <edwarnicke> #info we need to update *all* internal dependencies to the current highest snapshot version
02:02:54 <edwarnicke> (I believe cdub has been both helpfully harassing people and pushing patches on that count ;) )
02:03:09 <edwarnicke> #info all projects need to remove SNAPSHOT from any external dependencies
02:03:21 <edwarnicke> #info openflowplugin done with system.outs & some other items - the other items status is on the spreadsheet
02:03:27 <cdub> indeed
02:03:34 <edwarnicke> #info that last one was a mistake :(
02:03:38 <edwarnicke> cutting and pasting to fast
02:03:50 <edwarnicke> #info I know we have tests for copyrights, but all projects need to get that resolved by the end of the wek
02:03:53 <cdub> most look good, and I plan to update spreadsheet
02:04:30 <edwarnicke> cdub: That's a good reminder
02:04:37 <edwarnicke> #info please update the spreadsheets folks :)
02:05:04 <edwarnicke> Because among other things we need to read out to the TSC tomorrow
02:05:14 <edwarnicke> Does anyone else have anything else for this meeting?
02:05:36 <suchiraman> Thanks to cdub and madhu with global tasks.
02:05:55 <hideyuki> VTN Project has done dry run.
02:06:12 <hideyuki> https://jenkins.opendaylight.org/vtn/job/vtn-bulk-release-prepare-only/
02:06:27 <edwarnicke> hideyuki: That's excellent news :)
02:06:59 <edwarnicke> Anything else?
02:07:02 <cdub> wow, nice
02:07:07 <ChristineH> snmp4sdn is working on dry run :)
02:07:18 <edwarnicke> ChristineH: That's excellent news :)
02:07:18 <hideyuki> To make it success, we use IGNORE_SNAPSHOTS parameter to ignore snapshot artifacts in dependencies.
02:07:34 <edwarnicke> hideyuki: That's not only excellent news, that's an amazing tip!
02:07:44 <hideyuki> Is it ok to use this IGNORE_SNAPSHOTS parameter?
02:07:47 <edwarnicke> Could you be very specific about what you did so we can pass it on to others?
02:07:58 <cdub> hideyuki: for dry run, i think it's ok
02:08:00 <edwarnicke> hideyuki: For the dry run, yes. but not for the release artifacts
02:08:09 <cdub> hideyuki: for real...we have to get no more snapshots
02:08:11 <edwarnicke> hideyuki: It may actually be brilliant for the dry run :)
02:08:37 <edwarnicke> Could you describe how you did it? Was it an ENV variable, a command line flag, or something else?
02:08:42 <hideyuki> I think dry run job never become sucessful without IGNORE_SNAPSHOTS at that time.
02:08:51 <edwarnicke> hideyuki: You are correct
02:09:10 <hideyuki> Please see: https://jenkins.opendaylight.org/vtn/job/vtn-bulk-release-prepare-only/configure
02:09:27 <hideyuki> In this page, you can see "IGNORE_SNAPSHOTS".
02:10:49 <hideyuki> Does this answer your question?
02:11:01 <edwarnicke> #link https://jenkins.opendaylight.org/vtn/job/vtn-bulk-release-prepare-only/configure has an example of using IGNORE_SNAPSHOTS to allow the dry run to succeed. This is very useful for dryrun, but should not be done for release.
02:11:17 <edwarnicke> Yes :)
02:11:18 <hideyuki> edwarnicke: thank you!
02:11:19 <edwarnicke> Thank you :)
02:11:28 <edwarnicke> Anything else?
02:11:55 <hideyuki> no stuff from me.
02:12:28 <edwarnicke> OK... going to end the meeting then :)
02:12:31 <edwarnicke> #endmeeting