17:04:41 <edwarnicke> #startmeeting
17:04:41 <odl_meetbot> Meeting started Thu Jan 30 17:04:41 2014 UTC. The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:41 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:04:52 <edwarnicke> Please #info in
17:04:58 <edwarnicke> #info Ed Warnicke for controller
17:05:09 <tykeal> #info Andrew Grimberg for infrastructure support
17:05:56 <prasanna> #info Prasanna For OF plugin
17:06:04 <abhijitkumbhare> #info Abhijit Kumbhare for OF plugin
17:06:09 <paulz> #info Paul Zimmerman for docs
17:06:32 <phrobb> #info Phil Robb for Download page and other
17:07:01 <edwarnicke> #agenda bashing
17:07:09 <edwarnicke> #topic agenda bashing
17:07:33 <edwarnicke> I think what we mostly need to cover here is docs and release reviews, can folks thing of other issues?
17:08:21 <edwarnicke> Oh... and we should check in on things like VMs, dockers, etc
17:09:17 <edwarnicke> Opinions?
17:09:29 <phrobb> that list sonds good to me edwarnicke
17:09:31 <edwarnicke> #topic Documentation
17:10:01 <edwarnicke> Here is our documentation page: https://wiki.opendaylight.org/view/Release/Hydrogen
17:10:44 <paulz> I have been wrapping my mind around the current set of content... wondering if there are any other bits to fill out my understanding, like specs or presos...
17:11:22 <edwarnicke> I think part of our issue is folks are not putting things in the right places (or linking them in)
17:11:29 <edwarnicke> #link https://wiki.opendaylight.org/view/Release/Hydrogen/Developer_Guide is almost empty
17:11:48 <edwarnicke> But I know folks are furiously scribbling developer docs... but they are putting them off their project pages
17:11:55 <edwarnicke> Someone needs to link all of that in
17:12:00 <edwarnicke> Would you be willing to work on that paulz ?
17:12:03 <Madhu> #info Madhu for ovsdb
17:12:31 <paulz> Sure... thanks for pointing me to the project areas to get the info.
17:13:04 <LuisGomez> #info Luis for Integration
17:13:07 <edwarnicke> Guys... please #info in where your developer docs are... because they are not in the develiopers guide: https://wiki.opendaylight.org/view/Release/Hydrogen/Developer_Guide
17:13:19 <paulz> That would help a lot.
17:15:11 <cdub> beuller...beuller...
17:15:17 <edwarnicke> prasanna Madhu ?
17:15:34 <Madhu> edwarnicke: hi.
17:15:36 <cdub> Madhu you gave me a brief ovsdb docs update yesterday...anything new there?
17:15:43 <networks_> #info Brent for OVSDB
17:15:53 <Madhu> networks_: is in :) he can update i hope
17:15:56 <cdub> i know it's skeletal and needs to be translated to english
17:16:21 <edwarnicke> #info It looks like VTN docs are rooted here: v
17:16:23 <edwarnicke> https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Main
17:16:25 <edwarnicke> #link https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Main
17:16:51 <prasanna> should we link to plugin developer docs....to the above link
17:17:08 <abhijitkumbhare> I have put the link to the plugin docs here: https://wiki.opendaylight.org/view/Release/Hydrogen
17:17:23 <abhijitkumbhare> So have most projects
17:17:35 <networks_> for ovsdb have been keeping everything linked through a spreadsheet. Today we are focusing on compiling it all cause
17:17:56 <networks_> will update it in tonights meeting
17:17:56 <edwarnicke> #info For controller docs are actively being remarshalled and reorganized
17:18:09 <prasanna> https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Developer_Guide
17:18:51 <networks_> is there consensus wether the guide goes on the home page of the project or in a subdir?
17:19:02 <networks_> Ive seen 3 different
17:19:12 <edwarnicke> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:Developer_Guide - BGPLS developers guide
17:20:01 <prasanna> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Developer_Guide
17:20:30 <abhijitkumbhare> However there is no link for the release review for the projects at https://wiki.opendaylight.org/view/Release/Hydrogen - do we need it there in that table matrix?
17:20:48 <edwarnicke> #link https://wiki.opendaylight.org/view/BGP_LS_PCEP:User_Guide - BGPLS Users Guide
17:21:35 <edwarnicke> networks_: I think that folks are drifting towards doing guides off their project pages and linking them in... I am not going to comment on the goodness or badness of that... just kind of how its drifting
17:22:22 <networks_> kk thanks
17:22:59 <edwarnicke> paulz: Do you have an opinion, since you actually know what you are doing with docs?
17:23:28 <abhijitkumbhare> edwarnicke & paulz: many of the projects have linked their user guides and the developer guides in the scratch area of https://wiki.opendaylight.org/view/Release/Hydrogen
17:24:16 <paulz> Consistency is one of the keys to ensuring that the readers find what they're looking for... so the content should either be in a central location OR on the project pages, but not both
17:24:49 <paulz> If they remain in the project areas, there should be some sort of roadmap for folks to find stuff.
17:24:52 <edwarnicke> paulz: I think that we are going to need subpages no matter what we do... so much content
17:24:59 <abhijitkumbhare> We can point from the central location to the project pages?
17:24:59 <paulz> Of course
17:24:59 <networkstatic> At lease linked centrally
17:24:59 <edwarnicke> abhijitkumbhare: Thanks for the pointer :)
17:25:54 <abhijitkumbhare> edwarnicke: I just linked the OF plugin docs there right now :-)
17:26:15 <paulz> Yes, we can do that... maybe a main page that contains the content map for folks to find what they're looking for. Also we can add some navigation to the other pages like I did on the original ODL docs... which reminds me that I need to update that stuff...
17:26:29 <edwarnicke> abhijitkumbhare: Thank you :)
17:26:50 <edwarnicke> Anything else for docs?
17:27:34 <abhijitkumbhare> off topic - today there is no TSC - right?
17:28:19 <phrobb> Today there *is* a TSC. I cancelled the TSC for *next* week
17:28:31 <abhijitkumbhare> OK
17:29:03 <edwarnicke> #topic Release Reviews
17:29:22 <edwarnicke> Release Reviews are *here* tomorrow. Please make sure you show up with a prepared Release Review doc
17:30:27 <edwarnicke> #link https://wiki.opendaylight.org/view/Sample_Release_Review - Release review template
17:31:02 <edwarnicke> Please link your Release Review docs as a subpage under your page named something like 'Hydrogen Release Review'
17:31:40 <abhijitkumbhare> We can add the release review in the scratch area matrix of https://wiki.opendaylight.org/view/Release/Hydrogen
17:32:49 <edwarnicke> abhijitkumbhare: Would you please?
17:32:58 <abhijitkumbhare> Planning to
17:34:32 <edwarnicke> Thanks :)
17:34:44 <edwarnicke> Please #info if you have a release review document?
17:35:57 <networkstatic> Can you example one for those who dont.
17:36:08 <edwarnicke> networkstatic: Sure :)
17:36:19 <edwarnicke> A Release Review is the closing step of doing a release
17:36:28 <edwarnicke> We document what we've done and the state we are in
17:36:45 <edwarnicke> #link https://wiki.opendaylight.org/view/Sample_Release_Review - has the template... its intended to be very light
17:36:54 <edwarnicke> So tomorrow morning, we come together to review those
17:37:02 <edwarnicke> Does that answer your question? Do you have other questions?
17:37:20 <networkstatic> roger, thanks pal.
17:37:57 <edwarnicke> Any other questions about release docs?
17:38:01 <abhijitkumbhare> #info The project scratch area matrix of https://wiki.opendaylight.org/view/Release/Hydrogen updated with an additional column for "Release Review"
17:38:06 <networkstatic> has anyone done it yet? RL example
17:38:09 <edwarnicke> Thanks abhijitkumbhare :)
17:38:17 <edwarnicke> I think abhijitkumbhare has done one
17:38:22 <edwarnicke> Doing controller is on my list for today
17:38:46 <networkstatic> ah nm, i see one from abhijitkumbhare link, ty
17:39:15 <edwarnicke> Cool.
17:39:16 <abhijitkumbhare> The moderator has to pound action for projects to link it to individual projects "release reviews"
17:39:56 <edwarnicke> #action All projects please link your release reviews into the scratch area of https://wiki.opendaylight.org/view/Release/Hydrogen
17:40:11 <edwarnicke> #action All project please link your documentation into the scratch area of https://wiki.opendaylight.org/view/Release/Hydrogen
17:40:15 <edwarnicke> Anything else?
17:40:29 <edwarnicke> #topic VMs etc
17:40:39 <edwarnicke> Do we have any of the folks working on VMs etc on the line?
17:41:16 <abhijitkumbhare> I need to drop off right now
17:41:16 <networkstatic> I am ed
17:41:33 <edwarnicke> networkstatic: What can you tell us about the VM etc and how they are coming?
17:41:37 <networkstatic> bye abhijitkumbhare
17:41:40 <abhijitkumbhare> (will keep online and check later)
17:42:07 <networkstatic> Everything is straight forward minus devstack, so business as usual
17:42:12 <LuisGomez> so i have to finish the test VM by this week
17:42:26 <networkstatic> on the fence of even handing people a granade
17:42:44 <edwarnicke> networkstatic: Most users respond poorly to shrapnel. They whine.
17:42:47 <Madhu> am building 1 now (for the summit)
17:42:54 <networkstatic> for what project Madhu ?
17:42:57 <Madhu> which luis, Tom & myself will be using
17:42:58 <networkstatic> just to sync
17:43:01 <networkstatic> rogr
17:43:03 <edwarnicke> Cool
17:43:09 <edwarnicke> But what about the VMs for the download page?
17:43:33 <Madhu> edwarnicke: I am not working on that personally. But I think Luis is :)
17:43:41 <LuisGomez> yes, thats me
17:43:44 * networkstatic crickets
17:43:52 <edwarnicke> Cool... is that the test VM you referenced earlier?
17:43:53 <Madhu> i can talk for him. because he is sitting right next to me @ ericsson ;)
17:44:25 <LuisGomez> ed: i sent mail to discuss yesterday about the content of the test VM
17:44:39 <LuisGomez> nobody disagrees so far
17:44:46 <edwarnicke> Cool :)
17:44:55 <edwarnicke> Anything else guys, because we call it a meeting?
17:44:57 <LuisGomez> so it will be ready by Friday
17:45:08 <edwarnicke> #endmeeting