#opendaylight-meeting: OpenDaylight TSC Meeting

Meeting started by phrobb at 18:01:26 UTC (full logs).

Meeting summary

    1. dmm (dmm, 18:02:19)
    2. vijoy (vijoy, 18:03:21)
    3. Chris Wright (cdub, 18:04:17)
    4. Rob Dolin, proxy for Rajeev Nagar (Microsoft) (RobDolin, 18:04:49)

  1. Acceptance of Minutes (phrobb, 18:06:06)
    1. people have not reviewed the minutes, plan is to push them as drafts and then approve them formally later (colindixon, 18:07:37)
    2. note that janmedved is here on behalf of edwarnicke_ (colindixon, 18:08:18)
    3. Hackfest details are here: https://wiki.opendaylight.org/view/HackFestAgenda#HackFest_Agenda:_March_26th_-_28th (RobDolin, 18:10:37)
    4. https://wiki.opendaylight.org/view/HackFestAgenda#HackFest_Agenda:_March_26th_-_28th (a clickable version of the hackfest link) (colindixon, 18:11:25)

  2. Creation Review DPDK_vSwitch (phrobb, 18:12:22)
    1. https://wiki.opendaylight.org/view/Project_Proposals:OpenDayLight_Intel%C2%AE_DPDK_vSwitch Uri (Intel) is presenting on DPDK vSwitch proposal (RobDolin, 18:14:43)
    2. dmm asks "how ready" the project is to move to incubation? (phrobb, 18:16:48)
    3. team does not know that a new project is needed. The team will first see if working with existing projects is sufficient (phrobb, 18:19:45)
    4. the DPDK vSwitch team will do deeper eval of work needed and impact on existing projects. They will then come back and see if a new project is warranted, or if they could fit within the existing projects. (phrobb, 18:23:01)

  3. Helium Release Planning and the Fall Summit (phrobb, 18:28:32)
    1. vote on shall the next release of OpenDaylight be named "Helium"? (phrobb, 18:29:19)
    2. AGREED: The name of the second release is "Helium" (phrobb, 18:29:36)
    3. there is a discussion about whether we should name the sub-releases as isotopes of the element of the main release, e.g., deuterium, tritium, etc. (colindixon, 18:31:46)
    4. discussion ensued on minor release naming… (phrobb, 18:31:57)
    5. others propose simple numbering for minor releases (colindixon, 18:31:57)
    6. AGREED: as project goes along, major releases as elements, minor releases numbered (phrobb, 18:34:36)
    7. who maintains the branches and how does it get done? (phrobb, 18:35:02)
    8. the work is too much for one person (phrobb, 18:35:16)
    9. a release engineer can manage the overall mechanics, but each project needs to manage the creation and evolution of stable branches within their projects (phrobb, 18:36:46)
    10. it is noted that we need a bug-fix release soon. What are the concrete steps? (phrobb, 18:37:24)
    11. ACTION: janmedved agreed to work with cdub on creating a stable release branch for minor releases (phrobb, 18:40:06)

  4. Helium planning and the Summit (phrobb, 18:47:30)
    1. ACTION: phrobb will take the discussion for actual dates to the list (phrobb, 18:48:54)

  5. At-Large TSC Elections (phrobb, 18:49:04)
    1. dmm had sent a mail proposing 2 at large TSC members to the TSC list (phrobb, 18:49:38)
    2. , response from the list agreed that two members were a good number (phrobb, 18:50:07)
    3. dmm asks how will nominations be done (phrobb, 18:50:33)
    4. discussion ensued on various methods for nomination (phrobb, 18:51:28)
    5. several members are in favor of changing charter to allow all contributors to the project to be allowed to run and vote for at large TSC positions (phrobb, 18:54:34)
    6. ACTION: cdub to build a proposal for charter-change for TSC review for next week's TSC meeting. (phrobb, 18:55:53)

  6. DLUX request to change the project license to Apache or dual licensed as Apache/EPL; Is there technical merit in that activity the TSC would agree to? (phrobb, 18:57:37)
    1. question from cdub - does the DLUX team see a code-flow moving at the pace of Horizon - or is there other motivation (phrobb, 18:58:34)
    2. DLUX team noted that code created to augment horizon code can't be contributed back, so it is difficult stay in sync with horizon project (phrobb, 18:59:39)
    3. several TSC members would like to understand technical options of using Horizon while not changing the license of the DLUX project (phrobb, 19:07:49)
    4. AGREED: TSC requests DLUX team to provide more detail on what they want to do, the various options on how to do it, and the cost/benefit technically of each - creating a wiki page to cover these topics, and the technical implications (phrobb, 19:15:11)

  7. Collaboration Tools (phrobb, 19:17:01)
    1. topic deferred until next week (phrobb, 19:17:48)

  8. INCNTRE engagment update (phrobb, 19:18:10)
    1. dmm provided update on activities thus fare with trying to work with INCNTRE to date. (phrobb, 19:19:49)
    2. this effort is currently "stuck" due to NDA requirement. (phrobb, 19:20:25)

  9. Branding (phrobb, 19:23:05)
    1. ACTION: phrobb to get branding discussions going again (phrobb, 19:23:21)

  10. Possible renaming of Application Policy project to avoid confusion between OpenDaylight and OpenStack projects (phrobb, 19:24:59)
    1. need to understand tech/logistic issues of changing repo, mailing lists, etc. (phrobb, 19:25:46)
    2. several TSC members expressed desire to not oversee naming of projects unless there is some kind of onforeseen issue (phrobb, 19:29:08)
    3. AGREED: TSC does not need to intervene on this topic at this time (phrobb, 19:29:54)


Meeting ended at 19:30:18 UTC (full logs).

Action items

  1. janmedved agreed to work with cdub on creating a stable release branch for minor releases
  2. phrobb will take the discussion for actual dates to the list
  3. cdub to build a proposal for charter-change for TSC review for next week's TSC meeting.
  4. phrobb to get branding discussions going again


Action items, by person

  1. cdub
    1. janmedved agreed to work with cdub on creating a stable release branch for minor releases
    2. cdub to build a proposal for charter-change for TSC review for next week's TSC meeting.
  2. phrobb
    1. phrobb will take the discussion for actual dates to the list
    2. phrobb to get branding discussions going again


People present (lines said)

  1. phrobb (48)
  2. tnadeau (14)
  3. colindixon (10)
  4. RobDolin (8)
  5. mestery (6)
  6. vijoy (3)
  7. dmm (2)
  8. odl_meetbot (2)
  9. alagalah (2)
  10. ekarlso (1)
  11. cdub (1)
  12. ashaikh (1)


Generated by MeetBot 0.1.4.