#opendaylight-meeting Meeting

Meeting started by colindixon at 17:17:43 UTC (full logs).

Meeting summary

  1. hackfest (colindixon, 17:17:53)
    1. phrobb asks for people to please rsvp or contact him if they need help. it's in 2 weeks. (colindixon, 17:18:10)

  2. samples and tutorials (colindixon, 17:18:20)
    1. networkstatic has a sample tutorial relating to OVSDB that he wants to push somewhere (colindixon, 17:20:07)
    2. there's discussion as to whether we want a separate project (colindixon, 17:21:17)
    3. there's discussion as to whether we want a separate project for samples and tutors (colindixon, 17:21:23)
    4. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Hydrogen_Developer_Guide:MD-SAL_App_Tutorial sample tutorial for the MD-SAL building a learning switch as well (colindixon, 17:21:42)
    5. some people suggest using the integration project as a home for these things (also there was discussion in the past of using integration for docs) (colindixon, 17:22:07)
    6. ACTION: colindixon to look into these approaches (colindixon, 17:22:16)

  3. MD-SAL performance with jan medved (presentation happening on webex) (colindixon, 17:22:36)
    1. the current test is using the fork of cbench that came with edwarnicke__'s mininet VM (colindixon, 17:24:17)
    2. https://git.opendaylight.org/gerrit/gitweb?p=openflowplugin.git;a=tree;f=drop-test;h=fa281245e06ce49410bcb9dfbe1099078b6508bd;hb=HEAD (ttkacik, 17:24:45)
    3. openflowplugin.git/drop-test (ttkacik, 17:25:08)
    4. the cbench running seems to produce something like 14,000 operations per second using a simple reactive drop rule (colindixon, 17:26:52)
    5. that bounces around though (regXboi, 17:27:07)
    6. http://yuba.stanford.edu/~derickso/docs/hotsdn15-erickson.pdf for those interested, this is David Erickson's paper on Beacon's performance in HotSDN which showed getting a bit more than 10 million ops per second (colindixon, 17:32:28)
    7. this isn't to say that we can actually get there, but it's useful to read (colindixon, 17:32:49)
    8. testing floodlight and producing results that are about the same, peaking around 16,000 operations per second (colindixon, 17:33:26)
    9. (it should be noted that the 10 million number for Beacon is on real hardware) (colindixon, 17:33:39)
    10. it should be noted that when running floodlight, we're using their default forwarding, not a dummy drop program (colindixon, 17:34:43)
    11. colindixon asks if logging is hurting performance, rovarga says he doesn't think so because they used debug logging in the MD-SAL to deal with things and it didn't drop too much (colindixon, 17:40:16)
    12. running with AD-SAL gets gets 34,000-37,000 operations per second, but subsequent runs seems to not work (colindixon, 17:41:54)
    13. this needs to be looked into a bit (at least the failing after the first) and to see if the cbench is recording the packet_outs in addition to the flowmods, but we will look into that (colindixon, 17:43:39)
    14. there is a reactive dropping application for the AD-SAL at controller.git/samples/reactiveforwarding/ (colindixon, 17:44:23)
    15. actually it's controller.git/opendaylight/samples/reactiveforwarding/ (colindixon, 17:44:45)

  4. MD-SAL datastore performance testing (colindixon, 17:46:50)
    1. performance is ~100x slower than other tests, i.e., 45-50 operations per second (colindixon, 17:48:28)
    2. the cpu utilization seems to be relatively low, and thus likely there are not enough threads and/or too many locks (colindixon, 17:49:15)
    3. most time is being spent in the two phase commit logic (which means that you're presumably holding the lock) (colindixon, 17:49:54)
    4. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:DOM_DataStore (ttkacik, 17:54:27)

  5. planning for the MD-SAL data store going forward (colindixon, 17:55:12)
    1. it's clear that we need to fix this performance, and we need to start a dialog about what we want to use to fix this (colindixon, 17:56:39)
    2. at the same time, we are also going to want to have it handle clustering (colindixon, 17:57:03)
    3. colindixon asks if it being a tree data store is likely to cost us something vs. normal key-value store. jan seems to think it might since you're also storing relationships. (colindixon, 17:59:21)
    4. some suggestions are Akka, Cassandra, Mongo, and Infinispan; apparently some of them have distributed tree stores (colindixon, 17:59:56)
    5. http://docs.mongodb.org/manual/tutorial/model-tree-structures/ this is an example for Mongo (colindixon, 18:00:06)

  6. queries to the MD-SAL (colindixon, 18:01:26)
    1. somebody asks do we know what kind of queries we want to run (colindixon, 18:02:20)
    2. regXboi points out that there was a GSoC proposal around using a query language instead of walking the DOM (colindixon, 18:02:53)
    3. networkstatic and regXboi both point to finding interfaces for data stores (colindixon, 18:07:16)
    4. https://wiki.opendaylight.org/view/Project_Proposals:Data_Persistence (regXboi, 18:09:19)


Meeting ended at 18:10:34 UTC (full logs).

Action items

  1. colindixon to look into these approaches


Action items, by person

  1. colindixon
    1. colindixon to look into these approaches


People present (lines said)

  1. colindixon (44)
  2. rovarga (5)
  3. regXboi (4)
  4. ttkacik (3)
  5. ashaikh (3)
  6. odl_meetbot (2)


Generated by MeetBot 0.1.4.