16:59:35 <phrobb> #startmeeting
16:59:35 <odl_meetbot> Meeting started Thu Mar 13 16:59:35 2014 UTC. The chair is phrobb. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:46 <dmm> #info dmm
17:00:10 <phrobb> #topic rollcall
17:00:58 <colindixon> #info colin dixon for IBM (in proxy for Vijoy)
17:01:26 <phrobb> #chair dmm colindixon
17:01:26 <odl_meetbot> Current chairs: colindixon dmm phrobb
17:02:08 <cdub> #info Chris Wright is here
17:04:13 <RobDolin> Will we be using this IRC channel for the OpenDaylight TSC meeting today?
17:04:19 <colindixon> RobDolin: yes
17:04:25 <edwarnicke__> #info Ed Warnicke
17:04:32 <colindixon> RobDolin: are you the proxy today? if so #info in
17:04:51 <phrobb> #chair RobDolin
17:04:51 <odl_meetbot> Current chairs: RobDolin colindixon dmm phrobb
17:05:50 <RobDolin> #info Rob Dolin proxy for Rajeev Nagar (Microsoft)
17:06:22 <colindixon> RobDolin: are you on the voice?
17:06:26 <phrobb> rob, can you get audio?
17:06:43 <cdub> we don't need no stinkin' audio
17:06:50 * edwarnicke__ muted
17:06:52 <colindixon> #link https://meetings.webex.com/collabs/meetings/join?uuid=MA3SRND964PIX06V2LS3SXX3RE-9VIB this is the webex we're using
17:06:52 <cdub> ;)
17:07:25 <phrobb> #topic Agenda bashing
17:07:49 <phrobb> #info new category "top of mind" as discussion topics to touch on
17:09:08 <phrobb> #topic acceptance of the minutes
17:09:30 <alagalah> Trust me, there are a few of us who read the min
17:09:57 <edwarnicke__> I read the minutes... really I did... I just wasn't at the meeting last time :(
17:10:06 <phrobb> #info acceptance pushed until next week
17:10:33 <RobDolin> meeting recording turned-on
17:11:29 <RobDolin> #info Phil mentions that there was an amendment to the minutes, it was added on the wiki but was not reflected on MeetBot.
17:11:38 <phrobb> #topic Event Updates
17:11:38 <RobDolin> #topic Event Updates
17:12:26 <RobDolin> For hackfest, Phil says its useful to have some topics posted ahead of time
17:12:47 <RobDolin> For hackfest, Phil says we have ~30 registrants for the hackfest.
17:12:52 <alagalah> From last week, iirc there was talk of it being 50% design, 50% hackfest
17:13:21 <RobDolin> Phil suggests potential topics: performance, tools, docs, policy discussion, others... ?
17:13:23 <colindixon> #info phrobb points out that it would be useful to have topics before the hackfest, also as of now we have only 28 registrants for the hackfest which is low for us
17:13:53 <colindixon> #info there was discussion from last week of having explicitly designated time to do actual hacking vs. designing
17:13:53 <RobDolin> #info Ed Warnicke suggests automating release process as a good topic
17:14:19 <phrobb> #info edwarnicke__ noted automated release processes are a good topic for the hackfest
17:14:52 <phrobb> #info performance testing plans / code/tools would be helpful
17:15:06 <LuisGomez> #info i would like to have discussion around performance test strategy
17:15:24 <RobDolin> #info Colin Dixon suggests designated hacking time
17:17:03 <cdub> #link https://wiki.opendaylight.org/view/HackFestAgenda#HackFest_Agenda:_March_26th_-_28th Add your agenda items there
17:19:18 <cdub> #info Colin Dixos also note that hacking (code sharing) works well remotely, remote whiteboarding and design is harder
17:19:31 <cdub> hmm, colindixon got a new name
17:19:50 <colindixon> :p
17:19:58 <cdub> combo of Dixon and Paxos
17:20:11 <RobDolin> #info Phil is making progress on OpenDaylight showcase at Layer 123 SDN World Congress. Email him if you want more info.
17:22:18 <RobDolin> #info Phil suggesting fall 2014 summit be a smaller event and then spring 2015 be bigger again
17:22:39 <phrobb> thanks Rob!
17:23:18 <RobDolin> @phrobb no problem. I hope I captured accurately. Please feel free to add more to clarify.
17:23:53 <RobDolin> #info Ed Warnicke suggests it would be good to have an on-ramp opportunity like a day of tutorial
17:24:30 <phrobb> #info tutorials first then more involved discussion aftward
17:25:04 <RobDolin> #info Luis Gomez and Rob Dolin: +1
17:25:16 <RobDolin> #topic System Integration and Testing Update
17:26:39 <RobDolin> #info Luis recently sent email update on integration
17:27:56 <cdub> #info I would like to volunteer to work w/ openflow team and others to port relevant bugfixes/perf fixes to a table Hydrogen release
17:28:10 <phrobb> thanks cdub
17:28:15 <colindixon> +10 to cdub for volunteering for that
17:28:26 <edwarnicke__> Many thanks to cdub for taking this on
17:28:37 <dmm> definitely +{large but fininte} @cdub
17:29:02 <RobDolin> #topic Creation Reviews
17:29:07 <phrobb> w#action cdub and colindixon to work w/ openflow team and others to port relevant bugfixes/perf fixes to a table Hydrogen release
17:29:20 <RobDolin> David Meyer will again ask projects to schedule creation reviews
17:29:25 <phrobb> #action cdub and colindixon to work w/ openflow team and others to port relevant bugfixes/perf fixes to a table Hydrogen release
17:29:46 <RobDolin> #action David Meyer will again ask projects to schedule creation reviews
17:29:58 <phrobb> #topic Stability, scalability performance
17:30:35 <dmm> #topic Stability, Scalability and Performance Hydrogen Releases
17:31:02 <phrobb> #info cdub suggests each proj has a stable branch with low risk bug fixes...
17:31:02 <colindixon> #info cdub says each repo needs to have a stable branch and we need criteria for what goes into those branches
17:31:20 * colindixon will defer to phrobb here
17:32:23 <RobDolin> #info Chris Wright (cdub) suggests minimizing new features into "stable" branch
17:32:27 <phrobb> #info no new features in stable branch, with perf changes are case-by-case, totally broken performance should be fixed in stable branch, but otherwise performance could wait
17:32:39 <RobDolin> * RobDolin defers to phrobb here too
17:33:24 <phrobb> #info important to get all projects responsible identify what are going into main branch that should also go to stable branch
17:34:08 <phrobb> #info possibly starting a page of what is in main branch that could go into stable branch…
17:34:49 <phrobb> #info different opinions on mandating bug #s on each patch for it to be accepted.
17:35:42 <phrobb> #info edwarnicke__ suggests strongly encourage bug # in patches but not mandate.
17:36:12 <RobDolin> #info Chris Wright suggests requiring a bug # associated with check-ins to the stable branch
17:36:26 <phrobb> #info cdub suggests requiring bug#s in stable branch patches as a possiblity
17:36:53 <RobDolin> #info Colin Dixon suggests having a weekly update / status email
17:37:06 <phrobb> did we want to pound agree that TSC now requires bug # on stable branch?
17:37:24 <dmm> phil: yes
17:38:13 <phrobb> #agreed The TSC requires that patches submitted to the stable branch of a project must reference a bug number.
17:38:48 <phrobb> #action phrob to work with LF infrastructure to add this change to the build environment
17:38:50 <dmm> #info line-count is a low-pass filter
17:39:09 <RobDolin> @phrobb - For formality, it would be good to have David Meyer call for consensus on this on the audio stream
17:39:09 <cdub> dmm: nice reduction
17:39:33 <phrobb> RobDolin: agreed, dmm could you do that?
17:40:23 <cdub> colindixon: ever the optimist....assuming common sense ;)
17:40:51 <ghall> How many "committers" are required to agree on a stable commit?
17:40:54 <dmm> @rob: sure, though there is consensus based on what the members on the phone have said (I counted)
17:41:04 <cdub> ghall: we have no policy
17:41:09 <RobDolin> Great. Thanks for tracking that David.
17:41:12 <cdub> ghall: i'd recommend 2
17:43:02 <ashaikh> i will repeat my opinion that, given where we are, it is *not* inappropriate for the TSC to raise concerns about a patch (or patches) that introduces a major change
17:43:09 <dmm> Rob: :-)
17:43:37 <phrobb> #info cdub suggests that the TSC build a more comprehensive set of guidelines/mandates for patch submission
17:43:48 <colindixon> ashaikh: I agree
17:44:07 <phrobb> ashaikh: your double negative threw me for a minute… had to read it a couple of times
17:44:21 <dmm> @ashaikh sure, common sense should rule
17:44:46 <ashaikh> phrobb: yes, sorry :-) — was trying to use the same language as on the call
17:44:56 <edwarnicke__> #info suggests that the TSC take care in the phrasing of TSC comprehensive guidelines for stable branch releases to respect the line between what the TSC can mandate and the perogatives of the projects.
17:46:33 <phrobb> #action cdub and edwarnicke__ to initiate the activity for the comprehensive list
17:47:13 <phrobb> #action AChirputkar and colindixon also will join the comprehensive list workgroup
17:49:19 <RobDolin> #topic Quality-based Release Plan for Helium
17:49:26 <RobDolin> #info tabled to next week per David Meyer
17:49:28 <phrobb> #topic documentation
17:50:00 <colindixon> just as a note, mlemay was definitely interested in this
17:50:14 <phrobb> tnadeau: are you on the call?
17:50:27 <dmm> I don't think he is
17:50:57 <RobDolin> FYI: There was a brief call on documentation earlier this week organized by Paul Zimmerman
17:53:37 <phrobb> #info There are multiple groups beginning to work on documentation - we need to improve organization around the activitye
17:54:25 <RobDolin> #action Phil to create a "documentation" listserv
17:54:27 <phrobb> #action probb to get a documentation list created for the documentation group
17:55:00 <RobDolin> #info Ed Warnicke suggests we have a listing of group project calls
17:55:34 <cdub> this is an example of what we need
17:55:37 <RobDolin> #info Phil has added a box to each project's main page including: mailing list, IRC channel, list of committers, etc.
17:55:38 <cdub> (just a wiki page)
17:55:57 <cdub> #link https://wiki.openstack.org/wiki/Meetings <-- example of meetings
17:57:22 <mlemay> #info sorry missed it but yea we're done documentation work.. not passing the build just yet because of external plugin will commit shortly
17:57:54 <ekarlso> afaik https://wiki.opendaylight.org/view/Meetings
17:58:01 <ekarlso> https://wiki.opendaylight.org/view/IRC
17:58:11 <ekarlso> there's already those :)
17:58:18 <mlemay> #info we drafted 3 guides (User Guide, Install Guide and OpenStack +ODL guide based off brent's blogs)
17:58:24 <cdub> ekarlso: right, we just don't advertise it or keep it up to date
17:58:30 <phrobb> #action RobDolin to work with Colin M. to create a Documentation cross-project page
17:58:59 <RobDolin> #topic OVSDB Project Rename
17:59:24 <RobDolin> #info Madhu: A few days back, there was a twitter conversation about the OVSDB project name
17:59:49 <RobDolin> Madhu clarified that Ben Pfaff asked
18:00:03 <dmm> rob: that was me :-)
18:00:30 <RobDolin> :)
18:01:18 <RobDolin> Madhu, did you say "Open Network" ?
18:01:29 <phrobb> #info Madhu_offline suggests a new name of opennetvirt
18:01:33 <dmm> opennetvirt
18:01:56 <dmm> Rob: Open Network Virtualization --> opennetvirt
18:02:12 <RobDolin> Thanks :)
18:03:58 <RobDolin> #info Ed Warnicke suggests this name may be overly broad
18:06:31 <RobDolin> <- Raises hand
18:07:09 <dmm> Rob: you're next
18:07:54 <phrobb> #info dicsussion ensued on if the name is too broad compared with "Virtual Tenant Network" and Open Distributed Overlay Network
18:08:16 <edwarnicke__> <- Raises hand
18:09:33 <phrobb> #info RobDolin suggests a more uniform type of naming scheme for projects/plugins
18:10:04 <colindixon> sorry for violating the queue, I clearly need to multiplex my brain fewer ways and read the IRC channel more
18:10:11 <RobDolin> Ex: OVSDB Plugin, OpenFlow 1.3 Plugin, etc.
18:10:17 <dmm> colin: no worries
18:10:41 <abhijitkumbhare> If VMware is having a OVSDB IETF draft - then calling it OVSDB plugin should be fair game
18:10:44 <phrobb> #info edwarnicke__ notes that all functions of the OVSDB Integration plug center around that SB protocol with integration into other things that would need to work with OVS
18:12:52 <abhijitkumbhare> <- Raises hand
18:13:02 <RobDolin> #info David Meyer plans to leave this item on the agenda for next week
18:13:33 <phrobb> #action dmm asks that Madhu_offline and Networkstatic to come and continue this discussion for next week's TSC meeting
18:14:45 <cdub> abhijitkumbhare: the OVSDB authors asked for the change, because they see confusing calling it only OVSDB
18:15:15 <cdub> abhijitkumbhare: as...we are not the authors of OVSDB server, more client
18:15:27 <edwarnicke__> so perhaps ovsdbclient ?
18:15:36 <abhijitkumbhare> OK - so they may be OK with something like "OVSDB southbound plugin"?
18:15:38 <edwarnicke__> or ovsdbplugin
18:15:42 <edwarnicke__> or ovsdbdriver
18:15:43 <cdub> abhijitkumbhare: yes
18:15:45 <LuisGomez> just a comment: one thing is project name and other plugin name, they may or may not match in some cases
18:15:46 <edwarnicke__> or ovsdbsupport ?
18:15:54 <colindixon> edwarnicke__: ovsdb client is their built in one that comes with ovs
18:16:04 <edwarnicke__> colindixon: Good to know :)
18:16:14 <phrobb> Isn't the real name of the project "OVSDB Integration"?
18:16:31 <colindixon> +1 to dmm's proposal to push this off
18:16:39 <drizzt_> It is, the challenge is simply that hasn't been the name any one uses in common parlance
18:16:40 <GiovanniMeo> ovsdb project includes also neutron integration
18:16:48 <GiovanniMeo> hence there is more to ovsdb
18:16:59 <abhijitkumbhare> +1 to pushing it off
18:17:01 <edwarnicke__> +1 to dmm's proposal to push this off to better accomidate ovsdb committers ability to participate :)
18:17:04 <GiovanniMeo> as well OF1.0/OF1.3
18:17:37 <edwarnicke__> GiovanniMeo: The Neutron integration and the OF integration are both in service of using the ovsdb protocol
18:17:37 <GiovanniMeo> integration
18:17:40 <edwarnicke__> Tightly bound
18:18:06 <GiovanniMeo> no really
18:18:23 <RobDolin> #info Neela Jacques suggests the primary request is just to not call the project only "OVSDB"
18:19:42 <RobDolin> #topic TSC Co-Chair
18:20:29 <RobDolin> #info David Meyer suggests this would be good for redundancy, back-up, and preserving institutional knowledge
18:21:13 <RobDolin> #info Phil suggests this would take a bylaws change to add a co-chair or vice-chair
18:21:27 <RobDolin> #info David Meyer clarifies that he meant vice-chair
18:21:29 <cdub> chair'
18:21:54 <colindixon> #info phrobb mentions that we need to think about whether we want a co-chair or vice-chair, i.e., equal power or a stand-in when the chair is available
18:22:20 <colindixon> #info I mean, when the chair is unavailable
18:23:15 <cdub> dmm: did we lose you?
18:23:35 <phrobb> #info edwarnicke__ asks what would the nuts & bolts be for the role of the vice-chair
18:23:45 <alagalah_> http://www.youtube.com/watch?v=-8bqQ-C1PSE
18:24:04 <alagalah_> We are a self-deterministic autonomous collective....
18:25:52 <phrobb> #info dmm states the main purpose is for a back-up/redundancy and succession planning
18:26:19 <tnadeau> hey guys. please keep the transcriptions detailed. i'd like to particiipate but im on a plane w just IRC avail
18:26:51 <cdub> tnadeau: good point
18:26:51 <RobDolin> Ed asks about specific duties
18:27:20 <dmm> phil: can you give me the ball
18:28:25 <RobDolin> Call-in User_4 also suggests there are other technical leadership areas where the current TSC Chair provides leadership (ex: working with INCNTR)
18:29:09 <RobDolin> Was call-in user_4 Neela?
18:30:02 <dmm> rob: yes
18:30:35 <RobDolin> #info Ed Warnicke suggests we have an email discussion about this.
18:31:06 <phrobb> #info there is general consensus that the notion of a vice-chair is "good"
18:31:21 <dmm> can people hear me?
18:31:26 <cdub> dmm: nope
18:31:28 <dmm> sigh
18:31:43 <colindixon> sorry
18:31:46 <cdub> dmm: is proving the vice chair point
18:31:59 <cdub> "dave's not here, man"
18:32:49 <RobDolin> David Meyer is now back on audio
18:33:15 <RobDolin> #info David Meyer will keep this on the agenda for next week.
18:33:35 <RobDolin> #topic At-Large TSC Elections
18:33:37 <phrobb> #action TSC to discuss the notion of a vice-chair
18:34:11 <phrobb> #action phrobb to write up bylaw changes for vice chair to allow discussion
18:35:14 <RobDolin> #info Phil has noticed there was a challenge in identifying committers
18:35:52 <RobDolin> #info Nominations will go out today for at-large committers to join the TSC
18:36:05 <RobDolin> #info Election will use similar tool to what was used for "Most Valuable Developer"
18:36:14 <RobDolin> #info Voting would end on 04 April
18:36:29 <RobDolin> #info Colin Dixon asks about if committers is the right pool
18:36:47 <RobDolin> #info Phil: decision was made _for this round_
18:37:00 <RobDolin> #info Chris Wright expresses his dissent
18:37:31 <RobDolin> #topic Branding
18:37:40 <RobDolin> #info Phil suggests this is for week after next
18:38:05 <RobDolin> #topic Release Engineer
18:38:24 <RobDolin> #info Chris Wright is writing-up a position description
18:38:32 <RobDolin> #topic Clustering
18:39:00 <RobDolin> #info David Meyer asks if we should push-off to Technical Work Stream (TWS) ConCall
18:39:15 <RobDolin> #info Colin Dixon agrees to push to TWS ConCall
18:39:41 <RobDolin> #info Colin Dixon encourages people to attend the TWS ConCall
18:39:57 <phrobb> #action colindixon to schedule clustering discussion for TWS call
18:40:01 <colindixon> thanks phrobb
18:40:54 <phrobb> colindixon: my pleasure
18:41:44 * colindixon <-- raises hand after dmm in the queue at this point I think
18:42:21 <phrobb> #info edwarnicke__ notes we don't need to come to one complete consensus so the people don't block on consensus to get work done, but realizes that not getting consensus could also block, and asks for others opiions
18:43:13 <phrobb> #info dmm notes this is more a technical decision
18:44:44 <phrobb> #topic Pre-incubation aka Scratch area
18:45:55 <RobDolin> #info Chris Wright: We need to help people get involved in the project without doing anything formal like applying for a project creation review
18:46:25 <phrobb> #info cdub notes the idea is to allow new people/projects some place to initially engage in preparation for bringing a formal proposal forward
18:46:44 <colindixon> +1 to this
18:46:59 <RobDolin> Great phrase cdub: "lob it over the process wall"
18:47:25 <phrobb> #info cdub proposes the word "Forge" only because it is common for this type of venue
18:49:31 <phrobb> #info edwarnicke__ is in agreement such a place is needed, also adds some things such as DCO enforcement is needed.. also important to be clear on what is a real project and what is a forge activity
18:49:54 <phrobb> #info dmm notes that we need support from LF to make it real
18:50:35 <phrobb> #edwarnicke__ volunteers to work with LF to build this out
18:51:19 <phrobb> #info dmm suggests we have a place (wiki) to collect ideas for creating this
18:51:49 <phrobb> #action edwarnicke__ to take lead on creating a plan and getting input from the community
18:52:52 <phrobb> #action cdub to help edwarnicke__ on building out plan
18:53:27 <RobDolin> #topic DLUX Licensing
18:53:43 <RobDolin> #info Phil: The IP and Legal subcommittee will be reviewing that material
18:54:03 <RobDolin> #info: David Meyer: We did raise this with the board so they know its going on
18:54:11 <phrobb> #topic Meeting Collaboration Tools
18:55:14 <phrobb> #info dmm notes that the meetbot came from this initial topic, but there may be more to do here
18:56:12 <phrobb> #info cdub notes that webex is poorly supported on Linux (ubuntu works, rhel/fedora not so much)
18:56:27 <cdub> that's not exactly true
18:56:35 <cdub> it is poorly supported on linux
18:56:50 <cdub> it can be made to work, based on a number of odd tradeoffs
18:56:58 <RobDolin> #info Ed Warnicke: I'm not wed to WebEx, but here are some useful features: Who is talking, Who is dialed-in, Shared screen, Ability for moderator to mute
18:57:00 <dmm> #info correction: I proposed the meetbot but cdub wanted to leave the agenda item due to the fact that Webex doesn't work well on all platforms
18:57:10 <phrobb> #info edwarnicke__ notes that webex features that should persist include see who is talking , who is dialed-in, share descktop, mute noisy people
18:59:34 <phrobb> #info dmm requests that we have voice as part of the meeting
18:59:47 <colindixon> webex works with just phone
18:59:53 <RobDolin> +1 on continuing to have voice / audio
18:59:54 <colindixon> if all we care about is voice
19:01:02 <RobDolin> Possible idea: WebEx for audio only, MeetBot for text, and #link in meetbot for sharing docs
19:03:31 <RobDolin> #info David Meyer asks if TSC would be open to: WebEx for voice, MeetBot for text, and #link in MeetBot for sharing
19:03:36 <cdub> +1
19:03:38 <colindixon> +1
19:03:44 <RobDolin> +1
19:03:45 <alagalah_> +1
19:03:50 <edwarnicke__> +1
19:03:52 <phrobb> #agreed for next week TSC meeting will use webex for voice meetbot for text and pound link for sharing
19:05:05 <phrobb> #endmeeting