#opendaylight-meeting Meeting

Meeting started by regXboi at 16:09:00 UTC (full logs).

Meeting summary

  1. AKKA for ODL as part of MD-SAL (regXboi, 16:09:14)
  2. Prototyping Akka in ODL (regXboi, 16:10:15)
    1. presentation from mlemay on prototyping akka for md-sal framework and data store (regXboi, 16:10:46)
    2. presentation will be posted to the wiki and/or mailing list later (hopefully during this call) (colindixon, 16:14:12)
    3. dmm asks if Akka is written in erlang (colindixon, 16:27:10)
    4. it is not, it's written in Scala which runs on the JVM (colindixon, 16:27:21)
    5. it provides Java bindings and you can call it from pure Java code, but mlemay says that it's easier to consume in some cases by calling from Scala (colindixon, 16:28:01)
    6. mlemay goes on to point out that it's actually compiled to java bytecode, so it's not even compiled, which is all good (colindixon, 16:29:17)
    7. jan medved asks about loading it and debugging it in Eclipse (colindixon, 16:29:35)
    8. mlemay responds that it might actually be easier than the yang stuff and actually aside from trapping into Scala-based Akka code, works just like it had been in Java (colindixon, 16:30:26)

  3. actors (colindixon, 16:31:09)
    1. actors are basically a mailbox, some execution and some local state (colindixon, 16:31:43)
    2. jan medved asks about how threads are assigned to actors, is it single threaded? (colindixon, 16:33:28)
    3. by default, yes (colindixon, 16:33:32)
    4. jan further asks about prioritizing threads (colindixon, 16:33:42)
    5. answer is that it can be done, but it's not done in the current code (colindixon, 16:33:52)
    6. actors have built-in support for load balancing, routing, partitioning, and cluster management (which is pretty useful), but getting into these would take almost a call for each topic (colindixon, 16:35:38)
    7. http://doc.akka.io/docs/akka/current/AkkaJava.pdf the Akka Java Documentation (courtesy of phudgins) (colindixon, 16:36:02)
    8. http://doc.akka.io/docs/akka/snapshot/project/licenses.html (alagalah, 16:38:03)
    9. http://doc.akka.io/docs/akka/snapshot/project/licenses.html Akka is under the apache 2 license and that should be considered (thanks alagalah) (colindixon, 16:38:36)

  4. Akka-based DataStore Design (colindixon, 16:39:42)
    1. links to gerrit patches implementing this to follow (colindixon, 16:41:16)
    2. https://git.opendaylight.org/gerrit/#/c/5971/ (colindixon, 16:41:20)
    3. https://git.opendaylight.org/gerrit/#/c/5970/ (colindixon, 16:41:23)
    4. https://git.opendaylight.org/gerrit/#/c/5953/ (colindixon, 16:41:29)
    5. https://git.opendaylight.org/gerrit/#/c/5967/ (colindixon, 16:41:32)
    6. mlemay notes that it's still not fully baked yet, so take it for what it is (colindixon, 16:41:51)
    7. there is an independently-written Akka DataBroker, which then talks to an in-memory data store, which talks to the Akka Actor System, which runs on a (different?) OSGi Runtime (colindixon, 16:43:53)
    8. Jan Medved asks if this is the Akka datastore itself (becuase that seems to just be a log of all the messages) (colindixon, 16:44:57)
    9. answer is that no, this is a different data store using the Akka cluster (colindixon, 16:45:12)
    10. jan follows up by asking how it uses Akka cluster (colindixon, 16:45:26)
    11. answer is that it's a distributed K-V store right now (colindixon, 16:46:27)
    12. not clear what consistency properties they're currently using, but it's easily changed (colindixon, 16:46:52)
    13. the in-memory data store is described as a cache on top of a distributed data store (right now based on the Akka actors moddel) (colindixon, 16:48:11)
    14. Raghu asks how do the actors provide a data store (colindixon, 16:49:51)
    15. mlemay answers that it's 6-7 actors that eventually write to a ConcurrentHashMap and they provide fast ways to read and write into that (colindixon, 16:50:20)
    16. question about whether it's trees or key-value that's being stored (colindixon, 16:51:47)
    17. right now it's storing key-value pairs, and they're translated back and forth from trees to key-value in the Akka DataBroker (colindixon, 16:52:12)
    18. question as to whether it's integrated into MD-SAL? (colindixon, 16:53:56)
    19. answer: yes, it is, but there's still work going on (colindixon, 16:54:14)

  5. unfortunate administrivia (colindixon, 16:57:05)
    1. many, many people need to drop at the top of the hour (colindixon, 16:57:16)
    2. this will continue either later this week, or early next week (colindixon, 16:57:46)
    3. slides coming to a wiki near you (cdub, 16:58:23)
    4. meeting recording coming to md-sal wiki page (cdub, 16:59:03)
    5. ACTION: jan, tony, and/or ed will put the slides online and email out the plan for a meeting and the pointer to the recording and slides (colindixon, 16:59:19)
    6. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL (cdub, 16:59:19)


Meeting ended at 16:59:57 UTC (full logs).

Action items

  1. jan, tony, and/or ed will put the slides online and email out the plan for a meeting and the pointer to the recording and slides


People present (lines said)

  1. colindixon (53)
  2. cdub (9)
  3. regXboi (8)
  4. alagalah (8)
  5. odl_meetbot (5)
  6. phudgins (5)
  7. edwarnicke___ (2)
  8. edwarnicke__ (0)


Generated by MeetBot 0.1.4.