17:00:05 <phrobb> #startmeeting OpenDaylight TSC Meeting 2014-05-08
17:00:05 <odl_meetbot> Meeting started Thu May  8 17:00:05 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:05 <odl_meetbot> The meeting name has been set to 'opendaylight_tsc_meeting_2014_05_08'
17:00:08 <regXboi> running late
17:00:24 <regXboi> dmm: I do not (as far as I know) have delegation today
17:01:45 <phrobb> #topic TSC members please #info in
17:02:13 * regXboi waits for webex
17:02:30 <RobDolin> #info Rob Dolin proxy for Rajeev Nagar (Microsoft)
17:02:56 <cdub> #info Chris Wright
17:03:04 <ChrisOShea> #Info Chris O'Shea  proxy for Chris Price (Ericsson)
17:04:04 <dmm> @RobDolin: welcome
17:04:16 <Kent> #info Kent Watsen
17:04:37 <dmm> #info dmm
17:05:05 * regXboi now watches the spinning ball :(
17:05:14 <alagalah> regXboi: Its candy hitting a fan
17:05:30 <edwarnicke> I'm having some webex issues... still trying
17:07:17 <phrobb> #chair regXboi edwarnicke RobDolin
17:07:17 <odl_meetbot> Current chairs: RobDolin edwarnicke phrobb regXboi
17:07:43 <phrobb> #topic Agenda Bashing
17:07:47 <dmm> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda_Summary (agenda)
17:08:06 <edwarnicke> #info Ed Warnicke
17:08:06 <regXboi> #info regXboi for IBM ( I *do* hold the proxy today)
17:08:19 * edwarnicke feels sorry for our poor beleaguered agenda
17:08:26 <edwarnicke> always being bashed ;)
17:08:35 <regXboi> edwarnicke: really?
17:08:51 <phrobb> #topic Event Updates
17:09:17 <phrobb> #link http://www.opendaylight.org/events/2014-05-12/openstack-summit-atlanta
17:09:37 <cdub> could be ksh'ing, zsh'ing, dashing
17:09:46 <regXboi> #info dmm mentions that TSC members will be at OpenStack next week and hopes for running the call next week from the summit
17:09:47 <kwatsen> #info Kent Watsen
17:10:03 <alagalah> cdub: Oh man.
17:10:05 <phrobb> #topic At-Large TSC member election update
17:10:17 <regXboi> phrobb: you get the topics, I'll take the info
17:10:18 * cdub hands dmm an airhorn
17:10:53 * edwarnicke breaks out his protective ear gear
17:11:23 <regXboi> #info board meeting was held last night and the "option 1" proposal was discussed (removing the "unless otherwise represented" language for platinum members).
17:11:38 <regXboi> #info board approved with the stipulation that this clause only applies to the forthcoming election
17:11:59 <regXboi> #info so by-laws return to the original form for the next election
17:13:17 <phrobb> #topic Committer Promotions
17:13:39 <dmm> #link https://wiki.opendaylight.org/view/Group_Policy:Main (Group Policy)
17:13:50 <Madhu> phrobb: is it committer promotions or replacement ?
17:13:54 <regXboi> #info proposal: keith burns and rob adams to committer for group based policy
17:14:05 <Madhu> the email sounded like replacing committers due to unavailability of existing commiters
17:14:10 <regXboi> madhu: that is a good question
17:14:21 <regXboi> er Madhu: that is a good question
17:14:22 <phrobb> not sure.. just copied the agenda item
17:16:49 <readams> I don't see why we need to remove anyone
17:17:36 <Madhu> it is not about removing anyone actuallyy
17:17:40 <cdub> #link https://lists.opendaylight.org/pipermail/tsc/2014-May/001172.html (relevant list thread)
17:17:47 <regXboi> cdub: thanks
17:17:57 <Madhu> the question was due to previous decisions to add committers
17:18:17 <Madhu> and questions raised earlier about contributions etc.
17:18:26 <Madhu> for existing projects
17:22:11 <cdub> #info luis asks, can a committer voluntarily drop committer responsbility
17:22:29 * cdub was going to suggest that we add that to the charter
17:22:35 <cdub> but it's offtopic for this
17:22:57 <phrobb> #startvote "Shall we promote Kieth Burns and Rob Adams to Committer of Group Based Policy Project? 1, 0, -1
17:22:57 <odl_meetbot> Begin voting on: "Shall we promote Kieth Burns and Rob Adams to Committer of Group Based Policy Project? Valid vote options are 1, 0, -1.
17:22:57 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:23:07 <cdub> #info we don't have charter mechanism for that, while could  be useful, it's offtopic
17:23:07 <RobDolin> #vote +1
17:23:07 <odl_meetbot> RobDolin: +1 is not a valid option. Valid options are 1, 0, -1.
17:23:11 <dmm> #vote +1
17:23:11 <odl_meetbot> dmm: +1 is not a valid option. Valid options are 1, 0, -1.
17:23:12 <cdub> #vote +1
17:23:12 <odl_meetbot> cdub: +1 is not a valid option. Valid options are 1, 0, -1.
17:23:13 <edwarnicke> #vote +1
17:23:13 <odl_meetbot> edwarnicke: +1 is not a valid option. Valid options are 1, 0, -1.
17:23:16 <ChrisOShea> #vote 1
17:23:17 <regXboi> #vote 0
17:23:20 <RobDolin> @vote 1
17:23:20 <cdub> #vote 1
17:23:25 <kwatsen> #vote 0
17:23:26 <dmm> #vote 1
17:23:33 <RobDolin> Sorry, I voted "+1" instead of "1"
17:23:35 <cdub> turns out i can't read
17:23:35 <edwarnicke> #vote 1
17:23:49 <phrobb> #endvote
17:23:49 <odl_meetbot> Voted on ""Shall we promote Kieth Burns and Rob Adams to Committer of Group Based Policy Project?" Results are
17:23:49 <odl_meetbot> 1 (4): cdub, ChrisOShea, dmm, edwarnicke
17:23:49 <odl_meetbot> 0 (2): kwatsen, regXboi
17:23:54 <edwarnicke> cdub: evidently my literacy is also questionable ;)
17:24:09 <alagalah> Thanks everyone!
17:24:10 <RobDolin> It's 4-0-2
17:24:11 <cdub> edwarnicke: maybe it's a prereq for this vote?
17:24:29 <readams> Thanks folks
17:24:40 <RobDolin> Congratulations Keith Burns and Rob Adams
17:24:50 <phrobb> #agreed Keith Burns and Rob Adams are now Committers on the Group Based Policy Project
17:24:56 <RobDolin> #info Ryan Moats (IBM) suggests this should be a special case and not a precedent
17:24:57 <alagalah> RobDolin: Thanks sir
17:25:01 <Madhu> regXboi: this is exactly what i was worried about :)
17:25:06 * edwarnicke suggestions we add #congratulations to meetbot :)
17:25:18 * regXboi hugs meetbot
17:25:23 <phrobb> #topic Creation Reviews
17:25:23 <tbachman> edwarnicke: or #suggestions ;)
17:25:38 <edwarnicke> tbachman: #happydance :)
17:25:41 <tbachman> lol
17:26:09 <cdub> i'm sure meetbot has a #patchesaccepted policy
17:26:22 <phrobb> #topic Creation-Review: ODL-SDNi App
17:26:45 <edwarnicke> cdub: I'm sure it does... but the results may prove too... entertaining ;)
17:26:53 <dkehnx> which code scan product?
17:27:10 <edwarnicke> dkehnx: Check in with Phil... he handles it
17:27:12 <cdub> presentation that does not have a link does not exist
17:27:38 <dkehnx> phrobb, which code scan product was being referred to?
17:27:45 <RobDolin> #link https://wiki.opendaylight.org/view/Project_Proposals:ODL-SDNi_App (SDNi Project Proposal)
17:27:51 <cdub> #link https://wiki.opendaylight.org/view/File:SDNiAppProposal1.ppt <-- slides
17:27:55 <phrobb> @dkehnx   Combination of FOSSology and Sonatype Component LifeCycle Manager
17:28:17 <dkehnx> phrobb, thx
17:30:12 <regXboi> #info question about whether this is hardcoded or user defined
17:32:49 <regXboi> phrobb: please scribe - I have some questions :)
17:33:00 <phrobb> regXboi:  you got it
17:33:33 <phrobb> Q:  regXboi asks "since this isn't clustering, are you assuming you are federating controllers in some way?"
17:33:58 <phrobb> #info Q:  regXboi asks "since this isn't clustering, are you assuming you are federating controllers in some way?"
17:34:49 <phrobb> #Info Q  in particular what does this project add above existing clustering capabilities?
17:35:25 <phrobb> #info A  We are trying to establish a federation of controllers - different controllers from different domains
17:38:49 <alagalah> I'm curious how you get "the best possible route" when network topology is in the "Extendable to:" section...
17:43:11 <phrobb> #info Q:  Concern this is federation based on BGP - issues with securing the data flowing between the domains
17:43:33 <phrobb> #info Q what is the plan to secure the trust-path?
17:45:10 <phrobb> #info A:  This is a known issue with BGP, with solutions being worked on
17:46:18 <regXboi> phrobb: thanks for scribing - as I said I had questions :)
17:46:41 <rovarga> #info I think sacurity of this is being handled in the sidr IETF working group
17:46:47 <phrobb> #info  there are dependencies on existing ODL-BGPCEP project and those are being taken into account in the release plan
17:47:13 <edwarnicke> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects - place to list yourself and your release plan (by Monday 5/12)  if you want to join Helium
17:48:10 <phrobb> #info Q:  Is this the first proposal that has described cross-domain federation?
17:48:17 <colindixon> I’ll jump in after dmm
17:48:36 <regXboi> #info A: yes and for opendaylight, things are bottom up
17:49:00 <phrobb> #info A:  This is the first federation type of proposal, everything before has been more clustering focused…
17:50:37 <phrobb> #info With a clustering datastore working, similar functionality is exists but having a more federation-view is also a valid methodology.
17:51:08 <phrobb> #info Is there any provision for different controllers having similar/compatible functionality?
17:53:21 <phrobb> #info Current plan is to share the data provided in this presentation.  More information can be shared in the future
17:54:00 <phrobb> #startvote Shall SDNi be moved to Incubation?  +1, 0 -1
17:54:00 <odl_meetbot> Begin voting on: Shall SDNi be moved to Incubation? Valid vote options are +1, 0, -1.
17:54:00 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:54:08 <regXboi> #vote 1
17:54:08 <odl_meetbot> regXboi: 1 is not a valid option. Valid options are +1, 0, -1.
17:54:09 <edwarnicke> #vote 1
17:54:09 <odl_meetbot> edwarnicke: 1 is not a valid option. Valid options are +1, 0, -1.
17:54:13 <regXboi> #vote +1
17:54:14 <dmm> #vote 1
17:54:14 <odl_meetbot> dmm: 1 is not a valid option. Valid options are +1, 0, -1.
17:54:17 <edwarnicke> #vote +1
17:54:29 <dmm> #vote +1
17:54:31 <ChrisOShea> #vote +1
17:54:38 <kwatsen> #vote +1
17:54:43 <cdub> #vote +1
17:54:59 <phrobb> #endvote
17:54:59 <odl_meetbot> Voted on "Shall SDNi be moved to Incubation?" Results are
17:54:59 <odl_meetbot> +1 (6): ChrisOShea, regXboi, dmm, edwarnicke, cdub, kwatsen
17:55:18 <edwarnicke> Who is ChrisOShea?
17:55:21 <regXboi> congratulations!
17:55:28 <ChrisOShea> Filling in for Chris Prices
17:55:29 <cdub> edwarnicke: ChrisPrice's proxy
17:55:29 <edwarnicke> Oh :)
17:55:36 <edwarnicke> Apologies :)  Missed that
17:55:38 <phrobb> #agreed ODL-SDNi is moved to Incubation
17:55:42 <regXboi> nice!
17:56:09 <phrobb> #topic Creation Review - South Bound Plugin To The OpenContrail Platform
17:57:22 <cdub> we need a link for the slides
17:57:46 <regXboi> dmm: can we get a #link for slides?
17:58:42 <regXboi> dmm: thanks
17:58:50 <kwatsen> #info I have to upload the slides to the wiki first
17:59:15 <RobDolin> Here's the project proposal:
17:59:17 <RobDolin> #link https://wiki.opendaylight.org/view/Project_Proposals:Southbound_plugin_to_the_OpenContrail_platform (Southbound plugin to the OpenContrail platform Proposal)
18:02:28 <Madhu> is it targeted for Virt edition only  ?
18:03:04 <cdub> for proposlas, there are no editions
18:03:20 <cdub> heh, a new kind of sla, a proposla
18:04:12 <colindixon> #info LuisGomez notes that the proposal seems to propose a completely vertically integrated approach with calls going from the Neutron plugin to their SB plugin and then to OpenContrail, he asks if there are any plans for more integration in the future.
18:04:26 <Madhu> cdub: thanks
18:04:44 <colindixon> #info answer is that they may integrate more in the future, but for now the veritcal integration is the plan for the first release efforts
18:05:22 <phrobb> thanks colindixon
18:05:30 <colindixon> phrobb: no worries
18:10:23 <phrobb> #info Question raised on added value expected from including OpenContrail plugin within OpenDaylight?
18:10:28 <colindixon> thanks
18:11:39 <phrobb> #info A: there have been customers wanting to manage OpenContrail-manged networks along with other types of networks all from OpenDaylight
18:12:39 <Madhu> am confused on this policy
18:13:01 <Madhu> doesnt openDOVE or VTN fall under the same question ?
18:13:02 <networkstatic> southbound REST_API sounds weird
18:13:16 <phrobb> #info Q: Given that Board has a Vendor-Neutral policy, can the TSC decide on this name?
18:14:13 <phrobb> #info A: dmm states that we will be only voting on the project.  The name of the project is still TBD until the Board decides on OpenDaylight's "Vendor Neutral" policy
18:17:41 <networkstatic> would like to know what else they are interested in contributing too. Would be sweet to see more then just the sbound driver.
18:18:06 <phrobb> #startvote "Shall the TSC give conditional approval the Southbound Plugin to the OpenContrail platform" to Incubation.. two conditions 1) the name to be used for the project not decided, and 2) a successful code scan? +1, 0, -1
18:18:06 <odl_meetbot> Begin voting on: "Shall the TSC give conditional approval the Southbound Plugin to the OpenContrail platform" to Incubation.. two conditions 1) the name to be used for the project not decided, and 2) a successful code scan? Valid vote options are +1, 0, -1.
18:18:06 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:18:27 <kwatsen> #vote 1
18:18:27 <odl_meetbot> kwatsen: 1 is not a valid option. Valid options are +1, 0, -1.
18:18:28 <regXboi> #vote +1
18:18:28 <edwarnicke> #vote +1
18:18:33 <RobDolin> #vote +1
18:18:33 <kwatsen> #vote +1
18:18:34 <ChrisOShea> #vote +1
18:18:39 <dmm> #vote +1
18:19:11 <cdub> #vote 0
18:19:16 <RobDolin> #endvote
18:19:16 <odl_meetbot> Voted on ""Shall the TSC give conditional approval the Southbound Plugin to the OpenContrail platform" to Incubation.. two conditions 1) the name to be used for the project not decided, and 2) a successful code scan?" Results are
18:19:16 <odl_meetbot> 0 (1): cdub
18:19:16 <odl_meetbot> +1 (6): ChrisOShea, regXboi, edwarnicke, dmm, kwatsen, RobDolin
18:20:25 <RobDolin> #agreed Conditional approval of project proposal
18:20:32 <phrobb> #topic Hydrogen Stable Release
18:21:14 <phrobb> #link https://wiki.opendaylight.org/view/CrossProject:Stable_Release
18:21:38 <cdub> #link https://lists.opendaylight.org/pipermail/tsc/2014-May/001156.html <-- mail thread
18:24:22 <phrobb> #info discussion ongoing on list.  Proposal made to not Cherrypick  all changes to master.  Instead pick a point in time and copy master to stable-branch then pull non-bug-fix patches from the stable copy.  Discussion is ongoing
18:27:59 <phrobb> #info cdub suggests maybe getting the specific projects that are having the problem of cherrypickig bug-fixes from master to do the mass-copy.  Other projects that have not had that much delta or cross-project-dependencies can just cherrypick the bug-fixes.
18:28:27 <rovarga> so I think the ask is to do this for yangtools and controller
18:30:22 <cdub> rovarga: it's wider than that
18:30:49 <cdub> rovarga: at least Abhijit replied effective +1 as well
18:32:28 <rovarga> cdub: yes, I know. yangtools and controller are the critical ones, as they are the ones blocking all others
18:32:36 <cdub> Madhu: it looks like this:  hydrogen->patch->pactch->patch->patch->patch[now]
18:33:10 <cdub> now name them A and B (A==stable B==not), hydrogen->A->B->A->B->
18:33:24 <cdub> you can eityher start w/ dropping B's or applying A's
18:33:32 <cdub> personally, makes no sense to drop B's
18:33:49 <cdub> but the projects are saying this works
18:35:30 <edwarnicke> dmm: I'm good
18:36:21 <phrobb> #topic Developer Best Practices
18:36:32 <regXboi> #link https://wiki.opendaylight.org/view/Developer_Best_Practices
18:37:51 <Madhu> cdub: if that works for projects... thats fine. but end of the day it has to be stable.
18:38:01 <cdub> Madhu: totally agree
18:38:04 <cdub> Madhu: time will tell
18:38:09 <Madhu> but it is weird on the approach we are taking.
18:38:16 <cdub> Madhu: shows the the modulraity is...not
18:38:17 <Madhu> maybe this learning is good for helium post
18:38:42 <Madhu> to start this stable/helium right away and never have to rewind or having this discussion half way
18:38:51 <Madhu> and many wasted efforts by many
18:39:08 <Madhu> cdub: i don't want to blame modularity :)
18:39:12 <cdub> yes, it's in the release planning for helium
18:39:18 <cdub> Madhu: why not?  it's true
18:39:51 <raghu67_> Agree. If we create the stable/helium concurrent with the helium release and require double commits for fixes, this should not be an issue
18:40:27 <Madhu> cdub: i was not clear. modularity will help if we follow that in practice.
18:41:24 <cdub> Madhu: ah, yup.  agree.  and it's _always_ tough to do cross-service (interdependent) changes...bugs should capture that inter-dependency
18:41:46 <phrobb> #info request is for TSC to advocate/strongly-encourage all projects in OpenDaylight to comply with 2 recommendations:  1) Build Time Testing, and 2) Comments documenting the code
18:42:56 <cdub> turns out it's not apple pie...it's a apple brown betty
18:43:41 <phrobb> #info comments made that this is "Motherhood and Apple pie", *but* we should probably look at a stylecheck rule that documentation is done with to succeed a build cycle
18:45:17 <phrobb> #info On commenting - not having comments is the exception not the norm… ie it must be explained why the comment is not there.
18:46:29 <colindixon> “Always code as if the person who ends up maintaining your code is a violent psychopath who knows where you live.” http://c2.com/cgi/wiki?CodeForTheMaintainer
18:46:42 <cdub> heh
18:46:54 <ChrsPriceAB> -> Austin !
18:48:25 <colindixon> I don’t think the TSC *can* mandate these things, but this is the venue where we can raise the issue and put pressure on people in the ways that we can
18:50:13 <cdub> ok...i mandate that we stop (ab)using "motherhood and apple pie"
18:50:20 <rovarga> colindixon: yes. or, as I tell my devs: "imagine you will come back to this pile in 5 years and try to make sense of it"
18:50:22 <Madhu> +1000
18:50:32 <Madhu> have never heard of so many times someone saying that :)
18:51:10 <colindixon> I’m 99% sure that devinavery wasn’t trying to say the TSC should mandate this, but should raise attention to the fact that, at least for some people, joining from the outside, we haven’t been doing as good a job as we should to make code accessible
18:51:25 <colindixon> and here are some concete suggestions
18:52:47 <rovarga> I think we need to create a 'cookbook' of recommendations on which committers agree
18:52:53 <cdub> #link https://pad.opendaylight.org/p/DevelopmentBestPractices <-- here's what i wrote down as things to consider
18:52:57 <phrobb> #info devinavery to continue this discussion on the list
18:53:04 <rovarga> cookbook as in -- how do I do this easily
18:53:09 <edwarnicke> devinavery: How can I help you on getting some checkstyle stuff going?
18:53:15 <phrobb> action devinavery to continue this discussion on the list
18:53:15 <rovarga> and let committers enforce it how they feel it's appropriate
18:53:29 <edwarnicke> I have a checkstyle bundle that can be be included as a maven dependency
18:53:36 <colindixon> #action devinavery will send a mail out to start this discussion about code best practices
18:53:38 <edwarnicke> We could start from that
18:53:41 <phrobb> #topic ovsdb.neutron in SP edition
18:53:53 <cdub> edwarnicke: checkstyle is busted for me, can you help me debug it?
18:54:39 <phrobb> #info madhu asks TSC " given the interest from the users, should we add ovsdb integration project to the SP edition?"
18:55:36 <devinavery> edwarnicke: I wasn't actually suggesting stylechecking. I believe the ball has to lie with the committers to encourage comments and unit tests. I believe at this point we would spend more time mandating and building controls instead of just commenting and testing. :) Will add more in e-mailto the lists
18:56:25 <ChrsPriceAB> I would ask that the TSC  review the "release vehicles" and their intentions for the release vehicles before Helium.
18:56:44 <phrobb> #info dmm notes that this request is also to add ovsdb to Hydrogen SP release
18:56:45 <dmm> @ChrisPriceAB -- that's in the release plan
18:57:10 <ChrsPriceAB> thanks, will check it.  only able to follow on IRC today. :)
19:00:18 <phrobb> #info dmm suggests that we take this discussion to the List to further explore ovsdb inclusion into stable hydrogen release of the SP edition
19:00:33 <phrobb> #endmeeting