#opendaylight-meeting: Pre-M4 Developer Meeting

Meeting started by phrobb at 15:30:00 UTC (full logs).

Meeting summary

  1. Project Contacts Please #info in with the Project you are representing (phrobb, 15:30:22)
    1. edwarnicke controller (edwarnicke, 15:30:30)
    2. goldavberg for lispflowmapping (goldavberg, 15:30:33)
    3. Madhu ovsdb (Madhu, 15:30:36)
    4. rovarga for bgpcep (rovarga, 15:30:42)
    5. colindixon for ttp (colindixon, 15:30:44)
    6. tbachman for groupbasedpolicy (tbachman, 15:30:49)
    7. oflibMichal for openflowjava (oflibMichal, 15:30:52)
    8. Hideyuki for VTN (hideyuki, 15:30:53)
    9. Liem for AAA (liemmn, 15:31:07)
    10. harman for dlux (harman_, 15:31:30)
    11. sheena for south plugin for opencontrail (sheena_, 15:31:30)
    12. mlemay for reservation (mlemay, 15:32:23)
    13. abhijitkumbhare for OpenFlow plugin (abhijitkumbhare, 15:32:43)
    14. paulz for documentation (paulz, 15:33:04)
    15. LuisGomez for integration (LuisGomez, 15:33:32)
    16. ChristineH and Chilung for SNMP4SDN project (ChristineH, 15:35:09)
    17. Rafat for ODL-SDNi (Rafat, 15:36:41)

  2. Agenda Bashing - Please bring forth any agenda topics you want us to cover today (phrobb, 15:37:06)
    1. Paul Quinn for SFC (paulq, 15:37:32)
    2. colindixon and Madhu for toolkit (colindixon, 15:39:01)
    3. ttkacik for yangtools (ttkacik, 15:39:03)
    4. brockners for snbi (brockners, 15:39:16)
    5. we’re currently still missing: Defense4All, L2 Switch, OpFlex Protocol Agent, PacketCable PCMM (we are expecting a representative from L2 Switch soon) (colindixon, 15:43:57)

  3. M4 Status Report Template Discussion (phrobb, 15:44:35)
    1. https://lists.opendaylight.org/pipermail/release/2014-July/000127.html M4 open daylight Helium update (Madhu, 15:44:46)
    2. The first section is to declare/ensure all projects are able to be at API Freeze at this point. Any questions on that one? (phrobb, 15:45:21)
    3. At the end of this discussion let's document our definition of what "API Freeze" means (phrobb, 15:48:22)
    4. http://stackoverflow.com/questions/9921715/create-prototype-scoped-spring-bean-with-annotations (tbachman, 16:26:21)
    5. AGREED: There is a lot of discussion about what constitutes API Freeze. Everyone agrees that the type signatures of things "public" in Java should not have any changes and that the high-level behavior should remain the same. For YANG files, a similar rule applies with no structural changes being made. Adding new functions, fields, etc. (that don't change the existing ones) will be allowed until code freeze (M5). However th (colindixon, 16:26:51)
    6. a few other notes of the discussion (colindixon, 16:26:58)
    7. we need to work out a way for people to complain or get things resolved if they feel an API has been changed on them (colindixon, 16:27:15)
    8. we really want a way to mark something as “in flux” so people aren’t caught unawares by changes (one idea would be to mark it as @deprecated with an explanation in the comments) (colindixon, 16:27:55)
    9. Process Check to everyone. We seem to have much to discuss when we get together. I would like to know if the Project Contact folks would like to hold this meeting weekly from now till the release (or in the unlikely event we run out of critical topics to discuss)? (phrobb, 16:28:09)
    10. The general idea of this is the following: don’t break people who depend on you. Stay in that spirit. (colindixon, 16:29:11)

  4. wrapping up (colindixon, 16:30:47)
    1. we didn’t get through everything we wanted here, so please, *please*, PLESE read the status summary e-mail phrobb sent out (colindixon, 16:31:19)
    2. phrobb would like to make this meeting time a weekly meeting (colindixon, 16:31:59)
    3. Madhu asks for a WebEx in the future edwarnicke does not, and colindixon would tend to fall on edwarnicke’s side here (colindixon, 16:32:31)
    4. ACTION: phrobb to set up another Release meeting for next wednesday same time.. some one else will chair/start the meeting as phrobb will be on vacation (phrobb, 16:33:20)
    5. If you have any questions on the M4 report out template, send them to me or to the designated person on the template (Luis G., Mathieu L, Paul Z. etc). (colindixon, 16:35:31)


Meeting ended at 16:36:03 UTC (full logs).

Action items

  1. phrobb to set up another Release meeting for next wednesday same time.. some one else will chair/start the meeting as phrobb will be on vacation


Action items, by person

  1. phrobb
    1. phrobb to set up another Release meeting for next wednesday same time.. some one else will chair/start the meeting as phrobb will be on vacation


People present (lines said)

  1. colindixon (123)
  2. edwarnicke (90)
  3. Madhu (63)
  4. phrobb (39)
  5. tbachman (30)
  6. rovarga (29)
  7. ChrisPriceAB (29)
  8. mlemay (20)
  9. abhijitkumbhare (11)
  10. ragbhat (10)
  11. LuisGomez (8)
  12. odl_meetbot (5)
  13. liemmn (5)
  14. hideyuki (4)
  15. brockners (4)
  16. ChristineH (3)
  17. ttkacik (1)
  18. paulq_ (1)
  19. paulz (1)
  20. regXboi (1)
  21. paulq (1)
  22. oflibMichal (1)
  23. goldavberg (1)
  24. sheena_ (1)
  25. Rafat (1)
  26. harman_ (1)
  27. dbainbri (0)


Generated by MeetBot 0.1.4.