14:30:35 <gzhao> #startmeeting Release daily sync
14:30:35 <odl_meetbot> Meeting started Fri Sep 12 14:30:35 2014 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:35 <odl_meetbot> The meeting name has been set to 'release_daily_sync'
14:30:47 <gzhao> chair colindixon tbachman edwarnicke
14:30:58 <gzhao> #chair colindixon tbachman edwarnicke
14:30:58 <odl_meetbot> Current chairs: colindixon edwarnicke gzhao tbachman
14:31:05 <colindixon> thanks
14:31:33 * regXboi wanders in late
14:31:56 <gzhao> colindixon: you want to drive?
14:32:13 <edwarnicke> #info edwarnicke
14:32:31 <colindixon> #info colindixon
14:32:33 <abhijitkumbhare> gzhao - I will provide the update in the format you sent later next week (around Tuesday)
14:32:37 <tbachman> #info tbachman for groupbasedpolicy
14:32:57 <colindixon> #undo
14:32:57 <colindixon> hmmm
14:32:57 <colindixon> can’t undo other people?
14:32:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2481c90>
14:32:59 <colindixon> #undo
14:32:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2481d90>
14:33:05 <colindixon> #info colindixon for TTP
14:33:19 <regXboi> #info regXboi for general uselessness
14:33:19 <colindixon> #info tbachman for groupbasedpolicy
14:33:19 <edwarnicke> colindixon: Are you trying to undo tbachman ... that seems aggressive ;)
14:33:21 <gzhao> #info gzhao release
14:33:27 <phrobb> #info phrobb
14:33:34 * tbachman sometimes feels undone
14:33:43 <abhijitkumbhare> #info abhijitkumbhare OpenFlowPlugin
14:33:48 <gzhao> abhijitkumbhare: thanks
14:33:49 * edwarnicke is pretty sure tbachman is a doer :)
14:33:56 <tbachman> lol
14:34:45 <colindixon> tbachman: is a colindixon-certified ODL badass
14:34:57 <tbachman> lol
14:35:16 <tbachman> :)
14:35:20 <lori> #info lori for lispflowmapping
14:35:29 <abhijitkumbhare> looks like we have a new certificate authority colindixon :)
14:36:14 <edwarnicke> abhijitkumbhare: Beware certificate revocations ;)
14:36:27 <gzhao> two minutes for roll call
14:36:37 <abhijitkumbhare> Nah - no problems colindixon :)
14:36:39 * edwarnicke is glad gzhao is here to be the adult :)
14:37:02 <abhijitkumbhare> agreed edwarnicke - otherwise we kids will be running around
14:37:34 <gzhao> then Ed will give overview of autorelease, then blocking issue ->round table status -> open
14:38:08 <colindixon> official notice: colindixon-certified certificates of ODL badassdom must be renewed once every 6 months
14:38:29 <colindixon> official notice: colindixon-certified certificates of “good people” are eternal :p
14:38:50 <gzhao> do we have representative from pluginoc, sdni, sfc , pcmm and snmp4sdn
14:39:10 <colindixon> is pcmm xsited?
14:39:18 <gzhao> colindixon: yes
14:39:43 <colindixon> xsited: you around?
14:39:43 <abhijitkumbhare> what is xsited? excited or exited :)
14:39:46 * edwarnicke notes xsited1 was seen last night furiously typing
14:40:06 <abhijitkumbhare> ok - its excited
14:40:25 <regXboi> more like who is xsited1?
14:40:25 <gzhao> #topic blocking issue
14:40:42 <colindixon> is this a call for blocking issues?
14:40:55 <gzhao> so defense4all got TSC exemption for Karaf, correct
14:40:56 <colindixon> or are you going to bring a up a blocking issue
14:41:10 <edwarnicke> gzhao: defense4all is in autorelease now
14:41:14 <gzhao> colindixon: yes, and current there are 7 project with red flag for RC1
14:41:14 <regXboi> um no
14:41:26 <colindixon> gzhao: it does not have the exception yet
14:41:30 <colindixon> people need to vote
14:41:39 <regXboi> defense4all has requested TSC exemption and is in autorelease pending approval
14:41:51 * regXboi speaks as one who is still considering his vote
14:42:12 <gzhao> ok, I would like to know the status for the 7 projects current have red flags for RC1
14:42:25 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-September/001638.html there has been a request for defense4all to not have to be in karaf, the TSC is voting on this mail thread, so far only one +1
14:42:44 <colindixon> gzhao: go for it!
14:43:56 <LuisGomez> #info LuisGomez for integration
14:44:05 <gzhao> #info list of projects in red for RC1: Defense4all, SDNi, pluginoc, PCMM, SFC, SNMP4SDN, VTN
14:44:06 <colindixon> gzhao: what are the 7 projects?
14:44:24 <edwarnicke> Is hideyuki here?
14:44:28 <colindixon> do we have representavites from the projects?
14:44:32 * edwarnicke puts on SFC committer hat
14:44:44 <edwarnicke> sfc will hit code freeze for RC1
14:45:18 <gzhao> I haven't got a chance to follow up all my eamil yet
14:45:20 <radhika> #info radhika for sdni
14:45:30 <gzhao> edwarnicke: is it frozen now?
14:45:57 <gzhao> radhika: hello,
14:46:18 <radhika> sdni is done with integration. code was uploaded...
14:46:44 <tbachman> gzhao: I’ve been working with the plugin2oc folks — no luck yet
14:46:48 <tbachman> something weird
14:46:54 <gzhao> radhika: change submited, but you need to follow https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#What_to_put_in_the_commit_message_to_assist_integration_committers_in_reviewing
14:47:18 <tbachman> I’d say, unfortunately, that plugin2oc is still red atm :(
14:47:21 <colindixon> #info edwarnicke says that SFC will hit code freeze by RC1 (and I’m assuming because he didn’t say so, it’s still not code-frozen yet)
14:47:27 * tbachman hopes he can get that changed soon
14:47:32 <edwarnicke> radhika: Link to your integration gerrit?
14:47:39 <colindixon> Christine from SNMP4SDN is not here
14:47:49 <colindixon> she was somebody who alwasy made the late meetings in Helium
14:48:05 <xsited> #info Thomas packetcable
14:48:21 <radhika> https://git.opendaylight.org/gerrit/#/c/11094
14:48:27 <gzhao> tbachman: they submit a change with no rebase, Chris helped them and pending their review https://git.opendaylight.org/gerrit/#/c/11077/
14:48:37 <gzhao> xsited: is pcmm code frozen
14:49:10 <colindixon> gzhao: beat me to the punch
14:49:23 <gzhao> radhika: thanks
14:49:53 <gzhao> #info SDNi Karaf change submitted pending review
14:50:27 <colindixon> so, we’re talking to people from sfc, pcmm, and sdni, that leaves d4a, plugin2oc, vtn and snmp4sdn
14:50:31 <radhika> gzhao: tbachman had reviewed our karaf ...
14:50:33 <edwarnicke> radhika: The test link must be to a *merge* job, your's in 11094 is to a verify job
14:50:55 <xsited> gzhao: no.  still on last reported out schedule for achieving that. yesterdays vote will trump that schedule.  we'll do the best we can to make it up.
14:51:02 <gzhao> so we missed representitives from d4a, pluginoc, snmp, vtn
14:51:11 * tbachman has another #fail
14:51:13 <colindixon> hideyuki said yesterday that vtn would be code-frozen by monday
14:51:24 <tbachman> radhika: sorry — saw the link but didn’t notice it was a verify
14:51:29 <tbachman> there should be a merge job there tho
14:51:34 <tbachman> should be easily fixable
14:51:44 <tbachman> b/c the merge also had the test and passed
14:51:57 <gzhao> #info pcmm code not forzen xsited is trying best to catch up
14:51:59 <tbachman> radhika: just amend the existing git with the updated link
14:52:00 <colindixon> #Info hideyukie said yesterday that VTN would be code frozen on monday (we will hope that is still true)
14:52:12 <colindixon> is sdni code-frozen other than karaf?
14:52:20 <gzhao> xsited: you know the TSC decision for meet RC1, right
14:52:33 <gzhao> colindixon: yes
14:52:52 <gzhao> sdni, pluginoc only for Karaf
14:53:09 <gzhao> sfc, pcmm, snmp, vtn is for code freeze
14:53:12 <xsited> gzhao: yes
14:53:27 <colindixon> xsited: the blunt version is: if pcmm is not code frozen (except bug fixes) by 5p pacific on Moday, it will not be part of Helium
14:53:32 <colindixon> kk
14:54:04 <colindixon> #info sfc, pcmm, snmp, vtn are in the “danger zone” for RC1 b/c of code freeze
14:54:43 <colindixon> #info sdni and plugin2oc are in the “danger zone” for RC1 b/c of karaf
14:55:09 <colindixon> #info we believe (hope) that defense4all will be removed from the “danger zone” for RC1 by TSC exception
14:55:13 <colindixon> just summarizing cleanly
14:55:40 <xsited> colin:  i understand.  Thanks.  i was there for the vote and i am moving mountain when possible.
14:55:41 <colindixon> LuisGomez: how are the patches from sdni and plugin2oc for karaf integration look?
14:55:54 <edwarnicke> #info working an issue for defense4all... they appear to have release versions from Hydrogen, not SNAPSHOT for Helium, and that must be corrected
14:56:13 <gzhao> #info missing representatives from RC1"danger zone" projects: Defense4All, pluginoc, SNMP4sdn, VTN
14:56:22 <LuisGomez> colindixon, let me check
14:56:24 <radhika> tbachman: all karaf code is uploaded and merged.. this is link for karaf upload https://git.opendaylight.org/gerrit/#/c/11046
14:56:25 <colindixon> xsited: you are a badass and I talk about the fact that you are a badass and got amazing things done with ODL without any help from us all the time, so I want badly for you to be in
14:56:44 <gzhao> Ok, any project has blocking issue to report?
14:56:44 <colindixon> xsited: let me, Madhu, gzhao, edwarnicke, or anyone know if you need help and thing we can
14:56:55 <colindixon> edwarnicke: good to know and a bit scare
14:57:14 <colindixon> #topic call for blocking issues from projects
14:57:45 <rovarga> based on TSC discussion -- whom should I bug about switching the branch from which the release is created?
14:58:28 <gzhao> rovarga: you mean for dev?
14:58:32 <colindixon> #info rovarga asks who should he talk to about changing the branch from which a projects code is pulled for auto-releases
14:58:38 <colindixon> I think that’s edwarnicke
14:58:41 <colindixon> but it’s a good question
14:58:51 <LuisGomez> colindixon: sdni, pending for review by committer, plugin2oc pending for review by project
14:58:54 <edwarnicke> rovarga: I can change the branch from which a project is pulled for autorelease
14:59:26 <colindixon> #info the answer (at least for now) is that edwarnicke is the keeper of the magic of the auto-release and can change what branch it pulls from in projects
14:59:35 <rovarga> edwarnicke: excellent. now what is the relationship between the autorelease and the RCs?
14:59:37 <gzhao> #info LuisGomez sdni, pending for review by committer, plugin2oc pending for review by project
14:59:42 <colindixon> #undo
14:59:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x26400d0>
15:00:27 <gzhao> rovarga: RC is built through autorelease
15:00:31 <colindixon> #info (from above on getting projects into karaf) LuisGomez sys the sdni karaf patch to integration is pending for review by integration committers
15:00:36 <rovarga> gzhao: for bgpcep we are ready for HElium, but would like to continue improving code quality (sonar warnings) for the next release. so we need to create the throttle branch, bump version on master and take it from there
15:01:06 <colindixon> #info (from above on getting projects into karaf) LuisGomez sys the plugin2oc karaf patch to integration is pending review by by the project
15:01:36 <gzhao> rovarga:  Is the decision for project wants to continue Lithium to create a dev branch to do so?
15:01:37 <rovarga> gzhao: ah, okay, so there is no 'Lithium autorelease' yet. that
15:01:40 <rovarga> 's fine
15:01:52 <colindixon> rovarga: noted and that makes total sense. as usual you are way ahead of the curve and I wish I was following suite. :-)
15:01:56 <edwarnicke> rovarga: There is no Lithium autorelease yet
15:02:23 <colindixon> PriyankaChopra: hey
15:02:29 <gzhao> PriyankaChopra: please #info in
15:02:46 <edwarnicke> rovarga: I probably won't be able to do a Lithium autorelease till after Helium goes out... but if you tell me the correct branch for bgpcep for Helium, I will switch the Helium autorelease to it :)
15:02:49 <rovarga> okay, we should be able to create a throttle branch in time for RC1 for tcpmd5 and bgpcep at least
15:02:56 <PriyankaChopra> #info PriyankaChopra for plugin2oc
15:03:25 <PriyankaChopra> colindixon : Hi
15:03:33 <gzhao> PriyankaChopra: you need to review: https://git.opendaylight.org/gerrit/#/c/11077/
15:03:36 <rovarga> edwarnicke: what is the current cadence of autorelease?
15:04:30 <edwarnicke> rovarga: Just tell me the projects and branch names and I will make it so :)  I've already worked out the 'how' because lispflowmapping uses branch 'develop' instead of master
15:04:41 <edwarnicke> rovarga: So the ideal cadence is:
15:04:51 <rovarga> edwarnicke: because based on past experience, the best way to cut the throttle branch is to create it retroactively once master's artifact versions have been bumped and published -- but we obviously do not want Helium autorelease to pick master after it was bumped
15:04:55 <gzhao> edwarnicke: I know we can do this, but there was a discussion when to cut stable/helium, and I am not sure before that, if projects wants to continue to do lithium work, they should create a dev branch and RC1/RC2 will be run from mater
15:05:01 <edwarnicke> a)  Every four hours, we do a test build, which does not push artifacts.  The purpose of which is to find out if autorelease is broken
15:05:12 <edwarnicke> b)  Nightly, we push a nightly build
15:05:20 <edwarnicke> c)  On RC1, we will push an RC1 build
15:05:27 <edwarnicke> rovarga: Does that answer your question?
15:05:41 <edwarnicke> rovarga: Honestly... that is an important discussion to have
15:06:14 <PriyankaChopra> gzhao : reviewed ..
15:06:22 <colindixon> I actually have a question about pushing patches, so is there any formal process for pushing bug fixes or is that left to projects with no broader oversight?
15:06:24 <phrobb> gzhao:  given that we have projects in the danger zone for Monday, can you tell us who you have received affirmative responses from that *know* about the hard cutoff Monday?  We can take extra steps today to reach out to those who may not yet know.
15:06:27 <rovarga> it sure does -- we'll do it the "flag day" way instead
15:06:43 <edwarnicke> rovarga: When thinking about the stable/helium cut, I was thinking those artifacts would replace SNAPSHOT with Helium-1-SNAPSHOT, and then the ongoing Helium stable autorelease would switch to just timestamp replacement for SNAPSHOT
15:07:43 <gzhao> phrobb: we are working actively with sdni, pluginoc moving to karaf, both in pending review stage.
15:07:44 <rovarga> edwarnicke: well.. versions again ... all this Helium-1 is just a band-aid for us not having sane versions :-/
15:08:05 <gzhao> phrobb: pcmm, snmp, vtn all respond they are working on code freeze
15:08:10 <colindixon> PriyankaChopra: the blunt version is: if plugin2oc does not have a karaf feature merged into integrationby 5p pacific on Moday, it will not be part of Helium
15:08:19 <colindixon> gzhao: phrobb meant have the acked that statement
15:08:20 <gzhao> phrobb: defense4all is waiting for tsc exemption
15:08:33 <colindixon> I know pcmm has
15:08:42 <colindixon> I know that defense4all has, but is hoping the exception
15:08:57 <colindixon> I’m 95% sure that Hideyuki acked it for VTN
15:09:02 <gzhao> phrobb: colindixon from ack's point of view, all projects responded
15:09:07 <rovarga> edwarnicke: which is to say: yangtools/tcpmd5/yangtools is fine letting the stable release cycle use the super-minor number space, eliminating the need for funky suffixes
15:09:40 <colindixon> #info phrobb asks if all projects in the “danger zone” for RC1 acked that they would be dropped if they didn’t get out my Monday at 5pm pacific
15:09:57 <colindixon> #info gzhao says that all 7 projects responded to that statement
15:09:58 <gzhao> edwarnicke: rovarga maybe we should let project as bgp to go for stable/helium earlier
15:10:34 <rovarga> gzhao: we can't do a release until yangtools and controller both undergo a release
15:10:44 <phrobb> gzhao:  Thanks!  That's great to hear.  I wanted to make sure no one was going to be blindsided after-the-fact.
15:11:05 <gzhao> phrobb: sure
15:11:06 <colindixon> gzhao: did they respond to just you? I’m not seeing that on the thread here: https://lists.opendaylight.org/pipermail/release/2014-September/000389.html
15:11:33 <edwarnicke> colindixon: defense4all also has a purely mechanical thing with versions... as a mechanical matter if they do not fix it by tonight I will have to remove them from the autorelease until its fixed, as their use of release versions will cause the autorelease to fail.
15:11:50 <gzhao> sdni,snmp, sfc just responded to me I think
15:12:17 <colindixon> edwarnicke: understood, but does that mean they’re testing against Hydrogen APIs?
15:13:20 <gzhao> if we are dong with blocking issue, shall we go to next topic, branch cutting and open questions
15:13:29 <radhika> gzhao: https://git.opendaylight.org/gerrit/#/c/11094  -- this is latest link for integration upload
15:13:31 <gzhao> any project has urgent issue to report
15:13:32 <edwarnicke> colindixon: I don't know... I encountered the issue while drafting the 'Please go test this against that' email
15:13:44 <gzhao> radhika: thanks
15:13:58 <edwarnicke> radhika: Your commit message is still pointing to a verify not a merge
15:14:03 <colindixon> gzhao: sorry, I’m trying to close this thing for phrobb really quickly
15:14:13 <radhika> gzhao: fixed all comments in karaf upload.. dont know what else is pending with us..?
15:14:21 <colindixon> so, you got e-mail acks from sfc, snmp4sdn, and sndi
15:14:44 <colindixon> we got acks in IRC from pcmm, and VTN
15:14:54 <PriyankaChopra> colindixon : I am working on including the features test case. Otherwise the integration patch has been submitted..
15:14:54 <radhika> edwarnicke: got a email from  George saying merge wil be happen tmrw night..
15:15:11 <colindixon> I’m assuming that we got an ack from defense4all bc/ of the request for an exception
15:15:22 <colindixon> and we just got an ack from PriyankaChopra (plugin2oc) in IRC
15:15:24 <colindixon> so that’s all 7
15:15:31 <gzhao> radhika: pending review, just stand by a little
15:15:41 <colindixon> phrobb: does that make sense
15:15:41 <gzhao> colindixon:ok
15:16:07 <gzhao> colindixon: yes. from those three project
15:16:11 <phrobb> colindixon:  yes.  It looks like we have coverage
15:16:30 <gzhao> colindixon: edwarnicke is working defense4all
15:16:42 * colindixon notes it would be a good idea to have a list of those acks documented, Ideally in publicly visible places
15:17:00 <gzhao> and I believe PriyankaChopra here can ack for pluginoc
15:17:11 <colindixon> the IRC ones are are logged in meetings (except maybe VTN), but let me go check
15:17:12 <vina_> #info Vina Ermagan for lispflowmapping
15:17:18 <edwarnicke> gzhao: Do we have clear instructions on what we are supposed to do for docs?
15:17:23 <edwarnicke> gzhao: I for one have no idea...
15:17:33 <edwarnicke> gzhao: I have seen industrious folks building web pages
15:17:33 <colindixon> gzhao: can you forward the mails you got from the other three to the release list so we have them logged?
15:17:43 <edwarnicke> gzhao: And different industrious folks building ascidoc
15:17:45 <gzhao> edwarnicke: docs in general or just for karaf?
15:17:57 <edwarnicke> gzhao: But I have no idea what the road forward for docs is personally (hoping its just me :) )
15:18:00 <colindixon> #action gzhao to forward the direct responses acking the RC1 requirements and consequences to the release list so that we have them publicly logged
15:18:04 <edwarnicke> gzhao: docs
15:18:46 <gzhao> colindixon: ok
15:18:49 <colindixon> edwarnicke: there are instructions
15:18:55 <colindixon> I’m finding them now
15:19:00 <edwarnicke> Many thanks :)
15:19:05 <edwarnicke> Because I am completely confused :)
15:19:12 <edwarnicke> Which I'm hoping is my fault for not RTFM :)
15:19:25 <phrobb> edwarnicke:  have you seen this wiki page Mathieu made?
15:19:35 <phrobb> #link https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Documentation_Guidelines
15:19:40 <colindixon> thanks
15:19:41 <colindixon> #undo
15:19:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x272e950>
15:19:55 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Documentation_Guidelines the documentation guidelines for Helium
15:20:05 <edwarnicke> colindixon: That's a lovely diagram... where's the 'how'
15:20:10 * colindixon apologizes for being anal-retentive when it comes to things like this
15:20:22 <edwarnicke> colindixon: Looking at that I can't tell 'how' to do docs
15:20:24 <PriyankaChopra> gzhao : https://git.opendaylight.org/gerrit/#/c/11077/ has already been merged.
15:20:26 <colindixon> #undo
15:20:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x272ef50>
15:20:29 <colindixon> hold on
15:20:30 <edwarnicke> Nor do I see 'how' they are being pulled together
15:20:30 <colindixon> I have it
15:20:37 <PriyankaChopra> That is Karaf integration for plugin2oc
15:20:55 <edwarnicke> PriyankaChopra: You still have no running feature tests: https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-merge/org.opendaylight.plugin2oc$features-plugin2oc/9/testReport/
15:21:02 <gzhao> PriyankaChopra: congratulations, plugin2oc is out of danger zone for RC1
15:21:21 <colindixon> edwarnicke: that is a damn good question
15:21:24 <edwarnicke> Meaning we have no way of knowing if this is going to break all of integration, or making sure that subsequent commits do not do so
15:21:29 <colindixon> mlemay: is there a “how” document on docs?
15:21:50 <colindixon> edwarnicke: maybe this https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Tools
15:21:55 <gzhao> #info plugin2oc Karaf features merged into integration. That project is out of "danger zone" for Helium RC1
15:22:07 <colindixon> and there was much rejoicing
15:22:09 <colindixon> thanks PriyankaChopra
15:22:18 <rafat> #info rafat for sdni along with Radhika
15:22:21 <mlemay> colindixon: yes what you sent to ed
15:22:25 <colindixon> #topic documentation
15:22:41 <gzhao> colindixon: how do I undo my #info
15:22:50 <mlemay> @colindixon: the "what to document" is still very "shady"...
15:22:51 <colindixon> gzhao: which one?
15:22:53 <rafat> Can we review for sdni as well, https://git.opendaylight.org/gerrit/#/c/11094/
15:23:03 <colindixon> you can only undo the last one
15:23:08 <colindixon> #undo
15:23:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x272e110>
15:23:09 <colindixon> #unod
15:23:13 <colindixon> #undo
15:23:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x272ec10>
15:23:15 <colindixon> #undo
15:23:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x272e590>
15:23:21 <colindixon> #info rafat for sdni along with Radhika
15:23:22 <gzhao> colindixon: thanks
15:23:31 <gzhao> colindixon: didn't catch edwarnicke 's comment
15:23:51 <colindixon> #topic documentation
15:24:02 <gzhao> folks 7 minutes to go
15:24:05 <colindixon> #info edwarnicke asks where the “how to” information is on creating documentation
15:24:25 <gzhao> radhika: let's put that to edwarnicke's queue
15:24:34 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Tools mlemay says this is it but it is stil “very shady”
15:25:10 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Documentation_Guidelines this is a flow chart of what kind of documentation you should be making
15:25:11 <edwarnicke> gzhao: If you examine the link for plugin2oc.. you will see https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-merge/org.opendaylight.plugin2oc$features-plugin2oc/9/testReport/ indicates they have *no tests at all* running for their feature... meaning that they are not running the OSGI load tests as part of their merge job there... which means they may
15:25:11 <edwarnicke> be breaking all of integration, and have no checks against subsequent breakage of integration
15:25:17 <colindixon> mlemay: so all docs go to the docs project?
15:25:18 <radhika> gzhao: thats for review...?
15:25:25 <colindixon> mlemay: or do some of them go to your own project?
15:25:38 <edwarnicke> It doesn't make sense to move the docs away from the project...
15:26:10 <gzhao> radhika: can you add test for the feature?
15:26:28 <gzhao> radhika: sorry, I mean to PriyankaChopra
15:27:04 <PriyankaChopra> gzhao: I am working on adding the test cases ..
15:27:05 <edwarnicke> PriyankaChopra: Please don't leave yet... as we need to make sure you get those tests running, otherwise the merge into integration is simply an error, as the merge job you linked does not contain the required execution of the feature load tests
15:27:15 <gzhao> PriyankaChopra: thanks
15:27:16 <edwarnicke> PriyankaChopra: Its not about adding functionality test cases
15:27:39 <edwarnicke> gzhao: Those feature load tests need to be fixed asap, as having a feature in integration that does not have them running
15:27:49 <edwarnicke> a)  Violates the requirement for inclusion in integration
15:27:57 <edwarnicke> b)  Produces very very strong risk of breakage to others
15:28:32 <colindixon> I realize that I’m now very confused about docs
15:28:37 <edwarnicke> gzhao: The merge to integration was in error, as it does not meet the criteria for review: https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#What_to_review
15:28:45 <PriyankaChopra> edwarnicke : can you give me a reference of the test cases you are referring to.. so that i can create the same for plugin2oc
15:29:26 <edwarnicke> #3 "Follow the "Feature Tests Pass:" link to make sure it points to Features Tests and they pass" as the link does not point to the features tests, and even if you were to drill down, you will find there are no such tests running, much less passing
15:29:53 <edwarnicke> PriyankaChopra: Let me send you a link from another integration commit for reference (there was also one in the instructions, but let me grab a more recent one)
15:29:56 <colindixon> mlemay: are you around
15:30:08 <mlemay> colindixon: yes
15:30:16 <radhika> gzhao: any updates for sdni..? anything needs to be do from ourside...?
15:30:18 <PriyankaChopra> edwarnicke : that would be helpful..
15:30:19 <PriyankaChopra> Thanks
15:30:27 <colindixon> mlemay: so, where should documentation actually go?
15:30:28 <mlemay> colindixon: but have to be called out :) (not watching the screen much)
15:30:43 <colindixon> mlemay: I know
15:31:17 <colindixon> mlemay: does it go in the docs git repo? or does it go in the project’s repo and then get pulled into the docs repo by the pom.xml?
15:31:22 <gzhao> radhika:  this https://git.opendaylight.org/gerrit/#/c/11094 is in edwarnicke's queue now
15:31:30 <mlemay> colindixon: depends on the type of documentation... and who is the target audience.. the docs project is for docs that are meant to people outside odl community
15:31:35 <edwarnicke> PriyankaChopra: https://jenkins.opendaylight.org/sfc/job/sfc-merge/org.opendaylight.sfc$features-sfc/47/testReport/ from https://git.opendaylight.org/gerrit/#/c/10829/
15:31:43 <radhika> gzhao: ok..
15:31:51 <mlemay> colindixon: goes in the docs repo when applicable to the official guides
15:32:25 <edwarnicke> radhika: Please change the link from https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-verify/lastBuild/testReport/ to   https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-verify/org.opendaylight.sdninterfaceapp$features-sdninterfaceapp/33/testReport/ (which is the correctly specific one)
15:32:34 <mlemay> colindixon: however most of the docs that exists on wiki I would qualify as developer doc for internal OPenDaylight developer so most of it is to be kept on wiki
15:32:47 <colindixon> ok
15:33:20 <radhika> edwarnicke: ok .. will do that..
15:33:27 <gzhao> Do we have any other issues
15:33:32 <colindixon> mlemay: so, is that to say that Developer guides go on the wiki
15:33:42 <colindixon> mlemay: and user guides go in the docs project?
15:34:36 <colindixon> gzhao: I think that there’s a question around the how to do documentation
15:34:44 <colindixon> but it seems it’s not going to get resolved here
15:35:14 <mlemay> colindixon: I need to be clear about developer.. if you are developing OpenDaylight itself = wiki, if you are a external consumer of OpenDaylight but a developper that is the docs dev guide (think RestConf app writer or system integrator or whaterver)
15:35:27 <PriyankaChopra> edwarnicke :Thanks.. I will include these asap. and update..
15:35:31 <mlemay> colindixon: what is the question exactly?
15:35:55 <gzhao> edwarnicke: I need to go back and read this https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#What_to_review
15:36:03 <colindixon> I mean, the real question is: “I’m working on project X and I’m ready to start my docs. What do I do?"
15:36:10 <edwarnicke> colindixon: YES :)
15:36:16 <edwarnicke> colindixon: And quite a few folks have asked
15:36:26 <edwarnicke> colindixon: And we need to see how that flows through end to end
15:36:33 <colindixon> mlemay: I think the answer is step one go here: https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Documentation_Guidelines
15:36:58 <colindixon> mlemay: but step 2 needs to provide 2-3 lines of guidance (at least for each of the blue square boxes)
15:37:11 <edwarnicke> mlemay: Also... do we have an example of this all working end to end?
15:37:21 <edwarnicke> mlemay: The docs stuff working end to end?
15:37:31 <colindixon> I know that l2switch was making asciidoc, but I don’t  see it in their repo
15:38:05 <edwarnicke> mlemay: My question is... if I do asciidoc... where do I see this all being posted to a website?
15:39:20 <gzhao> colindixon: edwarnicke can i end meeting since it runs over, or this is part of the meeting, we should record it
15:39:26 <colindixon> yeah
15:39:31 <edwarnicke> colindixon: mlemay thoughts?
15:40:01 <colindixon> I mean, we need the answers from mlemay, but it seems like we might not get them now
15:40:08 <colindixon> so, we should get them today and send an e-mail
15:40:26 <gzhao> colindixon: edwarnicke mlemay if we can have end to end steps that will be great, we can add check point at each step.
15:40:36 <edwarnicke> gzhao: net-net... I have no idea how to start doing docs right now
15:40:53 <mlemay> edwarnicke: docs don't get deployed to maven site right now... because I have to check that with Andrew... it stages the site locally though
15:41:11 <edwarnicke> mlemay: OK... we need to have it deploy
15:41:18 <mlemay> thing is trying to fit this in maven site vs just uploading the result is what is causing me pain
15:41:22 <edwarnicke> mlemay: And do you have a pointer to the 'how' to do docs?
15:41:51 <regXboi> I feel this pain
15:41:55 <mlemay> I tried maven site to save andrew work but in the end we might need a traditional www location where we dump the whole thing
15:42:10 <regXboi> and there was (I thought) a wiki page where I walked through how to do some of it
15:42:41 <colindixon> https://wiki.opendaylight.org/view/OpenDaylight_Controller:How_To:_Site_Deploy
15:42:48 <radhika> edwarnicke: any other comments for sdni... Can we have all the comments together.We are not able to do --amend --signoff.Everytime there is a new gerrit link.
15:43:12 <colindixon> radhika: if you use git review it should fix that
15:43:13 <mlemay> regXboi.. yes thanks Ryan but it's a little more than that cause it's not all maven .. so the "output" is a full www folder that needs to be uploaded and maven site really wants to do it all so I have to check if I can "site-deploy" without site-generate
15:43:14 <regXboi> that would be the page colindixon
15:43:27 <edwarnicke> radhika: Are you using git review?
15:43:56 <edwarnicke> mlemay is that folder attached as an artifact to the build?
15:44:17 <regXboi> mlemay: if I recall you should be able to do both
15:44:37 <gzhao> radhika: you still have an extra white space on line 68.-:)
15:44:41 <edwarnicke> mlemay: If we could attach the folder as an artifact, we would at least have something quick and dirty to reference
15:44:46 <regXboi> i.e. site-generate but part of site-generate is to copy in the full www folder so site-deploy picks it up
15:44:51 <edwarnicke> (far from ideal... but something that unblocks folks)
15:45:04 <mlemay> edwarnicke: nope
15:45:16 <regXboi> huh? what do we mean nope?
15:45:35 <mlemay> edwarnicke: I mean not attached to build.. has to be uploaded via wagon
15:45:45 <mlemay> very doable
15:45:48 <radhika> edwarnicke: git review is not working in our environment...
15:46:04 <regXboi> huh^2
15:46:12 <regXboi> why isn't a wagon upload part of build?
15:46:22 <regXboi> just to make it automagic
15:46:33 * regXboi seriously confused
15:46:35 <radhika> gzhao: we will remove that space and upload the latest..
15:47:25 <edwarnicke> radhika: OK... have you downloaded the gerrit trigger? (looking for docs)
15:48:19 <colindixon> gzhao: ChristineH is here from snmp4sdn if you wanted to ask anything
15:48:48 <rafat> Ed we have not done that.
15:48:55 <rafat> #info sdni
15:49:00 <ChristineH> Excuse me I couldn't show up until now :)
15:49:31 <gzhao> colindixon:
15:49:34 <gzhao> colindixon: thanks
15:49:50 <regXboi> mlemay: if you give me an example www folder zip file, I can see about getting it included as part of site-generate and/or site-deploy
15:49:51 <gzhao> ChristineH: hello, is code frozen for snmp4sdn?
15:49:52 <mlemay> regXboi: it's just a config thing because maven is not handling the complete build process as some of this was off OPenStack and OpenStack also builds have the docs via python so I need to translate the python pieces to maven build or replace that .. it's the index that holds the guides together
15:49:52 <rafat> Ed,we are trying to close the integration merge now.
15:49:55 <edwarnicke> ChristineH: Welcome :)
15:50:08 <edwarnicke> rafat: Many thanks, it looks like you guys are really close :)
15:50:18 <edwarnicke> PriyankaChopra: Were are you getting things fixed?
15:50:53 <rafat> Ed,one question.I incorporate the comments and up,oad the new gerrit link..It should work..right ?
15:50:55 <ChristineH> gzhao: not yet, mainly dealing with md-sal for snmp4sdn
15:51:07 <PriyankaChopra> edwarnicke : I am already looking into these.. Will update asap..
15:51:11 <mlemay> regXboi: if you want to help out on the site-deploy bit.. I won't say no :) I'm a little overwhelmed by the TODO list ;)
15:51:39 <colindixon> ChristineH: we just wanted to make sure that you know that if you are not code-frozen by Monday at 5pm pacific, the project will be dropped from Helium
15:51:41 <gzhao> ChristineH: when do you plan to freeze them, you know the TSC new rule for RC1, all projects need to reach code freeze
15:51:42 <mlemay> regXboi: uploading results is the last thing required from a toolchain perspective
15:51:45 <colindixon> not trying to be mean, just true
15:52:19 <regXboi> mlemay: I admit to being a bit confused here
15:52:32 <regXboi> mlemay: I'm no longer sure what the gaps are that need to be closed
15:53:45 <ChristineH> gzhao: I believe they will be frozen tomorrow, or the day after tomorrow
15:54:10 <colindixon> regXboi: there’s two high-level gaps: (1) I don’t know where to put my documentation and (2) I don’t know where the docs wind up when we “build” them
15:54:28 <regXboi> colindixon: talking on separate channel to avoid crosstalk
15:54:45 <gzhao> ChristineH: I will put tomorrow for now, you let me know if you cannot achieve that, do remember the deadline is Monday UTC to make Helium. thanks
15:55:18 <ChristineH> gzhao: sure, thanks :)
15:55:39 <edwarnicke> PriyankaChopra: Let me know if you hit any issues, we can totally work this out :)
15:55:50 <colindixon> regXboi: channel?
15:56:00 <regXboi> P2P channel
15:56:14 <regXboi> I think I can say that there is a little bit of confusion on the docs issue
15:56:14 <edwarnicke> rafat: Here's what I've looked at for you.  I looked at your commit message.  Its pointing to the wrong place.  I did the drill down far enough to see that you have the right stuff in the right place for #1.
15:56:22 <PriyankaChopra> edwarnicke : yes please I ll need some help..
15:56:41 <edwarnicke> rafat: What I haven;t' done yet is drill down and look at the guidelines releated stuff (odl- prefix, etc)... will do now, but I suspect you got that right :)
15:56:58 <edwarnicke> PriyankaChopra: You and I will get this fixed.  It will be OK :)
15:57:36 <PriyankaChopra> edwarnicke: Thanks a lot. :) :)
15:57:43 <rafat> Ed, I have done all the fixes now.Uploaded the code in new link:https://git.opendaylight.org/gerrit/#/c/11111
15:57:49 <gzhao> edwarnicke: thanks, it seems we should be able to claim "victory" for karaf war
15:58:07 <rafat> but the build is showing pending for me..Now how to get this right.
15:58:18 <rafat> Ed,how to get this right.
15:58:42 <colindixon> rafat probably waiting for build resoruces
15:59:30 <rafat> I am done with all the changes.It only needs to be reviewed for merge.
15:59:59 <rafat> Colin,what possible chances when the build will be initiated.
16:00:19 <edwarnicke> rafat: Link to your gerrit?
16:00:30 <colindixon> https://git.opendaylight.org/gerrit/#/c/11111
16:00:36 <rafat> Thats the one..
16:00:37 <edwarnicke> rafat: Looking at your old gerrit, the only issue I saw was the link
16:00:47 <rafat> yes..correct
16:00:50 <edwarnicke> rafat: Which means you are very likely in good shape with the new one
16:00:59 <edwarnicke> But lets hang out till we get it verified and merged :)
16:01:00 <rafat> we can go with that also if you are ok with the link
16:01:21 <gzhao> rafat: please rebase your code first, you overwritten plugin2oc's changes
16:01:32 <rafat> Is it.?
16:01:36 <edwarnicke> rafat: What is the link to your gerrit with teh correct link pointing directly to the feature tests (the ones that are checking the wiring)
16:01:37 <colindixon> rafat: https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/ (says your build is next in that queue)
16:01:58 <rafat> let me check
16:02:04 <edwarnicke> rafat: If you send me the link to your current gerrit, I will try to autorebase it for you :)
16:02:23 <edwarnicke> PriyankaChopra: I'm still here when you hit a place you need help :)
16:03:09 <PriyankaChopra> I am able to add the features-test.. https://git.opendaylight.org/gerrit/#/c/11060/8/
16:03:20 <rafat> sure ed...I had 2 links.
16:03:36 <rafat> https://git.opendaylight.org/gerrit/#/c/11094/ is the link where you gave the comment..This one is verified an awaiting merge
16:03:41 <PriyankaChopra> the test is failing because of cyclic dependencies
16:03:58 <rafat> https://git.opendaylight.org/gerrit/#/c/11111 is the new link where I tried updating the link...
16:04:07 <PriyankaChopra> logs : https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-verify/org.opendaylight.plugin2oc$features-plugin2oc/43/testReport/
16:04:16 <edwarnicke> PriyankaChopra: Looking here, the verify failure looks like its infra, not your code https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-verify/45/console
16:04:34 <edwarnicke> I would recommend retriggering the Jenkin's Job, do you know how to do that? (happy to explain if you don't ;) )
16:04:56 <edwarnicke> PriyankaChopra: https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-verify/org.opendaylight.plugin2oc$features-plugin2oc/43/testReport/ looks about right though :)
16:05:24 <PriyankaChopra> so what do I do next?
16:05:40 <edwarnicke> PriyankaChopra: Two things
16:05:48 <edwarnicke> 1)  Your tests are failing on wiring:
16:05:48 <edwarnicke> https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-verify/org.opendaylight.plugin2oc$features-plugin2oc/43/testReport/installFeature(org.opendaylight.yangtools.featuretest.SingleFeatureTest)[repoUrl_%20file__opt_jenkins-plugin2oc_jobs_plugin2oc-verify_workspace_features-plugin2oc_target_classes_features.xml,%20Feature_%20odl-plugin2oc%200/1]/installFea
16:05:48 <edwarnicke> ture/
16:05:57 <edwarnicke> But its a familiar *kind* of fail
16:06:11 <edwarnicke> java.io.IOException: Error resolving artifact org.opendaylight.controller:sal.implementation:jar:0.4.2-SNAPSHOT: Could not find artifact org.opendaylight.controller:sal.implementation:jar:0.4.2-SNAPSHOT in nexus-release-mirror
16:06:21 <PriyankaChopra> yes..
16:06:24 <edwarnicke> Means that you are lacking dependencies in your features/pom.xml
16:06:27 <rafat> Ed, Can we go ahead with https://git.opendaylight.org/gerrit/#/c/11094/
16:06:32 <edwarnicke> So.. here's how you fix that kind of thing
16:07:09 <edwarnicke> foreach <bundle> <repo> or <configfile> in your features.xml file, make sure you have the corresponding maven dependency in your features/pom.xml file
16:07:24 <edwarnicke> PriyankaChopra: Does that give you enough to go on to start working on fixing it?
16:07:30 <edwarnicke> rafat: Looking now :)
16:08:39 <edwarnicke> rafat: https://git.opendaylight.org/gerrit/#/c/11094/ still has an incorrect link for two reasons:
16:08:46 <edwarnicke> 1)  It points to the verify job, not the merge job
16:08:58 <PriyankaChopra> edwarnicke: I think I have for all.. still will cross check again..
16:09:19 <edwarnicke> 2)  It does not point directly to the tests, for that you would need something more like https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-verify/org.opendaylight.sdninterfaceapp$features-sdninterfaceapp/33/testReport/
16:09:32 <edwarnicke> (but note, https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-verify/org.opendaylight.sdninterfaceapp$features-sdninterfaceapp/33/testReport/ is not going to be the right link as it points to a verify job)
16:10:05 <rafat> The review needs to be closed for merge Ed.Will this link matter ?I am not able to initiate build for the new link created.
16:10:48 <edwarnicke> rafat: you can't merge your feature to integration until its merged to your own repo first
16:11:11 <rafat> ok...so I need to initiate the merge from here as we have been doing before ?
16:11:24 <rafat> I need your help here with the steps.
16:12:02 <edwarnicke> rafat: What is the link to the gerrit for you putting the features into your own repo?
16:12:32 <rafat> The one I creates for sdninterfaceapp ?
16:12:46 <edwarnicke> Yes :) (your repo name is long... I keep forgetting it ;) )
16:13:19 <rafat> https://git.opendaylight.org/gerrit/#/c/11046/
16:13:20 <rafat> This is merged also.
16:13:49 <rafat> https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-merge/
16:14:53 <rafat> I got the link issue...Can we let it go..Am not able to fix from here :-(
16:17:20 <CASP3R> https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-merge/org.opendaylight.sdninterfaceapp$features-sdninterfaceapp/10/testReport/
16:17:29 <CASP3R> rafat  i believe that the link edwarnicke  is looking for
16:17:38 <edwarnicke> rafat: this in the link you want to reference in your commit message for #1 for your gerrit for integration: https://jenkins.opendaylight.org/sdninterfaceapp/job/sdninterfaceapp-merge/org.opendaylight.sdninterfaceapp$features-sdninterfaceapp/10/testReport/
16:17:53 <edwarnicke> rafat: its the one that shows your merge job passing the feature wiring tests directly :)
16:18:07 <edwarnicke> CASP3R: You beat me to it :)
16:18:23 <rafat> I am not able to do the change Ed.So wondering if we can proceed without updating this link..Is it possible..?
16:18:47 <CASP3R> also when you amend your change can you remove the whitespace
16:18:58 <edwarnicke> PriyankaChopra: Specifically,  your test failure is claiming it can't find org.opendaylight.controller:sal.implementation:jar:0.4.2-SNAPSHOT, which probably means you are missing the correct dependency for the feature file for feature-adsal in your features/pom.xml
16:19:39 <rafat> Ed, any input for me..Or I need to start with the new gerrit link creation...?git commit –amend --signoff does not work for me..
16:19:42 <edwarnicke> PriyankaChopra: Things that can commonly go wrong there would be that you have the dependency without having the correct <type>xml</type> and <classifier>features</classifier> in the dependency
16:20:06 <CASP3R> rafat what error message you getting
16:20:07 <edwarnicke> rafat: Yes... one moment
16:20:43 <edwarnicke> rafat: If https://git.opendaylight.org/gerrit/#/c/11094/ is your integration patch (which I think it is) go to it
16:21:00 <rafat> Ed: It is my patch...
16:21:09 <edwarnicke> rafat: Notice that in your commit message the second to last line is:
16:21:09 <edwarnicke> Change-Id: I2fd6fbc78938c4ee7fa7a49983f8ccdabf00ba8c
16:21:24 <edwarnicke> Gerrit uses Change-id to determine if something is the same gerrit
16:21:32 <edwarnicke> So when you do your
16:21:36 <edwarnicke> git commit --amend --signoff
16:21:41 <rafat> I am not able to do git commit –amend --signoff
16:21:47 <rafat> thats the whole issue
16:21:50 <edwarnicke> rafat: Lets be very precise
16:21:55 <edwarnicke> Are you unable to do
16:22:01 <edwarnicke> git commit --amend --signoff
16:22:05 <rafat> yes
16:22:15 <edwarnicke> Or is it that when you do it and push you get a brand new gerrit?
16:22:38 <rafat> Since I am not able to do git commit --amend --signoff, i have to push a new gerrit everytime
16:22:52 <rafat> Need your help Ed.
16:23:18 <edwarnicke> rafat
16:23:21 <edwarnicke> What happens when you run
16:23:27 <edwarnicke> git commit --amend --signoff
16:23:43 <rafat> It allows me to change the ID,but then gives error in pushing...
16:23:51 <rafat> says someone else is the owner.
16:23:56 <rafat> Have tried several times.
16:24:13 <edwarnicke> rafat: Ah
16:24:15 <edwarnicke> Hang on
16:24:16 <rovarga_> --amend --author 'Your Name <your@email>
16:24:20 <edwarnicke> I know how to fix that one :)
16:24:21 <rovarga_> '
16:24:24 <edwarnicke> rovarga_: Beat me to it :)
16:26:40 <PriyankaChopra> edwarnicke:  for all <repo> tags we need to have <type>xml</type> and <classifier>features</classifier> in the dependency tag
16:27:26 <PriyankaChopra> for others its only group id, artifact id and version solves the purpose..?
16:27:34 <edwarnicke> PriyankaChopra: Short answer: yes.
16:27:54 <PriyankaChopra> edwarnicke : This is what I followd
16:28:05 <PriyankaChopra> followed*
16:28:11 <PriyankaChopra> just cross checked..
16:28:16 <edwarnicke> PriyankaChopra: Longer answer would involve talking about that being what you are doing in the mvn: url for the repo... but everyone is using the convention of <type>xml</type> <classifier>features</classifier> so the short answer should be true ;)
16:28:40 <edwarnicke> PriyankaChopra: Is what's on your master correct? (about to pull your code)
16:29:07 <PriyankaChopra> have few additional changes which i didnt merge..
16:29:35 <PriyankaChopra> Can I email you the features files ?
16:30:21 <edwarnicke> PriyankaChopra: Could you push a patch?
16:30:27 <edwarnicke> PriyankaChopra: email is a really hard way to share code
16:30:40 <edwarnicke> rafat: Did rovarga_ 's suggestion help you?
16:30:49 <PriyankaChopra> sure..
16:31:08 <rafat> I am pushing the new link
16:32:31 <CASP3R> rafat   you just removed plugin2oc   in your patch
16:32:33 <rafat> Ed I have created a new link but the build is not getting initiated.
16:32:49 <rafat> HOw is that possible. ?
16:32:57 <CASP3R> u did a git pull
16:33:03 <rafat> Yes.
16:33:06 <CASP3R> then u copy over the over .xml files
16:33:13 <rafat> Yes
16:33:24 <CASP3R> so the git pull   had the new plugin2oc
16:33:29 <CASP3R> then ur new file didn't
16:33:42 <rafat> Ok In that case we need to work with https://git.opendaylight.org/gerrit/#/c/11094/ only.
16:36:01 <rafat> can somene please help here..All my build is pending...
16:37:16 <edwarnicke> rafat: Looking
16:37:25 <rafat> ok..
16:38:34 <edwarnicke> rafat: Deep cleansing breath :)  integration is very very infrastructure resource strapped... it sometimes takes a little while for the verify job to start
16:39:18 <rafat> I did -amen --signoff also on  https://git.opendaylight.org/gerrit/#/c/11094/..cant see the change in the link...Am getting a panic attack now
16:40:12 <edwarnicke> rafat: Deep cleansing breath, we will get this worked out
16:40:28 <rafat> Yes Ed.
16:42:04 <edwarnicke> rafat: What is the output in your local integration repo of
16:42:05 <edwarnicke> git rev-parse HEAD
16:43:16 <rafat> No I can see th update in https://git.opendaylight.org/gerrit/#/c/11094/ but it will take time to build.Some 2 more build in between...
16:43:25 <rafat> *Now
16:44:12 <edwarnicke> rafat: Your link is correct :)
16:44:17 <edwarnicke> rafat: Now just need to wait on the verify
16:44:25 <edwarnicke> rafat: Thank you for staying late on a Friday :)
16:44:40 <CASP3R_> no the patch deletes plugin2oc
16:44:44 <rafat> ok...so which link are we referring to...https://git.opendaylight.org/gerrit/#/c/11094/
16:45:01 <rafat> https://git.opendaylight.org/gerrit/#/c/11094/  does not..
16:45:05 <rafat> i think
16:45:11 <CASP3R_> patch set 2 does
16:46:16 <rafat> Ed if this works..I am the happiest on earth..Please stay around...
16:46:40 <edwarnicke> rafat: I will stay around
16:46:48 <edwarnicke> rafat: I don't get peace until we get you guys in :)
16:47:43 <rafat> sure Ed..There is one build going on...We dont need it..The next 2 builds pending in line are the one...We can take any of it...
16:48:22 <edwarnicke> rafat: are you saying there are builds for previous patchsets of 11094 before the version that really matters?
16:48:27 <edwarnicke> rafat: If so, I can cancel them
16:48:34 <edwarnicke> rafat: Get you to your weekend earlier ;)
16:48:40 <rafat> the one going on you can cancel..
16:48:47 <edwarnicke> Link?
16:48:55 <rafat> we need https://git.opendaylight.org/gerrit/#/c/11094/
16:49:18 <rafat> or https://git.opendaylight.org/gerrit/#/c/11112
16:51:01 <rafat> https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/
16:52:06 <edwarnicke> https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/325/ looks like its for a patch of yours https://git.opendaylight.org/gerrit/#/c/11111/ may I cancel https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/325/
16:52:21 <rafat> yes
16:58:33 <edwarnicke> rafat: https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/326/ is for your patch https://git.opendaylight.org/gerrit/#/c/11112/ may I cancel it?
17:00:20 <rafat> It is the right patch ed..If this builds fine,we can take it...
17:00:39 <rafat> then we can cancel the remaining one left..Got to wait for this one to complete.
17:01:09 <rafat> we will need to merge it once the build is done.
17:02:17 <edwarnicke> So  https://git.opendaylight.org/gerrit/#/c/11112/ is  a good patch to consider for merging once it verifies?
17:02:44 <rafat> yes..But why is the build blink in grey..Normally its blue...
17:02:49 <rafat> Am i thinking too much ?
17:03:38 <tykeal> rafat: a grey blinking ball just means that the last build that went through on that job was either (a) no job [it's the first build] or (b) the previous job was cancelled
17:03:51 <rafat> ok..
17:03:58 <tykeal> a blinking blue means that the previous build was a success
17:04:08 <tykeal> a red blinking means the previous build was a failure
17:04:17 <tykeal> and a yellow blink means the previous build was unstable
17:04:49 <tykeal> essentially the ball shows the color of the _last_ completed build but blinks to indicate that another build is in progress
17:07:16 <edwarnicke> tykeal: Good morning! :)
17:08:55 <gzhao> edwarnicke: just question, has the meeting ever ended?
17:09:16 <edwarnicke> gzhao: LOL... I think we are still going ;)
17:09:39 <gzhao> ok, I will standby, I can scroll up for my action
17:10:17 <edwarnicke> rafat: Ping me when your patch verifies
17:10:38 <rafat> yes add..I hope we will merge right after that
17:10:48 <edwarnicke> rafat: That's the plan :)
17:10:54 * tykeal notes he saw a failed merge job for the docs project because they tried to upload to org/opendaylight/documentation and not org/opendaylight/docs (like all other projects uploading against their project name)
17:10:55 <edwarnicke> rafat: I am an integration commiter, so I can do it :)
17:11:12 <edwarnicke> mlemay: Did you see tykeal's note two lines above?
17:11:17 <rafat> yes ed..I just hopes there are no more issues...
17:11:33 <edwarnicke> gzhao: Do we have a spreadsheet to report testing of features for RC0 ?
17:11:39 <edwarnicke> gzhao: I have been pushing folks to do that :)
17:12:06 * tykeal also notes that it just happened to jump out at him because he doesn't usually pay attention to the jenkins mailing list spew
17:12:16 <edwarnicke> tykeal: Many thanks :)
17:12:32 <tykeal> probably caught my attention because it was build #1 ;)
17:13:00 <gzhao> edwarnicke: current empty, I am thinking of merge this one https://docs.google.com/spreadsheets/d/12MWfLYNG_YO8pnUt5CrFD2xL1vHUXcmnUNrH-m6EdC0/edit#gid=0
17:13:35 <gzhao> to my spreadsheet: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=829479065
17:14:12 <mlemay> tykeal: yuip
17:14:15 <gzhao> edwarnicke: Monday release sync will be the last one for RC1, correct?
17:14:17 <mlemay> tried to od it quick
17:14:36 <mlemay> thanks for spotting it I'm fixing that in between other things
17:15:54 <mlemay> but yea that means groupId is wrong everywhere  :( (codebase existed before repo creation)
17:16:09 <mlemay> never got changed
17:16:26 <mlemay> will fix right away
17:17:03 <edwarnicke> gzhao: I don't understand what you mean by " Monday release sync will be the last one for RC1, correct?"
17:20:35 <edwarnicke> gzhao: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=829479065 seems to be for RC1, do we have something for RC0?
17:21:53 <gzhao> edwarnicke: we will cut RC1 on Monday, right?
17:21:59 <edwarnicke> gzhao: Yes :)
17:22:04 <colindixon> gzhao, edwarnicke: I hope so :-)
17:22:09 <colindixon> speaking of which
17:22:18 * edwarnicke starts to rev up threats to sequence bits by hand...
17:22:22 <colindixon> is there any process by which projects are supposed to document bugfixes before merging them?
17:22:33 <gzhao> so monday's 7:30am is the last meeting for projects to meet RC1 and get included in Helium
17:22:40 <colindixon> edwarnicke: etch them with your teeth. ETCH THEM WITH YOUR TEETH!!!!
17:22:56 <colindixon> gzhao: it’s the last formal meeting
17:22:59 * edwarnicke strikes a teeth etching bits pose!
17:23:14 <colindixon> I guess we should decide if we want to also use the TWS call
17:23:15 <edwarnicke> gzhao: But then we are going to need to keep going for RC2
17:23:22 <colindixon> we need to figure out docs
17:23:28 <edwarnicke> colindixon: Damn straight
17:23:55 <colindixon> I think mlemay and regXboi_on_phone were chatting, but I’ll have to connect with them later
17:24:02 <gzhao> edwarnicke: the meeting will keep going, however, if a project didn't make RC1, do we allow them to be back for RC2?
17:24:04 <regXboi_on_phone> no sorry
17:24:16 <regXboi> I was on the phone with dlenrow
17:24:17 <mlemay> I am there
17:24:17 <colindixon> gzhao: no
17:24:24 * regXboi is back
17:24:29 <regXboi> let's talk docs
17:24:36 * edwarnicke trembles in fear ;)
17:24:49 <edwarnicke> <joking />
17:24:54 * tbachman notes this is an awfully long bug scrub meeting :)
17:24:59 <regXboi> so the problem (as I now see it) is that we don't have a clean process
17:24:59 <gzhao> colindixon: edwarnicke that is what I mean last meeting for "meet all conditions" for RC1
17:25:11 <regXboi> and I'm doubtful we'll get a clean process for He
17:25:20 <gzhao> edwarnicke: I see my original sentence might confuse you as last release sync meeting
17:25:25 <colindixon> so I think if you don’t meet the conditions for RC1, you get dropped from *Helium*
17:25:29 <colindixon> not from *RC1*
17:25:40 <edwarnicke> gzhao: That was my confusion... as long as we keep up daily candence to get things done I'm happy :)
17:26:12 <regXboi> so right now if a POV (plain old vanilla) project wants to work on documentation, there are several types that need to be worked on
17:26:22 <gzhao> edwarnicke: and RC1 probably with all projects in karaf in, thus, I create spreadsheet directly for RC1
17:26:24 <mlemay> regXboi: I agree.. about the "not clean process"
17:26:31 <regXboi> enunciation of rest interfaces is one that can go via maven to site and site-deploy
17:26:36 <regXboi> javadoc the same way
17:26:43 <regXboi> but those are aimed squarely at developers
17:26:46 <edwarnicke> gzhao: Could we get one for RC0?  Would be good to try to get folks in the habit early :)
17:26:50 <gzhao> edwarnicke: for RC0, just check the two conditions, and autorelease built, or any blocking issues
17:27:05 * edwarnicke just encouraged a bunch of controller zone folks to test... and would like to be able to report :)
17:27:18 <regXboi> things like UI documentation, install requirements, etc that are aimed at operations and consumers need to go to the documentation project to get encorporated there
17:27:37 <gzhao> edwarnicke: with feature list ?
17:27:47 <regXboi> so it looks like projects need to have "ambassadors" that work with the documentation folks on the project piece parts that get committed into the documentation project
17:27:54 <regXboi> and that's as clean as I can make it right now
17:28:02 <gzhao> regXboi: yes!!!
17:28:43 <regXboi> once we have that, then I think the rest of the problem becomes mechanical
17:28:57 * regXboi quotes bugs bunny:  "so??!?!?!?! it's mechanical!"
17:29:11 * regXboi wonders how many will get that reference :)
17:29:22 <colindixon> regXboi: we have a docs representative for each project (or are supposed to)
17:29:31 <colindixon> :-/
17:29:32 <gzhao> edwarnicke: I will create one and send out, so project in good shape and already start testing could start to fill the testing status
17:29:35 * colindixon will be back in a few
17:30:04 <regXboi> colindixon: when you are back - do we know who they are (i.e. is it documented in the project template box)?
17:30:30 * regXboi doesn't see it and things it should be added
17:31:08 <regXboi> er *thinks*
17:31:27 <mlemay> https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Docs_Decision_Matrix is the closest thing to a process
17:31:56 <colindixon> regXboi: I think it’s the primary contact for most
17:31:58 <regXboi> ok, we need a bunch of text around that
17:32:09 <regXboi> colindixon: I think we should call it out specifically going forward
17:32:24 <regXboi> so that the primary contact doesn't get overloaded (any more than they already are)
17:32:38 <edwarnicke> mlemay: That doesn't tell me anything about what to do or now... non-actionable sadly :(
17:32:55 <phrobb> #link https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/16-SbSzdBzTXEk8lD6Q09zl-Ip8jBU3B8_BBqRPXGimg/edit#gid=0 <— this is the tracking spreadsheet the documentation project has been using.  It contains the contacts… but is very sparse on actual work getting/being done… sadly because not much has yet been done to date.
17:32:59 <mlemay> regXboi: that is the current state (ambassadors) some projects have been worked with so far.. I think I saw BGP, DLUX, OVSDB that have been covered so far.. LISPFlowmapping too I think
17:33:19 <mlemay> but it's crappy docs
17:33:25 <mlemay> but much better than no docs at all
17:33:41 <mlemay> and by "crappy I mean" we need to rewrok as in .. docs doesn't flow well
17:33:44 <rafat> Ed: Verification build done...shall we merge
17:33:46 <mlemay> the writers are working on this
17:34:04 <edwarnicke> rafat: gerrit link? ;)
17:34:12 <regXboi> yeah, writing docs is an art
17:34:18 <regXboi> that coders usually aren't good at
17:34:22 <edwarnicke> (rafat Apologies... I'm servicing a lot of intrupts... not a lot of state carry forward ;) )
17:34:27 <rafat> https://git.opendaylight.org/gerrit/11112
17:34:34 <gzhao> mlemay: we have two copies of this? https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Documentation_Guidelines
17:34:35 <edwarnicke> regXboi: Are you implying we don't write pretty? ;)
17:34:44 <regXboi> um... yes...
17:34:54 <gzhao> and https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Docs_Decision_Matrix?
17:36:08 <mlemay> gzhao: right..
17:36:26 <rafat> Ed: It is https://git.opendaylight.org/gerrit/11112
17:36:43 <mlemay> gzhao: was hoping Documentation Guildlines would be more than just that graph ;)
17:37:00 <mlemay> I'll make wiki edits if I find bandwidth to do so
17:37:02 <gzhao> mlemay: can sync the graph to use the same source?
17:37:05 <edwarnicke> rafat: It looks like you are clipping out plugin2oc: https://git.opendaylight.org/gerrit/#/c/11112/1/features/src/main/resources/features.xml
17:37:14 <rafat> Is it ?
17:37:16 <mlemay> it's using the same file no?
17:37:25 <rafat> so how do we fix that..
17:37:25 <edwarnicke> rafat: It looks like it, see the link
17:37:35 <rafat> so now how to fix that..
17:37:37 <gzhao> mlemay:  right now, no
17:37:42 <edwarnicke> rafat: put plugin2oc back ;)
17:37:48 <mlemay> gzhao: then definiltey
17:37:53 <rafat> and then again merge..
17:38:15 <mlemay> gzaho: lemme add that to the todo..
17:38:20 <regXboi> we need to wrap that picture (whichever one we use in an actionable process)
17:38:41 <regXboi> that goes on the to do list and I'll draft something for it
17:39:22 <regXboi> Now one thing I want to put in that process is a page on the mechanics
17:39:36 <regXboi> I can link to the existing page for site/site-deploy and javadocs/enunciate
17:39:57 <gzhao> mlemay: done, mainly the arrow fix.
17:40:21 <regXboi> but does a POV project have any mechanics they can do against the documentation project or is that a black box they contribute docs to via asciibook?
17:41:22 <rafat> Ed: It is only feature.xml..Am i right
17:41:23 <regXboi> colindixon: when you are back - put me on the list for the TWS for monday
17:41:35 <regXboi> I can talk through the wiki pages I've committed to writing
17:42:03 <mlemay> black box  in part B of the guides and right now.. the process has been work with writers to give them contents and have them structure that in the right places of the guides
17:42:19 <regXboi> mlemay: ping - you ok if I take a swing at the process wiki and then take it to the TWS?
17:42:20 <mlemay> which I think is somewhat appropriate as it's been a case by case thing
17:42:38 <mlemay> regXboi please do
17:42:41 <regXboi> That's pretty much where I was going to end up going
17:42:45 <regXboi> mlemay: done
17:42:45 <mlemay> I am not avail monday
17:43:00 <regXboi> that was my recollection, which is why I stepped up to the plate
17:43:09 <mlemay> but I'm here to answer anything ? you might have right now
17:44:16 <edwarnicke> rafat: Looks like it
17:44:17 <regXboi> I don't think so
17:44:33 <regXboi> I mean it's pretty straightforward
17:44:52 <regXboi> the POV projects may howl, but it's how it's going to be for He
17:48:47 <edwarnicke> regXboi: POV ?
17:48:58 <regXboi> Plain Old Vanilla
17:55:11 <rafat> Hi Ed
17:55:42 <rafat> Can you cancel all the builds and allow only https://git.opendaylight.org/gerrit/#/c/11117 to build...this is fine and needs no review hopefully
17:56:08 <rafat> Ed are you there
17:56:47 <edwarnicke> rafat: Apologies... back
17:57:00 <edwarnicke> PriyankaChopra: Could we move things into channel here so I don't have to context switch?
17:57:08 <rafat> yes please allow only the build for https://git.opendaylight.org/gerrit/#/c/11117
17:57:08 <edwarnicke> rafat: On it
17:57:32 <rafat> also juct check the feature.xml so we dont have any more rework involved.
17:58:27 <edwarnicke> rafat: Looks like 11117 is next in queue, number 327: https://jenkins.opendaylight.org/integration/job/integration-master-verify-distributions/
17:58:37 <edwarnicke> rafat: But something else is building, so its queued
17:58:55 <rafat> is it...it gave this issue sometime back but then resumed building..
17:59:02 <edwarnicke> regXboi: What do you mean by Plain Old Vanilla?
17:59:29 <regXboi> one sec
17:59:41 <rafat> 327 is mine itself.you can remove it if possible
18:01:38 <edwarnicke> rafat: I'm confused, I thought 327 was for 11117 and 11117 was the right patch...
18:02:10 <rafat> 11117 is the right patch..
18:02:42 <regXboi> edwarnicke: POV projects are non-documentation projects (i.e. the rest of the world)
18:02:50 <rafat> 327 and 328 bot are pending...the one corresponding to 11117 needs to be built.
18:03:04 <edwarnicke> regXboi: OK... apologies... only vaguely following... why are they going to be unhappy?
18:03:25 <edwarnicke> rafat: I think thats 327 :)
18:03:25 <rafat> why is the build not getting initiated..
18:03:32 <regXboi> because the He doc process I'm going to write up in the wiki and talk about on Monday's TWS will be:
18:03:33 <edwarnicke> rafat: Which should come before 328
18:03:41 <regXboi> for javadoc/enunciated REST, use site/site-deploy page
18:03:57 <rafat> I just uploaded 11117..I am not sure if it 327 or 328..
18:04:06 <regXboi> for anything externally facing that isn't for devs, have a documentation contact work with the Docs project to get the content in
18:04:09 <edwarnicke> rafat: I'm pretty sure its 327 :)
18:04:13 <regXboi> that's as good as we can do
18:04:23 <rafat> k..then we need to wait for it to build.
18:04:38 <edwarnicke> regXboi: Could we please get detailed 'how' instructions about 'how' to write docs, how to test them, how to get them in etc
18:04:39 <edwarnicke> ?
18:04:46 <edwarnicke> regXboi: Something actionable
18:04:59 <rafat> its pending...is there something we can do to initiate the build or we need to wait..
18:05:10 <PriyankaChopra> edwarnicke: sure
18:05:13 <edwarnicke> rafat: That means that its waiting on infra resources in integration
18:05:14 <regXboi> how to write docs?
18:05:18 <regXboi> you are kidding right?
18:05:22 <edwarnicke> rafat: Sadly integraiton is infra starved :(
18:05:38 <edwarnicke> PriyankaChopra: OK... locally I get a build failure with:
18:05:52 <rafat> ok...So we need to let both build...The one corresponding to 11117 needs to be merged.
18:05:53 <regXboi> how to write docs is a graduate course, not an actionable wiki :)
18:05:56 <edwarnicke> Could not find artifact org.opendaylight.controller:features-yangtools:xml:features:0.6.2-SNAPSHOT
18:06:04 <edwarnicke> PriyankaChopra: Same as in Jenkins
18:06:06 <edwarnicke> Looking at why
18:06:08 <rafat> Ed this may take very long...
18:06:59 <PriyankaChopra> edwarnicke : in features pom the group id is wron
18:07:14 <edwarnicke> PriyankaChopra: Good catch :)
18:07:29 <PriyankaChopra> org.opendaylight.controller --> org.opendaylight.yangtools
18:07:53 <edwarnicke> PriyankaChopra: Cut and paste kills me everytime ;)
18:07:58 <PriyankaChopra> :D
18:08:02 <rafat> Ed:Can we review the features.xml file so we can proceed right after verification build ?
18:09:01 <edwarnicke> rafat: Let me look at 11117
18:09:07 <rafat> ok
18:11:53 <edwarnicke> rafat 11117 looks good... just need verify
18:12:24 <rafat> Ok Ed..So the build is pending..Once built we need to merge..
18:12:54 <rafat> Can I take a break and check tomorrow morning.Its already midninght here..
18:13:46 <rafat> The build is also pending..once it starts it will take over an hour...
18:14:08 <rafat> Is it ok If I do the merge for 11117...
18:15:11 <edwarnicke> rafat: If it verifies, I will merge and add to the autorelease
18:15:43 <rafat> great Ed..I will be up early and be around...
18:15:47 <edwarnicke> rafat: If you don't see it merged, and you can't find me on IRC, my mobile is +1 919-621-0958
18:16:04 <edwarnicke> rafat: I have no idea when I will be around... its touch and go here... but will be around ;)
18:16:21 <rafat> Sure Ed...great..I think it will work this time...just dont know if it is 327 or 328 :-)
18:17:43 <regXboi> edwarnicke: can I ping you about docs after a call I have at the bottom of the hour?
18:17:54 <edwarnicke> regXboi: Of course :)
18:18:00 <edwarnicke> PriyankaChopra: How is the fix going?
18:18:00 <regXboi> want to understand how to meet your requirements of how without writing a graduate college course
18:20:02 <PriyankaChopra> uploading patch
18:21:22 <edwarnicke> PriyankaChopra: Did it work building against an empty .m2/repository/org/opendaylight ?
18:22:57 <PriyankaChopra> test failure.. pushing to gerrit..
18:26:02 <PriyankaChopra> https://jenkins.opendaylight.org/plugin2oc/job/plugin2oc-verify/51/console
18:31:05 <PriyankaChopra> eswarnicke: I tried adding this dependency(logging.bridge) to features pom, it then asked for another maven artifact.. and this goes into an endless chain of dependencies
18:32:46 <edwarnicke> PriyankaChopra: One moment
18:43:49 <edwarnicke> PriyankaChopra: OK... back
18:44:06 <edwarnicke> Hmm... interesting... I wasn't getting that locally against an empty .m2
18:44:51 <PriyankaChopra> ah.. Now thats strange..
18:50:25 <edwarnicke> PriyankaChopra: Was it building clean locally for you with an empty .m2/repository/org/opendaylight ?
18:51:17 <PriyankaChopra> no.. locally features module fails..
18:51:37 <PriyankaChopra> however Jenkins passes it.. but build stays unstable..
18:52:08 <edwarnicke> PriyankaChopra: Jenkin's is saying its unstable because the feature wiring tests fail
18:52:21 <PriyankaChopra> right..
18:54:30 <PriyankaChopra> now the question is why I am getting these cyclic dependencies.. As per my understanding I have included dependencies correctly..
18:54:33 <PriyankaChopra> :(
18:58:23 <edwarnicke> Rebuilding locally from PatchSet 2
18:58:57 <edwarnicke> PriyankaChopra: Which is pre-requisite to working at all
18:58:57 <PriyankaChopra> even i cleared m2 locally
18:59:17 <PriyankaChopra> and now rebuilding
19:02:07 <edwarnicke> PriyankaChopra: OK, getting the failure on logging-bridge
19:02:40 <PriyankaChopra> right.. now if we add this dependency it will fail for another artifact
19:02:59 * tbachman remembers this trail….
19:03:28 <edwarnicke> tbachman: If you have wisdom here.. this is the side of the house I don't know as well...
19:03:37 <tbachman> edwarnicke: this was truly weird
19:03:46 <tbachman> I don’t understand where these dependencies are coming from
19:04:14 <edwarnicke> tbachman: I don't either... the MD-SAL stuff has very clean very well designed dependency schemes...
19:04:19 <PriyankaChopra> i do remember .. have been trying to resolve them all day long..
19:04:20 <tbachman> exactly
19:04:40 <tbachman> edwarnicke: just a sec...
19:04:50 * tbachman goes back to gerrit he was working on with PriyankaChopra
19:06:48 <PriyankaChopra> Now another interesting thing that i tried... in this way if we keep resolving 3-4 such dependencies we find another "wierd" issue
19:08:05 <tbachman> PriyankaChopra: but the dependencies you resolve — they aren’t called out in your bundle at all
19:08:52 <edwarnicke> tbachman: It can be transitive
19:09:04 <PriyankaChopra> it fails saying : No feature named 'yangtools-data-binding' with version 0.6.2-SNAPSHOT available.
19:09:06 <tbachman> but how come we don’t see this with other projects?
19:09:09 <edwarnicke> Bundle A requires bundle B at runtime, requires bundle C at runtime... etc
19:09:26 <edwarnicke> PriyankaChopra: I think we solved that one with the groupId fix, right?
19:09:28 <tbachman> seriously — it’s only like 6 java files
19:09:33 <PriyankaChopra> seconds tbachman*
19:09:38 <tbachman> and it’s not like they’re pulling in all sorts of crazy stuff
19:10:05 <PriyankaChopra> edwarnicke : yes..
19:10:21 <tbachman> edwarnicke: https://git.opendaylight.org/gerrit/#/c/11090/
19:12:35 <edwarnicke> Looking
19:16:31 <edwarnicke> PriyankaChopra: Building
19:17:41 <PriyankaChopra> my local is still building..
19:18:19 <tbachman> edwarnicke: that gerrit was to show the dependencies I’d added
19:18:23 <tbachman> I eventually stopped
19:18:28 <tbachman> b/c it seemed like a losing battle
19:18:38 <tbachman> and these dependencies seemed to have nothing to do with this plugin
19:19:10 <edwarnicke> tbachman: They are the dependencies of the dependencies of the dependencies of the plugin
19:19:27 <PriyankaChopra> again seconds tbachman again..
19:19:47 <tbachman> edwarnicke: but — why do they only show up in this project?
19:19:53 <tbachman> in other words
19:20:11 <tbachman> shouldn’t it be the same as specifying the same dependencies they use to *build* their plugin?
19:20:23 <tbachman> (i.e. the plugin — not the karaf part)
19:20:38 <PriyankaChopra> right.. so what do we do.. keep adding these..
19:20:44 <edwarnicke> tbachman: Depends on whether the features they depend on were done correctly
19:20:44 <tbachman> otherwise where do the transitives stop?
19:20:54 <edwarnicke> PriyankaChopra: Trying to figure out the issues
19:21:09 <tbachman> edwarnicke:  it just felt like there was something more fundamental broken here
19:21:15 <edwarnicke> PriyankaChopra: The yangtools one sounds like the 'groupId is controller instead of yangtools' you solved before
19:21:24 <edwarnicke> tbachman: We have two dependency trees
19:21:29 <edwarnicke> tbachman: Build time and runtime
19:21:32 <tbachman> right
19:21:35 <tbachman> mvn and karaf
19:21:46 <edwarnicke> Sadly, the buildtime tree (maven) is utterly broken from the runtime point of view (its a long standing annoyance of maven)
19:21:58 <edwarnicke> the features.xml files construct the runtime dependency tree
19:22:13 <edwarnicke> So two things can happen
19:22:17 <tbachman> I guess, just looking at their plugin, I don’t get why it could be pulling in so many more dependencies than other projects
19:22:31 <tbachman> It’s like it’s just missing a reference to the right feature
19:22:34 <edwarnicke> tbachman: Oh, that... I don't know, haven't looked closely enough yet
19:22:41 <edwarnicke> tbachman: It does seem like that
19:22:42 <PriyankaChopra> edwarnicke: i guess its org.opendaylight.yangtools only..
19:22:43 <tbachman> They seriously only have like 6 files
19:22:49 <edwarnicke> tbachman: Yeah... I know
19:22:50 <tbachman> and they aren’t huge
19:23:07 <tbachman> and the # of imports there is small-ish, and they aren’t that exotic
19:23:09 <edwarnicke> But they pull in a giant deeply intertwined bunch of stuff most of which their six files don'
19:23:10 <edwarnicke> t use,
19:23:22 <tbachman> The JNPR ones are the ones I was wondering about
19:23:23 <edwarnicke> But are runtime dependencies of the things they do
19:23:27 <tbachman> b/c I wasnt’ sure how that was created
19:23:28 <tbachman> but
19:23:44 <tbachman> I wouldn’t have expected it to cause all these runtime issues for controller artifacts
19:23:53 * edwarnicke note to self, neutron needs to be cleaned up to be sparse dependency-wise.. only really *needs* a few things, but needlessly uses a bunch
19:24:03 <edwarnicke> tbachman: Which JNPR ones?
19:24:12 <tbachman> there are imports in their files
19:24:18 * tbachman pulls up the code
19:25:03 <edwarnicke> tbachman: The patch you pointed me to:
19:25:05 <edwarnicke> https://www.irccloud.com/pastebin/lPBu01jt
19:25:08 <tbachman> https://git.opendaylight.org/gerrit/gitweb?p=plugin2oc.git;a=blob;f=neutron/src/main/java/org/opendaylight/plugin2oc/neutron/Activator.java;h=f81d01615fca1ae083d1e1f80dc6ed8fc852b29c;hb=752b9accae0d57597df6ff21448371d88363d314
19:25:11 <edwarnicke> Doesn't seem to even run the wiring tests
19:25:25 <tbachman> lol
19:25:26 <tbachman> sorry
19:25:29 <tbachman> I never pushed the lates
19:25:31 <tbachman> latest
19:25:35 <tbachman> I commented out the wrong thing
19:25:42 <tbachman> meant to comment out the other yangtools dependency
19:25:54 <tbachman> ended up commenting out the features-test ;)
19:25:55 <tbachman> lol
19:25:58 <PriyankaChopra> :)
19:26:02 <edwarnicke> tbachman: OK... so PriyankaChopra , tbachman What patch should I be checking stuff against?
19:26:05 <tbachman> that fooled us at 3am
19:26:26 <edwarnicke> tbachman: Yeah, I see your point on neutron... it shouldn't need much of anything
19:26:40 <tbachman> sorry edwarnicke — that was probably more of a distraction than help. I was just trying to point out the chain of deps that I had added to features/pom.xml
19:26:49 <tbachman> I was doing this incrementally :P
19:26:57 <tbachman> felt like a bad approach
19:26:58 <tbachman> build
19:27:02 <tbachman> see failure
19:27:05 <tbachman> add next dep
19:27:06 <tbachman> repeat
19:27:14 <edwarnicke> tbachman: But its pulling in way more than the activator would indicate
19:27:26 <edwarnicke> PriyankaChopra: Which patch should I be working with
19:27:38 <PriyankaChopra> patchset 2
19:27:47 <PriyankaChopra> the one that you cloned last
19:28:44 <tbachman> edwarnicke: I was trying to use OVSDB as a crib
19:28:52 <tbachman> since they also include neutron NB
19:29:03 <tbachman> but — couldn’t find any magic feature to add
19:29:27 <edwarnicke> PriyankaChopra: Link? (apologies... lots of stuff... I loose context)
19:29:44 <PriyankaChopra> edwarnicke: https://git.opendaylight.org/gerrit/#/c/11116
19:29:47 <PriyankaChopra> patchset 2
19:31:02 <edwarnicke> PriyankaChopra: OK... failing on logging-bridge
19:31:09 <PriyankaChopra> yes..
19:32:02 <PriyankaChopra> if we add this.. it will ask for ganymed..
19:32:39 <edwarnicke> Priya... some things I am seeing at random (not necessarily the root of the issue
19:32:40 * tbachman clearly doeesn’t understand the way the karaf runtime dependency chaining works
19:32:50 <edwarnicke> 1)  You don't seem to be getting third party versions from odlparent
19:33:22 <edwarnicke> Example: you are using guava 14.0, the rest of ODL is on 14.0.1
19:33:55 <edwarnicke> Example you are on commons-lang 2.3, the rest of ODL is on 2.6
19:35:03 <PriyankaChopra> i can change and try..
19:35:14 <edwarnicke> Not yet :)
19:35:20 <edwarnicke> Just running through things that look odd first
19:35:28 <edwarnicke> Neither of those would cause the logging bridge thing
19:35:31 <PriyankaChopra> hmm... makes sense..
19:35:42 <PriyankaChopra> :D
19:36:29 <edwarnicke> You are using javassist 3.15.0-GA, the rest of ODL is on 3.17.1-GA
19:37:40 <edwarnicke> PriyankaChopra: OK... those are the anomolies I see in your neutron/pom.xml... I don't think any of those are it
19:38:17 <PriyankaChopra> hmm..
19:38:22 <edwarnicke> tbachman: Here's a good example of buildtime vs runtime... there are only API dependencies for things like sal in plugin2oc/neutron... but clearly you need runtime implementations in the features.xml runtime depenencies :)
19:38:43 <edwarnicke> PriyankaChopra: I'm just doing a linear walk right now looking for things that look odd.. figured I might as well report them as I go
19:39:06 <tbachman> edwarnicke: at one time, I did add the neutron stuff
19:39:11 <tbachman> grabbed it from OVSDB
19:39:11 <tbachman> fwiw
19:39:12 <PriyankaChopra> sure.. we might catch something..
19:39:51 <edwarnicke> tbachman: I learned an important lesson once from Leon Lederman, Nobel Prize winnning physicist... when you understand nothing, classify everything ;)
19:40:00 <tbachman> :)
19:40:03 <edwarnicke> Now looking at your feature file...
19:40:12 * tbachman will spend the rest of his classifying then ;)
19:40:13 <tbachman> lol
19:40:29 <PriyankaChopra> :D
19:40:59 <tbachman> btw — we can’t forget to endmeeting at some point
19:41:06 <edwarnicke> OK... since it's logging.bridge
19:41:09 <edwarnicke> Looking now at
19:41:27 <edwarnicke> controller/features/adsal/src/main/resources/features.xml to chase back where it is there
19:41:32 <edwarnicke> Its mentioned as
19:41:38 <edwarnicke> <bundle>mvn:org.opendaylight.controller/logging.bridge/${logging.bridge.version}</bundle>
19:41:42 * tbachman got a bit confused there
19:41:45 <edwarnicke> In odl-adsal-thirdparty
19:41:52 <edwarnicke> tbachman: What is the source of your confusion?
19:41:55 <tbachman> I was trying something similar
19:42:05 <tbachman> oh - just where the controller exported some of its features
19:42:10 <tbachman> tracking them down was a bit tricky
19:42:11 * edwarnicke is logging his fast pass through debugging in the hopes it helps others :)
19:42:15 <tbachman> and I couldn’t find some of them
19:42:25 * tbachman appreciates it :)
19:42:49 <edwarnicke> odl-adsal-thirdparty is referenced in odl-adsal-core
19:42:56 <edwarnicke> <feature version="${project.version}">odl-adsal-thirdparty</feature>
19:43:37 <edwarnicke> odl-adsal-core is referenced in odl-adsal-all (among other places)
19:43:50 <edwarnicke> So... next question... what version is ${logging.bridge.version}
19:44:21 <PriyankaChopra> one sec.
19:44:31 <edwarnicke> PriyankaChopra: Sure :)
19:45:03 <edwarnicke> <logging.bridge.version>0.4.2-SNAPSHOT</logging.bridge.version> in controller/opendaylight/commons/opendaylight/pom.xml
19:45:39 <PriyankaChopra> Right!
19:47:05 <edwarnicke> OK... so now I am looking in my local .m2/
19:47:19 <edwarnicke> https://www.irccloud.com/pastebin/bY0iXhMK
19:47:42 <edwarnicke> Which means it thinks its not finding it in nexus
19:48:37 <edwarnicke> But it is in nexus: http://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/org/opendaylight/controller/logging.bridge/0.4.2-SNAPSHOT/
19:48:52 <edwarnicke> Which makes me suspicious about the <repository> definitions in plugin2oc's pom.xml files
19:48:55 <edwarnicke> Looking at that
19:50:13 <edwarnicke> plugins2oc/commons/parent/pom.xml has
19:50:24 <edwarnicke> https://www.irccloud.com/pastebin/S2EyosNM
19:50:32 <edwarnicke> Not as nicely done as what you get from odlparent
19:50:35 <edwarnicke> But should be OK
19:51:20 <edwarnicke> Oh wait... something odd
19:51:34 <edwarnicke> https://www.irccloud.com/pastebin/ET4Q2tYe
19:51:50 <edwarnicke> This is odd because it means someone somewhere was depending on logging.bridge 0.4.1
19:52:11 <PriyankaChopra> right..!
19:52:27 <edwarnicke> Running: mvn dependency:tree
19:53:06 * tbachman believes edwarnicke is getting to the root of the issue
19:53:21 <edwarnicke> tbachman: It has the feel of rootiness ;)
19:53:26 <tbachman> feels like munge all over again ;)
19:54:26 <PriyankaChopra> :D
19:55:35 <edwarnicke> OK... this is fascinating... and the maven level, I *only* get logging.bridge 0.4.1... and its brought in by org.opendaylight.controller:features-base:xml:features:1.4.2-SNAPSHOT
19:55:49 <edwarnicke> (I think, these trees can be hard to read sometimes ;) )
19:55:52 <edwarnicke> So looking at that
19:56:18 <edwarnicke> features-base is brought in by: org.opendaylight.controller:features-nsf:xml:features:0.4.2-SNAPSHOT
19:56:35 <tbachman> edwarnicke: you’re getting this from mvn dependency:tree?
19:56:39 <edwarnicke> Yes
19:56:41 <tbachman> k
19:56:42 <tbachman> thx
19:56:45 <PriyankaChopra> nice..
19:57:12 <PriyankaChopra> tbachman: atleast we are able to trace things better now..
19:57:57 <PriyankaChopra> thanks to edwarnicke ..
19:58:38 <edwarnicke> So I need to squint harder, as it looks like mvn dependency:tree in controller/features/base/ does not have logging bridge
20:03:47 * edwarnicke is going through a brief period of confusion... please standby
20:09:25 <edwarnicke> PriyankaChopra: Other weirdness
20:09:42 <edwarnicke> PriyankaChopra: It seems like someone somewhere may depend on commons.opendaylight 1.4.1
20:10:04 <tbachman> edwarnicke: the commons/parent/pom.xml originally called this out
20:10:20 <tbachman> I changed it to 1.4.2-SNAPSHOT
20:10:27 <tbachman> but it didn’t seem to change anything
20:10:38 <tbachman> (not checked in tho)
20:12:58 <edwarnicke> Ah... looking
20:13:16 <edwarnicke> tbachman: Yeah, that's the kicker
20:13:23 <edwarnicke> I bet that fixes it
20:13:40 <edwarnicke> tbachman: Could you try to see if that fixes it?
20:13:46 * tbachman would be happy if it does… but is doubting  as per his name
20:14:02 <tbachman> edwarnicke: is that the only change you’ve updated to PriyankaChopra’s last gerrit?
20:14:06 * tbachman will fetch it and try
20:14:09 <edwarnicke> I am building another thing for someone else at this particular moment
20:14:13 <tbachman> k
20:14:16 <PriyankaChopra> m trying
20:14:16 <edwarnicke> tbachman: I haven't updated it yet
20:14:21 <edwarnicke> Let me be sure
20:14:23 <tbachman> k
20:14:28 <edwarnicke> But I don't think I've changed anything yet
20:14:46 <edwarnicke> tbachman: I have changed nothing in the source for plugin2oc
20:14:53 <tbachman> k
20:15:00 <edwarnicke> PriyankaChopra: I would counsel adding target/ to your .gitignore thouhg :)
20:15:46 <PriyankaChopra> sure edwarnicke.. :)
20:17:01 <edwarnicke> tbachman: PriyankaChopra changed  the 1.4.1 to 1.4.2-SNAPSHOT and am building against an empty .m2/repository/org/opendaylight
20:17:25 * tbachman is fetching the gerrit
20:18:32 <tbachman> edwarnicke: note: the features-plugin2oc/pom.xml doesn’t have a relative path for its parent
20:18:36 <tbachman> fyi
20:19:01 <edwarnicke> tbachman: So... its parent is one directory up, correct?
20:19:06 <tbachman> right
20:19:12 <edwarnicke> tbachman: maven *might* be smart enough to handle that without freaking out
20:19:14 <tbachman> also — was a bit concerned about versinos
20:19:15 <tbachman> k
20:20:54 <edwarnicke> tbachman: So far you've been way ahead of me on this :)
20:22:21 * tbachman blinks eyes
20:22:26 * tbachman rubs eyes
20:22:30 <tbachman> can this be?
20:24:32 <edwarnicke> LOL
20:24:50 <edwarnicke> Dude... I am not all knowing and all seeing... I miss stuff and am wrong (a lot)...
20:24:57 <edwarnicke> I just swing at a lot of pitches
20:25:05 <regXboi> hey edwarnicke
20:25:11 <regXboi> let's talk docs :)
20:25:16 <regXboi> :) :) :) :) :) :) :)
20:25:16 <tbachman> edwarnicke: I know I changed this
20:25:26 <edwarnicke> regXboi: Sure... you go first :)
20:25:37 <tbachman> so, must be some piece that goes with it
20:25:39 <regXboi> so... you want actionable docs is in "how to write them"
20:25:50 <regXboi> so I hope you aren't looking for how to write javadoc?
20:25:54 <regXboi> how to write enunciate?
20:26:06 <regXboi> how to write asciibook?
20:26:29 <regXboi> because that turns into style guides and that's something I'm not prepared to fix at this point
20:26:35 <regXboi> maybe in Li, but not now :)
20:27:31 <edwarnicke> regXboi: So... someone needs to be able to come in cold and know what to do
20:27:54 <edwarnicke> regXboi: For the mechanics of asciidoc, that should mean links to docs on it
20:28:01 <edwarnicke> regXboi: And hopefully some examples in ODL
20:28:15 <edwarnicke> PriyankaChopra: BUILD SUCCESS
20:28:34 <PriyankaChopra> too fast.. its still building here
20:28:35 <edwarnicke> https://www.irccloud.com/pastebin/lsXHiUZD
20:29:08 <tbachman> PriyankaChopra: redoing, with clean .m2
20:29:15 <edwarnicke> PriyankaChopra: As a side note (not for Helium, but after)...,please please please do not depend on org.opendaylight.controller:commons.opendaylight
20:29:23 <edwarnicke> PriyankaChopra: That is the controllers parent pom
20:29:39 <edwarnicke> It was never intended to serve any project but controller
20:29:55 <PriyankaChopra> sure...
20:29:58 <edwarnicke> And it can and will change in the future in ways that are likely to break other projects that use it as a parent pom
20:30:01 <edwarnicke> And when that happens
20:30:03 <PriyankaChopra> note taken!
20:30:20 <edwarnicke> I will say 'You should never have been using commons.opendaylight as your parent, you should have been using odlparent'
20:30:29 <edwarnicke> And will feel no remorse whatsoever ;)
20:30:38 <PriyankaChopra> very true..
20:30:38 <edwarnicke> But not an issue for Helium
20:30:59 <regXboi> I doubt I have examples of asciibooks for Helium sitting around
20:31:11 <edwarnicke> regXboi: So the litmus test is
20:31:13 <regXboi> I mean I can make references to the existing books, but that's as good as can be done
20:31:13 <tbachman> folks — should we endmeeting?
20:31:20 <edwarnicke> Can someone come in cold and do it from the docs
20:31:21 <tbachman> for sake of posterity?
20:31:40 <edwarnicke> tbachman: I thought we were keeping the meeting going so posterity could subsequently join ;)
20:31:44 <tbachman> lol
20:31:48 <regXboi> edwarnicke: I doubt you'll get that on the first pass
20:31:51 <regXboi> or even the second
20:31:54 * tbachman pictures endless scroll of meeting minutes
20:31:58 <edwarnicke> regXboi: Have you looked at the karaf step by step ?
20:32:05 <tbachman> people will read with grep ;)
20:32:13 <PriyankaChopra> :P
20:32:14 <regXboi> edwarnicke: nope, I'm still blissfully ignorant
20:32:23 <regXboi> and intent to remain so for the rest of He
20:32:29 <regXboi> but karaf is *NOT* docs
20:32:41 <regXboi> that's part of the problem - docs != code
20:32:47 <edwarnicke> tbachman can tell me if I'm just deluding myself here... but https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide
20:33:08 <edwarnicke> tbachman can tell me if I'm just deluding myself here... but https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide
20:33:16 <edwarnicke> Seems to have gotten a bunch of folks successfully going
20:33:24 <tbachman> That’s been good to me :)
20:33:26 <regXboi> you didn't hear me ... so I'll say this with Camel Caps
20:33:30 <edwarnicke> regXboi: So maybe,, just maybe docs like that help :)
20:33:32 <regXboi> Docs != Code
20:33:32 * tbachman is trying to remember the one edit he wanted to make
20:33:43 <edwarnicke> regXboi: I know
20:33:49 <edwarnicke> regXboi: I wasn't arguing they were
20:34:08 <regXboi> but saying "I want an actionable process" *IS* making that equiv in some way
20:34:21 <regXboi> and that's 100% dangerous
20:34:35 <regXboi> we can go some of the way there
20:34:46 <regXboi> but it's not going to be what you are thinking of (I can guarantee)
20:34:54 <edwarnicke> regXboi: I think we mean something different by an actionable process
20:35:18 <edwarnicke> regXboi: Because I completely disagree with your statement... and experience with you would therefore suggests I'm misreading it
20:35:29 * tbachman notes that its early Saturday for PriyankaChopra
20:35:40 <tbachman> PriyankaChopra: thx for sticking this out!
20:36:09 <regXboi> so you want to know how to write docs
20:36:16 * tbachman hears sounds of “zzzz” coming from PriyankaChopra’s IRC handle
20:36:17 <regXboi> which implies you want examples of good docs
20:36:21 <PriyankaChopra> I need to thank you guys big time.. Without your help i would not have been able to make this..!
20:36:35 <tbachman> PriyankaChopra: thank us when we get you there
20:36:42 <PriyankaChopra> Thank you tbachman and edwarnicke .. :)
20:36:43 <regXboi> and what I'm trying to explain is that good docs are an art
20:37:04 * tbachman notes it was edwarnicke who found the keyhole and unlocked the door
20:37:07 <regXboi> and is not 100% prescriptive
20:37:10 <PriyankaChopra> lol
20:38:15 <edwarnicke> PriyankaChopra: Once we get this all working correctly... if you could fix the other version mismatches I identified if possible
20:38:21 <edwarnicke> PriyankaChopra: They worry me ;)
20:38:35 <PriyankaChopra> yeah sure..
20:38:40 <regXboi> aw shoot
20:38:48 <PriyankaChopra> will upload then.. :)
20:38:59 <edwarnicke> tbachman: I think all I did was point out that you had the key, had put it in the keyhole, unlocked the door, and in a fit of pure fatigue forgetten the 'push on door' step
20:39:11 <edwarnicke> regXboi: Ah
20:39:12 <edwarnicke> regXboi: OK
20:39:14 <edwarnicke> regXboi: I get it
20:39:20 <PriyankaChopra> BUILD SUCCESS :D :D
20:39:24 <PriyankaChopra> cheeers !!
20:39:27 <edwarnicke> regXboi: You are thinking I'm wanting you to write Strunk and White
20:39:33 <regXboi> :)
20:40:05 <regXboi> yes - I can tell people here are links to asciibook, etc.
20:40:12 <tbachman> PriyankaChopra: you can do yours, or there’s this:
20:40:13 <tbachman> https://git.opendaylight.org/gerrit/11119
20:40:20 <tbachman> your call
20:40:25 <regXboi> but then I have to say "work with the documentation folks" to make it readable by a non dev
20:40:37 * tbachman tried pushing a fetch of PriyankaChopra’s gerrit, but failed miserably
20:41:50 <edwarnicke> regXboi: OK
20:41:59 <edwarnicke> So I am thinking in terms of mechanics and structure
20:42:17 <regXboi> yeah - that's (relatively) simple
20:42:25 <regXboi> and for some things descriptive/prescriptive
20:42:32 <edwarnicke> regXboi: Think: take this template, fill it in with something, run this command to build it, weep in sorrow at your writing skills
20:42:48 <regXboi> we can do that with the pure dev stuff
20:42:53 <edwarnicke> regXboi: Nothing we can do will make engineers into Oscar Wilde
20:43:05 <edwarnicke> regXboi: But we can at least get some stuff out of them that the docs guys can clean up
20:43:11 <regXboi> but as far as the doc stuff it gets a bit more 'hand wavy"
20:43:12 <PriyankaChopra> tbachman: I will upload with changes suggested by edwarnicke. :)
20:43:21 <regXboi> doc stuff == non-dev doc stuff
20:43:30 <edwarnicke> regXboi: Even with features... I can't really dictate the Strunk and White level (God knows it would be different if I could)
20:43:38 <regXboi> well
20:43:39 <edwarnicke> PriyankaChopra: Two things
20:43:49 <regXboi> I'll warn you that we will need to estable style guides in Li
20:43:50 <edwarnicke> 1)  Please push your fix that fixes the features first as a separate thing
20:43:56 <regXboi> that's coming down the pike :/
20:43:59 <edwarnicke> 2)  Please push the version changes as a separate gerrit
20:44:00 <edwarnicke> Here's why
20:44:22 <edwarnicke> It is *probably* the case that the version normalization I have requested will not have adverse impact on the functioining of your code
20:44:23 <edwarnicke> But if it does
20:44:30 <edwarnicke> I would prefer you have a clean patch to revert
20:44:36 <edwarnicke> That would not also revert the fix to the features
20:44:47 <edwarnicke> Does that make sense?
20:44:48 <PriyankaChopra> makes complete sense.. :)
20:45:11 <edwarnicke> regXboi: I would settle for us just doing a plan in Lithium rather than 'because venue'
20:45:35 * edwarnicke is not bitter about Helium plan, not at all
20:49:05 <regXboi> anyway
20:49:12 <edwarnicke> PriyankaChopra: Let me know when you've pushed a patch
20:49:26 <regXboi> I now understand what you want (I think) and will put together something that is my interpretation of how to do each and build each
20:49:38 <PriyankaChopra> sure..
20:49:41 <regXboi> and then we can all refine it
20:49:48 <PriyankaChopra> i am testing things locally first..
20:50:08 <PriyankaChopra> will ping the gerrit link.
20:51:13 <regXboi> actually, edwarnicke: I think that https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Tools has a bunch of the scaffolding - it just needs some work
20:51:58 <edwarnicke> regXboi: And socialization :)
20:52:10 <regXboi> well - first socialization will be TWS on Monday
20:52:17 <regXboi> I've told colindixon to put me in the slot
20:52:28 <colindixon> regXboi: hey
20:52:41 <regXboi> see - he wakes up when called :)
20:52:54 <regXboi> is this meeting going to set a record for open time?
20:53:02 <regXboi> i.e. do we still have a chair to end it ?
20:54:29 <edwarnicke> regXboi: tbachman feels we should have a meeting for posterity... so we have to wait awhile for them to arise ;)
20:54:43 <edwarnicke> colindixon: How long until your child can join us here so we can close the meeting?
20:54:45 <edwarnicke> ;)
20:54:49 <regXboi> ok... sorry this is too easy
20:54:57 <tbachman> lol
20:55:01 <posterity> so I've arisen - let's end this meeting
20:55:36 <edwarnicke> posterity bears a striking resemblence to regXboi... its uncanny
20:55:54 <regXboi> that would be a scary thought if we think too much about it
20:57:21 <regXboi> actually, looking at this page and this diagram, edwarnicke this should actually be rather easy
20:57:31 <regXboi> we just need to fill in the *how* on the blue boxes
20:57:55 <regXboi> and then you have what you want
20:58:19 <regXboi> so that's what I plan on doing on Sunday
20:58:19 <tbachman> seriously - should we do the endmeeting?
20:58:27 <tbachman> Or do we want to capture the docs stuff first?
20:58:43 <edwarnicke> #endmeeting