14:31:55 <colindixon> #startmeeting release daily sync
14:31:55 <odl_meetbot> Meeting started Tue Sep 16 14:31:55 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:55 <odl_meetbot> The meeting name has been set to 'release_daily_sync'
14:31:58 <edwarnicke> gzhao: We really could use some adult supervision here...
14:32:03 <colindixon> #topic roll call and agenda bashing
14:32:06 <abhijitkumbhare> Doing two timing (another OF plugin meeting same time)
14:32:14 <abhijitkumbhare> #info abhijitkumbhare OF plugin
14:32:17 <tbachman> #info tbachman for groupbasedpolicy
14:32:18 <edwarnicke> abhijitkumbhare: Welcome to the wonder of IRC meetings :)
14:32:21 <edwarnicke> #info edwarnicke
14:32:21 <colindixon> #info colindixon for TTP (and braaaaiiinnnns)
14:32:40 <gzhao> #info gzhao
14:32:42 <oflibMichal> #info oflibMichal for openflowjava
14:32:44 <regXboi> #info regXboi (for general gad-fly-ness)
14:33:48 <tbachman> regXboi: what happened to mischief?
14:33:57 <colindixon> #chair regXboi edwarnicke tbachman gzhao
14:33:57 <odl_meetbot> Current chairs: colindixon edwarnicke gzhao regXboi tbachman
14:34:05 <tbachman> lol
14:34:07 * edwarnicke rummages in his hat trunk for a mischief hat
14:34:11 <gzhao> edwarnicke: my modem is down, resetting it
14:34:12 * tbachman asks for mischief, gets chaired
14:34:16 <colindixon> welcome hideyuki
14:34:20 <regXboi> tbachman: mischief turned into gad-fly-ness because I'm really just hanging around
14:34:26 <hideyuki> colindixon: Thank you :)
14:34:33 <regXboi> and so I end up getting chaired as well
14:34:37 * regXboi sighs
14:34:40 <tbachman> lol
14:34:56 <xsited1> #info thomas packetcable
14:35:01 <colindixon> we’ll wait for another minute or two and then get started and people can #info in as we go
14:35:14 <ttkacik> #info ttkacik yangtools & mdsal
14:35:36 <hideyuki> #info Hideyuki Tai for VTN
14:37:16 <colindixon> ok
14:37:33 <tbachman> probably time to kick it :)
14:37:46 <colindixon> #topic auto-release
14:37:47 <tbachman> #topic Project Status
14:37:49 <tbachman> lol
14:37:53 <colindixon> #undo
14:37:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x26bfb90>
14:37:54 <tbachman> trumped
14:38:02 <tbachman> auto-release is probably best
14:38:03 <colindixon> edwarnicke: how did we do with defense4all and snmp4sdn?
14:38:21 <edwarnicke> colindixon: OK... so let me give the omnibus autorelease readout
14:38:32 * alagalah salutations
14:38:32 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2014-September/000403.html we’ll use gzhao’s agenda from yesterday as a skeleton
14:38:46 * tbachman waves to alagalah
14:38:48 <edwarnicke> autorelease last night hit two issues, one in plugin2oc, one in dlux
14:38:58 <tbachman> #topic auto-release
14:39:01 <edwarnicke> I believe I have resolved the issue in plugin2oc
14:39:09 <colindixon> #undo
14:39:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x26bf190>
14:39:11 <edwarnicke> I am testing a fix for the dlux issue
14:39:12 <tbachman> oops
14:39:14 <colindixon> tbachman: we already had that
14:39:18 <edwarnicke> (should know in less than 5 min)
14:39:27 <edwarnicke> defense4all has put in the change that should fix them
14:39:28 <tbachman> ah — my topic was still showing status… sorry
14:39:29 <edwarnicke> *so*
14:39:49 <edwarnicke> I expect to kick off RC1 build again in the next 30 minutes *with* defense4all included
14:40:08 <colindixon> #info edwarnicke reports that snmp4sdn and defense4all both should be good for auto-release at this point, but RC1 cutting hit two issues: one in plugin2oc and one in dlux
14:40:12 <colindixon> what about the dlux issue?
14:40:14 <gzhao> edwarnicke: +1
14:40:33 <edwarnicke> Well a couple of things
14:40:49 <edwarnicke> It seems the dlux guys added features-l2switch to their distro yesterday (which is both cool and valid)
14:41:04 <edwarnicke> And the l2switch guys already depended on dlux (because they pull dlux into their repo)
14:41:14 <edwarnicke> So I had to build an 'aggregator' pom for the two of them
14:41:23 <edwarnicke> That caused the reactor order to shuffle a bit
14:41:36 <edwarnicke> And it turned out dlux was missing one internal dependency between dlux-web and dlux.resources
14:41:51 <edwarnicke> Evidently they had just been lucky in reactor order or saved by SNAPSHOT before
14:42:12 <colindixon> #info edwarnicke believes he’s fixed both the plugin2oc and dlux issues and will have a fully RC1 kicked off in the next 30 minutes
14:42:14 <edwarnicke> gershon: Welcome!  Happy new for you... RC1 hit a bump, and so I'm adding defense4all to the rerun we are doing :)
14:42:32 <AsafOron> great
14:42:33 <colindixon> everyone should #info in as they come
14:42:53 <gzhao> #info AsafOron for D4A
14:43:18 <edwarnicke> gershon: AsafOron I know you guys are new, so a brief explanation... customimarily folks type "#info <ircnick> <project>" so the meetbot records their attendence in the meeting minutes
14:43:31 <colindixon> ok… so, anything else to say about auto-release?
14:43:32 <edwarnicke> gershon: AsafOron welcome ;)
14:43:56 <edwarnicke> I don;'t think so... just that it looks like we will have everyone in for RC1, which is awesome :)
14:44:14 <gershon> edwarnicke: Hi Ed, good news, thanks a lot!:)
14:44:18 <colindixon> cool
14:44:25 <edwarnicke> dlux fix works
14:44:34 <gzhao> edwarnicke: great
14:44:34 <edwarnicke> Going to add it and defense4all and then kick off the RC1 build
14:44:38 <colindixon> #topic project status and blocking issues
14:44:50 <edwarnicke> gershon: Thank you guys for working so valiantly to get your fix in :)
14:45:08 <colindixon> so, do we actually want to have every project report in?
14:45:32 <AsafOron> Thank you Ed George and all who helped us so much last night !!
14:45:47 <gzhao> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 <= spreadsheet to track project feature testing
14:45:55 <gzhao> AsafOron: you are welcome
14:46:05 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2014-September/000418.html send this e-mail asking people to track their feature testing with the above spreadsheet
14:46:11 <colindixon> #undo
14:46:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x250dcd0>
14:46:20 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2014-September/000418.html sent this e-mail asking people to track their feature testing with the above spreadsheet
14:47:14 <colindixon> all projects please report their testing, so that we have an idea of where we are in terms of blocking issues
14:47:24 <tbachman> #info groupbasedpolicy was working as of late last night, but there was a new bug that’s causing the Proof of Concept to fail
14:47:42 <colindixon> if you don’t report testing, expect gently prodding and then cranky e-mails from gzhao, edwarnicke, and others
14:48:00 <colindixon> #info if you don’t report testing, expect gently prodding and then cranky e-mails from gzhao, edwarnicke, and others
14:48:04 <tbachman> lol
14:48:12 <colindixon> tbachman: ok
14:48:17 <colindixon> is there a patch?
14:48:18 * edwarnicke looks for his cranky hat
14:48:23 <tbachman> not yet
14:48:27 <colindixon> tbachman: you guys are a leaf project, no?
14:48:28 <tbachman> was just discovered this a.m.
14:48:37 <tbachman> yeah — as far as I know, no one depends on us
14:48:43 <tbachman> we’re just a POC for Helium
14:48:53 <colindixon> ok, so that’s good to know but not blocking
14:48:59 <tbachman> yup
14:49:11 <edwarnicke> For those who are interested... RC1 build: https://jenkins.opendaylight.org/odlautorelease/view/Helium%20Autorelease%20view/job/autorelease-helium-worker/39/
14:49:19 <edwarnicke> We are off the races... takes about 3-4 hours
14:49:27 <tbachman> :o
14:49:29 <regXboi> um
14:49:38 <regXboi> isn't SFC dependent on GBP?
14:49:39 <edwarnicke> regXboi: ?
14:49:50 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/11067/ the TTP project merged this bug fix yesterday prior to RC1
14:49:53 <regXboi> or did I miss another lap
14:49:56 <edwarnicke> regXboi: I don't think so
14:50:18 <colindixon> regXboi: I think that gzhao compiled this based on pom-level dependencies: https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Helium_Project_Dependency_Diagram
14:50:23 * regXboi muses that things may have changed in unexpected ways from what he remembered
14:50:26 <tbachman> regXboi: the two projects have been talking, but I htink ay integration is going to happen in Lithium
14:50:44 <tbachman> s/htink ay/think any/
14:50:48 <regXboi> tbachman: ah - ok - that explains it - I'm a couple of months off in my head
14:50:55 <tbachman> :)
14:51:02 * regXboi notes being a couple of months off is a normal state of affairs
14:51:02 <edwarnicke> regXboi: A quick grep -r shows that sfc does not mention groupbasedpolicy in either its pom.xml or features.xml files
14:51:17 <edwarnicke> I recommend this as our gold standard for dependency
14:51:19 <edwarnicke> cd $PROJECT
14:51:25 <regXboi> edwarnicke: yes, no worries, I'm just causing unintentional mischief
14:51:32 <edwarnicke> grep -r --include=pom.xml <reponame> .
14:51:34 <edwarnicke> (for build time)
14:51:39 * regXboi looks for mischief/dunce cap and wanders into the corner
14:51:42 <edwarnicke> grep -r --include=features.xml <reponame> .
14:51:44 <edwarnicke> for runtime
14:51:45 <tbachman> regXboi: you said gadfly this time
14:52:18 <tbachman> ;)
14:52:18 <regXboi> tbachman: yes, but I've actually caused mischief this time
14:52:31 <gzhao> edwarnicke: just want to be sure, does #39 include defense4all?
14:52:53 <colindixon> edwarnicke: which does not catch comments hence finding that TTP depends on openflowjava even though it doesn’t right now
14:52:58 <colindixon> but it’s a really good first cut
14:53:01 <colindixon> ok, blocking issues?
14:53:09 <colindixon> bring out your blocking issues
14:53:20 * colindixon rings bell while walking a wheelbarrow
14:53:25 <edwarnicke> Quick correction, forgot to checkout defense4all sources in #39.. so this is now the build to watch: https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/41/
14:53:37 <gzhao> edwarnicke: thanks
14:54:14 <edwarnicke> gershon: AsafOron I moved defense4all pretty early in the build order so we can see it succeed or fail early, in the hopes that either you guys can breath a sigh of relief soon, or if there's an issue we can get right on it together :)
14:54:43 <edwarnicke> catohornet: Welcome!
14:54:47 <AsafOron> great !!! so we should know in about 30m
14:55:09 <colindixon> #topic blocking issues
14:55:20 <colindixon> barring this build failing, do we have any blocking issues?
14:55:36 <colindixon> looks at tbachman, gzhao, regXboi, etc.
14:55:42 <edwarnicke> AsafOron: That's the hope... I know its late for you guys and wanted you to know either way ASAP... would AsafOron and gershon stick around on IRC though till we get past defense4all so if there is an issue we can solve it?
14:55:45 <tbachman> colindixon: blocking as far as cutting the release?
14:55:58 * tbachman would like to see a fix for the NPE he hit this a.m. ;)
14:56:02 <AsafOron> Sure
14:56:18 <colindixon> blocking in that they would prevent us from releasing Helium
14:56:32 <colindixon> tbachman: do you have a link?
14:56:45 <edwarnicke> AsafOron: Many thanks :)
14:57:17 <tbachman> #link  https://bugs.opendaylight.org/show_bug.cgi?id=1907  bug for NPE when running groupbasedpolicy POC
14:57:20 * regXboi why are people looking at me?
14:57:23 <gershon> edwarnicke: Seems there is an issue with defense4all RC1 build... Could you please insure it?
14:57:37 * regXboi looks behind himself to see if he's missing something
14:57:49 <edwarnicke> gershon: Are you looking at https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/39/console
14:57:49 <colindixon> #info colindixon notes that testing and docs *need* to happen for each project
14:57:49 <edwarnicke> ?
14:58:24 <gershon> edwarnicke: yes
14:58:27 * edwarnicke has no idea why he just say ?
14:58:44 <edwarnicke> gershon: I saw that issue with build #39.  It was totally my fault.. I forgot to check out defense4all from git
14:58:55 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/tws/opendaylight-meeting-tws.2014-09-15-17.04.html the meeting minutes from yesterday’s TWS call go through a basic idea about how to do docs
14:58:57 <edwarnicke> gershon: So I fixed that an we are running https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/41/console
14:59:13 <edwarnicke> gershon: But good eye :)  Thank you for keeping an eye on it :)
15:00:06 <edwarnicke> dave_tucker: Welcome! :)
15:00:15 <gzhao> gershon: confirmed d4a is in the RC1 build
15:00:39 <colindixon> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_RC0 shows how to test RCs (they’re written for RC0, but the idea is the same except you’ll want to get the newer RC)
15:00:43 <edwarnicke> gershon: I also see it building in the console (not quite finished yet)
15:00:44 <dave_tucker> hi edwarnicke
15:01:02 <gershon> edwarnicke: after yersterday experience all my senses are tuned well :)
15:01:08 <colindixon> #action colindixon to add instructions/links on how to get more recent builds to the RC testing instructions
15:01:14 <edwarnicke> gershon: :)  I'm sorry about that miscommunication :(
15:01:15 <colindixon> edwarnicke: can you help me on that?
15:01:31 <edwarnicke> gershon: I had a lot going on, and didn't even notice your comments about RC2 till I was reviewing the log hours later
15:01:47 <edwarnicke> colindixon: Once RC1 is built, yes
15:02:08 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2014-September/000418.html this e-mail from gzhao describes how to report testing results
15:02:24 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 testing results should be reported on this spreadsheet
15:02:56 <edwarnicke> #info please also note we will have nightly builds, and testing the nightlies is also mega goodness
15:03:04 <colindixon> +1
15:03:18 <colindixon> gzhao: do we have a spreadsheet to track docs progress?
15:03:41 <colindixon> gzhao: at the very least, it would be good to get an idea from each project what kind of docs then intend to contribute
15:03:48 <edwarnicke> colindixon: There are rumors that you either have or very shortly will have l2switch docs to use as an example?
15:03:49 <gzhao> colindixon: this is what manny used to track doc. https://docs.google.com/spreadsheets/d/16-SbSzdBzTXEk8lD6Q09zl-Ip8jBU3B8_BBqRPXGimg/edit#gid=0
15:04:10 <colindixon> i.e., a demonstration that they’ve walked the diagram and somebody to verify that how they walked it makes sense
15:04:34 <colindixon> #link https://docs.google.com/spreadsheets/d/16-SbSzdBzTXEk8lD6Q09zl-Ip8jBU3B8_BBqRPXGimg/edit#gid=0 this spreadsheet is what we’re currently using to track docs
15:04:42 <colindixon> edwarnicke: I just checked and didn’t see the patch yet :-/
15:05:16 <colindixon> #undo
15:05:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x258de10>
15:05:19 <colindixon> sorry gzhao
15:05:23 <colindixon> did you want to use that to track this
15:05:29 <colindixon> since I’m guessing it’s going to fall to you
15:06:08 <gzhao> colindixon: the output of https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Documentation_Guidelines should be reported by each project in M5
15:06:24 <colindixon> and was it?
15:06:28 <gzhao> colindixon: I just didn't track doc, and leave that to Manny
15:06:46 <colindixon> ok…
15:06:58 <edwarnicke> gershon: AsafOron:
15:07:00 <edwarnicke> https://www.irccloud.com/pastebin/PrJ8SvG8
15:07:09 <edwarnicke> You two can sleep the sleep of the righteous :)
15:07:16 <edwarnicke> defense4all successfully built in RC1
15:07:17 <tbachman> edwarnicke: sleep?
15:07:20 <colindixon> and there is much rejoicing
15:07:33 <edwarnicke> Could someone inform the tsc ?
15:07:38 * tbachman certainly doesn’t see the sleep hat behind edwarnicke
15:07:41 <colindixon> edwarnicke: I can do that
15:07:47 <gzhao> edwarnicke: I will do it
15:07:59 <edwarnicke> tbachman: my sleep hat was eaten by rabid vampire reindeer
15:08:02 <AsafOron> ed: great , so d4a is ok now ?
15:08:05 <tbachman> lol
15:08:09 <colindixon> #action colindixon to inform the TSC that defense4all built successfully in the RC1
15:08:27 <edwarnicke> AsafOron: LOL... OK is more than I can assert to... but you guys at least build without error in the RC1 build... testing is up to you ;)
15:08:45 <AsafOron> ed: I'm too tired to sleep
15:08:51 <colindixon> #action gzhao to harass projects about reporting documentation status or at least what kind of docs they’re going to produce
15:09:03 <edwarnicke> AsafOron: I feel ya... been there, done that...
15:09:09 <colindixon> #link https://docs.google.com/spreadsheets/d/16-SbSzdBzTXEk8lD6Q09zl-Ip8jBU3B8_BBqRPXGimg/edit#gid=0 we will use this spreadsheet to track doc status for each project
15:09:45 <colindixon> I feel like I’ve made it through as much badgering and providing info about how to test, doc, and report progress on both as is possible
15:10:06 * tbachman thanks colindixon for his badgering :)
15:10:14 <colindixon> gzhao: I hope the #action above is ok with you
15:10:25 <gzhao> colindixon: yes
15:10:30 <gershon> edwarnicke: no problem at all, you are doing a great and important work here with a lot of details, so things could be missed and it completely understood... I am learning  to work in this env (maybe in tough way).. :)
15:10:34 <gzhao> colindixon: I will track that
15:10:44 <colindixon> #topic other topics and issues
15:11:31 <gzhao> I need to go back and listen yesterday's TWS documentation meeting
15:11:32 <colindixon> anyone who has anything?
15:11:41 <phrobb> I'm glad to see D4A made it into RC1.  Congrats Asaf and Gershon
15:11:48 <gzhao> anything highlight there?
15:12:10 <colindixon> otherwise, I’ll give everyone back 15 minutes
15:12:13 * tbachman would like to congratulate and thank folks like edwarnicke, gzhao, colindixon, regXboi, Madhu, et. al. who are all helping each other make Helium happen
15:12:24 <tbachman> ttkacik: oflibMichal as well!
15:12:25 <regXboi> ?
15:12:26 <AsafOron> phrobb: thanks !
15:12:32 <gzhao> also, can project contact review: https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Helium_Project_Dependency_Diagram
15:12:36 <abhijitkumbhare> +1 tbachman :)
15:12:40 * tbachman has surely missed some folks
15:12:55 <Madhu> tbachman: u missed yourselves there... but we all know it
15:13:05 <gzhao> AsafOron: gershon thanks for working hard to merge to gerrit
15:13:13 <Madhu> hi guys. good morning. btw
15:13:17 <edwarnicke> gzhao: SFC does not depend on ovsdb
15:13:23 <edwarnicke> Either at build time or runtime
15:13:41 <edwarnicke> But ovsdb project does have both build time and runtime dependencis on SFC
15:13:49 <gzhao> edwarnicke: yes from pom.xml and build's point of view
15:13:52 <Madhu> gzhao: edwarnicke is right.
15:13:59 <Madhu> but that will change in lithium
15:14:01 <AsafOron> edwarnicke: we've qa working on the product as well. We take care of the testing
15:14:30 <gzhao> edwarnicke: but ovsdb is a southbound plugin
15:14:38 <colindixon> ok
15:14:39 <AsafOron> gzaho: thank you for all the help
15:14:40 <edwarnicke> gzhao: Of what?
15:14:52 * colindixon raises gavel
15:14:55 <gzhao> AsafOron: you're welcome
15:14:55 <colindixon> going once
15:15:01 * colindixon counts to 10
15:15:06 * edwarnicke holds breath
15:15:12 * tbachman plugs ears
15:15:16 <colindixon> going twice
15:15:32 * colindixon swings gavel
15:15:33 <colindixon> BANG
15:15:34 * edwarnicke makes mild rustling noises from beneath a mountain of hats
15:15:37 <colindixon> #endmeeting